Course Errata for LabVIEW Performance Course

Overview

Part Number: 325539B-01 and 325501B-01
Primary Software: LabVIEW
Primary Software Version: 2010 SP1

The following is a list of errata for the manual, slides, exercises, and solutions for the course.

Details

Example VIs 
The following example VIs are used in the course, but are not shipped with LabVIEW 2013 and later. If you are using LabVIEW 2013 or later, you can download the VIs from the Attachments section.

  • Smart Buffer Example. vi
  • Timing Template (data dep).vi
  • Dynamic Load Example.vi


The following changes pertain to the LabVIEW Performance Exercises manual, part number 325539B-01. 

Exercise 3-4 Tracing an Application 
Page 3-14, steps 3 and 4 
If you are using the Desktop Execution Trace Toolkit 2013 or later, replace steps 3 and 4 on page 3-14 with the following instructions. 
3. Open DETT. 
4. Click Capture Settings and select all the options. 

Page 3-16, step 7 
7. Save the current trace for future use.

  • Select File»Save in DETT.
  • Save the file as FirstBenchmarkTrace.det in the <Exercises<\LabVIEW Performance\Measure directory.


Page 3-17, step 10 
10. Compare the first and second traces.

  • Open the FirstBenchmarkTrace.det file that you previously saved.
  • In DETT, select View»Compare Traces.
  • In the Compare Traces window, select FirstBenchmarkTest in the Session Name pull-down menu on the Compare 1 side. Select the session you just completed on the Compare 2 side.
  • Click the Compare button.

Do you notice the differences between the two traces? 

11. Close the Desktop Execution Trace Toolkit and the DETT Example VI. 


Exercise 4-3 Data Value Reference
Page 4-11, step 5
 
5. Trace execution using the Desktop Execution Trace Toolkit.

  • Open DETT by selecting Tools»Profile»Trace Execution.

Note: If a dialog box appears, follow the instructions to enable VI Server access. This is necessary for DETT to communicate with LabVIEW.

  • Click Capture Settings and verify that the Memory Allocations checkbox is enabled.
  • Click Start.
  • In LabVIEW, set the Test Selection control to Data Value Reference. Run the VI.

Resume the exercise on p. 4-12 of the LabVIEW Performance Exercises manual. 
Note: The DETT results will look slightly different than Figure 4-6 and Figure 4-7. 


Exercise 4-4 Dynamic VIs and Memory Usage
Page 4-14, Part I: Windows XP

1. Open the Dynamic Load Example VI

  • Download the attached Dynamic Load Example.zip
  • Extract all files to the computer's desktop
  • Double-click dynload.llb to open it
  • In the LLB Manager window, open the Dynamic Load Example.vi

Page 4-15, Part II: Windows 7
1. Open the Dynamic Load Example VI

  • Download the attached Dynamic Load Example.zip
  • Extract all files to the computer's desktop
  • Double-click dynload.llb to open it
  • In the LLB Manager window, open the Dynamic Load Example.vi
 

Exercise 5-1 Reaction Time 
Page 5-1, step 4 
4. Perform a trace on the Reaction Time VI.

  • In the Desktop Execution Trace Toolkit, configure the trace to ensure that the following events will appear in the trace results:
    • Event Structures and User Events
      • Timeout
    • User-Defined Trace Events
    • VI Execution
  • In DETT, click Start.
  • Run the Reaction Time VI.
  • On the front panel, click OK to test your reaction time. After a few attempts, stop the VI.
  • Click Stop in DETT to stop the trace.


Resume the exercise with step 5 on p. 5-2 of the LabVIEW Performance Exercises manual. 

Exercise 5-4 Reentrancy 
Pages 5-10 throught 5-13, steps 3 through 8 

3. Perform a trace on the Calling2Loops VI.

  • In DETT, click Capture Settings.
  • Configure the trace session to enable only the VI Execution checkbox.
  • In DETT, click Start.
  • Run the Calling2Loops VI.
  • In DETT, click Stop.


4. View the results of the trace. 

  • Notice that Calling2LoopsSubVI is called from different threads. In this case, the subVI is non-reentrant. The VI must be called and then return before it can be called from the second instance.


5. Modify the Calling2Loops VI to be reentrant.

  • On the block diagram of the Calling2Loops VI, double-click the Calling2LoopsSubVI VI.
  • From the front panel of the Calling2LoopsSubVI VI, select File»VI Properties.
  • In the VI Properties dialog box, select Execution from the pull-down menu.
  • Select the Preallocated clone for each instance option.
  • Click OK.
  • Save the Calling2LoopsSubVI VI.


6. Perform a new trace on the Calling2Loops VI.

  • In DETT, click New Trace. In DETT, click Start.
  • Run the Calling2Loops VI.
  • In DETT, click Stop.


7. View the results of the trace.

  • Notice that now the subVI is reentrant and multiple calls to the VI appear simultaneously in the trace. The subVI now appears with an appended number (Calling2LoopsSubVI.vi:830001). The number that appears next to the subVI name is the clone that is being executed.


8. Close the Calling2Loops VI without saving.