Table Of Contents

Recording Commands VeriStand Sends to the Target

Last Modified: June 10, 2021

Use the Macro Recorder tool to record commands, such as the setting of channel or parameter values, model execution states, and fault or alarm values, that VeriStand sends to the target and save them to a macro (.nivsmacro) file.

Before you begin, verify that you have the tool in your Workspace Tools menu. If you do not, refer to Adding a Standard or Custom Tools Menu Item.
spd-note-note
Note  

You can also use the Macro Recorder VIs to access the Macro Recorder and create macro files programmatically from LabVIEW. Use the Execution API to access the Macro Recorder from any .NET-compatible programming language.

  1. In the Workspace, select Tools»Macro Recorder to launch the tool.
    spd-note-note
    Note  

    The name of this menu item might differ depending on how you named it in the Tools Properties dialog box.

  2. In the Macro Recorder tool, click Record to begin recording.
  3. Use controls on the Workspace to send commands to the target. The Workspace Macro list displays each command you send.
  4. Click Pause to pause recording.
    spd-note-note
    Note  

    The Macro Recorder does not record any commands you send while it is paused. You can click Resume to continue appending commands to the same macro recording.

  5. Click Stop to finish recording.
  6. Click File»Save As to save the macro file.
You can use the Macro Player tool to play back macro files you create using the Macro Recorder tool.

Recently Viewed Topics