Table Of Contents

Source Waveform Configurations

Last Modified: November 23, 2020

Use the source waveform configuration document to view, modify, save, and load source waveform files (.tdms). Use the source functionality when the data you need to use is site-specific or only determined at run time, such as when you need to write registers or test converters. You can send multiple source waveforms with the same configuration in a single pattern burst. Use the source_start and source opcodes to send waveform data when you burst the pattern. An asterisk (*) next to a filename in the Project Explorer window and in the document tab indicates that the file has been modified but not saved.

Select File»New or click the Add Item button Add Item on the Project Explorer window toolbar to create a new document. Create a single .tdms file for each individual source waveform you require. Double-click a .tdms file in the Project Explorer window or right-click the file and select Open from the context menu to launch the source waveform configuration document. The Digital Pattern Editor opens only .tdms waveform files that have the same structure as the waveform files the editor creates. You can also use the NI-Digital LabVIEW, .NET, or C API to configure and load source waveforms you create or edit with the source waveform configuration document. Refer to the Related information section at the end of this topic for a link to more information about source and capture functionality.

Configuring Waveforms

You must specify values for the following components of the waveform. Options that do not apply dim based on the values you specify.

  • Waveform Name — Specifies the name of the waveform.
  • Status — Indicates one of the following states of the waveform:
    • Not Loaded — The waveform has not been loaded on the digital pattern instrument.
    • Loaded — The waveform has been loaded on the digital pattern instrument.
    • Out of Sync — The waveform has been loaded on the digital pattern instrument but has been modified since it was loaded.
  • Waveform Type — Specifies one of the following types of waveforms:
    • Serial — Specifies that the waveform uses the serial configuration. When you configure the source functionality for serial use, each vector that contains a source opcode serially shifts 1 bit on the pin using the drive from source pin state (D) to indicate what value to drive. Only one pin per vector can source in this mode.
    • Parallel — Specifies that the waveform uses the parallel configuration. When you configure the source functionality for parallel use, the entire waveform sample is sourced on all specified pins in parallel for each vector that contains a source opcode. Use the drive from source pin state (D) for each pin on each such vector that corresponds to the pins to source.
  • Sample Format — Specifies one of the following options to display data in decimal (no prefix), hexadecimal (0x prefix), or binary (0b prefix) format.
  • Sample Width — Specifies the width in bits of each serial sample when you select Serial for the Waveform Type. Valid values are 1-32.
  • Bit Order — Specifies whether to evaluate the most significant bit (MSB) or the least significant bit (LSB) first when sourcing a sample of a serial waveform.
  • Pins/Pin Groups — Specifies the pins or pin groups configured for the waveform. Use the type-ahead drop-down menu to select valid pins and pin groups.
  • Data Mapping — Specifies one of the following data mapping options:
    • Broadcast — Specifies to broadcast the waveform data in the Site 0 column of the Source Data table to all sites.
    • Site Unique — Specifies to source unique waveform data for each site from the separate corresponding column for each site in the Source Data table. If using a pin with a shared pin connection, the waveform data must be identical for each of the sites that a pin is shared on.

The Source Data tab of the document displays editable source waveform data per site in columns. When you set Data Mapping to Broadcast, only the column for Site 0 is used. You can edit the data directly in the Source Data tab, or you can edit the source waveform file in another application and then click the Import Source Data button Import Source Data on the toolbar or the Import From File button on the Source Data tab to update the data to source. Use the Number of Sites control or right-click the source data table and select Set Number of Sites from the context menu to specify the number of sites to use.

Importing Source Waveform Data

To import data to a source waveform, click the Import Source Data button Import Source Data on the toolbar or click the Import From File button on the Source Data tab and select a .csv file of source waveform data in decimal, hexadecimal, or binary format to store and load with the waveform configuration.

The following table shows examples of text files and the corresponding Source Data tab.

Text File Source Data tab
0, 15
1, 14
Source Data Tab Decimal
0x0, 0xF
0x1, 0xE
Source Data Tab Hexadecimal
0b0000, 0b1111
0b0001, 0b1110
Source Data Tab Binary

Loading Waveforms

The Digital Pattern Editor prompts you to load waveforms on the instrument before bursting a pattern if the pattern directly uses a waveform, including waveforms used in patterns that the pattern jumps to. You can also click the Load Waveform button Load or Apply on the toolbar or right-click the waveform file in the Project Explorer window and use the context menu to manually load the current waveform on the instrument. You must specify a name and at least one pin for the waveform. You cannot load a waveform with the same name as another already loaded waveform. Click the Unload All Patterns and Waveform Configurations button Unload to remove all source and capture waveforms and patterns from the instrument. If you modify and save the waveform, you must unload and reload the waveform for the changes to take effect on the instrument. The Digital Pattern Editor prompts you to reload modified files before bursting a pattern.

When you load a parallel source or capture waveform through the Digital Pattern Editor, the order of pins you specify in the Pins/Pin Groups configuration determines the mapping for the bits in each sample. For example, the left-most bit maps to the left-most pin you specify, and each subsequent bit maps to each subsequent specified pin. For pin groups, the left-most bit maps to the top pin of the pin group, and each subsequent bit maps to the subsequent pin in the pin group.

Keyboard Shortcuts within the Source Waveform Configuration File

Action Shortcut
Load a source waveform file <Ctrl+L>

Recently Viewed Topics