NI-​RIO​和​LabVIEW​版本​兼容性

概览

本​页​显示​LabVIEW​开发​系统​支持​的​NI-​RIO​版本。​升级​系统​或​软件​时​参考​本文,​可​确保​安装​正确​的​工具​包​版本。​使用​不​兼容​的​版本​可能​会​导致​程序​错误,​或者​选​板​或​函数​丢失。

从​LabVIEW 2015​开始,​NI-​RIO​分​为了​三​个​独立​的​安装​程序。​CompactRIO​设备​驱动​程序​(支持​CompactRIO​和​单​板​RIO)、​R​系列​多功能​(支持​R​系列​卡)​和​FlexRIO(支持​FlexRIO​板)。​下面​的​兼容​性​表​适用​于​所有​独立​安装​程序。



请​注意,​本文​替代​知识​库​的​4ESLI3UI​文​档:​NI-​RIO​和​LabVIEW​版本​兼容​性。 一些​NI​手册​可能​仍然​参考​以前​的​文​档。​如果​您​是​通过​以前​的​知识​库​网址​跳​转​到​这里,​请​相应​更新​您​的​书签。

NI‑RIO LabVIEW​版本
2009 2009 SP1 2010 2010 SP1 2011 2011 SP1 2012 2012 SP1 2013 2013 SP1 2014 2014 SP1 2015 2015 SP1 2016 2017 2017 SP1 2018 2018 SP1
3.3                                    
3.3.1                                    
3.4                                    
3.5.1                                  
3.6                                  
3.6.1                                  
4.0                                
4.1                                
12.0                              
12.1                              
13.0                              
13.0.1                              
13.1                              
13.1.1                              
14.0                              
14.0.1                              
14.5.0                              
15.0                              
15.5                              
16.0                              
17.0                              
17.6                              
18.0                              
18.5                              

 

 

更多​资源

避免​CompactRIO​系统​的​软件​兼容​性​问题
驱动​程序​和​更新:​CompactRIO​设备​驱动​程序
驱动​程序​和​更新:​R​系列​多功能​RIO
驱动​程序​和​更新:​FlexRIO
驱动​程序​和​更新:​NI-​RIO
NI-​RIO​设备​驱动​程序​的​已知​问题​和​漏洞​修复
CompactRIO、​CompactDAQ、​单​板​RIO、​R​系列​和​EtherCAT​设备​的​软件​支持