Vision Acquisition Software and LabVIEW Compatibility

Overview

This page shows the supported versions of Vision Acquisition Software are required with LabVIEW. Reference this information to ensure you install the correct driver version when upgrading or updating your system, when migrating or porting code to a new system, or after the purchase and installation of new NI hardware. Using incompatible versions may result in errors, the inability for your operating system to recognize or detect and then find a driver for your device, or missing devices in NI Measurement & Automation Explorer (MAX).

Note: NI-IMAQ,NI-IMAQ I/O and NI-IMAQdx is part of the Vision Acquisition Software bundle and can't be downloaded separately.

Note that this article replaces KnowledgeBase 5MQDBB19:What Versions of NI-IMAQ, NI-IMAQdx, and NI-IMAQ I/O Come with My Version of Vision Acquisition Software?. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

Vision Acquisition Software

In the Downloads section at the bottom of this page, you can download a copy of this table, which may include older software versions.

 

Vision Acquisition Software NI-IMAQ NI-IMAQdx NI-IMAQ I/O NI-IMAQ IEEE 1394*    LabVIEW Version
2020 2019 2018 2017 SP1 2017 2016 SP1 2016 2015 SP1 2015 2014 SP1
20.0 20.0 20.0 20.0 N/A          
19.5 19.5 19.5 19.5 N/A        
19.0 19.0 19.0 19.0 N/A        
18.5 18.5 18.5 18.5 N/A      
18.0 18.0 18.0 18.0 N/A      
17.5 17.5 17.5 17.5 N/A      
17.1 17.0 17.1 17.0 N/A        
2017.01 16.0 16.2 16.1 N/A          
2016.09 16.0 16.1 16.0 N/A            
2016.02 15.5 15.5 15.5 N/A              

 

*NI-IMAQ IEEE 1394 is a legacy product and was wrapped into the IMAQdx drivers in later Vision Acquisition Software versions.

Compatible