Sound and Vibration Software and LabVIEW Compatibility

Visão geral

This page shows supported versions of NI Sound and Vibration Software, sometimes referred to as Sound and Vibration Measurement Suite (SVMS), or Sound and Vibration Toolkit (SVT) with LabVIEW development systems. Reference this information to ensure you install the correct toolkit version when upgrading or updating your system or software. Using incompatible versions may result in errors, or missing LabVIEW palettes or functions.

Note that this article replaces KnowledgeBase 6H3CTJOU: NI Sound and Vibration Software and LabVIEW Version Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

Contents

Sound and Vibration Software and LabVIEW Compatibility for Versions 2010 and Later

Beginning with LabVIEW 2010, NI Sound and Vibration software will only install and work with the corresponding version of LabVIEW. 

For example: If you have NI Sound and Vibration 2015 software, it is only compatible with LabVIEW 2015, and if you have NI Sound and Vibration 2016 software, it is only compatible with LabVIEW 2016.

 

Sound and Vibration Software and LabVIEW Compatibility for Versions 2009 or Earlier

Use this table to compare Sound and Vibration Software and LabVIEW Compatibility
Sound and Vibration Software Version LabVIEW Version
8.2 8.2.1 8.5 8.6 2009
5.0        
6.0        
7.0  
2009


Compatible


Note: NI Sound and Vibration Software versions 5.0 and 6.0 may be able to install on newer versions of LabVIEW. However, we recommend using the appropriate newer version of the software, as the older versions have not been tested and are not supported on newer releases of LabVIEW. If you do decide to use the older version of the NI Sound and Vibration software on a newer version of LabVIEW, be advised that you will need to mass compile your code after installing the new software.

Note: For all versions of NI Sound and Vibration, you will need to install NI-DAQmx in order to use NI hardware to perform data acquisition. For more information on which version of NI-DAQmx is compatible with your version of LabVIEW, see below.