LabVIEW 2012 Jitter Analysis Toolkit Readme

Version 12.0


June 2012


This file contains information to introduce you to the LabVIEW 2012 Jitter Analysis Toolkit. This file also contains important information about the toolkit, including system requirements, installation instructions, new features, and known issues.



Overview

System Requirements

Installation Instructions

New Features

Upgrade and Compatibility Issues

Known Issues

Bug Fixes

Accessing the Toolkit and Help

Finding Examples

Automating the Installation of NI Products

Overview

The LabVIEW Jitter Analysis Toolkit provides a library of VIs optimized for performing high-throughput, automated jitter, eye diagram, and phase-noise measurements. The toolkit is hardware-independent and can be used with NI high-speed and high-resolution digitizers as well as third-party oscilloscopes and digitizers.


System Requirements

In addition to the system requirements for the LabVIEW Development System, the Jitter Analysis Toolkit has the following requirements:


  • LabVIEW 2012 Full or Professional Development System (32-bit)
  • At least 150 MB of disk space

Refer to the LabVIEW Readme file in the labview directory for additional system requirements and supported operating systems for LabVIEW 2012.


Installation Instructions

You can install all of your LabVIEW products—including the Jitter Analysis Toolkit—using the LabVIEW 2012 Platform DVDs. Refer to the LabVIEW Installation Guide on the LabVIEW Platform DVD 1 for installation instructions and system requirements.


To request additional LabVIEW Platform DVDs, refer to the National Instruments website.


Note: If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.


New Features

The LabVIEW 2012 Jitter Analysis Toolkit introduces the following new features.


Characterizing Random and Periodic Jitter

The Jitter palette includes the new RJ PJ Separation VI, which separates the random and periodic components of jitter in a jitter sequence and returns their RMS and peak-to-peak values.


Support for Waveforms Represented by Integers

Depending on how you acquire waveform data, the Y data values that are part of the waveform data type might be double-precision, floating-point numeric values or 8-bit signed integers. Analyzing waveforms represented by integers reduces the size of the data you must analyze, which requires less memory. The following VIs include polymorphic instances that can operate on the waveform data type when it contains double-precision floating-point data or 8-bit signed integers:


  • Area VI
  • Burst Width
  • Clock Recovery (Mean Clock)
  • Clock Recovery by PLL Filter
  • Clock Recovery by Second Order PLL
  • Eye Data Generation
  • Eye Height and Width
  • Eye Pattern Limit Test
  • Fall Time
  • Find Transitions
  • Level Crossing
  • Max and Min Voltage
  • Overshoot and Undershoot
  • Peak to Peak Voltage
  • Quality Factor
  • Reference Bit Waveform Creation
  • Reference Levels
  • Rise Time
  • Root Mean Square Voltage
  • State Levels

Miscellaneous VI Enhancements and Behavior Changes

The LabVIEW 2012 Jitter Analysis Toolkit includes the following VI enhancements and behavior changes:


  • The Signal with Jitter VI contains a PJmetrics output, which returns characteristics of the periodic jitter contained in the waveform this VI generates.
  • The Sequence to XY Graph VI no longer appears on the Jitter subpalette of the Jitter Analysis palette.

Upgrade Issues and Compatibility Issues

You might encounter the following compatibility issues when you upgrade to the LabVIEW 2012 Jitter Analysis Toolkit:


  • LabVIEW no longer supports the Periodic Jitter VI. Replace this VI in your applications with the nTone instance of the RJ PJ Separation VI.
  • If you open VIs saved in a previous version of LabVIEW that contain the Level Crossing, Reference Levels, or Eye Height and Width VI, LabVIEW might prompt you to find missing subVIs. Click the Ignore Item button to dismiss the dialog, and LabVIEW opens the VI without errors.
  • The Clock Recovery (Mean Clock) VI no longer contains a reset input.

Known Issues

You can access the software and documentation known issues list online. Refer to the LabVIEW Toolkits Known Issues website for an up-to-date list of any known issues in the Jitter Analysis Toolkit.


Bug Fixes

The following items are the IDs and titles of a subset of issues fixed between the LabVIEW 2011 Jitter Anlaysis Toolkit and the LabVIEW 2012 Jitter Anlaysis Toolkit. This is not an exhaustive list of issues fixed in the current version of the Jitter Analysis Toolkit. If you have a CAR ID, you can search this list to validate the issue has been fixed.


ID Fixed Issue
336767 Clock Recovery (Mean Clock) VI returns error -20068 when processing certain waveforms
334701 Rj Dj Separation VI does not appear on the Jitter Analysis Toolkit palette
334182 Duty cycle distortion values yield inconsistent results
321442 The high state level parameter is miscalculated and yields results that are higher than expected
288897 Glitch appears in eye diagram even though actual waveform is correct
288895 Clock Recovery (Mean Clock) VI does not sufficiently estimate unit interval for Eye Data Generation VI
285695 Jitter Analysis Toolkit example VIs do not show up in Example Finder

Accessing the Toolkit and Help

To access the Jitter Analysis Toolkit VIs, select View»Functions Palette from the block diagram in LabVIEW and navigate to the Addons»Jitter Analysis palette. You also can right-click any blank space on the block diagram to display the Functions palette.


Refer to the Toolkits»Jitter Analysis VIs book on the Contents tab of the LabVIEW Help for more information about the Jitter Analysis Toolkit.


Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. LabVIEW examples for the Jitter Analysis Toolkit are located in the labview\examples\Jitter Analysis directory. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.


Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.


If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.


For more information, refer to the following KnowledgeBase articles:



Important Information

Copyright


© 2010–2012 National Instruments. All rights reserved.


Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.


National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.


End-User License Agreements and Third-Party Legal Notices


You can find end-user license agreements (EULAs) and third-party legal notices in the following locations:


  • Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
  • EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
  • Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

Trademarks


LabVIEW, National Instruments, NI, ni.com, the National Instruments corporate logo, and the Eagle logo are trademarks of National Instruments Corporation. Refer to the Trademark Information at ni.com/trademarks for other National Instruments trademarks.


Other product and company names mentioned herein are trademarks or trade names of their respective companies.


Patents


For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.