From 08:00 PM CDT Friday, August 12 - 01:00 PM CDT Saturday, August 13, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW Simulation Interface Toolkit 5.0.1 Readme

December 2008


The LabVIEW Simulation Interface Toolkit (SIT) 5.0.1 addresses and corrects problems found in the LabVIEW Simulation Interface Toolkit 5.0. This file contains the following information about the LabVIEW Simulation Interface Toolkit 5.0.1


System Requirements

Installation/Upgrading Instructions

Upgrading from SIT 2.0.x/3.0.x/4.0

What's New in 5.0.1

What's New in 5.0

Support for Real-Time Targets

Accessing the Help and Examples

Development Tips

Known Issues

Bug Fixes

System Requirements

To install the LabVIEW Simulation Interface Toolkit 5.0.1, you must already have installed National Instruments LabVIEW 8.6 Development System on the same computer.


To create a host VI for a previously-developed model, you need only LabVIEW installed. To develop a model, you also must be a properly licensed user of and have the following software installed on the host computer or a remote networked computer:


  • The MathWorks, Inc. MATLAB® software and The MathWorks, Inc. Simulink® software application software release 13.x, 14.1, 14.2, 14.3, 2006a, 2006b, 2007a, 2007b, 2008a, or 2008b

To control an offline simulation using SIT 5.0.1, you must install SIT 5.0.1 in addition to the MATLAB application software and the Simulink application software.


To convert a model into a model DLL, you must install the following software:


  • The MathWorks, Inc. Real-Time Workshop® software release 13.x, 14.x, 2006a, 2006b, 2007a, 2007b, 2008a, or 2008b
  • Microsoft Visual C++ 6.0, .NET 2003, 2005 (Professional or Express), or 2008 (Professional or Express)

To control a simulation with a model in DLL form (Real-Time Target or Driver VI on Localhost), you must be a properly licensed user of and have the following software installed on both the host computer and the real-time target.


  • National Instruments LabVIEW 8.6 Real-Time Module for ETS Targets.
  • (Optional) National Instruments LabVIEW 8.6 FPGA Module, to create customized FPGA bitfiles used in real-time simulations involving NI FPGA devices.
  • You also must install the following driver software versions, depending on the type of hardware you want to use.

    National Instruments Hardware Driver Software Version Required
    National Instruments FPGA Devices NI-RIO™ 3.0 or later
    National Instruments CAN Interfaces NI-CAN™ 2.6 or later
    National Instruments DAQ Devices NI-DAQmx™ 8.7.2 or later

Installation/Upgrading Instructions

Installing from the LabVIEW 8.6.1 Platform DVDs

If you purchased LabVIEW 8.6.1, you can install all of your LabVIEW products—including the LabVIEW Simulation Interface Toolkit—using the LabVIEW 8.6.1 Platform DVDs. Refer to the LabVIEW DVD Installation Instructions or the LabVIEW Release Notes, which are available in your LabVIEW box, for information about the LabVIEW Platform DVDs.


Installing from the LabVIEW Simulation Interface Toolkit 5.0.1 Installation Media

Complete the following steps to install the LabVIEW Simulation Interface Toolkit 5.0.1.


  1. Install and activate the necessary software as described in the System Requirements section of this document.
  2. Uninstall any existing installations of the LabVIEW Simulation Interface Toolkit. If you do not perform this step, the installer automatically uninstalls any existing installations.
  3. Insert the LabVIEW Simulation Interface Toolkit 5.0.1 installation media.
  4. Run the setup.exe program.
  5. Follow the instructions that appear on the screen.
Tip  For information about activating the LabVIEW Simulation Interface Toolkit, refer to the Activation Instructions for National Instruments Software document that ships with the LabVIEW Simulation Interface Toolkit 5.0.1.

Upgrading from SIT 2.0.x/3.0.x/4.0

  • Load a host VI saved in SIT 3.0.x/4.0 and launch the SIT Connection Manager dialog box. Click the OK button to apply new settings. The conversion process preserves control/indicator mappings and all block diagram code. You will lose changes to SIT 3.0.x driver VI, but SIT 5.0.1 maintains hardware mappings. If the path to the model is invalid, SIT 5.0.1 prompts you to specify a valid path.
  • SIT 3.0.x driver VIs are not supported in SIT 5.0.1. If you are not using the SIT Connection Manager you will need to manually upgrade the driver VI. Refer to one of the examples for the correct driver VI structure.
  • SIT 5.0.1 does not convert driver VIs that SIT 2.0.x generated. Use the SIT Connection Manager dialog box to build a new driver VI for use in real-time simulations.
  • SIT 5.0.1 does not convert host VIs that SIT 2.0 generated.
  • The Simulation Interface Toolkit 4.0 deprecated the following VIs: SIT Execute Task and SIT Synchronize Base Rate.
  • The Simulation Interface Toolkit 5.0.1 relies heavily upon the SIT Connection Manager dialog box. National Instruments recommends you use this dialog box to create host VIs and driver VIs.
  • When running a simulation in Simulation Environment, the SignalProbe blocks from SIT 3.0.x/4.0 do not recognize tuneable variables specified through Data Objects. To be able to tune variables specified as tuneable through Data Objects, you must delete and re-add the SignalProbe block.
  • Update any custom FPGA bitfiles and VIs you developed in SIT 3.0.x/4.0 to the new FPGA VI template and recompile them.
  • SIT Write Log Settings to Configuration File.vi and SIT Write Playback Settings to Configuration File.vi in the User API have a new required input for Model Path.

What's New in 5.0.1

The Simulation Interface Toolkit 5.0.1 includes the following new features:


  • Free Compiler Support—SIT 5.0.1 now supports the Express Editions of the Microsoft Visual C++ 2005 and Microsoft Visual C++ 2008 compilers. Refer to the KnowledgeBase at ni.com for more information about using these compilers.
  • The MathWorks, Inc. Support—SIT 5.0.1 now supports the 2008b software release of The Mathworks, Inc. MATLAB®, Simulink®, Real-Time Workshop®, and Stateflow® software.

What's New in 5.0

The Simulation Interface Toolkit 5.0 includes the following new features:


  • Reconfigurable TDMS Data Logging—Create several logging configurations in the SIT Connection Manager and then switch between them and control them at run time.
  • Reconfigurable Data Log File Playback—Create several playback configurations in the SIT Connection Manager and then switch between them and control them at run time.
  • Support for Workspace Variables—You now can map a control to a workspace variable. Updating the workspace variable updates all parameters that are dependent on it.
  • Tuning Parameters in a The MathWorks, Inc. Stateflow® Software Chart—You can tune parameters in Stateflow charts using workspace variables.
  • SIT I/O Blocks—Allow hardware connections to any level of model.
  • Updated dialog for doing hardware I/O mappings—All hardware types configured and mapped in a single dialog.
  • Increased I/O in default FPGA Bitfiles—The default FPGA bitfiles now have 8 analog in, 8 analog out, 40 digital in, 40 digital out, 8 PWM in, and 8 PWM out channels.
  • Improved Probing of Virtual Signals—You now can probe virtual signals in more cases.
  • Specifying a MDL File—It is no longer necessary to specify a MDL model file when the execution host is Real-Time Target or Driver VI on Localhost.
  • Project Directory—You can specify a project directory that is different from the MDL or DLL model file directory.
  • Import of Data Files for Replay—Replay supports importing data from MAT, MDF, TDM, LVM, CSV and TXT files. You may need to get a plugin from http://ni.com/dataplugins to support the data file type.
  • VxWorks Support Files—Refer to the X:\SimulationInterfaceToolkit\5.0\VxWorks\readme_sit_vxworks.txt for information about enabling VxWorks support where X is the drive letter where you installed the Simulation Interface Toolkit.

Support for Real-Time Targets

The LabVIEW Simulation Interface Toolkit supports running a simulation on the following types of National Instruments RT Series Hardware:


  • PXI
    • Any PXI-RT controller
  • FieldPoint
    • Any Compact FieldPoint controller
  • CompactRIO
    • Any CompactRIO controller is supported. A default bitfile is provided for the cRIO-9103 with NI-9215, NI-9263, NI-9411 and NI-9474 I/O modules. If you are using a different controller or a different set of I/O modules you can use LabVIEW FPGA module to compile a custom bitfile.
    • You can use the Single Point Timed I/O Timing Engine in the FPGA Wizard to help create the FPGA VI for use with SIT. FPGA VIs created by the FPGA Wizard can only be used when there is only one HW timed device in the system. If you are using more than one HW timed device (e.g. two R-series boards in a PXI chassi) you need to use the template provide with SIT.
    • If you are using a VxWorks-based controller refer to the X:\SimulationInterfaceToolkit\5.0\VxWorks\readme_sit_vxworks.txt for information about enabling VxWorks support where X is the drive letter where you installed the Simulation Interface Toolkit.
    • National Instruments recommends that you do not install the Scan Engine if you are using the CompactRIO controller with Simulation Interface Toolkit.

The Simulation Interface Toolkit 5.0.1 ships with FPGA VIs for the following FPGA devices:


  • NI PCI-7811R
  • NI PXI-7811R
  • NI PCI-7813R
  • NI PXI-7813R
  • NI PCI-7831R
  • NI PXI-7831R
  • NI PCI-7833R
  • NI PXI-7833R
  • NI cRIO-9103

Accessing the Help and Examples

The LabVIEW Help contains conceptual, how-to, and reference information about the Simulation Interface Toolkit. Complete the following steps to access this help file.


  1. Launch LabVIEW.
  2. Select Help»Search the LabVIEW Help to launch the LabVIEW Help.
  3. Click the Contents tab.
  4. Navigate to the Toolkits»Simulation Interface top-level topic.

The LabVIEW Simulation Interface Toolkit examples are located in the labview\examples\Simulation Interface\ directory.


Development Tips

  • Driver VIs running on NI FPGA devices use the hardware settings for channel measurements.

Known Issues

Installation


  • If you installed the MATLAB application software files as read-only, the SIT Server does not start automatically and you cannot place a SignalProbe block in the Simulink window. You must modify the matlabrc.m file in order to make these changes. Refer to the Communicating with the SIT Server topic in the LabVIEW Help for information about making these changes.

General


  • SIT 4.0 driver VIs do not support controlling replay and datalogging configurations until the simulation is running.
  • You can use only one instance of a typedefed cluster in a SIT host VI.
  • Importing mappings exported in SIT 3.0.x/4.0 may fail to import some signals if the block name has a linefeed in the name.
  • You cannot import hardware mappings exported in SIT 3.0.x/4.0 in SIT 5.0.1.
  • When converting a model to a model DLL, you can improve conversion time by excluding signals from virtual blocks. However, if you exclude these signals, you cannot probe these signals unless you add a non-virtual block to the signal. Complete the following steps to exclude signals from virtual blocks.
    1. Launch the Simulink application software and load the model you want to convert.
    2. For the MATLAB application software release 13, select Simulation»Simulation parameters to launch the Simulation Parameters dialog box.

      For the MATLAB application software release 14, select Simulation»Configuration Parameters to launch the Configuration Parameters dialog box.
    3. Click the Real-Time Workshop tab.
    4. Click the Browse button to launch the System Target File Browser dialog box.
    5. Select nidll.tlc—NI Real-Time Target from the list.
    6. Click the OK button.
    7. For the MATLAB application software release 13, enter nidll.tlc -aNiDisableVirtualBlockMap=1 in the System target file text box.

      For the MATLAB application software release 14, enter -aNiDisableVirtualBlockMap=1 in the TLC options text box.
  • If you do not map file playback channels before you attempt to play back a TDMS file, the driver VI does not execute correctly. Workaround: If you enable file playback, use the Edit Mappings dialog box to map file playback channels before you play back a TDMS file. You also can remove the checkmark from the Enable File Playback option in File Playback page of the SIT Connection Manager dialog box.
  • When you map a fixed-point control or indicator to a model parameter, LabVIEW returns an error when you run the simulation. Workaround: Do not map fixed-point controls or indicators to a model parameter. Instead, map double-precision controls or indicators to model parameters.
  • If you run a driver VI on a non-RT target and want to connect to the driver VI by using a networked PC, you must run the driver VI before attempting to connect to it from the networked PC. You also must complete the following steps on the PC running the driver VI.
    1. Launch LabVIEW and open the driver VI.
    2. Select Tools»Options from the pull-down menu.
    3. Select VI Server: Configuration in the Category list.
    4. Place a checkmark in the TCP/IP checkbox.
    5. Select VI Server: Machine Access in the Category list.
    6. Click the Add button, and enter the IP address of the networked PC in the Machine name/address text box.
    7. Select VI Server: Exported VIs in the Category list.
    8. Click the Add button, and enter the path and name of the driver VI in the Exported VI text box.
    9. Click the OK button.
  • If you are running a multirate simulation and a lower-priority task finishes late, this late finish forces the driver VI to report an overrun, which halts the simulation.
  • If you map more than one model signal to a host VI indicator, the signals tree does not automatically highlight the signals you selected.
  • The target model of a model reference block cannot contain a SignalProbe block. Placing a SignalProbe block in a target model prevents the simulation from running.
  • If you do not specify any signals to probe, SIT 5.0.1 does not return the current simulation time in the Simulation Details dialog box.
  • Waveform charts might scroll incorrectly to a slightly different time than the end time of the simulation. For example, the chart might display 299.90 instead of 300.00. This is an issue with the LabVIEW chart. Workaround: Enter the correct end time into the scale of the chart to show the appropriate data.
  • If you run a simulation more than once, an XY graph does not clear between runs.
  • You cannot use SIT to connect to a Simulation Environment in the Simulink application software release 14.0. You can connect using the Simulink application software releases 14.1, 14.2, or 14.3.
  • SIT is listed under LabVIEW 5.0 in NI License Manager if SIT is installed but LabVIEW 8.6 is not installed.
  • SIT I/O blocks are not supported in triggered subsystems.

Documentation


  • The LabVIEW Help does not include topics for the following VIs:
    • SIT Probe Data Log Signals
    • SIT Read Replay FIFO
  • The LabVIEW Help does not include topics for the following palettes:
    • Data Logging (subpalette of Model Interface)
    • File Playback (subpalette of Model Interface)
    • Data Logging (subpalette of User Interface)
    • File Playback (subpalette of User Interface)
    The LabVIEW Help incorrectly states that VIs on these palettes are owned by the higher-level Model Interface and User Interface palettes. However, the VI documentation is otherwise accurate.

Bug Fixes

The following items are the IDs and titles of issues fixed in the Simulation Interface Toolkit 5.0.1.


129413 Placing a forward slash character in a block name prevents mapping to that signal.
123348 Building a model DLL can produce unterminated character error in certain circumstances.
129060 Remove dependency on MFC from codegen.
121733 In NI-FPGA plug-in, PWM In only retains results for one clock cycle.
121727 In NI-FPGA plug-in, PWM output does not function as expected.
121580 NI-DAQ plug-in does not request RTSI if only analog outputs are configured.
121253 All elements of a Vector Inport/Outport have the same value when the vector is greater than four elements wide.
132726 Unable to save a model with a signal probe in The MathWorks, Inc. Simulink® software release 14.

The following items are the IDs and titles of issues fixed in the Simulation Interface Toolkit 5.0.


97408 There are incorrect values for some multi-rate models.
69875 The SIT Connection Manager hangs if you try to map a control or indicator with a model that has no parameters or signals.
60086 Using SIT in Simulation Environment Mode crashes the Simulink software when probing signals.
59224 sit Get Current Data.vi needs to be re-entrant.
58830 Multiple SIT DLLs do not work on a single RT target.
58826 When you are using multiple DLLs with SIT 4.0, you cannot run models.
35937 Remove cRIO Calibration VIs from SIT personality.
104172 Error 2206 in driver VI when you stop a simulation programmatically.
95267 Making a mapping and then deleting control ConnMngr results in error 1055 on close.
61309 If you cancel the SIT Connection Manager after adding a new mapping, the mapping is retained.
59012 Not able to probe fixed-point values.
58993 Multi-rate model with no inports hangs.
58830 Multiple SIT DLLs do not work on a single RT target.
58550 _FTPToTarget.llb contains duplicate VIs of other places in VI.lib.
58441 Virtual signal from inport does not become available for probing in DLL.
58438 Virtual signal from Demux does not probe correct part of original signal.
57944 Exiting Data Log Dialog in maximized state makes it appear behind the ConnMngr the next time it's launched.
57845 Opening SIT example models in R13 (Simulink software 5.0) produces a warning.
57842 Block with more than one output port does not work correctly in SIT DLL for R14.2 and later.
57831 Logging more than 63 signals in TDMS in SimEnv shifts logged data up one channel.
57477 Probing 2D signals in DLL returns 1D array in client VI.
57468 Getting Error 42 when running a client VI with TDMS logging disabled.
57369 Compile error with models with long file names.
57293 Allow users to configure time stamp format for data log files.
57228 Allow mapping to masked S-Function parameters.
57156 Start driver VI immediately without waiting for client.
56852 There are problems parsing models saved on another platform.
56829 SIT needs better error reporting for ftp of DLL.
56806 List of FPGA targets does not update if they have changed after first search.
56731 TLC build error in R2006a with a model that has Inline Parameters off and contains a Model Reference block.
56223 Allow setting of decimation and halt on data loss options in the SIT Connection Manager instead of only in the Simulation Details dialog box.
56122 Handle complex parameters and signals in the Simulink environment (complex vector inports).
54354 In the SIT Connection Manager, add an option for scaling or not scaling controls to parameter size.
42732 Model parameters show up twice.
40538 Remap dialog doesn't refresh Model Signals or Parameters tree when rearranging Current Mappings.
40525 Remap Dialog can be shut down with error 1055 (invalid object reference).
40190 Clean up host VI running as a executable.
40165 SIT mappings scroll bar does not update position.
39101 Error 1077 when setting Knob max scale to infinity.
38552 Simulation Interface Toolkit shows error when using international regional settings.

Copyright


© 2002–2008 National Instruments Corporation. All rights reserved.


Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.


Trademarks


MATLAB®, Real-Time Workshop®, Stateflow®, and Simulink® are registered trademarks of The MathWorks, Inc.


CompactRIO, FieldPoint, LabVIEW, National Instruments, NI, and ni.com are trademarks of National Instruments Corporation. Other product and company names are trademarks or trade names of their respective companies.


Only Licensed Use is Permitted


You are only permitted to use this product in accordance with the accompanying license agreement. All rights not expressly granted to you in the license agreement accompanying the product are reserved to NI. Further, and without limiting the forgoing, no license or any right of any kind (whether by express license, implied license, the doctrine of exhaustion or otherwise) is granted under any NI patents or other intellectual property right of NI with respect to any other product(s) of NI or of anyone else (including without limitation, the MATLAB, Simulink and or the Real-Time Workshop software of The MathWorks, Inc.), including without limitation, the right to use any of these other products. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.


Patents


For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.