<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta name="ContentType" content="readme" />
<meta name="ProductCategories" content="318601" />
<meta name="Section" content="support" />
<meta name="PageType" content="leaf" />
<meta name="DeliveredBy" content="readme file" />
<meta name="DocStatus" content="current" />
<meta name="Language" scheme="rfc3066" content="en" />
<meta name="ShortTitle" content="FlexLogger 2020 R1 Readme" />
<title>FlexLogger 2020 R1 Readme - National Instruments</title>
<style type="text/css">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</style>


<meta http-equiv="x-dns-prefetch-control" content="on">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="dns-prefetch" href="//assets.adobedtm.com">
<link rel="dns-prefetch" href="//dpm.demdex.net">
<link rel="dns-prefetch" href="//ds.serving-sys.com">
<link rel="dns-prefetch" href="//bs.serving-sys.com">
<link rel="dns-prefetch" href="//nsmetrics.ni.com">
<link rel="dns-prefetch" href="//cdn.tt.omtrdc.net">
<link rel="dns-prefetch" href="//ni.tt.omtrdc.net">
<link rel="dns-prefetch" href="//s7d5.scene7.com">
<link rel="dns-prefetch" href="//ni.scene7.com">

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="Wrapper" content="yes" />

<script type="text/javascript" src="/niassets/jquery/js/jquery.min.js"></script>

<script src="/niassets/js/niua.min.js"></script>


<script src="//assets.adobedtm.com/a3a673425858388bc1b1e0ed01eb252ad8ce12e0/satelliteLib-1401ce0fc9dae9e8602fcc34896d0a249c42abb2.js"></script>


<script type="text/javascript" src="/niassets/jquery/js/jquery-migrate-1.2.1.min.js"></script>

<script type="text/javascript" src="/niassets/bootstrap/js/bootstrap.min.js"></script>

<script type="text/javascript" src="/niassets/jquery/jqueryui/js/jquery-ui.min.js"></script>

<link rel="stylesheet" href="/niassets/bootstrap/css/bootstrap.min.css">
<script type="text/javascript" src="/niassets/ni.min.js"></script>

<link rel="stylesheet" type="text/css" href="/niassets/jquery/jqueryui/css/jquery-ui.min.css">


<link rel="stylesheet" type="text/css" href="/niassets/ni.min.css">
<link rel="stylesheet" type="text/css" href="/niassets/wrapper/css/non-responsive-specific.css">
</head>
<body>
<div class="ni-page-wrap">
<div class="ni-wrapper-header noindex">



<nav class="navbar navbar-default">

<div class="container-fluid">
<div class="row">
<div class="container">
<div class="row">
<div class="ni_logo col-md-5 col-xs-4">
<a href="//www.ni.com/" class="navbar-brand analytics-utilitylogo-link"></a>
</div>
<div class="utility-nav col-md-7 pull-right">
<ul class="nav nav-pills pull-right">

<li class="hidden-xs myaccount-utility">
<span class="pull-left user"></span>
<span class="global-header-nav-up-wrap"></span>
</li>

<li class="cart cart-badge analytics-utilitycart-link" data-badge="0"><a href="http://sine.ni.com/apps/utf8/nios.store?action=view_cart&amp;loc=en-US">&nbsp;</a></li>

<li class="visible-xs search search-box" role="button" data-toggle="modal" data-target="#wrapperSearchModal">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="48px" height="48px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#FFFFFF" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z" />
</g>
</g>
</svg>
</li>


<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</ul>
</div>
</div>
</div>
</div>
<div class="row">
<div class="container">
<div class="row">
<div class="ni-nav col-md-8 col-sm-9 pull-left col-xs-12">
<div id="navbar" class="navbar-collapse collapse">
<ul class="nav navbar-nav">
<li class="innovations ">
<a class="analytics-header-link" href="//www.ni.com/innovations/">INNOVATIONS</a>
</li>
<li class="products ">
<a class="analytics-header-link" href="//www.ni.com/shop/">PRODUCTS</a>
</li>
<li class="support  current">
<a class="analytics-header-link" href="//www.ni.com/en-us/support.html">SUPPORT</a>
</li>
<li class="community ">
<a class="analytics-header-link" href="//forums.ni.com">COMMUNITY</a>
</li>
<li class="nav-myaccount visible-xs">
<span class="pull-left user"></span>
<div class="mobile-nav-up-wrap">
<a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">My Account</a>
<br>
<span>
<a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">Log in</a>
</span>
</div>
</li>
</ul>
<div class="hidden-xs" id="navSlider">&nbsp;</div>
</div>

</div>
<div class="col-md-4 col-sm-3 pull-right col-xs-4 global-header-search">
<div class="hidden-xs pull-right">
<form id="autoComplete-global" name="autoComplete-global" type="GET" action="//search.ni.com/nisearch/app/main">
<div class="autoCompleteItem-global">
<div class="input-group stylish-input-group">

<input placeholder="" class="niAutocompleteInput pull-right" data-search-type="globalSearch" type="text" id="n33_autoCompleteInput" name="q" />
<input type="hidden" name="pg" id="pg" value="1" />
<input type="hidden" name="sn" id="sn" value="" />
<span class="input-group-addon">
<button type="submit">
<span class="search search-icon">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="35px" height="35px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#065FA3" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z" />
</g>
</g>
</svg>
</span>
</button>
</span>
</div>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<div class="container global-header-breadcrumb">
</div>
<link rel="stylesheet" type="text/css" href="//zone.ni.com/css/reference/common/help.css">
<div class="container-fluid">
<div id="breadcrumb" class="breadcrumb row">
<span class="noindex ni-body-copy-secondary container">
<a href="//www.ni.com">Home</a><span class="delimiter"></span><a href="//www.ni.com/support">Support</a><span class="delimiter"></span><a href="//www.ni.com/manuals">Manuals</a><span class="delimiter"></span><a href="#">FlexLogger 2020 R1 Readme</a>
</span>
</div>
</div>
<div class="container">
<div class="row">
<div class="col-xm-12">
<h1>FlexLogger 2020 R1 Readme</h1>
<p>January 2020</p>
<p>This file contains important information about FlexLogger, including system requirements, installation instructions, and supported hardware.</p>
<hr>
<a name="top"></a>
<p><a href="#overview">Overview</a></p>
<p><a href="#requirements">System Requirements</a></p>


<p><a href="#installation">Installation Instructions</a></p>

<p><a href="#updates">Product Security and Critical Updates</a></p>
<p><a href="#New">New Features</a></p>
<p><a href="#hardware">Supported Hardware</a></p>


<p><a href="#plugin">Extending FlexLogger with the FlexLogger Plugin Development Kit</a></p>
<p><a href="#help">Accessing the Help</a></p>


<p><a href="#meta">Changes to Log File Metadata in FlexLogger 2019 R4</a></p>
<p><a href="#win10">Using NI Software with Microsoft Windows 10</a></p>
<p><a href="#win8">Using NI Software with Microsoft Windows 8.1</a></p>
<p><a href="#win32bit">FlexLogger Drops Support for Windows 7 64-bit in 2021</a></p>
<p><a href="#legal">Legal Information</a></p>

<hr>
<h2><a name="overview">Overview</a></h2>
<p>FlexLogger is application software for quick sensor configuration and data logging of mixed signals to verify electromechanical systems, all without programming.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>
<h2><a name="requirements">System Requirements</a></h2>
<p>FlexLogger has the following minimum system requirements:</p>
<table border="1">
<tbody>
<tr>
<th width="195" scope="col">&nbsp;<strong>Operating System</strong></th>
<th width="211" scope="col">&nbsp;<strong>RAM/Processor</strong></th>
<th width="142" scope="col">&nbsp;<strong>Required Software<sup>1</sup></strong></th>
</tr>
<tr>
<td><ul>
<li>64-bit version of Windows 10/8.1<sup>2</sup>/7 SP1<sup>3</sup></li>
<li>1024 x 768 resolution (1366 x 768 or higher recommended)</li>
</ul></td>
<td><ul>
<li>Pentium 4 G1 equivalent (Intel i5 equivalent or higher recommended)</li>
<li>12 GB disk space</li>
<li>4 GB RAM (8 GB or more recommended)</li>
</ul></td>
<td><ul>
<li>NI-DAQmx software 19.5 or higher</li>
<li>NI-XNET software 19.1 or higher</li>
</ul></td>
</tr>
<tr><td colspan="3"><p><sup>1</sup> Required drivers are included with the FlexLogger installer.</p>
<p><sup>2</sup> NI software installs VC2015 Runtime and .NET 4.6.2. Windows 8.1 requires Microsoft updates to support these items. Refer to Microsoft <a href="http://digital.ni.com/express.nsf/bycode/expfcj" target="_blank">KB2919442</a> and <a href="http://digital.ni.com/express.nsf/bycode/exkd3p" target="_blank">KB2919355</a> for more information about how to install these updates.</p>
<p><sup>3</sup> NI software is signed with a SHA-256 certificate. Windows 7 SP1 requires Microsoft updates to support SHA-256. Refer to Microsoft <a href="http://digital.ni.com/express.nsf/bycode/exf7ig" target="_blank">KB3033929</a> for more information about how to install this security update.</p>
</td></tr>
</tbody>
</table>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="installation">Installation Instructions</a></h2>
<p>NI automates FlexLogger installation using NI Package Manager. Visit <span class="Monospace">ni.com/info</span> and enter the Info Code <a href="http://digital.ni.com/express.nsf/bycode/NIPMDownload" target="_blank">NIPMDownload</a> to download NI Package Manager. Refer to the <a href="http://digital.ni.com/express.nsf/bycode/NIPMManual" target="_blank">NI Package Manager Manual</a> for more information about installing, removing, and upgrading NI software using NI Package Manager.</p>

<p class="Body"><a href="#top">Back to Top</a></p>
<hr>


<h2><a name="updates">Product Security and Critical Updates</a></h2>
<p>Visit <a href="http://www.ni.com/security" target="_blank">ni.com/security</a> to view and subscribe to receive security notifications about NI products. Visit <a href="http://ni.com/critical-updates" target="_blank">ni.com/critical-updates</a> for information about critical updates from NI.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="New">New Features</a></h2>
<h3>2020 R1 (January 2020)</h3>
<ul>
<li>Added PXI Express support for SC Express, sound and vibration, and automotive bus modules. Refer to the <a href="#hardware">Supported Hardware</a> section for specific model information.</li>
<li>Added hardware support for:
<ul><li>NI 9262</li>
</ul></li>
<li>Added support for LVDT/RVDT sensors</li>
<li>XY graph type added to Screens</li>
<li>Event triggering on test stop</li>
</ul>
<h3>2019 R4 (September 2019)</h3>
<ul><li>Added hardware support for:
<ul><li>NI 9252</li>
<li>NI 9253</li>
</ul>
<li>Apply zero and null offset calibration to multiple channels simultaneously</li>
<li>Export alarm history to CSV file format</li>
<li><strong>Save project as</strong> support for existing projects</li>
<li>Event triggered on test time elapsed</li>
<li>Toast notification support for channel alarms</li>
<li>Integrated system health metric reporting</li>
<li>Digital input support in arithmetic and boolean formulas</li>
<li>Calculation formula support for logarithm functions, ? : operator, and <em>e</em>, true, and false constants</li>
<li>Configurable sample rate for CAN/LIN</li>
<li>Support for custom analysis plugins created with the FlexLogger Plugin Development Kit 1.1</li>
</li>
</ul>
<h3>2019 R3 (July 2019)</h3>
<ul><li>Added hardware support for the FD-11605</li>
<li>Alarms for input channels, including the following features:</li>
<ul><li>Alarm history pane</li>
<li>Event triggering from alarms</li>
</ul>
<li>Reset values on output channels</li>
<li>Additional measurement types for counter input modules:</li>
<ul><li>Angular position</li>
<li>Linear position</li>
<li>Pulse</li>
</ul>
<li>Hardware filter support for FieldDAQ</li>
<li>Support for custom plugins created with the FlexLogger Plugin Development Kit 1.0</li>
<li>Boolean logic for analog channels</li>
<li>Digital input event triggering</li>
<li>Output support for LIN</li>
<li>LIN master support</li>
<li>Offline FlexLogger manual access</li>
</ul>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="hardware">Supported Hardware</a></h2>
<p>The following tables detail the hardware models supported in FlexLogger.</p>
<h3>CompactDAQ</h3>
<br>
<h3>CompactDAQ Chassis</h3>
<br>
<table border="1">
<thead>
<tr>
<th>NI Product</th>
<th><span style="white-space:nowrap">Model Name</span></th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td rowspan="11">CompactDAQ Chassis</td>
<td>cDAQ-9171</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9174</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9178</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9179</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9181</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9184</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9185</td>
<td>This chassis supports network synchronization using IEEE 802.1AS protocol. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/using-network-synchronization/" target="_blank">Using Network Synchronization in Your Acquisition</a> topic for more information.</td>
</tr>
<tr>
<td>cDAQ-9188</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td><span style="white-space:nowrap">cDAQ-9188XT</span></td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>cDAQ-9189</td>
<td>This chassis supports network synchronization using IEEE 802.1AS protocol. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/using-network-synchronization/" target="_blank">Using Network Synchronization in Your Acquisition</a> topic for more information.</td>
</tr>
<tr>
<td>cDAQ-9191</td>
<td align="center">&mdash;</td>
</tr>
</tbody>
</table>
<p></p>
<h3>C Series Modules</h3>
<br>
<table border="1">
<thead>
<tr>
<th>NI Product</th>
<th><span style="white-space:nowrap">Model Name</span></th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td rowspan="20">C Series Voltage Input Modules</td>
<td>NI 9201</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9202</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9205</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9206</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9209</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9215</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9220</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9221</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9222</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9223</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9224</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9225</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9228</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9229</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9238</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9239</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9242</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9244</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9251</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9252</td>
<td>The NI 9252 module supports hardware filtering. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/reducing-signal-noise/" target="_blank">Reducing Signal Noise</a> topic for more information.</td>
</tr>
<tr>
<td rowspan="4">C Series Voltage Output Modules</td>
<td>NI 9262</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9263</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9264</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9269</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="6">C Series Current Input Modules</td>
<td>NI 9203</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9208</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9227</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9246</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9247</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9253</td>
<td>The NI 9253 module supports hardware filtering. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/reducing-signal-noise/" target="_blank">Reducing Signal Noise</a> topic for more information.</td>
</tr>
<tr>
<td rowspan="2">C Series Current Output Modules</td>
<td>NI 9265</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9266</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>C Series Voltage and Current Input Module</td>
<td>NI 9207</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="5">C Series Sound and Vibration Input Modules</td>
<td>NI 9230</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9231</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9232</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9234</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9250</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="8">C Series Temperature Input Modules</td>
<td>NI 9210</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9211</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9212</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9213</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9214</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9216</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9217</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9226</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="2">C Series Universal Analog Input Modules</td>
<td>NI 9218</td>
<td>For the <span style="white-space:nowrap">NI 9218</span>, all connectivity accessories must be configured in MAX in order to appear in your FlexLogger project.</td>
</tr>
<tr>
<td>NI 9219</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="3">C Series Strain/Bridge Input Modules</td>
<td>NI 9235</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9236</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9237</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>C Series Counter Input Module</td>
<td>NI 9361</td>
<td>FlexLogger supports pull-up resistor functionality and input voltage threshold for the <span style="white-space:nowrap">NI 9361</span>.
</td>
</tr>
<tr>
<td rowspan="7">C Series Digital Modules (serial digital I/O)</td>
<td>NI 9375</td>
<td rowspan="7">
<ul>
<li>The NI 9375 can only use one port (input or output) at a time in a project.</li>
<li>You cannot use parallel and serial modules together on the same FlexLogger project unless they are installed in separate cDAQ chassis.</li>
</ul>
</td>
</tr>
<tr>
<td>NI 9403</td>
</tr>
<tr>
<td>NI 9425</td>
</tr>
<tr>
<td>NI 9426</td>
</tr>
<tr>
<td>NI 9476</td>
</tr>
<tr>
<td>NI 9477</td>
</tr>
<tr>
<td>NI 9478</td>
</tr>
<tr>
<td rowspan="16">C Series Digital Modules (parallel digital I/O)</td>
<td>NI 9344</td>
<td rowspan="16">You cannot use parallel and serial modules together on the same FlexLogger project unless they are installed in separate cDAQ chassis.</td>
</tr>
<tr>
<td>NI 9401</td>
</tr>
<tr>
<td>NI 9402</td>
</tr>
<tr>
<td>NI 9411</td>
</tr>
<tr>
<td>NI 9421</td>
</tr>
<tr>
<td>NI 9422</td>
</tr>
<tr>
<td>NI 9423</td>
</tr>
<tr>
<td>NI 9435</td>
</tr>
<tr>
<td>NI 9436</td>
</tr>
<tr>
<td>NI 9437</td>
</tr>
<tr>
<td>NI 9472</td>
</tr>
<tr>
<td>NI 9474</td>
</tr>
<tr>
<td>NI 9475</td>
</tr>
<tr>
<td>NI 9481</td>
</tr>
<tr>
<td>NI 9482</td>
</tr>
<tr>
<td>NI 9485</td>
</tr>
<tr>
<td rowspan="3">C Series CAN and Vehicle Multiprotocol Interface Modules</td>
<td>NI 9860</td>
<td>FlexLogger supports all compatible transceiver cables for the NI 9860 (<span style="white-space:nowrap">TRC-8542</span>, <span style="white-space:nowrap">TRC-8543</span>, and <span style="white-space:nowrap">TRC-8546</span>).</td>
</tr>
<tr>
<td>NI 9861</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>NI 9862</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>C Series LIN Interface Module</td>
<td>NI 9866</td>
<td align="center">&mdash;</td>
</tr>
</tbody>
</table>
<p></p>
<h3>FieldDAQ Devices</h3>
<br>
<table border="1">
<thead>
<tr>
<th>NI Product</th>
<th>Model Name</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td rowspan="3">Voltage Input Devices for FieldDAQ</td>
<td>FD-11601</td>
<td>External powered sensor configuration is supported in FlexLogger.</td>
</tr>
<tr>
<td>FD-11603</td>
<td>Revision B and later of the <span style="white-space:nowrap">FD-11603</span> supports hardware filtering. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/reducing-signal-noise/" target="_blank">Reducing Signal Noise</a> topic for more information.</td>
</tr>
<tr>
<td>FD-11605</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>Sound and Vibration Input Devices for FieldDAQ</td>
<td>FD-11634</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>Strain/Bridge Input Devices for FieldDAQ</td>
<td><span style="white-space:nowrap">FD-11637</span></td>
<td>Revision B and later of the <span style="white-space:nowrap">FD-11637</span> supports hardware filtering. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/reducing-signal-noise/" target="_blank">Reducing Signal Noise</a> topic for more information.</td>
</tr>
<tr>
<td rowspan="2">Temperature Input Devices for FieldDAQ</td>
<td>FD-11613</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>FD-11614</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td colspan="3">
<p><strong>Note:</strong> FieldDAQ devices support network synchronization using <span style="white-space:nowrap">IEEE 802.1AS</span> protocol. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/using-network-synchronization/" target="_blank">Using Network Synchronization in Your Acquisition</a> topic for more information.</p>
<p><strong>Note:</strong> FieldDAQ devices support hardware filtering. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/reducing-signal-noise/" target="_blank">Reducing Signal Noise</a> topic for more information. (See <strong>Notes</strong> column for exceptions.)</p>
</td>
</tr>
</tbody>
</table>
<h4>&nbsp;</h4>
<h3>PXI Express</h3>
<br>
<h4>PXI Chassis</h4>
<br>
<table border="1">
<thead>
<tr><th>NI Product</th><th>Notes</th></tr>
</thead>
<tbody>
<tr><td>PXIe-1062Q</td><td rowspan="3">FlexLogger does not support any module used in a PXI peripheral slot.</td></tr>
<tr><td>PXIe-1065</td></tr>
<tr><td>PXIe-1066DC</td></tr>
<tr><td>PXIe-1073</td><td align="center">—</td></tr>
<tr><td>PXIe-1075</td><td align="center">—</td></tr>
<tr><td>PXIe-1078</td><td align="center">—</td></tr>
<tr><td>PXIe-1082</td><td align="center">—</td></tr>
<tr><td>PXIe-1082DC</td><td align="center">—</td></tr>
<tr><td height="23">PXIe-1084</td><td align="center">—</td></tr>
<tr><td><span style="white-space:nowrap">PXIe-1085 (12 GB/s and 24GB/s)</span></td><td align="center">—</td></tr>
<tr><td>PXIe-1092</td><td align="center">—</td></tr>
<tr><td>PXIe-1095</td><td align="center">—</td></tr>
</tbody>
</table>
<p></p>
<p><strong>PXI Controllers</strong></p>
<p>Supported embedded controllers must meet the minimum system requirements. Refer to the <a href="#requirements">System Requirements</a> section for more information.</p>
<p></p>
<h4>PXI Modules</h4>
<br>
<table border="1">
<thead>
<tr>
<th>NI Product</th>
<th>Model Name</th>
<th>Compatible Accessories</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td rowspan="7">PXI Analog Input Modules</td>
<td><span style="white-space:nowrap">PXIe-4300</span></td>
<td>
<ul>
<li>TB-4300</li>
<li>TB-4300B</li>
<li>TB-4300C</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4302</td>
<td>
<ul>
<li>TB-4302</li>
<li>RM-4302</li>
<li>TB-4302C</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4303</td>
<td>
<ul>
<li>TB-4302</li>
<li>RM-4302</li>
<li>TB-4302C</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4304</td>
<td>
<ul>
<li>TB-4304</li>
<li>RM-4304</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4305</td>
<td>
<ul>
<li>TB-4304</li>
<li>RM-4304</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4309</td>
<td>
<ul>
<li><span style="white-space:nowrap">TB-4309 (ST)</span></li>
<li><span style="white-space:nowrap">TB-4309 (MT)</span></li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4310</td>
<td>
<ul>
<li>TB-4310</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="3">PXI Strain/Bridge Input Module</td>
<td>PXIe-4330</td>
<td>
<ul>
<li>TB-4330</li>
<li><span style="white-space:nowrap">RM-24999</span></li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4331</td>
<td>
<ul>
<li>TB-4330</li>
<li>RM-24999</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4339</td>
<td>
<ul>
<li>TB-4339</li>
<li>TB-4339B</li>
<li>TB-4339C</li>
<li>RM-4339</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXI Displacement Input Module</td>
<td>PXIe-4340</td>
<td>
<ul>
<li>TB-4340</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="2">PXI Temperature Input Module</td>
<td height="49">PXIe-4353</td>
<td>
<ul>
<li>TB-4353</li>
<li>TC-4353</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4357</td>
<td>
<ul>
<li>TB-4357</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXI Analog Output Module</td>
<td>PXIe-4322</td>
<td>
<ul>
<li>TB-4322</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td rowspan="7">PXI Sound and Vibration Modules</td>
<td>PXIe-4464</td>
<td align="center">&mdash;</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4480</td>
<td align="center">&mdash;</td>
<td>FlexLogger 2020 R1 does not support the Charge measurement type.</td>
</tr>
<tr>
<td>PXIe-4492</td>
<td align="center">&mdash;</td>
<td rowspan="5">FlexLogger automatically selects the <span style="white-space:nowrap">Medium (100 Hz)</span> data rate for the <span style="white-space:nowrap">PXIe-449<em>x</em></span>. Using data rates between <span style="white-space:nowrap">1,000 Hz</span> and <span style="white-space:nowrap">8,000 Hz</span> with the <span style="white-space:nowrap">PXIe-449<em>x</em></span> may cause delays when configuring channels.</td>
</tr>
<tr>
<td>PXIe-4496</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4497</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4498</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXIe-4499</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXI Vehicle Multiprotocol Interface Module</td>
<td><span style="white-space:nowrap">PXIe-8510</span> (2-Port and 6-port)</td>
<td>
<ul>
<li>TRC-8542</li>
<li>TRC-8543</li>
<li>TRC-8546</li>
</ul>
</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>PXI CAN Interface Module</td>
<td>PXI-8512 (1-port and 2-port)</td>
<td align="center">&mdash;</td>
<td rowspan="2">Must be used in a PXIe Hybrid Compatible slot of a supported PXI Express chassis. For additional information on PXI compatibility with PXI Express chassis, visit <a href="http://www.ni.com/r/pxicompatibility" target="_blank">ni.com/r/pxicompatibility</a>.</td>
</tr>
<tr>
<td>PXI LIN Interface Module</td>
<td>PXI-8516</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td colspan="4"><strong>Note:</strong> FlexLogger does not currently support synchronization between multiple chassis or other devices in the system.
</td>
</tr>
</tbody>
</table>
<h3>USB Devices</h3>
<br>
<table border="1">
<thead>
<tr>
<th>NI Product</th>
<th><span style="white-space:nowrap">Model Name</span></th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAN Interface Devices</td>
<td>USB-8502</td>
<td align="center">&mdash;</td>
</tr>
<tr>
<td>LIN Interface Devices</td>
<td>USB-8506</td>
<td align="center">&mdash;</td>
</tr>
</tbody>
</table>
<p></p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>


<h2><a name="plugin">Extending FlexLogger with the FlexLogger Plugin Development Kit</a></h2>
<p class="Body">You can extend the functionality of FlexLogger (version 2019 R4 or higher) by creating and importing a custom plugin using the FlexLogger Plugin Development Kit (version 1.1). The FlexLogger Plugin Development Kit is available for download in NI Package Manager. Refer to the <a href="http://www.ni.com/r/flexloggerplugin1.1rm">FlexLogger Plugin Development Kit 1.1 Readme</a> for more information.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="help">Accessing the Help</a></h2>

<p class="Body">The online FlexLogger manual contains the most current help for your product version. Refer to the <a href="http://www.ni.com/documentation/en/flexlogger/latest/manual/manual-overview/">FlexLogger Manual</a>, accessible from <strong>Help»FlexLogger manual</strong>, for more information about using FlexLogger.</p>
<p class="Body">Users without online access can choose to use an offline version of the FlexLogger manual. To enable the use of the offline FlexLogger manual, go to <strong>File&#0187;Preferences&#0187;General</strong> and select <strong>Always use offline manual</strong>.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="meta">Changes to Log File Metadata in FlexLogger 2019 R4</a></h2>
<p class="Body">In FlexLogger 2019 R4, metadata properties organized as a hierarchy are defined by a tilde (~) character between properties. Previous FlexLogger versions used a double greater symbol (&#0062;&#0062;) to separate these metadata properties. Any data post-processing configured to use &#0062;&#0062; may produce unexpected results.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="win10">Using NI Software with Microsoft Windows 10</a></h2>
<p>Microsoft Windows 10 is the latest version of the Windows operating system and features significant changes compared to previous versions. Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. For more information about NI support for Windows 10, visit <a href="http://ni.com/windows10" target="_blank">ni.com/windows10</a>.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="win8">Using NI Software with Microsoft Windows 8.1</a></h2>
<p>When you install NI software on Microsoft Windows 8.1, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement &amp; Automation Explorer (NI MAX), and NI Launcher. For more information about NI support for Windows 8.1, visit <a href="http://ni.com/windows8" target="_blank">ni.com/windows8</a>.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>


<h2><a name="win32bit">FlexLogger Drops Support for Windows 7 (64-Bit)</a></h2>
<p>FlexLogger will drop support for Windows 7 (64-bit) operating systems starting in 2021. Versions of this product that ship after May 1, 2021, will not install or run on this operating system. For detailed information about NI operating system support, visit <a href="http://www.ni.com/r/windows764bit" target="_blank">ni.com/r/windows764bit</a>.</p>
<p class="Body"><a href="#top">Back to Top</a></p>
<hr>

<h2><a name="legal">Legal Information</a></h2>

<p><strong>Copyright</strong></p>
<p>© 2017&ndash;2020 National Instruments. All rights reserved.</p>
<p>Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.</p>
<p>NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.</p>
<p><strong>End-User License Agreements and Third-Party Legal Notices</strong></p>
<p>You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:</p>
<ul>
<li>Notices are located in the <span class="Monospace">&lt;National Instruments&gt;\_Legal Information</span> and <span class="Monospace">&lt;National Instruments&gt;</span> directories.</li>
<li>EULAs are located in the <span class="Monospace">&lt;National Instruments&gt;\Shared\MDF\Legal\license</span> directory.</li>
<li>Review <span class="Monospace">&lt;National Instruments&gt;\_Legal Information.txt</span> for information on including legal information in installers built with NI products.</li>
</ul>
<p><strong>U.S. Government Restricted Rights</strong></p>
<p>If you are an agency, department, or other entity of the United States Government (&quot;Government&quot;), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.</p>
<p><strong>IVI Foundation Copyright Notice</strong></p>
<p><span class="DNL">Content from the IVI specifications reproduced with permission from the IVI Foundation.</span></p>
<p><span class="DNL">The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.</span></p>

<p><strong>Trademarks</strong></p>
<p>Refer to the <em><span class="DNL">NI Trademarks and Logo Guidelines</span></em> at <a href="http://digital.ni.com/express.nsf/bycode/rdtrad" target="_blank"><span class="DNL">ni.com/trademarks</span></a> for information on <span class="DNL">NI</span> trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.</p>

<p><strong>Patents</strong></p>
<p>For patents covering the NI products/technology, refer to the appropriate location: <strong>Help»Patents</strong> in your software, the <span class="Monospace">patents.txt</span> file on your media, or the <em>NI Patent Notice</em> at <a href="http://digital.ni.com/express.nsf/bycode/rdlv17" target="_blank">ni.com/patents</a>.</p>
<p>377046H-01</p>
</div>
</div>
</div>

<div id="cookieLaw" class="ni-darkgrey" style="display: none;">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-10">
<p>This site uses cookies to offer you a better browsing experience. Learn more about <a href="//www.ni.com/legal/privacy/unitedstates/us/">our privacy policy.</a></p>
</div>
<div class="col-xs-12 col-sm-2 text-right">
<button id="btnUnderstood" class="ni-uppercase ni-btn ni-btn-tertiary" type="button">OK</button>
</div>
</div>
</div>
</div>


<div class="footer noindex">
<footer class="footer noindex">
<div class="container-fluid">
<div class="row">
<div class="container">
<div class="row clearfix">

<div class="hidden-xs footer-nav col-xs-12 col-sm-12 col-md-9 col-lg-9">
<div class="col-xs-4 left">
<h4>PRODUCT</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/status/">Order status and history</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-us/shop/cart">Order by part number</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/myproducts/app/main.xhtml?lang=en">Activate a product</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/apps/utf8/niwq.retrieve_quote">Retrieve a quote</a>
</li>
</ul>
</div>
<div class="col-xs-4">
<h4>SUPPORT</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/srm/app/myServiceRequests">Submit a service request</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/manuals/">Manuals</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/downloads/drivers/">Drivers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/alliance/">Alliance Partners</a>
</li>
</ul>
</div>
<div class="col-xs-4">
<h4>COMPANY</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/company/">About National Instruments</a>
</li>
<li>
<a class="analytics-footer-link" href="//investor.ni.com/">Investor Relations</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-us/events.html">Events</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/careers/">Careers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/contact-us/">Contact Us</a>
</li>
</ul>
</div>
</div>
<div class="motto-table col-xs-3">

<div class="motto">
<h4>MISSION</h4>
<p>NI equips engineers and scientists with systems that accelerate productivity, innovation, and discovery.</p>
</div>

<div class="footer-social-media">
<div id="niaSvgSocial">
<a href="http://www.facebook.com/NationalInstruments" class="analytics-footer-link"><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33.1,0H2C0.9,0,0.1,0.9,0.1,1.9V33c0,1.1,0.9,1.9,1.9,1.9h16.8V21.3h-4.6V16h4.6v-3.9
c0-4.5,2.8-7,6.8-7c1.9,0,3.6,0.1,4.1,0.2v4.7h-2.8c-2.2,0-2.6,1-2.6,2.6v3.4h5.2l-0.7,5.3h-4.6V35H33c1.1,0,1.9-0.9,1.9-1.9V2
		C35,0.9,34.1,0,33.1,0z" /></svg></a>
<a href="//twitter.com/niglobal" class="analytics-footer-link"><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33,0H2A2,2,0,0,0,0,2V33a2,2,0,0,0,2,2H33a2,2,0,0,0,2-2V2A2,2,0,0,0,33,0ZM26.2,13c0,.19,0,.39,0,.58A12.76,12.76,0,0,1,6.56,24.37a9.45,9.45,0,0,0,1.07.07,9,9,0,0,0,5.58-1.93A4.49,4.49,0,0,1,9,19.4a4.8,4.8,0,0,0,.85.08A4.6,4.6,0,0,0,11,19.32a4.49,4.49,0,0,1-3.6-4.4v-.06a4.41,4.41,0,0,0,2,.56,4.49,4.49,0,0,1-1.38-6,12.73,12.73,0,0,0,9.25,4.69,4.31,4.31,0,0,1-.12-1A4.49,4.49,0,0,1,25,10a8.92,8.92,0,0,0,2.85-1.09,4.43,4.43,0,0,1-2,2.48,9.29,9.29,0,0,0,2.58-.7A9.15,9.15,0,0,1,26.2,13Z" /></svg></a>
<a href="https://www.linkedin.com/company/3433?trk=tyah" class="analytics-footer-link"><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33.1,0H2C0.9,0,0,0.9,0,2v31c0,1.1,0.9,2,2,2H33c1.1,0,2-0.9,2-2V2C35.1,0.9,34.2,0,33.1,0
	 M10.4,30.6H4.7V13.7h5.7V30.6L10.4,30.6z M7.5,11.5L7.5,11.5c-1.9,0-3.1-1.3-3.1-2.9c0-1.7,1.3-2.9,3.2-2.9s3.1,1.3,3.1,2.9
	S9.5,11.5,7.5,11.5 M30.7,30.6h-5.6v-9.1c0-2.3-0.8-3.8-2.9-3.8c-1.6,0-2.5,1-2.9,2.1c-0.1,0.4-0.2,0.9-0.2,1.4v9.5h-5.6
	c0,0,0.1-15.4,0-16.9H19v2.4c0.7-1.2,2.1-2.8,5.1-2.8c3.7,0,6.5,2.4,6.5,7.6C30.7,21,30.7,30.6,30.7,30.6z" /></svg></a>
<a href="//www.youtube.com/nationalinstruments" class="analytics-footer-link"><svg class="footer-social" viewBox="5 -7 37 43"><path style="fill:#FFFFFF;" d="M43.5,5.7c0,0-0.5-3.1-1.8-4.4c-1.7-1.8-3.6-1.8-4.4-1.8C31-1,21.7-1,21.7-1l0,0
				c0,0-9.4,0-15.6,0.5C5.2-0.4,3.3-0.4,1.6,1.3C0.2,2.7-0.1,5.7-0.1,5.7S-0.6,9.4-0.6,13v3.4c0,3.6,0.5,7.2,0.5,7.2
				s0.5,3.1,1.8,4.4c1.7,1.8,4,1.8,4.9,1.9c3.6,0.4,15.2,0.5,15.2,0.5s9.4,0,15.6-0.5c0.8-0.1,2.8-0.1,4.4-1.8
				c1.4-1.4,1.8-4.4,1.8-4.4s0.5-3.6,0.5-7.2v-3.4C44,9.4,43.5,5.7,43.5,5.7z M17,20.5V8l12.1,6.3L17,20.5z" /></svg></a>
</div>
</div>
</div>
</div>
<div class="row desktop">
<div class="container clearfix legal">
<div class="legal-desktop col-xs-8">

<div class="left">
<a class="analytics-footer-link truste-image" href="//privacy.truste.com/privacy-seal/validation?rid=342a514a-c792-40e3-ae36-17c7491387a7" target="_blank">
<img class="img-responsive" src="//privacy-policy.truste.com/privacy-seal/seal?rid=342a514a-c792-40e3-ae36-17c7491387a7" alt="TRUSTe" />
</a>
</div>
<div class="legal-copy">
<a class="analytics-footer-link" href="//www.ni.com/legal/">Legal</a> <span class="pipe">|</span>
<a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal/privacy/privacy-statement.html">Privacy </a>
&nbsp; &copy <span class="copyright"> </span> National Instruments. All rights reserved.
</div>
 </div>
<div class="col-xs-3 col-xs-offset-1">
<div class="footer-gg">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="24px" height="24px" viewBox="0 0 45 45" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#fff" d="M22,0C9.8,0,0,9.8,0,22s9.8,22,22,22s22-9.8,22-22S34.2,0,22,0z M36.4,35.7c-0.3,0.3-0.6,0.6-0.9,0.9l0,0   c-2.6,2.4-6,4.2-9.6,4.8c2.8-2.5,5.1-5.7,6.7-9.2c1.5,0.9,2.8,2,4.1,3.2C36.5,35.6,36.4,35.7,36.4,35.7z M7.6,8.3   C8,8,8.3,7.6,8.6,7.3l0,0c2.6-2.4,6-4.2,9.6-4.8c-2.8,2.5-5.1,5.7-6.7,9.2c-1.5-0.9-2.8-2-4.1-3.2C7.5,8.4,7.6,8.3,7.6,8.3z    M36.4,8.3l0.1,0.1c-1.3,1.3-2.6,2.4-4.1,3.2c-1.6-3.6-3.8-6.7-6.7-9.2c3.8,0.7,7.1,2.5,9.7,4.9l0,0C35.7,7.6,36,8,36.4,8.3z    M21,14.6c-2.6-0.1-5.2-0.8-7.5-1.9c1.6-3.7,4-6.9,7.2-9.5H21V14.6z M21,16.8V21h-9.4c0.1-2.2,0.4-4.3,1.2-6.3   C15.2,15.8,18,16.6,21,16.8z M21,23v4.2c-2.9,0.1-5.8,0.8-8.3,2.1c-0.6-2-1-4.1-1.2-6.3H21z M21,29.4v11.4h-0.3   c-3.2-2.6-5.8-5.9-7.2-9.5C15.7,30.2,18.3,29.5,21,29.4z M23,29.4c2.6,0.1,5.2,0.8,7.5,1.9c-1.6,3.7-4,7-7.2,9.5H23V29.4z M23,27.2   V23h9.3c-0.1,2.2-0.4,4.3-1,6.3C28.8,28.1,26,27.4,23,27.2z M23,21v-4.2c2.9-0.1,5.7-0.8,8.2-2c0.6,2,1,4.1,1.2,6.3H23V21z    M23,14.6V3.1h0.1c3.2,2.6,5.8,5.9,7.3,9.5C28.2,13.8,25.7,14.5,23,14.6z M10.8,13.7C10.1,16,9.5,18.4,9.4,21H2.1   c0.2-4.2,1.7-8.1,4.1-11.1v0.3C7.6,11.5,9.1,12.7,10.8,13.7z M9.4,23c0.1,2.5,0.5,5,1.4,7.2c-1.7,0.9-3.1,2.2-4.5,3.6v0.3   c-2.4-3-3.9-6.9-4.1-11.1H9.4z M7.6,35.7l-0.1-0.1c1.3-1.3,2.6-2.4,4.1-3.2c1.6,3.6,3.8,6.7,6.7,9.2c-3.7-0.7-6.9-2.4-9.6-4.8l0,0   C8.3,36.4,8,36,7.6,35.7z M33.2,30.3c0.7-2.3,1.3-4.7,1.4-7.2h7.3c-0.2,4.2-1.7,8.1-4.1,11.1v-0.3C36.4,32.5,34.9,31.3,33.2,30.3z    M34.6,21c-0.1-2.5-0.5-5-1.4-7.2c1.7-0.9,3.1-2.2,4.5-3.6V9.8c2.4,3.1,3.9,6.9,4.1,11.1H34.6z" />
</g>
</g>
</svg>
<a class="global-gateway analytics-utilitygg-link">
<span class="country">Choose your country</span>
</a>

<div class="gg-panel">
<div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-AU">Australia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pt-BR">Brasil</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-CA">Canada (English)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CA">Canada (Français)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-DE">Deutschland</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-ES">España</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-FR">France</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-IN">India</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="it-IT">Italia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="hu-HU">Magyarország</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-MY">Malaysia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-MX">México</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="nl-NL">Nederland</a>
</li>
</ul>
</div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-AT">Österreich</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pl-PL">Polska</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-CH">Schweiz</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-SG">Singapore</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CH">Suisse</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="sv-SE">Sverige</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-GB">United Kingdom</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-US">United States</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ru-RU">Российская Федерация</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-CN">中国 (China)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ja-JP">日本 (Japan)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ko-KR">대한민국 (Korea)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-TW">中國台灣 （Taiwan, China)</a>
</li>
</ul></div>
</div>
<div>
<div class="col-xs-12 gg-panel-bottom ">
<a href="http://www.ni.com/global-gateway/" class="analytics-utilityggallcountries-link global-gateway">See All Countries and Regions</a>
</div>
<div class="arrow"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</footer>
</div>


<script type="text/javascript">niAnalyticsBottomCall();</script>
</body>
</html>