NI Vision

NI Vision Builder for Automated Inspection Tutorial

June 2018
373379M-01
Worldwide Technical Support and Product Information

ni.com

Worldwide Offices
Visit ni.com/niglobal to access the branch office websites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.

National Instruments Corporate Headquarters
11500 North Mopac Expressway  Austin, Texas 78759-3504  USA  Tel: 512 683 0100

For further support information, refer to the NI Services appendix. To comment on National Instruments documentation, refer to the National Instruments website at ni.com/info and enter the Info Code feedback.

© 2002–2018 National Instruments. All rights reserved.
Legal Information

Limited Warranty
This document is provided “as is” and is subject to being changed, without notice, in future editions. For the latest version, refer to ni.com/manuals. NI reviews this document carefully for technical accuracy; however, NI MAKES NO EXPRESS OR IMPLIED WARRANTIES AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS.

NI warrants that its hardware products will be free of defects in materials and workmanship that cause the product to fail to substantially conform to the applicable NI published specifications for one (1) year from the date of invoice.

For a period of ninety (90) days from the date of invoice, NI warrants that (i) its software products will perform substantially in accordance with the applicable documentation provided with the software and (ii) the software media will be free from defects in materials and workmanship.

If NI receives notice of a defect or non-conformance during the applicable warranty period, NI will, in its discretion: (i) repair or replace the affected product, or (ii) refund the fees paid for the affected product. Repaired or replaced Hardware will be warranted for the remainder of the original warranty period or ninety (90) days, whichever is longer. If NI elects to repair or replace the product, NI may use new or refurbished parts or products that are equivalent to new in performance and reliability and are at least functionally equivalent to the original part or product.

You must obtain an RMA number from NI before returning any product to NI. NI reserves the right to charge a fee for examining and testing Hardware not covered by the Limited Warranty.

This Limited Warranty does not apply if the defect of the product resulted from improper or inadequate maintenance, installation, repair, or calibration (performed by a party other than NI); unauthorized modification; improper environment; use of an improper hardware or software key; improper use or operation outside of the specification for the product; improper voltages; accident, abuse, or neglect; or a hazard such as lightning, flood, or other act of nature.

THE REMEDIES SET FORTH ABOVE ARE EXCLUSIVE AND THE CUSTOMER’S SOLE REMEDIES, AND SHALL APPLY EVEN IF SUCH REMEDIES FAIL OF THEIR ESSENTIAL PURPOSE.

EXCEPT AS EXPRESSLY SET FORTH HEREIN, PRODUCTS ARE PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND AND NI DISCLAIMS ALL WARRANTIES, EXPRESSED OR IMPLIED, WITH RESPECT TO THE PRODUCTS, INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE OR NON-INFRINGEMENT, AND ANY WARRANTIES THAT MAY ARISE FROM THE USE OF TRADE OR COURSE OF DEALING. NI DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE OF OR THE RESULTS OF THE USE OF THE PRODUCTS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, OR OTHERWISE. NI DOES NOT WARRANT THAT THE OPERATION OF THE PRODUCTS WILL BE UNINTERRUPTED OR ERROR FREE.

In the event that you and NI have a separate signed written agreement with warranty terms covering the products, then the warranty terms in the separate agreement shall control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices
You can find end-user license agreements (EULAs) and third-party legal notices in the following locations:

- Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
- EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
- Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

U.S. Government Restricted Rights
If you are an agency, department, or other entity of the United States Government (“Government”), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

Trademarks
Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for more information on NI trademarks.

ARM, Keil, and µVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.
Contents

About This Manual
Related Documentation .................................................................................................... x

Chapter 1
Introduction to Vision Builder AI
Vision Builder AI Configuration Interface ................................................................. 1-4
   Elements of the Configuration Interface ............................................................... 1-4
   Inspection State Diagram ...................................................................................... 1-6
Vision Builder AI Inspection Interface ................................................................... 1-7
Running an Inspection .............................................................................................. 1-8
   Configuration Interface ......................................................................................... 1-8
   Inspection Interface .............................................................................................. 1-9

Chapter 2
Checking for the Presence of a Part
Creating a New Inspection ....................................................................................... 2-1
Acquiring Inspection Images .................................................................................... 2-1
Defining a Feature on which to Base a Coordinate System ..................................... 2-2
Setting a Coordinate System ................................................................................... 2-4
Checking for the Cap Using Measure Intensity ....................................................... 2-5
Setting the Inspection Status ................................................................................... 2-7
Testing the Inspection .............................................................................................. 2-8
Saving the Inspection ............................................................................................... 2-8

Chapter 3
Inspecting Objects for Correct Measurements
Creating a New Inspection ....................................................................................... 3-1
Acquiring and Calibrating Inspection Images ........................................................ 3-1
Locating Features to Measure ................................................................................ 3-4
Measuring Parts of the Gasket ............................................................................... 3-7
Setting the Inspection Status ................................................................................... 3-8
Testing the Inspection .............................................................................................. 3-9
Saving the Inspection ............................................................................................... 3-9

Chapter 4
Inspecting for Multiple Correct Instances of an Object
Creating a New Inspection ....................................................................................... 4-1
Acquiring Inspection Images .................................................................................... 4-1
Defining a Feature on which to Base a Coordinate System ..................................... 4-2
Setting a Coordinate System ................................................................................... 4-4
Measuring the Separation between Connectors ..................................................... 4-4
### Chapter 5
**Inspecting an Object that Spans Two Image Frames**

- Creating a New Inspection .............................................. 5-1
- Acquiring Inspection Images from Two Cameras ............... 5-1
  - Acquiring and Calibrating the Image of the Left Edge .......... 5-2
  - Acquiring and Calibrating the Image of the Right Edge ...... 5-4
- Locating the Right Edge of the Part .................................. 5-7
- Switching Images ................................................................. 5-9
- Locating the Left Edge of the Part ..................................... 5-9
- Calculating the Width of the Part ....................................... 5-11
  - Setting Calculator Step Inputs and Outputs .................. 5-11
  - Adding Operators and Constants .................................. 5-13
  - Connecting the Equation Elements .............................. 5-14
  - Making Logical PASS/FAIL Decisions with the Calculator Step 5-16
- Setting the Inspection Status ............................................ 5-17
- Testing the Inspection ....................................................... 5-18
- Saving the Inspection ....................................................... 5-18

### Chapter 6
**Branching and Decision Making**

- Creating a New Inspection .............................................. 6-1
- Creating the Inspection State Diagram ............................. 6-1
- Acquiring Inspection Images ............................................ 6-5
- Checking for a Spray Bottle in the Image .......................... 6-6
- Checking for the Cap Using the Caliper ............................. 6-8
- Setting the Inspection Status .......................................... 6-10
- Creating Custom Overlays for Inspection ......................... 6-10
- Configuring State Transitions ......................................... 6-13
- Testing the Inspection ..................................................... 6-14
- Saving the Inspection ..................................................... 6-15

### Chapter 7
**Looping and Variables**

- Creating a New Inspection ................................................ 7-1
- Creating the Inspection State Diagram ............................. 7-1
- Creating a Variable .............................................................. 7-5
- Acquiring Inspection Images ............................................ 7-6
- Finding Pin Edges ............................................................ 7-7
About This Manual

This manual contains many techniques for using NI Vision Builder for Automated Inspection (Vision Builder AI) to solve visual inspection tasks including inspection, gauging, part presence, guidance, and counting.

Follow the instructions in this manual to familiarize yourself with Vision Builder AI and perform common inspection tasks.

This manual contains the following chapters:

- **Chapter 1, **Introduction to Vision Builder AI, introduces the Vision Builder AI environment and describes how to run an inspection.
- **Chapter 2, **Checking for the Presence of a Part, introduces the Match Pattern, Measure Intensity, and Set Coordinate System steps. Follow the instructions in this chapter to create an inspection that checks for the presence of a spray bottle cap regardless of the bottle position in the inspection images.
- **Chapter 3, **Inspecting Objects for Correct Measurements, introduces image calibration, and the Detect Objects and Geometry steps. Follow the instructions in this chapter to create an inspection that measures the distance between holes in a gasket to verify that the gasket conforms to manufacturing specifications.
- **Chapter 4, **Inspecting for Multiple Correct Instances of an Object, introduces the Find Straight Edge, Caliper, and Decision Making steps. Follow the instructions in this chapter to create an inspection that measures the distance between the blade connectors of a fuse and checks the integrity of the fuse conductor regardless of the fuse position or whether the fuse is inverted.
- **Chapter 5, **Inspecting an Object that Spans Two Image Frames, introduces the Select Image and Calculator steps. Follow the instructions in this chapter to create an inspection that measures the width of a wooden plank that spans two images.
- **Chapter 6, **Branching and Decision Making, introduces the inspection state diagram and the Custom Overlay step. Follow the instructions in this chapter to create an inspection that checks the image for the presence of a spray bottle and, if a bottle is present, transitions to another state to determine if the bottle has a cap. If there is no spray bottle present in the image, the inspection moves on to the next image.
- **Chapter 7, **Looping and Variables, uses the inspection state diagram to implement a looping inspection and introduces the Set Variable and Array Operator steps. Follow the instructions in this chapter to create an inspection that inspects images of electronic components to determine if the distance between pins on the component is within a predetermined range. If the pin is too close or too far away from an adjacent pin, then the inspection fails. The inspection does not need to check every pin on the microchip before failing the inspection. The inspection fails at the first failed pin.
Related Documentation

The following documents contain information that you might find helpful as you read this manual:

- **NI Vision Builder for Automated Inspection Readme**—Contains information about the minimum system requirements, installation instructions, device support, and known issues for NI Vision Builder for Automated Inspection. The *NI Vision Builder for Automated Inspection Readme* is available at [Start»All Programs»National Instruments»Vision Builder AI Documentation](#).

- **NI Vision Builder for Automated Inspection: Configuration Help**—Contains information about using the Vision Builder AI Configuration interface to create a machine vision application. *NI Vision Builder for Automated Inspection: Configuration Help* is available by selecting **Help»Online Help** from the Vision Builder AI Configuration interface.

- **NI Vision Builder for Automated Inspection: Inspection Help**—Contains information about running applications created using Vision Builder AI in the Vision Builder AI Inspection Interface. *NI Vision Builder for Automated Inspection: Inspection Help* is available by selecting **Help»Online Help** from the Vision Builder AI Inspection interface.

- NI Developer Zone—Visit [ni.com/zone](#) for the latest example programs, tutorials, technical presentations, and a community area where you can share ideas, questions, and source code with developers around the world.

- **ISC-178x User Manual**—Describes the electrical and mechanical aspects of the ISC-178x smart camera, troubleshooting guidelines, and information about the LEDs, and connectors on the ISC-178x.

- **NI IC-317x User Manual**—Describes the electrical and mechanical aspects of the NI 317x industrial controller devices, software configuration guidelines, and information about the LEDs and connectors on those devices.

- **NI Smart Camera I/O Accessory User Guide**—Describes the features of the NI Smart Camera I/O Accessory, what you need to get started, and the installation and operation of the device.

- **NI Vision Concepts Help**—Describes the basic concepts of image analysis, image processing, and machine vision. This document also contains in-depth discussions about imaging algorithms for advanced users. The *NI Vision Concepts Help* is available by selecting **Start»All Programs»National Instruments»Vision Builder AI Documentation»NI Vision Concepts Help** from the Start menu.
Introduction to Vision Builder AI

This chapter introduces the Vision Builder AI environment and describes how to run an inspection.

Figures 1-1 and 1-2 show general instructions for creating a Vision Builder AI inspection. Figure 1-1 describes the basic steps for designing a Vision Builder AI inspection. The Add Inspection Steps module of Figure 1-1 is expanded in Figure 1-2.
Figure 1-1. Instructions for Creating a Basic Vision Builder AI Inspection

1. Open Vision Builder AI Configuration interface.
2. Add step to acquire an image of the parts under inspection.
3. Do you want to make measurements in real-world units?
   - Yes: Create or select a spatial calibration from the Calibration tab of the acquisition step.
   - No: Continue.
4. Do the parts appear in different locations from image to image?
   - Yes: Add step from the Locate Features palette to locate the part in the image.
   - No: Add a Set Coordinate System step to create a coordinate system based on the part location.
5. Add Inspection steps.
6. Do you want to create intermediate measurements based on the results of previous steps?
   - Yes: Add Calculator step.
   - No: Continue.
7. Do you want to customize the inspection decision?
   - Yes: Add Logic Calculator step or Calculator step.
   - No: Continue.
8. Add Set Inspection Status step.
9. Do you want to send measurements to an external device?
   - Yes: Add one of the Communication steps.
   - No: Continue.
10. Save inspection.

Refer to Figure 1-2 for details.
Figure 1-2. Adding Inspection Steps to a Vision Builder AI Inspection

- Does the image need to be enhanced?
  - Yes: Add Vision Assistant or Filter Image step
  - No: Proceed to the next step

- What type of inspection do you need to perform?
  - Location
    - Add step from the Locate Features palette
  - Presence/Absence
    - Add step from the Check for Presence palette
  - Identification
    - Add step from the Identify Parts palette
  - Gauging
    - Do you want to measure distances between object edges?
      - Yes: Add steps from the Locate Features palette
      - No: Add Caliper step

- Do you want to add another step?
  - Yes
  - No
Vision Builder AI Configuration Interface

Vision Builder AI has two modes of operation: Configuration and Inspection. Use the Configuration interface to configure and test your inspection. Use the Inspection interface to deploy the software and perform online or offline visual inspection.

Complete the following instructions to open the Vision Builder AI Configuration interface.

1. Select Start»All Programs»National Instruments»Vision Builder AI to launch Vision Builder AI.

   **Note** By default, My Computer is selected in the list of targets. When My Computer is selected Vision Builder AI runs on the development computer.

2. On the Vision Builder AI welcome screen, click New Inspection or double click on My Computer to open the Vision Builder AI Configuration Interface.

Elements of the Configuration Interface

Figure 1-3 shows the Vision Builder AI Configuration interface. The Configuration interface contains four areas: Main window, Overview window, Inspection Steps palette, and State Configuration window.
Figure 1-3. Vision Builder AI Configuration Interface

- **Main window**—Displays the image being processed, property pages for some inspection steps, or the state diagram for the inspection. Use the Main window to define regions of interest in an image, configure step parameters for some steps, and create/modify the state diagram for an inspection.
- **Overview window**—Displays a thumbnail view of either the current inspection image or the state diagram for the inspection.
- **Inspection Steps palette**—Lists and describes the steps that you use to create your inspection. When you click on most steps, the palette transforms into the property page for the step.
- **State Configuration window**—Displays the list of steps in the currently selected state in the inspection.

**Inspection State Diagram**

Vision Builder AI uses a state diagram to define inspections with unique states and transitions that govern the execution flow of the inspection. Simple inspections can be defined using the single-state default inspection, shown in Figure 1-4.
More complex inspections can be created by adding additional states and transitions to the default state diagram. Figure 1-5 shows an example of an inspection that uses the state diagram to perform branching and looping in the inspection.

Within a state diagram, each state can lead to one or multiple states or can end the inspection cycle. Each state diagram relies on in-state calculations or user input to determine the next state to execute. Vision Builder AI executes the state diagram continuously from the Start point to the End point.

Each state in an inspection is intended to contain a discrete set of inspection steps. To access the steps contained in a state, select the state on the state diagram. The steps present in the state will appear in the State Configuration window. The currently selected state is highlighted on the state diagram. Chapter 6, *Branching and Decision Making*, and Chapter 7, *Looping and Variables*, provide examples of using the state diagram.
Vision Builder AI Inspection Interface

As mentioned in the Vision Builder AI Configuration Interface section of this chapter, use the Vision Builder AI built-in Inspection Interface to deploy and run an inspection. Figure 1-6 shows the built-in Inspection interface, which has three main areas: the Results panel, the Inspection Statistics panel, and the Display window.

*Figure 1-6. Vision Builder AI Built-in Inspection Interface*

**Results panel**—Lists the steps in the inspection by name. For each inspection step, Vision Builder displays the step type, result (PASS or FAIL), measurement made, and a comment explaining the reason of a FAIL. **Inspection Status** shows the result of the complete inspection.

**Display window**—Displays the part under inspection.

**Inspection Statistics panel**—Contains three indicators that display the yield (ratio between PASS and FAIL), active versus idle time, and processing time of the inspection.

Running an Inspection

Vision Builder AI allows you to run inspections from both the Configuration and Inspection interfaces. The following sections describe the options for running an inspection in Vision Builder AI.
Chapter 1  Introduction to Vision Builder AI

Configuration Interface
Run an inspection from the Configuration interface during development to test and debug inspections. The Highlight Execution, Pause, and Single Step options are useful for debugging inspections. Table 1-1 lists the run options available for the Configuration interface:

Table 1-1. Configuration Interface Run Modes

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Run Inspection Once" /></td>
<td>Run Inspection Once</td>
<td>Runs the inspection through one iteration of the state diagram.</td>
</tr>
<tr>
<td><img src="image" alt="Run Inspection in Loop" /></td>
<td>Run Inspection in Loop</td>
<td>Runs the inspection continuously.</td>
</tr>
<tr>
<td><img src="image" alt="Run Inspection Until Failure" /></td>
<td>Run Inspection Until Failure</td>
<td>Runs the inspection until the Inspection Status variable has a value of FAIL.</td>
</tr>
<tr>
<td><img src="image" alt="Run Inspection Fast" /></td>
<td>Run Inspection Fast</td>
<td>Runs the inspection with similar timing and speeds as in the inspection interface.</td>
</tr>
<tr>
<td>—</td>
<td>Run Inspection Multiple Times</td>
<td>Runs the inspection a specified number of times. This option is available only from the Operate menu.</td>
</tr>
<tr>
<td><img src="image" alt="Stop Inspection" /></td>
<td>Stop Inspection</td>
<td>Stops the inspection.</td>
</tr>
<tr>
<td><img src="image" alt="Highlight Execution" /></td>
<td>Highlight Execution</td>
<td>Highlights the inspection execution when you run the inspection. If the Highlight Execution button appears yellow, execution highlighting is enabled.</td>
</tr>
<tr>
<td><img src="image" alt="Pause" /></td>
<td>Pause</td>
<td>Pauses or resumes execution of the inspection. If the Pause button appears red, execution is paused.</td>
</tr>
<tr>
<td><img src="image" alt="Step Into" /></td>
<td>Step Into</td>
<td>Steps through the inspection. Step Into is only available when the Pause button is pressed.</td>
</tr>
</tbody>
</table>
Inspection Interface

After an inspection is configured, use the Inspection interface to run the inspection and/or deploy your system. Complete the following instructions to run an inspection from the Inspection interface:

1. Select Start»All Programs»National Instruments»Vision Builder AI to launch the Vision Builder AI.
2. On the Vision Builder AI welcome screen, click Browse under Run Inspection.
3. Select the inspection that you want to run and click OK to open the inspection in the Inspection Interface.

Table 1-1. Configuration Interface Run Modes (Continued)

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Step Over" /></td>
<td>Step Over</td>
<td>Runs the current state. Step Over is only available when the Pause button is pressed.</td>
</tr>
<tr>
<td><img src="image" alt="Use Previous Image" /></td>
<td>Use Previous Image</td>
<td>Uses the previous inspection image the next time the inspection executes.*</td>
</tr>
<tr>
<td><img src="image" alt="Use Current Image" /></td>
<td>Use Current Image</td>
<td>Uses the current inspection image the next time the inspection executes.*</td>
</tr>
<tr>
<td><img src="image" alt="Use Next Image" /></td>
<td>Use Next Image</td>
<td>Uses the next inspection image the next time the inspection executes.*</td>
</tr>
<tr>
<td><img src="image" alt="Select Next Image" /></td>
<td>Select Next Image</td>
<td>Specifies the inspection image to process the next time the inspection executes.*</td>
</tr>
</tbody>
</table>

* This button applies only to inspections that either contain a Read Image File step, or are open on a simulated target.
4. Click the **Start Inspection** button. Vision Builder AI begins running the inspection and updating the three areas of the Inspection interface with the most recent inspection data.

By default, Vision Builder AI displays all the inspection images in the **Display** window. You can change the display settings in the **View** pulldown below the **Display** window to view only images that fail or to have no display. You also can change the magnification of the displayed images using the zoom buttons below the **Display** window.

Notice the performance data displayed in the **Inspection Statistics** panel. This data can help you determine how efficiently your inspection is running. Based on this data, you can make adjustments to improve the inspection speed.

5. Click the **Stop Inspection** button to stop the inspection.
Checking for the Presence of a Part

This chapter introduces the Match Pattern, Measure Intensity, and Set Coordinate System steps. Follow the instructions in this chapter to create an inspection that checks for the presence of a spray bottle cap regardless of the bottle position in the inspection images.

**Note** Launch Vision Builder AI if it is not open. Refer to the *Vision Builder AI Configuration Interface* section of Chapter 1, *Introduction to Vision Builder AI*, for more information.

Creating a New Inspection

Select **File»New** to load a new, blank Vision Builder AI inspection.

Acquiring Inspection Images

In the Inspection Steps palette, the Acquire Images tab contains several acquisition steps you can use to acquire images from many different types of cameras. The tab also contains a Read Image File step, which simulates image acquisition by loading images from file. The Select Image step enables you to switch to a previously acquired image that you need to process later in the inspection.

For simplicity, this tutorial instructs you to use the Read Image File step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Read Image File step that simulates acquiring images of spray bottles.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the **Read Image File** step. The property page for the step opens.
Chapter 2  Checking for the Presence of a Part

3. In the Step Name control, enter Acquire Spray Bottle.
4. Click the Browse button. The Select an Image or AVI File dialog box opens.

5. Navigate to <Public Documents>\National Instruments\<Vision Builder AI>\DemoImg\Tutorial 1.

   Note  Ensure that you have selected the appropriate folder if you have more than one version of Vision Builder AI installed.

6. Select the first image, Image 01.jpg, and click Open.
7. Make sure the Cycle Through Folder Images control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.
8. Click OK to add the step to the inspection.

Defining a Feature on which to Base a Coordinate System

In a machine vision inspection, you typically limit your inspection and processing to a region of interest (ROI) rather than the entire image for the following reasons:

• To improve your inspection results by avoiding extraneous objects
• To increase inspection speed

To limit the inspection area, the parts of the object you are interested in must always be inside the ROI you define.

If the object under inspection is fixtured and always appears at the same location and orientation in the images you need to process, defining an ROI is straightforward. However, if the object under inspection appears shifted or rotated within the images, the regions of interest need to shift and rotate with the object under inspection.

For the regions of interest to move in relation to the object, you need to set a coordinate system relative to a significant and original feature of the object under inspection. Choose a feature that is always in the field of view of the camera despite the different locations that the objects may appear in from image to image. Also, make sure the feature is not affected by major defects that could drastically modify the visual appearance of the feature.

Complete the following instructions to configure a Match Pattern step that locates a bottle feature on which you can base a coordinate system.
1. In the Inspection Steps palette, select the **Locate Features** tab.

2. Click the **Match Pattern** step. The NI Vision Template Editor opens.

3. Draw a rectangle around the base of the sprayer, as shown in Figure 2-1. This region becomes the pattern matching template.

   ![Figure 2-1. Creating a Template Pattern](image)

4. Click **Next**.
5. Click **Finish** to accept the template.
6. On the **Main** tab, enter **Locate Sprayer Base** in the **Step Name** control.

   The green ROI specifies the area of the image in which Vision Builder AI tries to locate the template. Assuming that the bottles are fixtured in such a way that they can move only horizontally within the field of view, you can limit the ROI so that it surrounds only the area of the image that may contain a template match during inspection.
7. Redraw or decrease the default green ROI so that it surrounds only the lower portion of the image, as shown in Figure 2-2.

**Figure 2-2. Limiting the Search Region**

8. On the Specifications tab,
   - set Number of Matches to Find to 1, and
   - uncheck Rotated.

9. On the Limits tab, enable the Minimum Number of Matches control, and set the value to 1.

10. Click **OK** to add the step to the inspection.

### Setting a Coordinate System

Complete the following instructions to configure a Set Coordinate System step based on the Match Pattern step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.
2. Click the **Set Coordinate System** step. The property page for the step opens.

3. On the **Main** tab, enter **Coordinate System** in the **Step Name** control.
4. Select **Horizontal and Vertical Motion** from the **Mode** control because the bottles appear shifted but not rotated from one image to another.

Notice the **Origin** list. **Match** [1], the match location of the previous **Locate Sprayer Base** step, is the default origin of the coordinate system because it is the only location point created by previous steps in the inspection.

5. Click **OK** to add the step to the inspection.

**Checking for the Cap Using Measure Intensity**

The image of the spray bottle was acquired using a backlight. The cap appears dark on the bright background. Complete the following instructions to configure a **Measure Intensity** step to check for the presence of a spray bottle cap.

1. In the Inspection Steps palette, select the **Measure Features** tab.

2. Click the **Measure Intensity** step. The property page for the step opens.

3. On the **Main** tab, enter **Check Cap Presence** in the **Step Name** control.
4. Enable the **Reposition Region of Interest** control.

Enabling this control allows you to link the regions of interest specified in this step to a previously defined coordinate system so that Vision Builder AI can adjust the location and orientation of the ROI from image to image relative to the specified coordinate system.

The **Reference Coordinate System** list shows all the previously defined coordinate systems. **Coordinate System** is the default reference coordinate system because it is the only **Set Coordinate System** step in the current inspection.

Notice that the **Measure Intensity** step supports a variety of different tools that enable you to draw different shaped regions of interest, such as a point, line, broken line, freehand line, rectangle, ellipse, annulus, polygon, and freehand region. These tools are available in the main toolbar.
5. Using the default Rectangle Tool, draw a region that enclose the top of the cap then hold down the <Ctrl> key, and draw two other regions of interest that enclose the edges on the sides of the cap, as shown in Figure 2-3. Pressing the <Ctrl> key enables you to draw multiple regions of interest for the step.

6. Click the Limits tab.

At the bottom of the Limits tab, Vision Builder AI returns the intensity statistics of the pixels inside the regions of interest. Pixel intensities can range from 0 through 255, where 0 equals black and 255 equals white.

The Minimum Intensity value at the bottom of the page returns the lowest pixel value inside the regions of interest. The backlit edges of the plastic cap appear in silhouette as dark pixels (which have low pixel intensities) on a bright background (which has high pixel intensities).

Therefore, when the cap is present, the minimum intensity for the regions is low. When the cap is not present, the minimum intensity for the regions is high because the regions contain only bright background pixels.
7. Enable the **Minimum** control. Set the **Maximum** value to 50.00.

8. Click **OK** to add the step to the inspection.

9. Click the **Run State Once** button located in the State Configuration window.

Vision Builder AI loads the next image, `Image 02.jpg`, from the
C:s\Users\Public\Public Documents\National Instruments\<Vision
Builder AI>\DemoImg\Tutorial 1 folder and runs the previous inspection steps in
the state on the new image.

Notice that the bottle appears closer to the left edge of the image. Vision Builder AI
repositions the regions of interest based on the new location of the bottle. The **Step Status**
for the image is **PASS** because the presence of the cap inside the regions of interest causes
the **Minimum Intensity** value to fall within the limits you set.

## Setting the Inspection Status

Complete the following instructions to add a **Set Inspection Status** step to determine whether
the inspection passes or fails.

1. In the Inspection Steps palette, select the **Use Additional Tools** tab.

2. Click the **Set Inspection Status** step. The property page for the step opens.

3. In the **Inspection Status** control, select the **Set to FAIL if any previous step fails** option.

4. Click **OK** to add the step to the inspection.
Testing the Inspection

Test the remaining images in the Tutorial 1 folder to make sure the inspection returns the correct results. Click the Run Inspection Once button to test the remaining images. Table 2-1 displays the expected results for each image.

Table 2-1. Expected Results for the Spray Bottle Inspection

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Inspection Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 01.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 02.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 03.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 04.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 05.jpg</td>
<td>FAIL</td>
<td>Cap is missing.</td>
</tr>
</tbody>
</table>

Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select File»Save or click the Save button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 1.vbai.
4. Click Save to save the inspection.

Tip Select File»Inspection Properties to add a short description or comments about the inspection.
Inspecting Objects for Correct Measurements

This chapter introduces image calibration, and the **Detect Objects** and **Geometry** steps. Follow the instructions in this chapter to create an inspection that measures the distance between holes in a gasket to verify that the gasket conforms to manufacturing specifications.

**Note** Launch Vision Builder AI if it is not open. Refer to the *Vision Builder AI Configuration Interface* section of Chapter 1, *Introduction to Vision Builder AI*, for more information.

### Creating a New Inspection

Select **File»New** to load a new, blank Vision Builder AI inspection.

### Acquiring and Calibrating Inspection Images

For simplicity, this tutorial instructs you to use the **Read Image File** step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a **Read Image File** step that simulates acquiring images of gaskets.

1. In the Inspection Steps palette, select the **Acquire Images** tab.

2. Click the **Read Image File** step. The property page for the step opens.

3. In the **Step Name** control, enter **Acquire Gasket**.

4. Click the **Browse** button. The **Select an Image or AVI File** dialog box opens.
Chapter 3   Inspecting Objects for Correct Measurements

5. **Navigate to** `<Public Documents>\National Instruments\<Vision Builder AI>\DemoImg\Tutorial 2`.

   ![Note] Ensure that you have selected the appropriate folder if you have more than one version of Vision Builder AI installed.

6. Select the first image, *Image 01.jpg*, and click **Open**.

7. Make sure that the **Cycle Through Folder Images** control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.

By default, Vision Builder AI returns measurements in pixel units. If you want the inspection to return measurements in real-world units, you need to map pixel units to real-world units through a process called spatial calibration.

8. Click the **Calibration** tab.

9. Click **Create Calibration** to launch the calibration training interface.

10. In the **Calibration Name** control, enter **Gasket Calibration**.

11. Click **Next**.

For this example, assume that the camera that acquired the inspection images is perpendicular to the image plane and lens distortion is negligible. Based on these assumptions, you can use **Point Distance Calibration** to calibrate your images. **Point Distance Calibration** transforms a pixel coordinate to a real-world coordinate through scaling in the x (horizontal) and y (vertical) directions.

12. Select the **Point Distance Calibration** option, and click **Next**.

13. Make sure that the current image is selected, and click **Next**.
14. Carefully click the 0 mm and 50 mm markings on the ruler at the bottom of the image, as shown in Figure 3-1.

**Tip** You may need to use the zoom buttons below the image to accurately click the ruler markings. You can also zoom in by using the mouse wheel. After zooming in, scroll down to see the ruler at the bottom of the image.

Figure 3-1. Specifying the Pixel Ratio

15. In the Distances control, enter 50 for the Real World value, and select millimeter for the Unit.

16. Click Next.

17. Ignore the Compute Lens Distortion Model option and click Next.

In the Specify Calibration Axis step, you can define the origin and angle of the calibration axis anywhere in the image. By default, the top, left pixel in the image is the calibration axis origin, and the horizontal axis of the image is the calibration axis angle. Use the default calibration axis settings for this exercise.

**Tip** In some applications, you may want to measure between a fixed reference feature on the part and other features in the image. Setting the origin of the calibration
axis to the location of the reference feature simplifies making measurements because
the starting point for the measurements becomes 0.

18. Click Next.
19. Click OK to learn the calibration information and exit the calibration training interface.
20. Click OK to add the step to the inspection.

Vision Builder AI typically saves the calibration to <ProgramData>\National
Instruments\Vision Builder AI\Calibration.

Tip  You can apply the learned calibration to all images acquired with the same
camera at the same resolution.

Locating Features to Measure

Complete the following instructions to configure a Detect Objects step that finds small holes in
the gasket.
1. In the Inspection Steps palette, select the Check for Presence tab.

2. Click the Detect Objects step. The property page for the step opens.

3. In the Step Name control, enter Detect Small Holes.
4. Using the default **Rectangle Tool**, draw a region of interest (ROI) around the entire gasket, as shown in Figure 3-2.

![Figure 3-2. Defining the ROI](image)

5. In the **Threshold** tab, select the **Bright Objects** option for the **Look For** control.

Notice that the blue shading highlights all bright pixels—pixels with high intensity values that fall within the **Threshold Range**—in the ROI. Vision Builder AI groups contiguous highlighted pixels into *objects*, which are depicted by red bounding rectangles.
Chapter 3    Inspecting Objects for Correct Measurements

6. Click the **Settings** tab. Scroll the Objects table to the right to view the **Area (mm)** measurement.

The step locates four objects, which are listed in Table 3-1. Depending on the location of the user-defined points previously configured in the calibration, the values for the **Size (mm²)** may differ slightly from the values shown in Table 3-1.

<table>
<thead>
<tr>
<th>Object Number</th>
<th>Size (mm²)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>62.43</td>
</tr>
<tr>
<td>2</td>
<td>461.26</td>
</tr>
<tr>
<td>3</td>
<td>1410.15</td>
</tr>
<tr>
<td>4</td>
<td>61.50</td>
</tr>
</tbody>
</table>

**Table 3-1. Sizes of Gasket Holes**

Object 1 and Object 4 are the small holes of interest in this step. The following steps describe how to use the **Minimum Object Size** and **Maximum Object Size** controls of the **Detect Objects** step to eliminate objects of no interest based on their size.

7. Enable the **Minimum Object Size** and **Maximum Object Size** controls.

   Based on the information in Table 3-1, the small holes have sizes of 61.97 mm² and 61.04 mm².

8. Set **Minimum Object Size** to 50 and **Maximum Object Size** to 70.

9. In the **Limits** tab, enable the **Minimum Number of Objects** and **Maximum Number of Objects** controls. Set their values to 2.

10. Click **OK** to add the step to the inspection.

Complete the following instructions to find the large hole in the gasket.

1. Right-click the **Detect Small Holes** step in the State Configuration window, and select **Copy**.

2. Right-click the **Detect Small Holes** step again.

3. Select **Paste**. A copy of the **Detect Small Holes** step is placed after the original step.

4. Double-click the **Detect Small Holes** copy or click the **Edit Step** button to launch the property page of the step for editing.

5. In the **Step Name** control, enter **Detect Large Hole**.

6. Select the **Settings** tab.

   Based on the information in Table 3-1, the large hole has a size of 1410.15 mm².
7. Set **Minimum Object Size** to 1300 and **Maximum Object Size** to 1450.
8. In the **Limits** tab, enable the **Minimum Number of Objects** and **Maximum Number of Objects** controls. Set their values to 1.
9. Click **OK** to add the step to the inspection.

**Measuring Parts of the Gasket**

Complete the following instructions to measure the distance from the top small hole to the large hole to inspect whether the distance meets specifications.

**Note**  Vision Builder AI returns the centers of mass for the holes as their locations.

1. In the Inspection Steps palette, select the **Measure Features** tab.
2. Click the **Geometry** step. The property page for the step opens.
3. In the **Step Name** control, enter **Check Distance**.
4. Click **Add Feature** icon.
5. In the **Feature Name** control, enter **Check Top Distance**.
6. In the **Geometric Feature** control, select the **Distance**.
7. Click the **Browse** button and select *Step #2: Detect Small Holes >> 1:Object [1]. Center of Mass (Pixels).*
8. Click **OK**.
9. Click the **Browse** button and select *Step #3: Object [1].Center of Mass (Pixels).*
10. Click **OK**.
11. Select the **Distance** check box in the Condition control and set **Minimum** and **Maximum** as 32 and 35 respectively.
12. Click **Add Feature** icon.
13. In the **Feature Name** control, enter **Check Bottom Distance**.
14. Click the **Browse** button and select *Step #2: Detect Small Holes >> 2: Object [2].Center of Mass (Pixels).*
15. Click **OK**.
Chapter 3   Inspecting Objects for Correct Measurements

16. Click the **Browse** button and select **Step #3: Object[1].Center of Mass (Pixels)**.
17. Click **OK**.
18. Select the **Distance** check box in the Condition control and set **Minimum** and **Maximum** as 38 and 40 respectively.
19. Click **OK** to add the step to the inspection.

### Setting the Inspection Status

Complete the following instructions to add a **Set Inspection Status** step to determine whether the inspection passes or fails.

1. In the Inspection Steps palette, select the **Use Additional Tools** tab.

2. Click the **Set Inspection Status** step. The property page for the step opens.

3. In the **Inspection Status** control, select the **Set to FAIL if any previous step fails** option.
4. Click **OK** to add the step to the inspection.
Testing the Inspection

Test the inspection to make sure it returns the results you expect. Click the Run Inspection Once button to run the inspection on each of the test images. Table 3-2 lists the test images, the inspection status to expect for each image, and an explanation of the status.

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Inspection Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 01.jpg</td>
<td>PASS</td>
<td>All steps passed.</td>
</tr>
<tr>
<td>Image 02.jpg</td>
<td>PASS</td>
<td>All steps passed.</td>
</tr>
<tr>
<td>Image 03.jpg</td>
<td>PASS</td>
<td>All steps passed.</td>
</tr>
<tr>
<td>Image 04.jpg</td>
<td>FAIL</td>
<td>The Check Distance step failed because the distance between the holes is too small.</td>
</tr>
<tr>
<td>Image 05.jpg</td>
<td>FAIL</td>
<td>The Detect Small Holes step failed because the bottom hole is missing. The missing hole also caused the Check Distance step to fail.</td>
</tr>
</tbody>
</table>

Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select File»Save or click the Save button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 2.vbai.
4. Click Save to save the inspection.

Tip  Select File»Inspection Properties to add a short description or comments about the inspection.
Inspecting for Multiple Correct Instances of an Object

This chapter introduces the Find Straight Edge, Caliper, and Decision Making steps. Follow the instructions in this chapter to create an inspection that measures the distance between the blade connectors of a fuse and checks the integrity of the fuse conductor regardless of the fuse position or whether the fuse is inverted.

Note     Launch Vision Builder AI if it is not open. Refer to the Vision Builder AI Configuration Interface section of Chapter 1, Introduction to Vision Builder AI, for more information.

Creating a New Inspection

Select File ➤ New to load a new, blank Vision Builder AI inspection.

Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the Read Image File step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Read Image File step that simulates acquiring images of fuses.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Read Image File step. The property page for the step opens.

3. In the Step Name control, enter Acquire Fuse.
Chapter 4    Inspecting for Multiple Correct Instances of an Object

4. Click the **Browse** button. The **Select an Image File** dialog box opens.

5. **Navigate to** `<Public Documents>National Instruments\Vision Builder AI\DemoImg\Tutorial 3`.

   **Note**  Ensure that you have selected the appropriate folder if you have more than one version of Vision Builder AI installed.

6. Select the first image, *Image 01.jpg*, and click **Open**.
7. Make sure the **Cycle Through Folder Images** control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.
8. Click **OK** to add the step to the inspection.

**Defining a Feature on which to Base a Coordinate System**

The fuses can appear shifted horizontally and slightly rotated from one inspection image to another. Complete the following instructions to configure a **Find Straight Edge** step that finds the left edge of the fuse so that regions of interest in subsequent steps can shift with the fuse.

1. In the Inspection Steps palette, select the **Locate Features** tab.

2. Click the **Find Straight Edge** step. The property page for the step opens.

3. In the **Step Name** control, enter *Locate Fuse Left Edge*. 
4. Draw a region of interest (ROI) across the left edge of the fuse, as shown in Figure 4-1.

Notice that the ROI contains blue search lines. The step searches along the search lines for sharp transitions in pixel intensities, which usually represent object edges. The step fits a straight line through the individual detected edge points of each search line to determine the left edge of the fuse.

5. Click **OK** to add the step to the inspection.
Chapter 4   Inspecting for Multiple Correct Instances of an Object

Setting a Coordinate System

Complete the following instructions to configure a Set Coordinate System step based on the Find Straight Edge step you configured.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Set Coordinate System step. The property page for the step opens.

3. In the Main tab, enter Set Coordinate System in the Step Name control.

4. Select Horizontal Motion from the Mode control.

Notice the Origin list. Point 1, the first point of the straight line detected by the Locate Fuse Left Edge step, is the default origin of the coordinate system. In this exercise, the location of the origin does not affect the measurement you need to make. Therefore, use the default origin.

5. Click OK to add the step to the inspection.

Measuring the Separation between Connectors

Complete the following instructions to configure a Caliper step that measures the distance between the blade connectors of the fuse.

1. In the Inspection Steps palette, select the Measure Features tab.

2. Click the Caliper step. The property page for the step opens.

3. In the Main tab, enter Measure Separation in the Step Name control.

4. Enable the Reposition Region of Interest control.
5. Draw an ROI across the blade connectors, as shown in Figure 4-2.

**Figure 4-2. Measuring the Distance Between Two Edges**

6. In the **Settings** tab, select the **Process** named **Vertical Min Caliper** to change the direction and orientation of the caliper search lines.

7. In the **Limits** tab, enable the **Minimum Distance** control and set the value to 150. Enable the **Maximum Distance** control and set the value to 160.

8. Click **OK** to add the step to the inspection.
Inspecting the Fuse Conductor

Complete the following instructions to configure Match Pattern steps that inspect the integrity of the fuse conductor.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Match Pattern step. The NI Vision Template Editor opens.

3. Draw an ROI around the conductor, as shown in Figure 4-3. This region becomes the pattern matching template.

4. Click Next.

5. Click Finish to accept the template.

6. On the Main tab, enter Match Conductor 1 in the Step Name control.
7. Make sure the **Reposition Region of Interest** control is enabled.
8. Redraw or decrease the default green ROI so that it surrounds an area slightly larger than the template, as shown in Figure 4-4.

**Figure 4-4. Limiting the Search Region**

9. In the **Specifications** tab, set **Number of Matches to Find** to 1.
10. In the **Limits** tab, enable the **Minimum Number of Matches** control and set the value to 1.
11. Click **OK** to add the step to the inspection.
12. Click the **Run Inspection Once** button twice so that Image 03.jpg becomes the active image.

**Note** The name of the active image is displayed in the **Acquire Fuse** step in the State Configuration window.
A fuse may be inverted when Vision Builder AI acquires an image of the fuse. This inversion causes the conductor to look different than the template, shown in Figure 4-5a. To prevent a good but inverted fuse from failing inspection, you need to learn a pattern matching template for the inverted instances of the conductor as well, shown in Figure 4-5b.

**Figure 4-5. Valid Templates for the Conductor**

13. In the Inspection Steps palette, select the **Locate Features** tab.

14. Click the **Match Pattern** step. The **NI Vision Template Editor** opens.

15. Draw an ROI around the conductor, similar to the region you drew in step 3.

16. Click **Next** to learn the inverted template.

17. Click **Finish** in the **NI Vision Template Editor** window.

18. In the **Step Name** control, enter **Match Conductor 2**.

19. Set the **Region of Interest** control to **Match Conductor 1**. This configures the **Match Conductor 2** step to use the same ROI that you previously defined for the **Match Conductor 1** step.

20. In the **Specifications** tab, set **Number of Matches to Find** to 1.

21. In the **Limits** tab, enable the **Minimum Number of Matches** control and set the value to 1.

22. Click **OK** to add the step to the inspection.
Making Logical PASS/FAIL Decisions

In the previous lessons, the inspection would fail if any of the steps in the inspection failed. In this lesson, because the conductor under inspection can match only one of the patterns you specified, one of the Match Pattern steps always fails. If you were to set the Inspection Status to fail if any of the steps in the inspection fail, the entire inspection will always fail because one of the Match Pattern steps always fails.

Using the Logic Calculator step, you can create a Boolean result that is based on the results of the previous inspection steps. The Set Inspection Status step can use this Boolean result to determine the Inspection Status.

Complete the following instructions to configure a Logic Calculator step that causes the inspection to pass when the conductor matches either the template in Match Conductor 1 or Match Conductor 2, and when the Measure Separation step passes.

1. In the Inspection Steps palette, select the Use Additional Tools tab.
2. Click the Logic Calculator step. The property page opens in the Main window.
3. In the Step Name control, enter Decide Pass/Fail.
4. In the First Operand frame, set Source to Measure Separation. Set Measure to Step Status. Current Value displays the value of the measurement based on the current image.
5. Make sure Second Operand is set to Constant, and Constant is set to True.
6. Click Add to add this expression to the Expression table.
8. Make sure Second Operand is set to Constant, and Constant is set to True.
9. Click Add to add this expression to the Expression table.
10. In the First Operand frame, set Source to Match Conductor 2. Set Measure to Step Status.
11. Make sure Second Operand is set to Constant and Constant is set to True.
12. Click Add to add this expression to the Expression table.
13. Select the second expression in the Expression table, and click AND/OR to change the binary operator to OR.
14. Hold down the <Shift> key, and select the second and third expressions in the Expression table.

15. Click () to group the expressions.

The Logic Calculator property page should resemble Figure 4-6.

**Figure 4-6. Logic Calculator Property Page**

16. Click OK to add the step to the inspection.

**Setting the Inspection Status**

Complete the following instructions to configure Vision Builder AI to pass the inspection when the Logic Calculator step passes, regardless of the results of individual steps in the inspection.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Set Inspection Status step. The property page for the step opens.

3. In the Step Name control enter Set Inspection Status.
4. In the Inspection Status control select the **Set to measurement value** option, and select **Decide Pass/Fail - Step Status** for the value.
5. Make sure the **Update Number of Parts Inspected** control is enabled.
6. Click **OK** to add the step to the inspection.

## Testing the Inspection

Test the inspection to make sure it returns the results you expect. Click the **Run Inspection Once** button to test the remaining images. Table 4-1 lists the test images, the inspection status to expect for each image, and an explanation of the status.

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Inspection Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 01.jpg</td>
<td>PASS</td>
<td>All steps pass but one <strong>Match Pattern</strong> step.</td>
</tr>
<tr>
<td>Image 02.jpg</td>
<td>PASS</td>
<td>All steps pass but one <strong>Match Pattern</strong> step.</td>
</tr>
<tr>
<td>Image 03.jpg</td>
<td>PASS</td>
<td>All steps pass but one <strong>Match Pattern</strong> step.</td>
</tr>
<tr>
<td>Image 04.jpg</td>
<td>PASS</td>
<td>All steps pass but one <strong>Match Pattern</strong> step.</td>
</tr>
<tr>
<td>Image 05.jpg</td>
<td>PASS</td>
<td>All steps pass but one <strong>Match Pattern</strong> step.</td>
</tr>
<tr>
<td>Image 06.jpg</td>
<td>FAIL</td>
<td>The <strong>Measure Separation</strong> step fails because the blade connectors are too close together.</td>
</tr>
<tr>
<td>Image 07.jpg</td>
<td>FAIL</td>
<td>Both <strong>Match Pattern</strong> steps fail because the conductor is blown.</td>
</tr>
<tr>
<td>Image 08.jpg</td>
<td>FAIL</td>
<td>Both <strong>Match Pattern</strong> steps fail because the conductor is melted.</td>
</tr>
</tbody>
</table>
Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select **File»Save** or click the **Save** button on the toolbar.

2. Navigate to the location where you want to save the inspection.

3. In the **File Name** control, enter **Tutorial 3.vbai**.

4. Click **Save** to save the inspection.

**Tip** Select **File»Inspection Properties** to add a short description or comments about the inspection.
Inspecting an Object that Spans Two Image Frames

This chapter introduces the Select Image and Calculator steps.

Assume that you need to measure the width of a wide wooden plank with high accuracy. The only cameras available for the application have low pixel resolutions.

To measure the width of a plank, you need to locate its left and right edges. If you were to set up the imaging system so both edges of a plank fit within an available camera’s field of view, the resulting image detail would be too low to yield accurate measurements. Because the required image detail exceeds the pixel resolution capability of a single camera, two cameras per plank are needed—one camera to acquire an image of the left edge and one camera to acquire an image of the right edge.

Follow the instructions in this chapter to create an inspection that measures the width of a wooden plank that spans two images.

Note   Launch Vision Builder AI if it is not open. Refer to the Vision Builder AI Configuration Interface section of Chapter 1, Introduction to Vision Builder AI, for more information.

Creating a New Inspection

Select File»New to load a new, blank Vision Builder AI inspection.

Acquiring Inspection Images from Two Cameras

For simplicity, this tutorial instructs you to use the Read Image File step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.
Acquiring and Calibrating the Image of the Left Edge

Complete the following instructions to configure Read Image File steps that simulate acquiring an image of the left section of the wooden plank and calibrating the image.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Read Image File step. The property page for the step opens.

3. In the Step Name control, enter Acquire Plank (Left).

4. Click the Browse button. The Select an Image File dialog box opens.

5. Navigate to <Public Documents>\National Instruments\Vision Builder AI\DemoImg\Tutorial 4 Left.

6. Select the first image, Image 01.jpg, and click Open.

7. Make sure that the Cycle Through Folder Images control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.

8. Click the Calibration tab.

9. Click Create Calibration to launch the calibration training interface.

10. In the Calibration Name control, enter Plank Calibration (Left).

11. Click Next.

For this example, assume that the camera that acquired the inspection images is perpendicular to the image plane and lens distortion is negligible. Based on these assumptions, you can use Point Distance Calibration to calibrate your images. Point Distance Calibration transforms a pixel coordinate to a real-world coordinate through scaling in the x (horizontal) and y (vertical) directions.

12. Select the Point Distance Calibration option, and click Next.

13. Make sure that the current image is selected, and click Next.
14. Carefully click the 1 cm and 5 cm markings on the ruler at the bottom of the image, as shown in Figure 5-1.

Tip You may need to use the zoom buttons below the image or the mouse wheel to accurately click the ruler markings. After zooming in, scroll down to see the ruler at the bottom of the image.

Figure 5-1. Defining the Pixel to Real-World Ratio

15. In the Distances control, enter 4 for the Real World value, and select centimeter for the Unit.
16. Click Next.
17. Ignore the Compute Lens Distortion Model option and click Next.
Chapter 5  Inspecting an Object that Spans Two Image Frames

18. In the Specify Calibration Axis step, click the 1 cm marking to define it as the origin of the calibration axis. Draw a line horizontally and to the right along the edge of the ruler to define the angle of the calibration axis, as shown in Figure 5-2.

**Figure 5-2. Defining the Origin and Angle of the Calibration Axis**

19. Set the Axis Reference control to Direct.
20. Click Next.
21. Click OK to learn the calibration information and exit the calibration training interface.
22. Click OK to add the step to the inspection.

**Acquiring and Calibrating the Image of the Right Edge**

This section simulates acquiring an image of the right section of the wooden plank. Because the simulated acquisition represents a second camera, you cannot reuse the calibration that you created for the first camera.

Complete the following instructions to configure Read Image File steps that simulate acquiring an image of the right section of the wooden plank and calibrating the image.

1. In the Inspection Steps palette, select the Acquire Images tab.
2. Click the **Read Image File** step. The property page for the step opens.

3. In the **Step Name** control, enter **Acquire Plank (Right)**.
4. Click the **Browse** button. The **Select an Image File** dialog box opens.

5. Navigate to `<Public Documents>\National Instruments\<Vision Builder AI>\DemoImg\Tutorial 4 Right`.

   **Note** Ensure that you have selected the appropriate folder if you have more than one version of Vision Builder AI installed.

6. Select the first image, **Image 01.jpg**, and click **Open**.
7. Make sure the **Cycle Through Folder Images** control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.
8. Click the **Calibration** tab.
9. Click **Create Calibration** to launch the calibration training interface.
10. In the **Calibration Name** control, enter **Plank Calibration (Right)**.
11. Click **Next**.

   Again, assume that the camera that acquired the inspection images is perpendicular to the image plane and lens distortion is negligible.

12. Select the **Point Distance Calibration** option, and click **Next**.
13. Make sure the current image is selected, and click **Next**.
Chapter 5   Inspecting an Object that Spans Two Image Frames

14. Carefully click the 38 cm and 42 cm markings on the ruler at the bottom of the image, as shown in Figure 5-35-3.

Tip You may need to use the zoom buttons below the image or the mouse wheel to accurately click the ruler markings. After zooming in, scroll down to see the ruler at the bottom of the image.

Figure 5-3. Defining the Pixel to Real-World Ratio

15. In the Distances control, enter 4 for the Real World value and select centimeter for the Unit.

16. Click Next.

17. Ignore the Compute Lens Distortion Model option and click Next.
18. In the **Specify Calibration Axis** step, click the 38 cm marking to define it as the origin of the calibration axis. Draw a line horizontally and to the right along the edge of the ruler to define the angle of the calibration axis, as shown in Figure 5-4.

**Figure 5-4.** Defining the Origin and Angle of the Calibration Axis

19. Set the **Axis Reference** control to **Direct**.

20. Click **Next**, then **OK** to learn the calibration information and exit the calibration training interface.

21. Click **OK** to add the step to the inspection.

**Locating the Right Edge of the Part**

Complete the following instructions to configure a **Find Edges** step that locates the right edge of the part.

1. In the Inspection Steps palette, select the **Locate Features** tab.

2. Click the **Find Edges** step. The property page for the step opens.
3. In the **Step Name** control, enter **Find Right Edge**.

4. Draw a line across the right edge of the part going from right to left, as shown in Figure 5-5.

   **Tip** Pressing the <Shift> key while drawing a line constrains the line tool to only draw horizontal or vertical lines.

5. Click the **Settings** tab.

6. In the **Look for** control, select **First Edge**.

7. In the **Edge Polarity** control, select **Bright to Dark Only**.

   ![Figure 5-5. Finding the Right Edge of the Plank](image)

   Notice the red square on the search line. The step searches along the search line for a sharp transition in pixel intensities, which usually represents an object edge. The red square marks the location of the right edge of the part.

8. Click **OK** to add the step to the inspection.
Switching Images

Now that you have configured the inspection to locate the right edge of the wooden plank, you need to switch to the image of the left side of the plank. Complete the following instructions to configure a Select Image step that makes the image of the left side of the plank active for processing.

1. In the Inspection Steps palette, select the Acquire Images tab.

2. Click the Select Image step. The property page for the step opens.

3. In the Step Name control, enter Switch to Left Side.

4. In the Image Selection list, select Acquire Plank (Left). The image of the left side of the part appears in the Main window.

5. Click OK to add the step to the inspection.

Locating the Left Edge of the Part

Complete the following instructions to configure a Find Edges step that locates the left edge of the part.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Find Edges step. The property page for the step opens.

3. In the Step Name control, enter Find Left Edge.
4. Hold down the <Shift> key and draw a line across the left edge of the part going from left to right, as shown in Figure 5-6.

5. Click the **Settings** tab.

6. In the **Look for** control, select **First Edge**.

7. In the **Edge Polarity** control, select **Bright to Dark Only**.

   **Figure 5-6.** Finding the Left Edge of the Plank

    The step searches along the search line and marks the location of the left edge with a red square.

8. Click **OK** to add the step to the inspection.
Calculating the Width of the Part

Now that you have located the right edge of the part in one image and the left edge of the part in another image, you need to combine the measurements from the two images to determine the width of the part. Use the Calculator step to combine the two measurements and compute the width.

Refer to the following equations as you configure the step.

\[
Right\ (LC) = Right\ (RC) + (Origin\ R - Origin\ L) \tag{5-1}
\]

\[
Part\ Width = Right\ (LC) - Left\ (LC) \tag{5-2}
\]

where

- \(Right\ (LC)\) = The x position of the right edge in the calibration axis of the left edge.
- \(Right\ (RC)\) = The x position of the right edge in the calibration axis of the right edge. This corresponds to the calibrated x position result of the Find Right Edge step.
- \(Origin\ R\) = The x position of the origin in the calibration axis of the right edge.
- \(Origin\ L\) = The x position of the origin in the calibration axis of the left edge.
- \(Left\ (LC)\) = The x position of the left edge in the calibration axis of the left edge. This corresponds to the calibrated x position result of the Find Left Edge step.

Setting Calculator Step Inputs and Outputs

Complete the following instructions to configure a Calculator step to select the input measurements from the previous Find Right Edge and Find Left Edge steps, and create output results for the calculated values.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Calculator step. The Calculator Setup Wizard opens.

Notice the Input Measurements list. The list contains all of the measurable data from each of the previous steps in the inspection.
Chapter 5  Inspecting an Object that Spans Two Image Frames

3. Select the following measurements from the **Input Measurements** list:
   - Step#3: Find Right Edge»Edge [1] X Position (Calibrated)»Edge [1].X Position (Calibrated)
   - Step#5: Find Left Edge»Edge [1].X Position (Calibrated)»Edge [1].X Position (Calibrated)

4. Select **Output Results** tab.

5. Click **Add New Output Result**. A new output appears in the **Output Results** list.

6. In the **Name** control, enter **Part Width**. This output will contain the results of Equation 5-2.

7. Make sure **Type** is set to **Numeric**.

8. Click **Add New Output Result** again.

9. In the **Name** control, enter **Right (LC)**. This output will contain the results of Equation 5-1.

10. Make sure **Type** is set to **Numeric**.

11. Click **OK** to close the Calculator Setup Wizard.

The **Main** window now displays a diagram with the measurement inputs and result outputs you specified in the Calculator Setup Wizard, as shown in Figure 5-7. The diagram also contains a default Boolean result named **Step Result**. You can connect the result of a computation to **Step Result**, which changes the status of the **Calculator** step to the result of the computation. Refer to the **Making Logical PASS/FAIL Decisions with the Calculator Step** section of this chapter for more information about **Step Result**.

**Figure 5-7.** Calculator Diagram Elements

Notice that the inputs and outputs are framed with color and have codes at the bottom of their frames. These colors and codes visually group inputs and outputs into their respective **data types**—numerics, Booleans, or strings.
12. To simplify the process of connecting the diagram elements later in this chapter, arrange the elements into the configuration shown in Figure 5-8 by dragging them to their new positions.

Figure 5-8. Arranging Diagram Elements

Adding Operators and Constants
Earlier in this chapter, you used the Calibration Wizard to set calibration axis origins for the right and left sides of the part. These origins are the only elements of Equations 5-1 and 5-2 not yet represented in the Calculator diagram: \(\text{Origin } R\) and \(\text{Origin } L\).

In step 18 of the Acquiring and Calibrating the Image of the Right Edge section of this chapter, you set the origin of the right side to the 38 cm marking of the imaged ruler. In step 18 of the Acquiring and Calibrating the Image of the Left Edge section of this chapter, you set the origin of the left side to the 1 cm marking of the imaged ruler. Therefore,

\[(\text{Origin } R - \text{Origin } L) = 38 - 1 = 37.\]

The distance between the calibration axis origins is a constant value. Add a constant with the value 37 to the Calculator diagram.

1. Click the Show Functions Palette button.
2. In the Functions Palette window, select Numeric palette.
3. Click the Numeric Constant.
4. Click inside the Calculator diagram below the Find Right Edge - Edge [1].X Position (Calibrated) input measurement to place the numeric constant on the Calculator diagram.
5. Double-click the numeric constant and type 37 to set the value of the constant.

6. Click the Add operator in the Functions palette. Click inside the Calculator diagram to the right of the Find Right Edge - Edge [1].X Position (Calibrated) input measurement.

   **Tip** Place the Add operator close enough to the Find Right Edge - Edge [1].X Position (Calibrated) input so that the Calculator step automatically connects the two elements with a wire.

7. Click the Help button in the Calculator diagram toolbar to launch the Help window. When you move your cursor over certain elements within the Calculator diagram, information about that item shows in the Help window.

8. Place your cursor over the Add operator. Notice in the Help window that the operator has an x input terminal, y input terminal, and x+y output terminal.

9. Click the Subtract operator in the Functions palette. Click inside the Calculator diagram to the right of the Find Left Edge - Edge [1].X Position (Calibrated) input measurement.

Your Calculator diagram should look similar to the diagram shown in Figure 5-9.

**Figure 5-9. Unconnected Diagram Elements**
Connecting the Equation Elements

Complete the following instructions to wire the diagram elements together such that they form Equation 5-1: \( \text{Right (LC)} = \text{Right (RC)} + (37) \).

1. Place your cursor on the small, triangular terminal located on the right side of the numeric constant. The cursor changes into a Wiring tool.

2. Use the Wiring tool to click the terminal and release the mouse. As you move the cursor across the Calculator diagram, the Calculator step draws a wire between the terminal and the Wiring tool as though the wire were unwinding from a spool.

3. Without holding down the mouse button, move the cursor to the \( y \) input terminal of the Add operator. The \( y \) input terminal blinks. Use the Wiring tool to click the \( y \) input terminal and complete the connection.

4. Click the output terminal of the Add operator, and connect it to the input terminal of Right (LC).

   **Tip** If you do not terminate a wire correctly, the wire is broken and appears as a dashed black line with a red X in the middle. Click Remove Broken Wires in the Main tab to remove broken wires.

Complete the following instructions to wire the diagram elements together such that they form Equation 5-2: \( \text{Part Width} = \text{Right (LC)} - \text{Left (LC)} \).

1. Place the cursor on the wire that connects the Add operator to Right (LC). The cursor changes into the Wiring tool.

2. Click the wire, and connect it to the \( x \) input terminal of the Subtract operator.

3. Click the Find Left Edge - Edge [1].X Position (Calibrated) output terminal, and connect it to the \( y \) input terminal of the Subtract operator.

4. Click the output terminal of the Subtract operator, and connect it to the input terminal of Part Width.
Chapter 5 Inspecting an Object that Spans Two Image Frames

Your connected Calculator diagram should look similar to the diagram shown in Figure 5-10.

Figure 5-10. Connected Elements of Calculator Diagram

5. In the **Calculator** step property page, click the **Measurements** tab.
6. Click **Compute Results** to see the results of the calculation thus far.

Making Logical PASS/FAIL Decisions with the Calculator Step

Now that you have created a diagram to measure the width of the part, you need a way to verify that the width meets manufacturing specifications. Complete the following instructions to add diagram elements that compare the measured width to minimum and maximum width tolerances and decide whether the plank passes inspection.

1. Click the up arrow in the Functions palette to return to the main palette.
2. Select the **Comparison** palette.
3. Click the **Less?** operator in the Comparison palette. Click inside the Calculator diagram below **Part Width**.
4. Connect the wire between **Subtract** and **Part Width** to the x input of the **Less?** operator.
5. Click the up arrow in the Functions palette to return to the main palette.
6. Select the **Numeric** palette.
7. Click the **Numeric Constant** in the Numeric palette.
8. Click close enough to the y input of **Less?** to automatically wire the numeric constant and y input together.
9. Double click the constant and type **40.5** to set the maximum width a plank can be to pass the inspection.
10. Click the up arrow in the Functions palette to return to the main palette.
11. Select the **Comparison** palette.

12. Click the **Greater?** operator. Click inside the Calculator diagram below the **Less?** operator.

13. Connect the wire between **Subtract** and **Part Width** to the **x** input of the **Greater?** operator.

14. Click the up arrow in the Functions palette to return to the main palette.

15. Select the **Numeric** palette.

16. Click the **Numeric Constant**.

17. Click close enough to the **y** input of **Greater?** to automatically wire the numeric constant and **y** input together.

18. Double click the constant and type 39.5 to set the minimum width a plank can be to pass the inspection.

19. Click the up arrow in the Functions palette to return to the main palette.

20. Select the **Boolean** palette.

21. Click the **And** operator. Click close enough to the left side of **Step Result** to wire the two elements together.

22. Connect the **Less?** output to the **x** input of **And**.

23. Connect the **Greater?** output to the **y** input of **And**.

Your completed Calculator diagram should look similar to the diagram shown in Figure 5-11.

**Figure 5-11. Calculator Diagram with Decision-Making Abilities**

---

24. In the **Calculator** step property page, click the **Limits** tab.

25. Enable the **Step Result is True** checkbox.

26. Click **OK** to add the step to the inspection.
Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to determine whether the inspection passes or fails.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Set Inspection Status step. The property page for the step opens.

3. In the Inspection Status control, Select the Set to FAIL if any previous step fails option.

4. Click OK to add the step to the inspection.
Testing the Inspection

Test the inspection to make sure it returns the results you expect. Click the Run Inspection Once button to test the remaining images. Table 5-1 lists the test images, the inspection status to expect for each image, and an explanation of the status.

![Note](image)

Note: Results may vary slightly based on the accuracy of the calibration and the edge detection location.

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Part Width</th>
<th>Inspection Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 01.jpg</td>
<td>39.99 cm</td>
<td>PASS</td>
</tr>
<tr>
<td>Image 02.jpg</td>
<td>40.12 cm</td>
<td>PASS</td>
</tr>
<tr>
<td>Image 03.jpg</td>
<td>40.25 cm</td>
<td>PASS</td>
</tr>
<tr>
<td>Image 04.jpg</td>
<td>39.23 cm (too short)</td>
<td>FAIL</td>
</tr>
<tr>
<td>Image 05.jpg</td>
<td>40.89 cm (too long)</td>
<td>FAIL</td>
</tr>
</tbody>
</table>

Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select File→Save or click the Save button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the File Name control, enter Tutorial 4.vbai.
4. Click Save to save the inspection.

Tip: Select File→Inspection Properties to add a short description or comments about the inspection.
Branching and Decision Making

This chapter introduces the inspection state diagram and the Custom Overlay step. Follow the instructions in this chapter to create an inspection that checks the image for the presence of a spray bottle and, if a bottle is present, transitions to another state to determine if the bottle has a cap. If there is no spray bottle present in the image, the inspection moves on to the next image.

**Note**  
Launch Vision Builder AI if it is not open. Refer to the *Vision Builder AI Configuration Interface* section of Chapter 1, *Introduction to Vision Builder AI*, for more information.

Creating a New Inspection

Select **File»New** to load a new, blank Vision Builder AI inspection.

Creating the Inspection State Diagram

The configurable process model in Vision Builder AI is represented by a state diagram. Complete the following instructions to create a state diagram to define the inspection.

1. Click the **Toggle Main Window View** button on the toolbar to bring the state diagram to the Main window.

![Figure 6-1. Default Inspection State Diagram](image)
2. Double-click the **Inspect** state to launch the Edit State Name dialog box.
3. In the State Name control, enter **Check Part Presence**, and click **OK**.
4. Right-click an open area on the state diagram and select **Create New State** to add a new state to the inspection, as shown in Figure 6-2. The Edit State Name dialog box opens.

   **Figure 6-2. Creating a New Inspection State**

5. In the State Name control, enter **Inspect Part**.
6. Create two more states named **Fail Part** and **Pass Part**. The state diagram should now resemble the state diagram shown in Figure 6-3.

   **Figure 6-3. Adding New States to the Inspection**
Next, you will create transitions between the various inspection states. Notice that every state has a default transition. You can also create additional transitions between states based on measurement results or variable values.

**Note**  
The default transition occurs if the transition requirements for other possible transitions are not met.

7. Click the arrow of the Check Part Presence default transition and drag it back to the Check Part Presence state. This creates a loop that will run the steps in the Check Part Presence State until a part is detected.
8. Click the **End** point and drag it to the bottom of the state diagram.
9. Click the Inspect Part default transition and drag it to the Fail Part state.
10. Click the Fail Part default transition and drag it to the End point.
11. Click the Pass Part default transition and drag it to the End point.

The state diagram should now resemble the state diagram shown in Figure 6-4.

---

**Figure 6-4.** Configuring the Default Transitions

---

12. Right-click the Check Part Presence state and select **Create New Transition**.
13. Click the **Inspect Part** state to create a transition between the Check Part Presence and Inspect Parts states, as shown in Figure 6-5.

**Figure 6-5. Creating a New Transition**

You can change the shape of the transition by dragging the anchor point at the center of the transition. You can move the location of the transition label by clicking the label and dragging it to the new location.

**Tip** When drawing a transition, click once on the state diagram to set the anchor point for the transition. The anchor point allows you to draw an arc instead of a straight line to represent the transition.

14. Double-click the transition to launch the Edit Transition dialog box, which is used to configure the transition.

15. In the **Transition Name** control, enter **Part Detected**, and click **OK**.

16. Create another transition named **Part OK** between the **Inspect Part** and **Pass Part** states.
The state diagram should now resemble the state diagram shown in Figure 6-6.

**Figure 6-6. Completed State Diagram for the Inspection**

![State Diagram Image]

**Note** You can remove a state or transition from the inspection by selecting the object you want to remove and pressing the <Delete> key.

**Note** You cannot rename or remove the default transition of a state.

Each state in an inspection is intended to contain a separate set of inspection steps. To access the functions in a state, click the state in the state diagram. The currently selected state is highlighted in blue on the state diagram.

### Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the **Read Image File** step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a **Read Image File** step that simulates acquiring images of spray bottles.

17. On the state diagram, click the **Check Part Presence** state.
Chapter 6  Branching and Decision Making

18. In the Inspection Steps palette, select the **Acquire Images** tab.

19. Click the **Read Image File** step. The property page for the step opens.

**Note**  When the property page for an inspection step opens, if the state diagram is displayed in the Main window, the state diagram switches from the Main window to the Overview window to allow you to use the current inspection image to configure the step.

20. In the **Step Name** control, enter **Acquire Image**.

21. Click the **Browse** button. The **Select an Image File** dialog box opens.

22. Navigate to `<Public Documents>\National Instruments\Vision Builder AI\DemoImg\Tutorial 5`.

**Note**  Ensure that you have selected the appropriate folder if you have more than one version of Vision Builder AI installed.

23. Select an image containing the entire spray bottle, such as **Image 00480.jpg**, and click **Open**.

24. Make sure the **Cycle Through Folder Images** control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.

25. Click **OK** to add the step to the inspection.

## Checking for a Spray Bottle in the Image

Complete the following instructions to configure a **Match Pattern** step to check for the presence of a spray bottle in the image.

1. In the Inspection Steps palette, select the **Locate Features** tab.
2. Click the **Match Pattern** step. The NI Vision Template Editor opens.

3. Draw a region of interest (ROI) around the bottom left edge of the bottle. This region becomes the pattern matching template.
4. Click **Next**.
5. Click **Finish** to accept the template.
6. On the **Main** tab, enter **Locate Bottle** in the **Step Name** control.
7. Adjust the default green ROI so that it only surrounds the area of the image that could contain the bottom left edge of a spray bottle, as shown in Figure 6-7.

![Figure 6-7. Adjusting the Search Region](image)

8. On the **Specifications** tab,
   - set **Number of Matches to Find** to 1, and
   - uncheck **Rotated**.
9. On the **Limits** tab, enable the **Minimum Number of Matches** control, and set the value to 1.
10. Click **OK** to add the step to the inspection.
Checking for the Cap Using the Caliper

You can check for the presence of the cap on a spray bottle by using the **Caliper** step to find two edges where the cap is supposed to be and measuring the distance between them. Complete the following instructions to configure a **Caliper** step to check for the presence of the spray bottle cap.

1. In the Overview window, click the **Inspect Part** state on the state diagram.
2. In the Inspection Steps palette, select the **Measure Features** tab.
3. Click the **Caliper** step. The property page for the step opens.
4. In the **Step Name** control, enter **Check Cap Presence**.
5. Draw an ROI around the area in the image where a cap should appear, as shown in Figure 6-8.

**Figure 6-8. Checking for Cap Presence**

6. On the **Settings** tab, select the **Process** named **Horizontal Max Caliper** to change the direction and orientation of the caliper search lines.

7. Set the **Gap** control to 10, **Edge Strength** to 40, and **Smoothing** to 12 to ensure that the step correctly detects the edges of the cap.

8. On the **Limits** tab, enable the **Minimum Distance (Pixels)** control, and set the value to 140.

9. Enable the **Maximum Distance (Pixels)** control, and set the value to 160.

10. Click **OK** to add the step to the inspection.
Chapter 6  Branching and Decision Making

Setting the Inspection Status

Complete the following instructions to add a Set Inspection Status step to determine whether the inspection passes or fails.

1. In the Inspection Steps palette, click the Use Additional Tools tab.

2. Click the Set Inspection Status step. The property page for the step opens.

3. In the Inspection Status control, select the Set to FAIL if any previous step fails option.

4. Click OK to add the step to the inspection.

Creating Custom Overlays for Inspection

Use the Custom Overlay step to create custom overlays that display whether the inspection passed or failed.

Complete the following steps to create an overlay to display when the inspection fails.

1. In the Overview window, click the Fail Part state on the state diagram.

2. In the Inspection Steps palette, select the Use Additional Tools tab.

3. Click the Custom Overlay step. The property page for the step opens.

4. In the Step Name control, enter Overlay Results.

5. On the Custom Overlay tab, select the Text tool and click a point in the image near the bottom of the spray nozzle of the bottle.
6. In the **Text** Control, enter *Missing Cap!.*
7. Click the **Text Properties** button. The Text Properties dialog box opens.

8. In the **Desired Font** control, select **User-Specified Font**.
9. Specify a **Font Name** and **Size** to use for the overlay.
10. In the **Horizontal Alignment** control, select **Center**. This centers the text around the point you selected using the Text tool.
11. Click **OK** to save the Text Properties settings and close the dialog box.
12. Click **OK** to add the step to the inspection.

Next, you need to create an overlay to display if the inspection passes. Complete the following steps to create an overlay to display when the inspection passes.

13. In the Overview window, click the **Pass Part** state on the state diagram.

15. Click the **Custom Overlay** step. The property page for the step opens.
16. In the **Step Name** control, enter *Overlay Results.*
17. On the **Custom Overlay** tab, select the **Rectangle** tool and draw a rectangle in the upper-left corner of the image.

18. Click the **Stroke** control, and select black.
19. Click the **Fill** control, and select a bright green color.
20. On the **Custom Overlay** tab, select the **Text** tool, and click a point just below the center of the rectangle overlay.

21. In the **Text** control, enter **Part OK**.
22. Click the **Text** color control, and select black.
23. Click the **Text Properties** button. The Text Properties dialog box appears.

24. In the **Desired Font** control, select **User-Specified Font**.
25. Specify a **Font Name** and **Size** to use for the overlay.
26. In the **Horizontal Alignment** control, select **Center**.
27. Click **OK** to save the Text Properties settings and close the dialog box.
28. Click **OK** to add the step to the inspection.

Figure 6-9 shows the overlays for both Pass and Fail images.

**Figure 6-9. Creating Custom Overlays for Images that Pass and Fail**
Configuring State Transitions

Once you have configured all of the states in the inspection and created transitions between the states, you need to define the conditions that trigger a transition between inspection states. Complete the following instructions to define the transitions between inspection states.

1. Click the **Toggle Main Window View** button to display the state diagram in the Main window.

2. Double-click the **Part Detected** transition to launch the Edit Transition dialog box, which is used to configure the transition.

3. In the Edit Transition dialog box, modify the controls to transition when **Locate Bottle - # Matches** is **Equal** to 1, as shown in Figure 6-10.

   **Figure 6-10.** Configuring the Part Detected Transition

4. Click **OK** to close the Edit Transition dialog box.

5. Double-click the **Part OK** transition. The Edit Transition dialog box opens.
6. In the Edit Transition dialog box, modify the controls to transition when **Check Cap Presence - Step Status** is **Pass**, as shown in Figure 6-11.

   **Figure 6-11. Configuring the Part OK Transition**

7. Click **OK** to close the Edit Transition dialog box.

**Testing the Inspection**

Test the images in the **Tutorial 5** folder to make sure the inspection returns the correct results. Click the **Run Inspection Once** button to test the remaining images. Table 6-1 displays the expected results for each image.

   **Table 6-1. Expected Results for the State Diagram Branching Inspection**

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Inspection Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 00480.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 01710.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
<tr>
<td>Image 03450.jpg</td>
<td>FAIL</td>
<td>Cap is missing.</td>
</tr>
<tr>
<td>Image 04200.jpg</td>
<td>PASS</td>
<td>Cap is present.</td>
</tr>
</tbody>
</table>
Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select **File»Save** or click the **Save** button on the toolbar.

2. Navigate to the location where you want to save the inspection.
3. In the **File Name** control, enter **Tutorial 5.vbai**.
4. Click **Save** to save the inspection.

**Tip**  Select **File»Inspection Properties** to add a short description or comments about the inspection.
Loopying and Variables

This chapter uses the inspection state diagram to implement a looping inspection and introduces the **Set Variable** and **Array Operator** steps. Follow the instructions in this chapter to create an inspection that inspects images of electronic components to determine if the distance between pins on the component is within a predetermined range. If the pin is too close or too far away from an adjacent pin, then the inspection fails. The inspection does not need to check every pin on the microchip before failing the inspection. The inspection fails at the first failed pin.

**Note**  
Launch Vision Builder AI if it is not open. Refer to the *Vision Builder AI Configuration Interface* section of Chapter 1, *Introduction to Vision Builder AI*, for more information.

Creating a New Inspection

Select **File** » **New** to load a new, blank Vision Builder AI inspection.

Creating the Inspection State Diagram

Complete the following instructions to create a state diagram to define the inspection.

1. Click the **Toggle Main Window View** button on the toolbar to bring the inspection state diagram to the Main window.

2. Double-click the **Inspect** state to launch the Edit State Name dialog box.
3. In the **State Name** control, enter **Acquire Image & Find Pin Edges**.
Chapter 7  Looping and Variables

4. Right-click an open area on the state diagram and select **Create New State** to add a new state to the inspection, as shown in Figure 7-1. The Edit State Name dialog box opens.

   **Figure 7-1. Creating a New Inspection State**

Next, you will define transitions between the various inspection states. Notice that every state has a default transition. You can also create additional transitions between states based on measurement results or variable values.

   **Note**  The default transition occurs if the transition requirements for other possible transitions are not met.

5. In the **State Name** control, enter **Check Pin Gap**.

6. Create two more states named **Fail Inspection** and **Pass Inspection**. The state diagram should now resemble the state diagram shown in Figure 7-2.

   **Figure 7-2. Adding New States to the Inspection**
7. Click the Acquire Image & Find Pin Edges default transition and drag it to the Check Pin Gap state.
8. Click the End point and drag it to the bottom of the state diagram.
9. Click the Check Pin Gap state default transition and drag it to the Pass Inspection state.
10. Click the Fail Inspection default transition and drag it to the End point.
11. Click the Pass Inspection default transition and drag it to the End point.

The state diagram should now resemble the state diagram shown in Figure 7-3.

**Figure 7-3. Configuring the Default Transitions**

12. Right-click the Acquire Image & Find Pin Edges state and select Create New Transition.
13. Click the **Fail Inspection** state to create a transition between the **Acquire Image & Find Pin Edges** state and the **Fail Inspection** state, as shown in Figure 7-4.

**Figure 7-4. Creating a New Transition**

You can change the shape of the transition by dragging the anchor point at the center of the transition. You can move the location of the transition label by clicking the label and dragging it to the new location.

**Tip** When drawing a transition, click once on the state diagram to set the anchor point for the transition. The anchor point allows you to draw an arc instead of a straight line to represent the transition.

14. Double-click the transition to launch the Edit Transition dialog box.

15. In the **Transition Name** control, enter **Wrong # Pins**, and click OK.

16. Create a transition named **Failed** between the **Check Pin Gap** and **Fail Inspection** states.

17. Create a transition from the **Check Pin Gap** state that loops back to the **Check Pin Gap** state named **Repeat for Next Pin**.
The state diagram should now resemble the state diagram shown in Figure 7-5.

**Figure 7-5. Completed State Diagram for the Inspection**

Creating a Variable

Since the same inspection needs to be performed on each set of pins, creating a loop in the inspection eliminates the need to configure separate steps to inspect each set of pins. Use the Variable Manager to configure a variable to keep track of the number of times the loop executes.

1. Select **Tools»Variable Manager** to launch the Variable Manager.
2. On the Inspection Variables tab of the Variable Manager, click **Add** to launch the Add Inspection Variable dialog box.
3. In the **Name** control, enter **Counter**.
4. In the **Type** control, select **Numeric**.
5. In the **Initial Value** control, enter 1.
6. Click **OK** to create the variable.
7. Click **OK** to close the Variable Manager.
Acquiring Inspection Images

For simplicity, this tutorial instructs you to use the Read Image File step. However, in your real-world inspection, use one of the other image acquisition steps to acquire images of the object under inspection.

Complete the following instructions to configure a Read Image File step that simulates acquiring images of the pins on electronic components.

1. On the state diagram, select the Acquire Image & Find Pin Edges state.
2. In the Inspection Steps palette, select the Acquire Images tab.
3. Click the Read Image File step. The property page for the step opens.

   **Note**  When the property page for an inspection step opens, if the state diagram is displayed in the Main window, the state diagram switches from the Main window to the Overview window to allow you to use the current inspection image to configure the step.

4. In the Step Name control, enter Acquire Pins.
5. Click the Browse button. The Select an Image File dialog box opens.
6. Navigate to <Public Documents>\National Instruments\Vision Builder AI\DemoImg\Tutorial 6.
7. Select image 01.jpg, and click Open.
8. Make sure the Cycle Through Folder Images control is enabled so that Vision Builder AI loads a different simulation image from the folder each time the step is run.
9. Click OK to add the step to the inspection.
Finding Pin Edges

Complete the following instructions to configure a Find Edges step to find the edges of the pins and determine if the microchip has the correct number of pins.

1. In the Inspection Steps palette, select the Locate Features tab.

2. Click the Find Edges step. The property page for the step opens.

3. In the Step Name control, enter Find Pin Edges.

4. Hold down the <Shift> key and draw a line from left to right across the width of the image where the pins are located, as shown in Figure 7-6.

   Figure 7-6. Locating the Edges of the Pins of a Microchip

5. On the Settings tab, in the Look for control, select All Edges.

6. In the Edge Polarity control, select Bright to Dark Only.

7. On the Limits tab, enable the Minimum Number of Edges control and set the value to 7.

8. Enable the Maximum Number of Edges control and set the value to 7.

9. Click OK to add the step to the inspection.
Chapter 7  Looping and Variables

Initializing the Variable

Use the Set Variable step to set the value of user-defined variables. Complete the following instructions to configure a Set Variable step to initialize the Counter variable.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Set Variable step. The property page for the step opens in the Main window.

3. In the Step Name control, enter Initialize Counter.

4. In the Operation control, select the Set to Constant option and enter 1 for the value.

5. Click OK to add the step to the inspection.

Indexing Measurements in a Result Array

Complete the following instructions to configure an Array Operator step to index the x and y position results for the $i$th edge, where $i$ is the value of the Counter variable. The position results are returned by the Find Pin Edges step in the Acquire Image & Find Pin Edges state.

1. In the Overview window, click the Check Pin Gap state on the state diagram.

2. In the Inspection Steps palette, select the Use Additional Tools tab.

3. Click the Array Operator step. The property page for the step opens.

4. In the Step Name control, enter Get Edge Position.

5. In the Array Function list, select Index.

6. In the Source Array control, select the following array elements:
   - Acquire Image & Find Pin Edges»Find Pin Edges»Edge[].X Position (Pixel)
   - Acquire Image & Find Pin Edges»Find Pin Edges»Edge[].Y Position (Pixel)

7. In the Element Index list, select Inspection Variable - Counter (1).

8. Click OK to add the step to the inspection.
In the *Updating the Variable* section of this tutorial, you will set the Counter variable to increment by one each time the Check Pin Gap state is run. This ensures that a different set of pins is inspected each time the *Array Operator* step is run.

### Setting a Coordinate System

Complete the following instructions to configure a *Set Coordinate System* step based on the *Find Pin Edges step* you configured.

1. In the Inspection Steps palette, select the *Locate Features* tab.

2. Click the *Set Coordinate System* step. The property page for the step opens.

3. On the *Settings* tab, in the *Mode* control, select *Horizontal Motion* because the pins may shift horizontally from one image to another.

4. Click OK to add the step to the inspection.

### Checking the Pin Gap

Complete the following instructions to measure the gap between two pins and determine if it is within a certain range.

1. In the Inspection Steps palette, select the *Measure Features* tab.

2. Click the *Caliper* step. The property page for the step opens.

3. In the *Step Name* control, enter *Measure Gap*.

4. Enable the *Reposition Region of Interest* control and verify that *Set Coordinate System* is selected for the *Reference Coordinate System* control.
5. Draw an ROI over the gap between the first two pins, as shown in Figure 7-7.

Figure 7-7. Measuring the Distance Between Pins

6. In the Settings tab, select the Process named Horizontal Max Caliper to change the direction and orientation of the caliper search lines.

7. On the Limits tab, enable the Minimum Distance control and set the value to 30.00. Enable the Maximum Distance control and set the value to 46.00.

8. Click OK to add the step to the inspection.

**Updating the Variable**

After you have measured the gap between two pins, you must increment the Counter variable so that the next time the state is executed the next set of pins is inspected. Complete the following instructions to use a Set Variable step to increment the value of the Counter variable.

1. In the Inspection Steps palette, select the Use Additional Tools tab.

2. Click the Set Variable step. The property page for the step opens in the Main window.

3. In the Step Name control, enter Update Counter.
4. In the **Operation** control, select the **Increment** option.
5. Click **OK** to add the step to the inspection.

## Identifying Failed Pins

Complete the following instructions to create an overlay to identify a failed pin using the **Custom Overlay** step.

1. In the Inspection Steps palette, select the Use **Additional Tools** tab.
2. Click the **Custom Overlay** step. The property page for the step opens.
3. In the **Step Name** control, enter **Overlay Failed Gap**.
4. On the **Custom Overlay** tab, select the **Indicator** tool and draw a small indicator on the image.
5. In the **Top Left Point** control, select **Get Edge Position - Edge [i]**. This aligns the top left point of the indicator overlay with the \(i\)th edge found by the **Get Edge Position** step.
6. In the **X Offset** control, enter 35. In the **Y Offset** control, enter 28. This positions the indicator overlay over the gap between two pins.
7. In the **Value** control, select **Measure Gap - Step Status** to set the indicator overlay to display the Step Status for the **Measure Gap** step in the inspection.
8. Delete the text in the **True Text** control since the overlay is only displayed if the inspection fails. Set the **Fill** to transparent.
9. In the **False Text** control, enter **FAIL**. Set the **Fill** to **red**.
10. Click **OK** to add the step to the inspection.
Chapter 7 Looping and Variables

Setting the Inspection Status

Complete the following instructions to set the Inspection Status for the inspection.

1. In the Overview Window, click the **Fail Inspection** state on the state diagram.
2. In the Inspection Steps palette, select the **Use Additional Tools** tab.
3. Click the **Set Inspection Status** step. The property page for the step opens.

4. In the **Step Name** control, enter **Set Inspection Status**.
5. In the Inspection Status control, select the **Set to FAIL** option.
6. Enable the **Update Number of Parts Inspected** checkbox.
7. Click **OK** to add the step to the inspection.

8. In the Overview Window, click the **Pass Inspection** state on the state diagram.
9. In the Inspection Steps palette, select the **Use Additional Tools** tab.
10. Click the **Set Inspection Status** step. The property page for the step opens.
11. In the **Step Name** control, enter **Set Inspection Status**.
12. In the Inspection Status control, select the **Set to PASS** option.
13. Enable the **Update Number of Parts Inspected** checkbox.
14. Click **OK** to add the step to the inspection.

Displaying the Current Inspection Image

Complete the following instructions to use a **Display Image** step to display the current inspection image.

1. In the Overview Window, click the **Fail Inspection** state on the state diagram.
2. In the Inspection Steps palette, select the **Use Additional Tools** tab.
3. Click the **Display Image** step. The property page for the step opens.

4. In the **Step Name** control, enter **Display Image**.
5. In the **Display Images** control, select the **Always** option.
6. Click **OK** to add the step to the inspection.
7. In the Overview window, click the **Pass Inspection** state on the state diagram.

8. In the Inspection Steps palette, select the **Use Additional Tools** tab.
9. Click the **Display Image** step. The property page for the step opens.
10. In the **Step Name** control, enter **Display Image**.
11. In the **Display Images** control, select the **Always** option.
12. Click **OK** to add the step to the inspection.

---

### Configuring State Transitions

After you have created the state diagram and configured all of the steps in the inspection, you must specify when you want transitions from one state to another state to occur. Complete the following sets of instructions to configure the transitions for the inspection.

If an image has an incorrect number of pins, the inspection should transition to the Fail Inspection state. Complete the following instructions to define the Wrong # Pins transition.

1. Click the **Toggle Main Window View** button on the toolbar to bring the inspection state diagram to the Main window.

2. Double-click the **Wrong # Pins** transition on the state diagram to launch the Edit Transition dialog box.
3. In the Edit Transition dialog box, modify the controls to transition when **Find Pin Edges - Step Status** is **Fail**.
4. Click **OK** to close the dialog box.
Chapter 7   Looping and Variables

Since the same inspection needs to be performed on each set of pins on the electronic component, the Repeat for Next Pin transition creates a loop in the inspection that eliminates the need to configure separate steps to inspect each set of pins. Complete the following instructions to configure the Repeat for Next Pin transition.

1. Double-click the Repeat for Next Pin transition.
2. In the Edit Transition dialog box, modify the controls to transition when Get Edge Position - Remaining Objects is Greater than 1.
3. Click OK to close the dialog box.

The final transition that must be defined for the inspection is the transition between the Check Pin Gap and Fail Inspection states that occurs when the pins on the component fail inspection. Complete the following instructions to configure the Failed transition.

1. Double-click the Failed transition.
2. In the Edit Transition dialog box, modify the controls to transition when Measure Gap - Step Status is Fail.
3. Click OK to close the dialog box.

Testing the Inspection

Test the images in the Tutorial 6 folder to make sure the inspection returns the correct results. Click the Run Inspection Once button to test the remaining images. Table 7-1 displays the expected results for each image.

<table>
<thead>
<tr>
<th>Image Name</th>
<th>Inspection Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image 01.jpg</td>
<td>PASS</td>
<td>All pins are present and straight.</td>
</tr>
<tr>
<td>Image 02.jpg</td>
<td>PASS</td>
<td>All pins are present and straight.</td>
</tr>
<tr>
<td>Image 03.jpg</td>
<td>PASS</td>
<td>All pins are present and straight.</td>
</tr>
<tr>
<td>Image 04.jpg</td>
<td>FAIL</td>
<td>Third pin is bent.</td>
</tr>
<tr>
<td>Image 05.jpg</td>
<td>PASS</td>
<td>All pins are present and straight.</td>
</tr>
<tr>
<td>Image 06.jpg</td>
<td>FAIL</td>
<td>Fifth pin is bent.</td>
</tr>
<tr>
<td>Image 07.jpg</td>
<td>PASS</td>
<td>All pins are present and straight.</td>
</tr>
<tr>
<td>Image 08.jpg</td>
<td>FAIL</td>
<td>Seventh pin is bent.</td>
</tr>
</tbody>
</table>
Saving the Inspection

Complete the following instructions to save the example inspection.

1. Select **File** > **Save** or click the **Save** button on the toolbar.

2. Navigate to the location where you want to save the inspection.

3. In the **File Name** control, enter **Tutorial 6.vbai**.

4. Click **Save** to save the inspection.

**Tip**  Select **File** > **Inspection Properties** to add a short description or comments about the inspection.
NI Services

NI provides global services and support as part of our commitment to your success. Take advantage of product services in addition to training and certification programs that meet your needs during each phase of the application life cycle; from planning and development through deployment and ongoing maintenance.

To get started, register your product at ni.com/myproducts.

As a registered NI product user, you are entitled to the following benefits:

• Access to applicable product services.
• Easier product management with an online account.
• Receive critical part notifications, software updates, and service expirations.

Log in to your MyNI user profile to get personalized access to your services.

Services and Resources

• **Maintenance and Hardware Services**—NI helps you identify your systems’ accuracy and reliability requirements and provides warranty, sparing, and calibration services to help you maintain accuracy and minimize downtime over the life of your system. Visit ni.com/services for more information.
  
  – **Warranty and Repair**—All NI hardware features a one-year standard warranty that is extendable up to five years. NI offers repair services performed in a timely manner by highly trained factory technicians using only original parts at an NI service center.
  
  – **Calibration**—Through regular calibration, you can quantify and improve the measurement performance of an instrument. NI provides state-of-the-art calibration services. If your product supports calibration, you can obtain the calibration certificate for your product at ni.com/calibration.

• **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.
Training and Certification—The NI training and certification program is the most effective way to increase application development proficiency and productivity. Visit ni.com/training for more information.

- The Skills Guide assists you in identifying the proficiency requirements of your current application and gives you options for obtaining those skills consistent with your time and budget constraints and personal learning preferences. Visit ni.com/skills-guide to see these custom paths.
- NI offers courses in several languages and formats including instructor-led classes at facilities worldwide, courses on-site at your facility, and online courses to serve your individual needs.

Technical Support—Support at ni.com/support includes the following resources:

- Self-Help Technical Resources—Visit ni.com/support for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on. Registered users also receive access to the NI Discussion Forums at ni.com/forums. NI Applications Engineers make sure every question submitted online receives an answer.

- Software Support Service Membership—The Standard Service Program (SSP) is a renewable one-year subscription included with almost every NI software product, including NI Developer Suite. This program entitles members to direct access to NI Applications Engineers through phone and email for one-to-one technical support, as well as exclusive access to online training modules at ni.com/self-paced-training. NI also offers flexible extended contract options that guarantee your SSP benefits are available without interruption for as long as you need them. Visit ni.com/ssp for more information.

Declaration of Conformity (DoC)—A DoC is our claim of compliance with the Council of the European Communities using the manufacturer’s declaration of conformity. This system affords the user protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC for your product by visiting ni.com/certification.

For information about other technical support options in your area, visit ni.com/services, or contact your local office at ni.com/contact.

You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office websites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.
Glossary

C
coordinate system A reference location (origin) and angle in an image that ROIs can relate to when positional and angular adjustments of the ROI are necessary. A coordinate system is depicted by two lines representing the orientation and direction of its two axes.

D
data type A format for information. Acceptable data types for most functions are numeric, array, and string.

F
field of view The area of inspection that the camera can acquire as an image.
focal point The pixel location in a pattern matching template whose coordinates are returned as the location of a match in the inspection image.

I
inspection A vision inspection application created in and run from Vision Builder AI that can perform inline or offline visual inspections.
intensity The gray-level value of a pixel in a grayscale image.

M
match score A number ranging from 0 to 1,000 that indicates how closely an area of an acquired image matches the template image. A match score of 1,000 indicates a perfect match. A match score of 0 indicates no match.

O
object A connected region or grouping of pixels in an image in which all pixels have intensity levels in the same range.
Glossary

P

pattern matching The technique used to quickly locate a grayscale template within a grayscale image.

pixel Picture element—The smallest division that makes up a digital image. For measurement tasks, optimum pixel dimensions are square (aspect ratio of 1:1, or the width equal to the height).

R

resolution The number of rows and columns of pixels. An image composed of $m$ rows and $n$ columns has a resolution of $m \times n$.

ROI Region of Interest—An area of the image that is graphically selected from a window displaying the image. This area can be used to focus further processing.

S

spatial calibration Assigning physical dimensions to the area of a pixel in an image.

state A particular set of steps that execute under certain conditions during an inspection.

state diagram A graphical representation of a finite state machine.

step A component of a Vision Builder AI inspection that performs a specific visual inspection task or supporting tasks, such as decision making and serial communication.

T

template Pattern that you are trying to match in an image using the Match Pattern, Match Color Pattern, Geometric Matching, or Detect Defects steps. A template can be a region selected from an image or it can be an entire image.

transition Event that causes the inspection to move from one state to another.