NI-DAQmx and LabVIEW NXG Compatibility

Overview

This page shows supported versions of the NI-DAQmx hardware driver with support for LabVIEW NXG Development System. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing LabVIEW palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX) or the Hardware tab of LabVIEW NXG.

Contents

NI-DAQmx Compatibility: Upgrades

The releases of DAQmx that do not add LabVIEW NXG support should not break or inhibit the previous DAQmx support for LabVIEW NXG that was installed. DAQmx runtimes will be upgraded, but will not upgrade or add new hardware features or support. For example, a system with LabVIEW NXG 1.0 can upgrade to DAQmx 17.1, but will not be able to use the PXIe-4309 in LabVIEW NXG 1.0 since hardware support was added in DAQmx 17.1.

 

NI-DAQmx and LabVIEW NXG Compatibility Table

For compatibility between NI-DAQmx and LabVIEW, please see NI-DAQmx and LabVIEW Compatibility.

In the Downloads section at the bottom of this page, you can download a copy of this table, which may include older software versions.

Use this table to compare versions of NI-DAQmx to compatible versions of LabVIEW NXG
NI‑DAQmx Version  LabVIEW NXG Version
5.0 4.0 3.1 3.0 2.1 2.0 1.0
20.0            
19.6            
19.5            
19.1            
19.0            
18.6          
18.5          
18.1            
18.0            
17.6          
17.5          
17.1              
17.0            

Fully Compatible Version

No Additional NXG ADE Support