实时控制器与实时操作系统之间的兼容性

概览

本页列出了实时操作系统可支持的实时控制器硬件驱动版本。在升级或更新操作系统时,或将代码迁移或移植到新系统时,请务必参考本页面信息,以确保安装正确的版本。使用不兼容的版本可能会导致错误、RTOS无法识别或检测和找到设备的驱动程序,或设备丢失。

单击“控制器”可获取用户手册,以了解更多信息。

请注意,本文替代知识库的4LRA4IQ0文档:《我的实时控制器上运行的是哪种操作系统以及为什么?》某些NI手册可能仍然参考该旧文档。如果您是通过以前的知识库网址跳转到这里,请相应更新您的书签。

使用此表比较实时控制器和实时操作系统兼容性
控制器系列 实时操作系统
Phar Lap** ETS VxWorks** NI Linux Real-Time(基于Intel x64) NI Linux Real-Time(基于ARM)
cDAQ 9132*      
cDAQ 9133*      
cDAQ 9134*      
cDAQ 9135*      
cDAQ 9136*      
cDAQ 9137*      
cDAQ 9138*      
cDAQ 9139*      
cFP-2000      
cFP-2010      
cFP-2020      
cFP-2100      
cFP-2110      
cFP-2120      
cFP-2200      
cFP-2210      
cFP-2220      
cRIO-9002      
cRIO-9004      
cRIO-9012      
cRIO-9014      
cRIO-9022      
cRIO-9023      
cRIO-9024      
cRIO-9025      
cRIO-9030      
cRIO-9031      
cRIO-9032      
cRIO-9033      
cRIO-9034      
cRIO-9035      
cRIO-9036      
cRIO-9037      
cRIO-9038      
cRIO-9039      
cRIO-9040      
cRIO-9041      
cRIO-9042      
cRIO-9043      
cRIO-9045      
cRIO-9046      
cRIO-9047      
cRIO-9048      
cRIO-9049      
cRIO-9053      
cRIO-9054      
cRIO-9056      
cRIO-9057      
cRIO-9063      
cRIO-9064      
cRIO-9065      
cRIO-9066      
cRIO-9067      
cRIO-9068      
cRIO-9072      
cRIO-9073      
cRIO-9074      
cRIO-9075      
cRIO-9076      
cRIO-9081*      
cRIO-9082*      
CVS-1454        
CVS-1455        
CVS-1456        
CVS-1457        
CVS-1458      
CVS-1459      
Desktop ETS      
FieldPoint      
IC-3120      
IC-3121      
IC-3171      
IC-3172      
IC-3173      
ISC-1781      
ISC-1782      
ISC-1783      
myRIO 1900      
myRIO 1950      
NI 1722      
NI 1742      
NI 1744      
NI 1762      
NI 1764智能相机      
NI 1772        
NI 1772C      
NI 1774      
NI 1774C      
NI 1776      
NI 1776C      
NI 1778智能相机      
NI 3110(Hypervisor)      
NI 8353 RT      
NI 9792可编程WSN网关      
NI EVS-1463      
NI EVS-1464      
NI robo RIO      
PXI-8100        
PXI-8108      
PXI-8109      
PXI-8110      
PXI-8119      
PXI-8145      
PXI-8183      
PXIe-8101      
PXIe-8102      
PXIe-8115      
PXIe-8130      
PXIe-8133      
PXIe-8135**      
PXIe-8820      
PXIe-8840      
PXIe-8840四核    
PXIe-8861      
PXIe-8880**    
sbRIO-9601      
sbRIO-9603      
sbRIO-9602      
sbRIO-9605      
sbRIO-9606      
sbRIO-9607      
sbRIO-9608      
sbRIO-9609      
sbRIO-9611      
sbRIO-9612      
sbRIO-9623      
sbRIO-9626      
sbRIO-9627      
sbRIo-9628      
sbRIo-9629      
sbRIO-9631      
sbRIO-9632      
sbRIO-9633      
sbRIO-9636      
sbRIO-9637      
sbRIo-9638      
sbRIO-9642      
sbRIO-9651      

 

*这些型号还提供运行Windows操作系统的版本。购买前,请与客户经理确认产品的操作系统。

 

** NI将在2020年发布的软件中删除cRIO对Phar Lap的支持,并在2022年发布的软件中删除PXI对Phar Lap的支持。有关更多信息,请查看Phar Lap RT OS EOL路线图。

兼容

实时操作系统和LabVIEW Real-Time兼容性

在此页面底部的“下载”部分中,您可以下载此表,该表格可能包括较旧的软件版本。

使用此表比较实时操作系统和LabVIEW Real-Time兼容性
实时操作系统 LabVIEW Real-Time版本
2020 2019 2018 2017 2016 2015 2014 2013 2012 2011
NI ETS 2020 *                  
NI ETS 2019 *                  
NI ETS 2018 *                  
NI ETS 2017 *                  
NI ETS 2016 *                  
NI ETS 2015 *                  
NI ETS 2014 *                  
NI ETS 2013 *                  
NI ETS 2012 *                  
NI ETS 2011 *                  

 

* Phar Lap ETS 13.1与LabVIEW Real-Time 8.5.1及以上版本配合使用。从NI ETS 2009开始,NI便开始使用LabVIEW版本号指代ETS操作系统,而不使用操作系统版本。该命名规则变更有助于更轻松地识别随每个LabVIEW Real-Time版本一起发布的实时操作系统(RTOS)。自2009年以来,NI不断对ETS进行改进和CAR修复。

 

注意:总体而言,只需在LabVIEW中针对具体终端重新编译代码,相同的LabVIEW代码可用于任意LabVIEW Real-Time终端。LabVIEW调用的任何外部代码(驱动程序或自定义文本代码)也需要针对具体终端进行编译。有关VxWorks终端的一些具体注意事项,参见知识库44HDTKQ0:《NI cRIO-901x和cRIO-907x常见问题解答(FAQ)》

兼容