NI-​DAQmx​和​LabVIEW​兼容性

概览

本​页​显示​LabVIEW​或​LabVIEW Real-​Time​开发​系统​支持​的​NI-​DAQmx​硬件​驱动​程序​版本。​请​参考​此​信息,​确保​在​升级​或​更新​系统​及​软件​时​安装​正确​的​版本。​使用​不​兼容​的​版本​可能​引发​错误、​LabVIEW​面板​或​函数​丢失,​或​导致​设备​及​任务​无法​显示​在​NI Measurement & Automation Explorer (MAX)​中。

请​注意,​本文​替代“知识​库​文​档​3PIA89N5:​DAQmx​和​LabVIEW​的​版本​兼容​性。”某些​NI​手册​可能​仍然​参考​该​旧​文​档。​如果​您​是​通过​以前​的​知识​库​网址​跳​转​到​这里,​请​相应​更新​您​的​书签。

内容

安装​LabVIEW Service Pack​后​LabVIEW​与​NI-​DAQmx​兼容性

LabVIEW Service Pack​不​影响​LabVIEW​和​NI-​DAQmx​的​兼容​性。​例如,​DAQmx 15.0​同时​兼容​LabVIEW 2015​及​LabVIEW 2015 SP1。​但​这​并不​一定​适用​于​其他​NI​驱动​程序。

NI-​DAQmx​和​LabVIEW​兼容​性表

关于​NI-​DAQmx​和​LabVIEW NXG​兼容​性的​信息,​请​参考此​文章。 较​早​版本​的​DAQmx​或​LabVIEW​之间​的​兼容​性​信息,​请​参考​本文下载部分​的​DAQmx LabVIEW​兼容​性​表。 

使用​本​表格​查找​LabVIEW​版本​与​NI-​DAQmx​版本​的​兼容性

NI-​DAQmx​版本 LabVIEW/​LabVIEW Real-​Time​版本  
2020 2019 2018 2017 2016 2015 2014 2013 2012
20.0                  
19.6                  
19.5                  
19.1                  
19.0                  
18.6                  
18.5                  
18.1                  
18.0                  
17.6                  
17.5                  
17.1.1                  
17.1                  
17.0                  

兼容