Archived: 与​Microsoft Windows 7​兼容​的​NI​产品

NI does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

概览

以下​文件​列出​了​NI​软件​支持​Windows 7​的​最低​版本。​随​附​的​表格​分别​列出​了​在​Windows 7 32​位​和​Windows 7 64​位​系统​上​运行​软件、​驱动​程序、​附加​组​件​和​工具​包​所需​的​最低​版本。

内容

Windows 7 32​位​和​Windows 7 64​位​系统​有何​区别?

Windows 7 32​位​系统​可以​在​x86​或​x64​硬件​上​运行。​Windows 7 32​位​系统​与​Windows XP 32​位​类似,​仅​能​访问​32​位​地址。​因此,​即使​Windows 7 32​位​系统​在​x64​硬件​上​运行,​也​只​局​限于​使用​4GB​的​RAM。​如果​驱动​或​软件​专​为​64​位​操作​系统​而​设计,​那么​这些​驱动​或​软件​就​无法​在​Windows 7 32​位​系统​上​运行。

Windows 7 64​位​系统​只能​安装​于​x64​硬件​上。​该​版本​的​操作​系统​允许​软件​使用​64​位​地址​访问​硬件,​因此​可以​访问​更大​的​内存​空间。 为了​成功​在​Windows 7 64​位​上​运行,​所有​驱动​程序​必须​原生​支持​64​位​系统。​但是,​大​多数​32​位​软件​应用​可以​在​Windows 7​仿真​层​中​运行。

如需​了解​更多​详细​关于​Windows 32​位​和​64​位​系统​的​区别,​请​参见“NI​产品​使用​之​Windows 32​位​和​64​位​系统​指南”

软件

以下​NI软件包与​所​列出​的​Windows 7 32​位​和​Windows 7 64​位​系统​版本​兼容。​截止​至​2011​年,​NI​软件​的​所有​新​版本​均​会​在​其​自述​文件​中​说明​其​与​Windows 7 64​位​和​LabVIEW 64​位​系统​的​兼容​性。​如​对​任何​软件​与​Windows​和​LabVIEW 64​位​版本​的​兼容​性​有​任何​疑问,​请​参见​该​版本​软件​的​自述​文件。

注:​在​下表​中,“Windows 7 64​位​(使用​32​位​软件)”一​列​列出​了​在​Windows​的​Windows (WOW64)​仿真​层​运行​的​32​位​软件​的​最低​版本。

NI​软件 Windows 7 32位 Windows 7 64位
​(使用​32​位​软件)
Windows 7 64位
​(使用​64​位​软件)
NI​模拟​视频​发生器 3.0 3.0 不​支持
NI​模拟​波形​编辑器 1.2.1 1.2.1 不​支持
NI AudioMASTER 6.2 6.2 不​支持
NI Calibration Executive 3.5 3.5 不​支持
NI Calibration Executive for Traditional DAQ 3.5.2 不​支持 不​支持
NI DIAdem 11.1 SP1 11.1 SP1 2015
NI​数字​视频​发生器 1.1 1.1 不​支持
NI​数字​波形​编辑器 3.0 3.0 不​支持
NI FlexLogger 不​适用 不​适用 2018 R2
NI​功能​安全​编辑器 不​支持 不​支持 2017​年​9月
NI Instrument Studio 不​适用 不​适用 2018
NI LabVIEW 32位 2009 SP1 2009 SP1 不​支持
NI LabVIEW 64位 不​支持 不​支持 2009
NI LabVIEW​通信​系统​设计​软件 不​支持 不​支持 1.0
NI LabVIEW​通信​系统​设计​套件 不​支持 不​支持 1.0
NI LabVIEW​教学版 2010 2010 不​支持
NI LabVIEW for LEGO® MINDSTORMS 2010 2010 不​支持
NI LabVIEW NXG 不​支持 不​支持 1.0
NI LabVIEW Run-​Time​引擎​(32​位) 2009 SP1 2009 SP1 不​支持
NI LabVIEW Run-​Time​引擎​(64​位) 不​支持 不​适用 2009 SP1
NI LabVIEW SignalExpress 2009 2009 不​支持
NI LabWindows/​CVI 2009 2009 2009
NI LabWindows/​CVI Run-​Time​引擎 2009 2009 2009
NI Lookout 6.5 6.5 不​支持
NI MATRIXx 8.1.x 8.1.x 8.1.x
NI Measurement & Automation Explorer 4.6.2 4.6.2 4.6.2
NI Measurement Studio 2009 2009 2009
NI Multisim 11.0 11.0 不​支持
NI​软件​包​管理器 不​支持 不​支持 17.0
NI​图像​质量​分析 (PQA) 1.0 1.0 2014
NI​实​时​管理​程序 3.0 不​支持 不​支持
NI Requirements Gateway 1.1 1.1 不​支持
NI I/​O Trace1 2.7.1 2.7.1 2.7.1
NI Switch Executive 3.5 3.5 2015
NI SystemLink Client 不​支持 不​支持 17.0
NI SystemLink Server 不​支持 不​支持 17.0
NI TestStand 32位 4.2.1 4.2.1 不​支持
NI TestStand 64位 不​支持 不​适用 2014
NI Ultiboard 11.0 11.0 不​支持
NI​更新​服务 2.0 2.0 17.0
NI VeriStand 2009 2009 不​支持
NI Video Measurement Suite (VMS) 3.1 3.1 不​支持
NI​自动​化​检测​视觉​生成器 2009 2009 2014 SP1
NI​批量​许可​证​管理器 3.0 3.0 不​支持
NI Test Integration Adapter for IBM Rational Quality Manager 1.0 2.0 不​支持
NI​批处理​安装​包​生成器 1.0 1.0 不​支持
InsightCM​服务器 不​支持 不​支持 3.0
NI LabVIEW​通信​系统​设计​套件 不​支持 不​支持 1.0
NI Software Platform Bundle NIWeek 2010 NIWeek 2010 NIWeek 2010
NI Developer Suite NIWeek 2010 NIWeek 2010 NIWeek 2010
NI LabVIEW​学生版 NIWeek 2010 NIWeek 2010 NIWeek 2010
NI Automated Test Software Suite NIWeek 2016 NIWeek 2016 NIWeek 2016
NI FRC Software 2012 2012 2012

1. NI Spy​从​3.0​版本​开始​更名​为​NI I/​O Trace。

附加​工具​和​工具包

以下​的​NI附加​工具​和​工具包与​所​列出​Windows 7 32​位​和​Windows 7 64​位​的​版本​兼容:

注:​在​下表​中,“Windows 7 64​位​(使用​32​位​软件)”一​列​列出​了​在​Windows​的​Windows (WOW64)​仿真​层​运行​的​32​位​软件​的​最低​版本。

NI​附加​组​件​和​工具包 Windows 7 32位 Windows 7 64位
​(使用​32​位​软件)
Windows 7 64位
​(使用​64​位​软件)
NI ActiveX​自动​化​符号​工具包  不​支持 不​支持 不​支持
NI-​CAN​汽车​诊断​指令集 1.0.2 1.0.2 15.0.0
NI​蓝牙​工具包 1.0 1.0 14.0
NI CANopen LabVIEW库 1.1.2 1.1.2 不​支持
NI CAN​帧/​通道​转换库 1.0.3 1.0.3 不​支持
NI ECU​测量​与​校准​工具包 2.1.2 2.1.2 14.0.0
NI FM/​RDS Measurement Suite 1.0 1.0 不​支持
NI GNSS Measurement Suite 3.0 3.0 不​支持
NI GPS​仿真​工具包 1.5 1.5 不​支持
NI GSM/​EDGE Measurement Suite 1.0 1.0 不​支持
NI InsightCM SDK 2.0 2.0 不​支持
NI LabVIEW​自​适应​滤波​器​工具包 2009 2009 不​支持
NI LabVIEW​分析​和​机器​学习​工具包 2017 2017 2018
NI LabVIEW​高级​信号​处理​工具包 2009 2009 2018
NI LabVIEW​应用​程序​生成器 2009 2009 2009
NI LabVIEW​生物​医学​工具包 2012 2012 不​支持
NI LabVIEW C​代码​生成​器​工具包 1.0 1.0 不​支持
NI LabVIEW Communications MIMO​应用​框架 不​支持 不​支持 1.0
NI LabVIEW​控制​设计​与​仿真​模块 2009 2009 2016
NI LabVIEW​数据​库​连接​工具包 2009 2009 不​支持
NI LabVIEW DataFinder​工具包 2009 2009 不​支持
NI LabVIEW​数据​记录​与​监​控​模块 2009 2009 不​支持
NI LabVIEW​桌面​执行​工具包 2009 2009 2016
NI LabVIEW​数字​滤波​器​设计​工具包 2009 2009 2018
NI LabVIEW​电力​工具包 2011 2011 不​支持
用于​ARM​微​控制器​的​NI LabVIEW​嵌入式​模块 2009 2009 不​支持
NI LabVIEW FPGA Compile Farm 2009 2009 不​支持
NI LabVIEW FPGA IP​生成器 2012 2012 不​支持
NI LabVIEW FPGA​模块 2009 2009 2018
NI LabVIEW FPGA Xilinx 10 2009 2009 不​支持
NI LabVIEW FPGA Xilinx 14 2009 2009 不​支持
NI LabVIEW FPGA Xilinx 2013.4 2014 2014 不​支持
NI LabVIEW FPGA Xilinx 2014.4 2015 2015 不​支持
NI LabVIEW FPGA Xilinx 2015.4 2016 2016 2016
NI LabVIEW​图形​化​差分​和​用户​接口​工具包 2009 2009 不​支持
NI LabVIEW​因​特​网​工具包 2009 2009 不​支持
NI LabVIEW​抖动​工具包 2009 2009 不​支持
NI LabVIEW LEGO® MINDSTORMS® NXT​模块 2009 2010 不​支持
NI LabVIEW MathScript RT​模块 2009 2009 2016
NI LabVIEW​移动​模块 2009 2009 不​支持
NI LabVIEW​调制​解调​工具包 4.2 4.2 4.3.3
NI LabVIEW​多核​分析​和​稀疏​矩阵​工具包 2011 SP1 2011 SP1 2011 SP1
NI LabVIEW OPC UA​工具包 2017 2017 不​支持
NI LabVIEW PID​和​模糊​逻辑​工具包 2009 2009 不​支持
NI LabVIEW Real-​Time​模块 2009 2009 不​支持
NI LabVIEW Real-​Time​执行​跟踪​工具包 2009 2009 不​支持
NI LabVIEW Microsoft Office​报表​生成​工具包 2010 2010 2014
NI LabVIEW​机器​人​模块 2009 2009 不​支持
NI LabVIEW​仿真​接口​工具包 2009 2009 不​支持
NI LabVIEW SoftMotion​模块 2009 2009 不​支持
NI LabVIEW​状态​图​模块 2009 2009 不​支持
NI LabVIEW​系统​辨识​工具包 2009 2009 不​支持
NI LabVIEW​触摸​屏​模块 2009 2009 不​支持
NI LabVIEW​单元​测试​架构​工具包 2009 2009 2016
NI LabVIEW​无线​传感器​网络​模块 2009 SP1 2009 SP1 不​支持
NI LabVIEW VI​分析​仪​工具包 2009 2009 2016
NI LabVIEW myRIO​工具包 2013 2013 不​支持
NI LabWindows/​CVI​执行​评​测​工具包 1.0 1.0 1.0
NI LabWindows/​CVI​调制​解调​工具包 4.1 4.1 不​支持
NI LabWindows/​CVI PID​工具包 2.1 2.1 2.1
NI LabWindows/​CVI Real Time​模块 2009 2009 不​支持
NI LabWindows/​CVI​信号​处理​工具包 2009 2009 2010
NI LabWindows/​CVI SQL​工具包 2.2 2.2 2.2
NI LTE Measurement Suite 1.0 1.0 不​支持
NI Measurement Suite (用于​固定​WiMAX) 1.0 1.0 不​支持
NI Measurement Suite(用于​移动​WiMAX) 1.0 1.0 不​支持
NI Motion Assistant 2.3.1 2.3.1 不​支持
NI OPC​服务器 2009 2009 不​支持
NI Visual Basic PID​工具包 不​支持 不​支持 不​支持
NI​声音​和​振动​工具包 2009 2009 2010
​(不含​Express VI)
NI​声音​和​振动​测量​套件 2009 2009 2010
​(不含​Express VI)
NI​频​谱​测量​工具包 2.5 2.5 2.6.3
NI SystemLink Server - 测试​模块 不​适用 不​适用 18.0
NI TDMS 2.4.0 2.4.0 2.4.0
NI TestStand ATML​工具包 2010 2010 2017
NI​视觉​开发​模块 2009 2009 2009
NI​视觉​开发​模​块​Run-​Time 2009 2009 2009
NI WCDMA/​HSPA Measurement Suite 1.0 1.0 不​支持
NI WLAN​工具包 3.0 3.0 14.0
第三​方​许可​和​激活​工具包 2010 2010 2010
NI​软件​校准​管理​工具包 2013 2013 不​支持
NI​燃烧​分析​系统​软件 2013 2013 不​支持
MINDSTORMS®​竞赛​工具包 2011 2011 不​支持
NI LabVIEW roboRIO​工具包 2015 2015 不​支持
NI TestStand​半导体​模块 2012 2012 2014
NI​无线​测试​模块 1.0.1 1.0.1 不​支持
NI-​RFFastACP 1.0.0 1.0.0 1.0.0

 

硬件​驱动​程序

以下​NI硬件​驱动​程序与​所​列出​Windows 7 32​位​和​Windows 7 64​位​版本​兼容。

注:​在​下表​中,“Windows 7 64​位​(使用​32​位​软件)”一​列​列出​了​在​Windows​的​Windows (WOW64)​仿真​层​运行​的​32​位​软件​的​最低​版本。

NI​硬件​驱动​程序 Windows 7 32位 Windows 7 64位
​(使用​32​位​软件)
Windows 7 64位
​(使用​64​位​软件)
MXI Express 参见​PXI Platform Services 参见​PXI Platform Services 参见​PXI Platform Services
MXI-4 参见​PXI Platform Services 参见​PXI Platform Services 参见​PXI Platform Services
NI-435x 不​支持 不​支持 不​支持
NI-488.2 2.7.3 2.7.3 2.7.3
NI-5640R 1.5 1.6 不​支持
NI-568x 1.0 1.1 1.2
NI-5690 1.1 14.5 14.5
NI-845x 1.1.3 1.1.3 2.1
NI-985x 1.3.4 1.3.4 不​支持
NI-​CAN 2.6.3 2.6.3 不​支持
传统​NI-​DAQ 7.5 不​支持 不​支持
NI-​DAQmx 8.9.5 8.9.5 8.9.5
NI-​DAQmx​基本版 3.4 3.4 不​支持
NI-​DCPower 1.3.1 1.3.1 1.3.1
NI-​Digital Pattern​驱动 16.01 16.0 16.0
NI-​DMM 3.0.0 3.0.0 3.0.0
NI-​DNET 1.6.5 1.6.5 不​支持
传统​NI ELVIS 3.0.5 3.0.5 不​支持
NI-​ELVISmx 4.2.2 4.2.2 不​支持
NI-​Embedded CAN for RIO 不​支持 不​支持 不​支持
NI-​FBUS 4.0.1 4.0.1 不​支持
NI-​FGEN 2.7 2.7 2.7
NI-​FieldPoint 6.0.6 6.0.6 不​支持
NI-​HSDIO 1.7.2 1.7.2 1.7.2
NI-​IMAQ 4.3 4.3 4.3
NI-​IMAQ for IEEE1394 参见​NI-​IMAQdx 参见​NI-​IMAQdx 参见​NI-​IMAQdx
NI-​IMAQ for USB 参见​NI-​IMAQdx 参见​NI-​IMAQdx 参见​NI-​IMAQdx
NI-​IMAQ I/O 2.3 2.3 2.6.1
NI-​IMAQdx 3.4 3.4 3.4
NI-​Industrial Communications for 60870-5 1.0 1.0 不​支持
NI-​Industrial Communications for 61850 1.0 1.0 不​支持
NI-​Industrial Communications for CANopen 1.0 1.0 不​支持
NI-​Industrial Communications for DeviceNet 2.0.1 2.0.1 不​支持
NI-​Industrial Communications for DNP3 1.0 1.0 不​支持
NI-​Industrial Communications for EtherCAT 不​支持 不​支持 不​支持
NI-​Industrial Communications for EtherNet/​IP 1.1 1.1 1.1
NI​仪器​设计库 1.0 1.0 1.0
NI IVI Compliance Package 4.1 4.1 4.1
NI-​Motion 8.0 8.1 不​支持
NI-​OSI 1.0 1.0 不​支持
NI PXI-5660 1.6.9 不​支持 不​支持
NI PXIe-5644R/​5645R/​5646R​仪器​设计库 1.0 1.0 不​支持
NI-​PXImc 1.0 1.0 1.0
NI-​RFSA 2.1.2 2.1.2 2.3.1
NI-​RFSG 1.5.1  1.5.1 1.6.3
NI-​RIO 3.2.1 3.2.1 3.2.1
NI-​Scope 3.6 3.6 3.6
NI-​Serial 3.5.1 3.5.1 3.5.12
NI-​SLSC 1.0 1.0 1.0
NI-​Switch 4.1 4.1 4.1
NI-​Sync 3.1 3.1 3.1
NI System Configuration 4.7 4.7 4.7
NI System Monitor 1.1.1 1.1.1 不​支持
NI-​TimeSync 1.0 1.0 不​支持
NI USRP 1.0 1.0 14.0
NI-​VISA 4.6 4.6 4.6
NI-​VISA Run-​time​引擎 4.6 4.6 4.6
NI​视觉​采集​软件 2009​年​8月 2009​年​8月 2009​年​8月
NI-​VNA 1.0 1.2 1.2
NI-​VXI 3.7 3.8 3.8
NI-​WSN 1.1 1.1 1.1
NI-​XNET 1.6 1.6 14.0
NI-​VirtualBench 1.0 1.0 1.0
NI-​RFmx SpecAn 1.0 1.0 1.0
NI-​RFmx Demod 1.0 1.0 1.0
PXI Platform Services 2.5.3 2.5.3 2.5.3
NI-​PAL 2.6 2.6 2.6
NI FlexRIO 12.0 12.0 12.0
NI CompactRIO​设备​驱动 2015​年​8月 2015​年​8月 2015​年​8月
NI R​系列​多功能​RIO​设备​驱动 2014​年​8月 2014​年​8月 2014​年​8月
NI-​PXIe-659x​仪器​设计库 14.0 14.0 14.0
NI​工业​控制器​设备​驱动 15.5 15.5 15.5

1.NI-​Digital Pattern​驱动​仅​支持​在​Windows 32​位​系统​进行​部署,​不​支持​在​Windows​上​进行​开发。 

2. 在​Windows 64​位​系统​上,​Serial ENET​接口​不受​NI-​Serial​支持,​但​可​通过​NI-​VISA​直接​使用。​如​欲​了解​更多​信息,​请​参见​NI-​VISA​帮助​文​档。

其它​资源

如需​了解​更多​关于​32​位​和​64​位​软件​之间​的​差异,​请​参见​以下​文章:

LabVIEW 64​位​和​32​位​应用​的​常见​问题​解答
LabVIEW 32​位​或​64​位​占用​多少​内存?