NI-Industrial Communications for EtherCAT and NI-RIO Compatibility

Publish Date: Feb 11, 2019 | 1 Ratings | 4.00 out of 5 | Print

Overview

This page shows the supported versions of NI-Industrial Communication for EtherCAT are required with NI-RIO Devices and Modules. Reference this information to ensure you install the correct driver version when upgrading or updating your system, when migrating or porting code to a new system, or after the purchase and installation of new NI hardware. Using incompatible versions may result in errors, the inability for your operating system to recognize or detect and then find a driver for your device, or missing devices in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 5R7C8D3I : NI-Industrial Communications for EtherCAT and NI-RIO Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

1. NI-Industrial Communications for EtherCAT and NI-RIO Compatibility

Use this table to compare NI-Industrial Communications for EtherCAT and NI-RIO Compatibility
NI-Industrial Communications for EtherCAT NI-RIO Version
3.1.0 3.2.1 3.4.0 3.5.1 3.6.0 4.0.0 4.1.0 12.0 12.1 13.0 13.1 14.0 14.5 15.0 16.0 17.0 17.6 18.0 18.1 18.5
1.0.3                                        
1.1                                        
1.2                                        
2.0                                        
2.1                                        
2.2                                        
2.3                                        
2.4                                        
2.5                                        
2.6                                        
2.7                                        
14.0                                        
14.5                                        
15.0                                        
16.0                                        
16.1                                        
17.0                                        
17.6                                        
18.0                                        
18.5                                        


  Compatible

 

Note: NI-RIO is a requirement for NI-Industrial Communications for EtherCAT. Therefore, NI-Industrial Communications for EtherCAT and LabVIEW compatibility is determined based on the NI-RIO version being used. Make sure to consult the NI-RIO and LabVIEW compatibility page as well as the NI-Industrial Communications for EtherCAT and NI-RIO compatibility page

Back to Top

2. Additional Resources

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit