Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW 2013 Service Pack 1 Readme for Windows

Version 13.0.1

December 2013

This file contains important information about LabVIEW 2013 Service Pack 1 (SP1) for Windows, including system requirements, installation instructions, a partial list of bugs fixed for LabVIEW 2013 SP1, and known issues.

Refer to the National Instruments website for the latest information about LabVIEW 2013 SP1.

Refer to the labview\readme directory for readme files about LabVIEW add-ons, such as modules and toolkits.

System Requirements

Installation Instructions

Product Security and Critical Updates

Known Issues

LabVIEW 2013 SP1 (64-bit)

Bug Fixes

Accessing the Help

Finding Examples

Automating the Installation of NI Products

How to Use NI Software with Microsoft Windows 8.x

NI Software Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003

Legal Information


System Requirements

WindowsRun-Time EngineDevelopment Environment
ProcessorPentium III/Celeron 866 MHz or equivalentPentium 4M or equivalent
RAM256 MB1 GB
Screen Resolution1024 x 768 Pixels1024 x 768 Pixels
Operating SystemWindows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Windows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Disk Space407 MB3.5 GB (includes default drivers from the NI Device Drivers DVD)
Color PaletteN/ALabVIEW and the LabVIEW Help contain 16-bit color graphics. LabVIEW requires a minimum color palette setting of 16-bit color.
Temporary Files DirectoryN/ALabVIEW uses a directory for storing temporary files. National Instruments recommends that you have several megabytes of disk space available for this temporary directory.
Adobe ReaderN/AYou must have Adobe Reader installed to search PDF versions of all LabVIEW manuals.
Note  The following list describes restrictions for using LabVIEW on Windows:
  • LabVIEW does not support Windows 2000/NT/Me/98/95 or Windows XP x64.
  • You cannot access LabVIEW using a Guest account on Windows.

Installation Instructions

Depending on whether you are installing LabVIEW for the first time or upgrading from a previous version, refer to one of the following documents for information about installing LabVIEW:

You can access the LabVIEW Installation Guide and the LabVIEW Upgrade Notes at ni.com as well as on the installation media.

Note  If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.

LabVIEW Updates and Notifications

National Instruments posts information about critical updates and security notifications on ni.com. Visit ni.com/info and enter Info Code updates to access this information.

Product Security and Critical Updates

Visit ni.com/security for security information about National Instruments products. Visit ni.com/critical-updates for information about critical updates from National Instruments.

Known Issues

You can access the software and documentation known issues list online. Refer to the National Instruments website for an up-to-date list of known issues in LabVIEW 2013 SP1.

LabVIEW 2013 SP1 (64-bit)

When run on Windows (64-bit), LabVIEW 2013 SP1 (64-bit) provides access to more memory than a 32-bit operating system or a 32-bit application can provide. LabVIEW 2013 SP1 (64-bit) includes nearly all of the development environment features of LabVIEW 2013 SP1 (32-bit).

Refer to the National Instruments website for information about obtaining a copy of LabVIEW 2013 SP1 (64-bit).

Supported Hardware

LabVIEW 2013 SP1 (64-bit) supports many hardware devices. Refer to the National Instruments website for information about drivers compatible with LabVIEW 2013 SP1 (64-bit). For GPIB devices, you must use at least NI-488.2 2.6 for Windows. Refer to the specific hardware documentation for more information about compatibility with LabVIEW 2013 SP1 (64-bit).

Supported Modules

LabVIEW 2013 SP1 (64-bit) supports only the NI Vision Development Module. Refer to the Vision Development Module documentation for more information. No additional modules support LabVIEW 2013 SP1 (64-bit).

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in LabVIEW 2013 SP1. This is not an exhaustive list of issues fixed in the current version of LabVIEW. If you have a CAR ID, you can search this list to validate the issue has been fixed.

ID Fixed Issue
408914 Using save for previous on a For Loop containing a subdiagram label in LabVIEW 2013 causes the loop N terminal to appear on top of the subdiagram label
408955 Crash when deleting a newly created comment with Automatic Tool Selection turned off
415901 When repairing LabVIEW 2013, the service locator dependency is uninstalled
416470 Using the Get Waveform Attribute in a subVI can cause incorrect data to be returned to the main VI
420622 If an HTTP method VI outputs an analog waveform it cannot be locally debugged
422680 Deploying a Web service to the Application Web Server gives an error "NI Application Web Server service is still starting"
423373 Under certain conditions, a compiler optimization will cause array shift registers to share memory space
423385 In LabVIEW 2013, once a Type Definition is made a Strict Type Def, it cannot be made non-strict
423616 If a LabVIEW executable containing .NET is included in an installer, it will fail to run when installed
425800 Calling Quit LabVIEW VI will not quit LabVIEW if the calling VI also contains an Event structure handling the Application Instance Close Event
426140 Building an installer with VIs that contain unsatisfied dependencies within diagram disable structures fails with "Error Generating Preview"
429282 In LabVIEW 2013, including VIs from some libraries causes building an installer to fail with error 1 "Error Generating Preview"
429509 LabVIEW 64-bit can crash when passing data to a Call Library Function Node that modifies the input data
429724 Under certain circumstances, an internal race condition can cause the LabVIEW UI thread to stop updating front panel objects
429726 .NET event callbacks to VIs that are already unloaded cause memory access violations
430748 Robust fix needed for .NET events calling back to VI that has already been de-registered
434571 In LabVIEW 64-bit manipulating arrays with the Array Subset node can cause LabVIEW to crash

Recompiling VIs for Bug Fixes

The following fixes require you to manually recompile VIs to correct the problem:

  • 416470—Using the Get Waveform Attribute in a subVI can cause incorrect data to be returned to the main VI
  • 429509—LabVIEW 64-bit can crash when passing data to a Call Library Function Node that modifies the input data
  • 430748—Robust fix needed for .NET events calling back to VI that has already been de-registered
  • 434571—In LabVIEW 64-bit manipulating arrays with the Array Subset node can cause LabVIEW to crash

To force a recompile of a VI without recompiling its subVIs, press the <Ctrl> key while you click the Run button. To force a recompile of all VIs in memory, press the <Ctrl-Shift> keys while you click the Run button. To force a recompile of the entire current VI hierarchy, close all VIs currently opened, open the top-level VI, and press the <Ctrl-Shift> keys while you click the Run button. This method does not recompile any of the VIs called dynamically in the hierarchy.

You can also recompile VIs in a specified directory using the following steps:

  1. Open LabVIEW.
  2. Select Tools»Advanced»Mass Compile to display the Mass Compile dialog box.
  3. Navigate to the directory you want and click the Current Folder button.
  4. Click the Mass Compile button to recompile all VIs in that directory with updates.
  5. Click the Done button to return to LabVIEW.

Accessing the Help

Refer to the LabVIEW Help, accessible by selecting Help»LabVIEW Help from LabVIEW, for information about LabVIEW 2013 SP1.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information, refer to the following KnowledgeBase articles:

How to Use NI Software with Microsoft Windows 8.x

When you install National Instruments software on Microsoft Windows 8.x, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher.

Using NI Launcher

NI Launcher helps you find and launch installed NI products. It provides you with a method of finding NI products similar to the Start menu in previous versions of Microsoft Windows. To use NI Launcher, click the NI Launcher tile in the Apps view. NI Launcher launches the desktop and opens a menu containing a list of NI products. Click any NI product to launch it.

Note  NI MAX does not appear as a desktop shortcut when installed on Microsoft Windows 8.x. You can launch NI MAX either from the Apps view or from within NI Launcher.

Pinning Frequently Used Applications

For convenience, you can pin your most-used NI applications, such as NI MAX, to either the Start screen or the Taskbar on the desktop, as necessary:

Current ApplicationIcon LocationPin to Action
Windows 8.x DesktopDesktop TaskbarRight-click application and select Pin to Taskbar
Windows 8.x Desktop Start screenRight-click application and select Pin to Start
Windows 8.x Start screenDesktop TaskbarRight-click application and select Pin to taskbar from the menu bar on the bottom of the screen

Finding All Programs

If you want to find a particular application or related files, such as documentation files, from the Start screen, you can access all installed files from the Apps view. To get to the Apps view, right-click anywhere on the Start screen and select All apps (Windows 8) or click the down arrow on the bottom left of the screen (Windows 8.1).

For more information about NI support for Windows 8.x, visit ni.com/windows8.

LabVIEW Drops Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 in 2016

National Instruments LabVIEW will drop support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 as of July 1, 2016. Versions of LabVIEW that ship after July 1, 2016 will not install or run on Windows Vista, Windows XP, or Windows Server 2003. For detailed information about NI application software product life cycles, visit ni.com/info and enter one of the following Info Codes:

Product Info Code
NI LabVIEWlifecycle
NI LabWindows™/CVI™cvi_lifecycle
NI Measurement Studiomstudiolifecycle
NI TestStandtslcp
NI DIAdemddlcp
NI SignalExpressselcp
NI VeriStandnivslifecycle

Legal Information

Copyright

© 2004–2013 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on National Instruments trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.