Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW 2014 Service Pack 1 Readme for Windows

Version 14.0.1

December 2014

This file contains important information about LabVIEW 2014 Service Pack 1 (SP1) for Windows, including system requirements, installation instructions, new features, known issues, and a partial list of bugs fixed for LabVIEW 2014 SP1.

Refer to the National Instruments website for the latest information about LabVIEW 2014 SP1.

Refer to the labview\readme directory for readme files about LabVIEW add-ons, such as modules and toolkits.

System Requirements

Installation Instructions

Product Security and Critical Updates

New Features

Known Issues

LabVIEW 2014 SP1 (64-bit)

Bug Fixes

Accessing the Help

Finding Examples

Automating the Installation of NI Products

How to Use NI Software with Microsoft Windows 8.x

NI Software Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003

Legal Information


System Requirements

Windows Run-Time Engine Development Environment
Processor Pentium III/Celeron 866 MHz (or equivalent) or later (32-bit)
Pentium 4 G1 (or equivalent) or later (64-bit)
Pentium 4M (or equivalent) or later (32-bit)
Pentium 4 G1 (or equivalent) or later (64-bit)
RAM 256 MB 1 GB
Screen Resolution 1024 x 768 Pixels 1024 x 768 Pixels
Operating System Windows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2012 R2 (64-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Windows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2012 R2 (64-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Disk Space 500 MB 5 GB (includes default drivers from the NI Device Drivers media)
Color Palette N/A LabVIEW and the LabVIEW Help contain 16-bit color graphics. LabVIEW requires a minimum color palette setting of 16-bit color.
Temporary Files Directory N/A LabVIEW uses a directory for storing temporary files. National Instruments recommends that you have several megabytes of disk space available for this temporary directory.
Adobe Reader N/A You must have Adobe Reader installed to search PDF versions of all LabVIEW manuals.
Note  The following list describes restrictions for using LabVIEW on Windows:
  • LabVIEW does not support Windows 2000/NT/Me/98/95 or Windows XP x64.
  • You cannot access LabVIEW using a Guest account on Windows.

Installation Instructions

Depending on whether you are installing LabVIEW for the first time or upgrading from a previous version, refer to one of the following documents for information about installing LabVIEW:

You can access the LabVIEW Installation Guide and the LabVIEW Upgrade Notes at ni.com as well as on the installation media.

Note   If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.

LabVIEW Updates and Notifications

National Instruments posts information about critical updates and security notifications on ni.com. Visit ni.com/info and enter Info Code updates to access this information.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about National Instruments products. Visit ni.com/critical-updates for information about critical updates from National Instruments.

New Features

LabVIEW 2014 SP1 includes the Profile Buffer Allocations window to identify and analyze buffer allocations in a LabVIEW application. Select Tools»Profile»Profile Buffer Allocations to display this window. You can use this window to complete the following tasks:

This window includes the following components:

Known Issues

You can access the software and documentation known issues list online. Refer to the National Instruments website for an up-to-date list of known issues in LabVIEW 2014 and LabVIEW 2014 SP1.

LabVIEW 2014 SP1 (64-bit)

When run on Windows (64-bit), LabVIEW 2014 SP1 (64-bit) provides access to more memory than a 32-bit operating system or a 32-bit application can provide. LabVIEW 2014 SP1 (64-bit) includes nearly all of the development environment features of LabVIEW 2014 SP1 (32-bit).

Refer to the National Instruments website for information about obtaining a copy of LabVIEW 2014 SP1 (64-bit).

Supported Hardware

LabVIEW 2014 SP1 (64-bit) supports many hardware devices. Refer to the National Instruments website for information about drivers compatible with LabVIEW 2014 SP1 (64-bit). For GPIB devices, you must use at least NI-488.2 2.6 for Windows. Refer to the specific hardware documentation for more information about compatibility with LabVIEW 2014 SP1 (64-bit).

Supported Modules

LabVIEW 2014 SP1 (64-bit) supports only the NI Vision Development Module. Refer to the Vision Development Module documentation for more information. No additional modules support LabVIEW 2014 SP1 (64-bit).

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in LabVIEW 2014 SP1. This is not an exhaustive list of issues fixed in the current version of LabVIEW. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

ID Fixed Issue
476710 Opening a VI Server Reference to two or more identically named VIs, contained in separate LabVIEW libraries in a running executable, can result in Error 1031.
487258 A LabVIEW 2014 Web Service does not run when it is built into an executable and then installed via an NI Installer.
491159 Type Definition instance does not require manual update (new to LabVIEW 2014) if last element of enum was deleted.
491225 Installing the LabVIEW 2014 Run-Time Engine via an NI Installer can prevent the NI System Web Server from starting if older versions of LabVIEW are also present or installed.
491714 Using Probes while Remote Debugging with General Error Handler VI present can cause LabVIEW 2014 to hang.
492159 Uninitialized array elements in block diagram array constants are less transparent in LabVIEW 2014.
492898 Open VI Reference hangs on second call.
493375 In certain cases, LabVIEW 2014 crashes when loading a VI with an updated type definition.
500664 Under certain conditions, the LabVIEW Digital Waveform Graph appears blank even with valid data present.

Accessing the Help

Refer to the LabVIEW Help, accessible by selecting Help»LabVIEW Help from LabVIEW, for information about LabVIEW 2014 SP1.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

How to Use NI Software with Microsoft Windows 8.x

When you install National Instruments software on Microsoft Windows 8.x, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher.

Using NI Launcher

NI Launcher helps you find and launch installed NI products. It provides you with a method of finding NI products similar to the Start menu in previous versions of Microsoft Windows. To use NI Launcher, click the NI Launcher tile in the Apps view. NI Launcher launches the desktop and opens a menu containing a list of NI products. Click any NI product to launch it.

Note  NI MAX does not appear as a desktop shortcut when installed on Microsoft Windows 8.x. You can launch NI MAX either from the Apps view or from within NI Launcher.

Pinning Frequently Used Applications

For convenience, you can pin your most-used NI applications, such as MAX, to either the Start screen or the Taskbar on the desktop, as necessary:

Current ApplicationIcon LocationPin to Action
Windows 8.x DesktopDesktop TaskbarRight-click application and select Pin to Taskbar
Windows 8.x Desktop Start screenRight-click application and select Pin to Start
Windows 8.x Start screenDesktop TaskbarRight-click application and select Pin to taskbar from the menu bar on the bottom of the screen

Finding All Programs

If you want to find a particular application or related files, such as documentation files, from the Start screen, you can access all installed files from the Apps view. To get to the Apps view, right-click anywhere on the Start screen and select All apps (Windows 8) or click the down arrow on the bottom left of the screen (Windows 8.1).

For more information about NI support for Windows 8.x, visit ni.com/windows8.

NI LabVIEW Drops Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 in 2016

National Instruments LabVIEW will drop support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 as of July 1, 2016. Versions of LabVIEW that ship after July 1, 2016 will not install or run on Windows Vista, Windows XP, or Windows Server 2003. For detailed information about NI application software product life cycles, visit ni.com/info and enter one of the following Info Codes:

Product Info Code
NI LabVIEWlifecycle
NI LabWindows™/CVI™cvi_lifecycle
NI Measurement Studiomstudiolifecycle
NI TestStandtslcp
NI DIAdemddlcp
NI SignalExpressselcp
NI VeriStandnivslifecycle

Legal Information

Copyright

© 2004–2014 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on National Instruments trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.

374715B-01