Archived: NI TestStand 4.x Patches Required for Compatibility with LabVIEW 2010 and Later

Publish Date: Feb 16, 2018 | 0 Ratings | 0.00 out of 5 | Print

Overview

This document has been archived and is no longer updated by National Instruments.

This article discusses known issues using LabVIEW 2010 or later with TestStand 4.0, 4.1, 4.1.1, 4.2, and 4.2.1.

Note: The issues listed below are fixed in TestStand 2010.

1. Introduction

The following are known issues when using LabVIEW 2010 and later with TestStand 4.0, 4.1, 4.1.1, 4.2, and 4.2.1:

  1. The Sequence Editor can crash when you activate the Module tab of a LabVIEW step that references a LabVIEW 2010 or later VI. The crash can occur with or without LabVIEW 2010 or later installed on the system.
  2. The Update VI Calls tool does not properly update steps that reference LabVIEW VIs if LabVIEW 2010 or later is the active version of LabVIEW.
  3. The LabVIEW Adapter is unable to load VIs with separate compiled code. The ability to configure a VI to have separate compiled code is a feature that was introduced in LabVIEW 2010.


The above mentioned issues are resolved in the following patches:

This patch will only run for TestStand 4.0.1f1 installations. If you have TestStand 4.0 or 4.0.1 installed, please install the patch linked below before installing Patch 236977:

NI TestStand Development System 4.0.1 - Windows XP/2000 - 4.0.1f1 Patch

If you cannot upgrade your TestStand 4.0 or 4.0.1 installation to the TestStand 4.0.1f1 version, please contact National Instruments Support.

After installing the patch for your particular version of TestStand linked above, you must also install the LabVIEW 2010 f2 patch to resolve the issue described in Why Do I Receive Error -18004 When Attempting to Configure or Execute LabVIEW 2010 VIs While Debugging My LabVIEW User Interface in LabVIEW 2010?

Note: Using LabVIEW 2010 with TestStand 3.5 and prior versions has not been tested; these versions of TestStand are no longer in mainstream support. Issue 1 does not apply to TestStand 3.5 and prior versions because the Module tab was introduced in TestStand 4.0. Issue 2 does not apply to TestStand 3.5 and prior versions because the Update VIs call tool was introduced in TestStand 4.1. For issue 3 listed above, TestStand 3.5 and prior cannot load LabVIEW 2010 or later VIs with separate compiled code when the adapter is configured to use the LabVIEW Run-Time Engine.

If you have installed software from the 2010 Developer Suite 2 DVDs or LabVIEW 2010 Platform DVD, you will also need to install the patch that resolves the issues described in Why do I Receive Error -1 or Error -10 when Building an Installer using the TestStand Deployment Utility?

 

Back to Top

2. Additional Resources

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit