Traditional NI-DAQ (Legacy) and LabVIEW Compatibility

Publish Date: Feb 13, 2017 | 0 Ratings | 0.00 out of 5 | Print

Overview

This page shows supported versions of the Traditional NI-DAQ (Legacy), formerly known as just NI-DAQ, hardware driver with LabVIEW development systems. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing LabVIEW palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 6OACQ2BO: Traditional (Legacy) NI-DAQ and LabVIEW Version Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

Table of Contents

  1. Traditional NI-DAQ (Legacy) vs NI-DAQmx
  2. Traditional NI-DAQ (Legacy) and LabVIEW Compatibility
  3. Additional Resources

1. Traditional NI-DAQ (Legacy) vs NI-DAQmx

This page is about NI-DAQ also known as Traditional NI-DAQ (Legacy). NI-DAQmx replaced Traditional NI-DAQ (Legacy) in 2003. NI strongly recommends using NI-DAQmx for new designs and migrating existing Traditional NI-DAQ (Legacy) applications to NI-DAQmx. Please review the Getting Started with NI-DAQmx guide for more information on migration.

 

Back to Top

2. Traditional NI-DAQ (Legacy) and LabVIEW Compatibility

Use this table to compare Traditional NI-DAQ (Legacy) and LabVIEW Compatibility
Traditional NI-DAQ Version LabVIEW Version
5.0.1 5.1 5.1.2 6.0 6.1 7.0 7.1 8.0 8.2 8.5 8.6 2009 2010 2011 2012 2013 2014 2015 2016
6.9.3                                      
7.0                                      
7.0.1                                      
7.1                                      
7.2                                      
7.3                                      
7.4                                      
7.4.1                                      
7.4.4                                      
7.5                                      


  Compatible
  Compatible with LabVIEW Only
  Compatible with LabVIEW Real-Time Only


Note: In order to use a 64-bit operating system, you will need to update to the NI-DAQmx drivers. Traditional NI-DAQ (Legacy) is not compatible with any 64-bit operating systems.

Note: If it is necessary to use a version of DAQ that does not install support for your version of LabVIEW, see Traditional NI-DAQ (Legacy) Palette Does Not Appear In LabVIEW.

 

Back to Top

3. Additional Resources

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit