National Instruments Driver and Software Support for Linux Distributions

Publish Date: Sep 19, 2018 | 7 Ratings | 3.43 out of 5 | Print

The Current Support section below lists the currently supported Linux distributions. The NI Drivers & Software section lists the most recent NI software packages that have been validated with these distributions. The Previous Support section lists previously supported distributions and NI software packages. NI's goal is to validate against the latest two versions of each supported Linux distribution and to update our support annually. The latest NI drivers and software can be found on the Drivers & Software Downloads page.

Note: Beginning in 2018, National Instruments offers a new catalog of Linux Desktop support for a variety of test and measurement hardware on the PXI Express platform. With this release, there has been a change to the way that National Instruments' driver software is acquired and installed onto a Linux Desktop system. Please see Downloading and Installing NI Driver Software on Linux Desktop for more information. 


Current Support for Linux Distributions
Distributions Versions
Red Hat Enterprise Linux Desktop + Workstation 6.x, 7.x
CentOS 7.x
OpenSUSE Leap 42.2, 42.3

Note: As of July 1, 2016, National Instruments no longer supports Intel 32-bit versions of Linux distributions. Versions of products that ship after July 1, 2016 may install and run on Intel 32-bit distributions, but official support is not provided.

 

NI Linux Device Drivers (July 2018)
Product Name Version
NI-VISA 18.2
NI-488.2 18.0
NI R Series 18.1
NI-DAQmx 18.1
NI System Configuration 18.1
NI-Sync 18.1
FlexRIO 18.1
PXI Platform Services 18.0


Previous Support


National Instruments recommends using the software listed above. NI does not actively validate previously supported Linux distributions, drivers, or software. However, if you want to use an existing installation, the table below lists support previously maintained by National Instruments. You may need to install a specific version of NI-KAL before your NI drivers or software can function properly on a particular Linux distribution. Refer to the Linux NI-KAL Driver Linux Compatibility document for more information about NI-KAL.

If you do not see current or previous support for your desired Linux distribution or NI software in the following table, post a message to the NI Linux Community Forums. The NI Linux Community may be able to help.

Previously Supported NI Drivers & Software
Product Name Most Recent Supported Version  Most Recent Supported Linux Distribution 32-bit 64-bit
NI-DAQmx Base 15.0 Red Hat Enterprise Linux 6 & 7
OpenSUSE 13.1, 13.2
CentOS 7
Scientific Linux 6
Yes No
NI-FGEN 2.4.1 Mandrakelinux 10.1 Official
Mandriva Linux 2006
SUSE LINUX Professional 9.3
SUSE LINUX 10.0
Red Hat Enterprise Linux WS 3
Yes No
NI-SCOPE 3.1 Mandrakelinux 10.1 Official
Mandriva Linux 2006
SUSE LINUX Professional 9.3
SUSE LINUX 10.0
Red Hat Enterprise Linux WS 3
Yes No
NI-DMM 2.5 Mandrakelinux 10.1 Official
Mandriva Linux 2006
SUSE LINUX Professional 9.3
SUSE LINUX 10.0
Red Hat Enterprise Linux WS 3
Yes No
PXI Platform Services 2.6 (Beta) Red Hat Enterprise Linux 5
Scientific Linux 5
Yes No

 


Related Links:

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit