Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

NI-DCPower 18.1 Readme

April 2018

This file contains important information about NI-DCPower, including installation instructions, new features, a partial list of bugs fixed, and known issues.

If you plan to use LabVIEW NXG, refer to LabVIEW NXG Support and Considerations.


Overview

System Requirements

Supported Operating Systems

Application Software Support

Installation Instructions

Product Security and Critical Updates

New Features

Supported Hardware

Known Issues

Bug Fixes

Accessing the Help

Finding Examples

LabVIEW NXG Support and Considerations

IVI Compliance Package Functionality

Automating the Installation of NI Products

Using NI Software with Microsoft Windows 10

Using NI Software with Microsoft Windows 8.1

Legal Information


Overview

NI-DCPower is an NI instrument driver that communicates with all NI programmable power supplies and SMUs. NI-DCPower is an interchangeable virtual instrument (IVI)–compliant instrument driver, and it features a set of operations and properties that exercise the functionality of the power supply or SMU and includes an interactive soft front panel and examples.

System Requirements

NI-DCPower 18.1 has the following requirements:

Minimum System Requirements

Recommended System

Refer to the LabVIEW Readme for additional system requirements and supported operating systems for LabVIEW.

Supported Operating Systems

NI-DCPower 18.1 supports the following operating systems:

1 NI software installs VC2015 Runtime and .NET 4.6.2. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

2 NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Note  In 2016 NI-DCPower dropped support for Windows Vista, Windows XP, Windows Server 2003, and installations of Windows 7 without any service packs. NI-DCPower 18.1 will not install or run on an unsupported OS. You cannot deploy or distribute applications that use NI-DCPower 18.1 to an unsupported OS. Additionally, after installing NI-DCPower 18.1, you cannot use any installers built on this computer with any version of LabVIEW, LabWindows™/CVI™, NI TestStand™, or Measurement Studio on an unsupported OS.

For more information about the changes to our OS support for 2016, refer to KB 79UC78LS, Why Does My NI ADE Installer Fail on Windows XP/Vista and Windows Server 2003?.

Note  Support for Windows 32-bit operating systems may require disabling physical address extension (PAE). To learn how this might affect your system and what actions you might need to take, visit ni.com/info and enter the Info Code PAESupport.

Application Software Support

NI-DCPower 18.1 supports the following application software versions, including service packs. If you are not using NI application software, refer to Microsoft Visual Studio Support.

Application SoftwareVersions Supported by NI-DCPower
LabVIEW 2015, 2016, 2017, 2018
LabVIEW Real-Time Module3 2015, 2016, 2017, 2018
LabVIEW NXG 2.0, 2.1
LabWindows™/CVI™ 2013 and later
LabWindows/CVI Real-Time Module3 2013 and later

3No support for PXIe-4162/4163 source measure units.

Microsoft Visual Studio Support

If you are using the NI-DCPower .NET Class Library, the .NET Framework 4.0 (minimum) is required. The NI-DCPower .NET Class Library can be used with the Visual C# or Visual Basic .NET programming languages in any Visual Studio version that can target the .NET Framework 4.0 or the .NET Framework 4.5.

To use the .NET API, you must select the .NET Framework 4.0 Languages Support or the .NET Framework 4.5 Languages Support packages in the NI-DCPower installer to install the .NET class libraries in addition to the NI device driver. For information about versions of the .NET Framework and the drivers each supports, as well as the download location of the installer files, refer to the National Instruments .NET Driver Support document at ni.com/info and enter Info Code NETAPIdriversupport.

Installation Instructions

Installing NI-DCPower 18.1 for LabVIEW

You can install all of your LabVIEW products—including NI-DCPower 18.1—using the LabVIEW 2018 Platform media.

To request additional LabVIEW Platform media, refer to the NI website.

Note

Installing NI-DCPower 18.1 for LabVIEW NXG

NI automates LabVIEW NXG installation using NI Package Manager. Visit ni.com/info and enter the Info Code NIPMDownload to download NI Package Manager. Refer to the NI Package Manager Manual for more information about installing, removing, and upgrading NI software using NI Package Manager.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

New Features

Supported Hardware

The following list details the hardware models supported in NI-DCPower 18.1:

NI 411x, 413x, 414x, and 4154 Power Supplies and SMUs

NI 416x SMUs

Known Issues

You can access the software and documentation known issues list online. Refer to the NI website for an up-to-date list of known issues in NI-DCPower 18.1.

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in NI-DCPower. This is not an exhaustive list of issues fixed in the current version of NI-DCPower. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

The following items are changes in NI-DCPower 17.6.1 from NI-DCPower 17.6.

ID Fixed Issue
672829
Fixed an issue in which the PXIe-4162/4163 did not invalidate measurements taken during range changes.
621134
Fixed an issue in which memory leaked when configuring properties in the Running state.

The following items are changes in NI-DCPower 17.1 from NI-DCPower 17.0.

ID Fixed Issue
671016
Fixed an issue in which the PXIe-4138 or PXIe-4139 failed to load upon system boot or device reset.
647700
Fixed an issue in which in rare cases, the PXI-4138 or PXIe-4139 failed to load due to a hardware error but the front panel LED did not reflect the presence of a hardware error.

Accessing the Help

Refer to the NI DC Power Supplies and SMUs Help, accessible from Start»All Programs»National Instruments»NI-DCPower»NI-DCPower Documentation, for information about NI-DCPower.

Finding Examples

You can access all the installed NI-DCPower examples at Start»All Programs»National Instruments»NI-DCPower»NI-DCPower Examples and online at ni.com/examples.

Select Help»Find Examples from LabVIEW or LabWindows/CVI to launch the NI Example Finder. LabVIEW examples for NI-DCPower are located in the LabVIEW XXXX\examples\instr\niDCPower directory. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

The NI Example Finder offers two ways to access all installed LabVIEW example VIs and their descriptions:

LabVIEW NXG Support and Considerations

The following sections detail considerations for using LabVIEW NXG with NI-DCPower.

LabVIEW NXG Operating Systems and System Requirements

Software support for LabVIEW NXG differs in the following ways:

LabVIEW NXG Hardware Support

NI 411x, 413x, 414x, and 4154 Power Supplies and SMUs

NI 416x SMUs

LabVIEW NXG Help

View context help in LabVIEW by pressing <Ctrl-H> and hovering over an object.

Search for items using the search bar in the upper right corner of the LabVIEW window. You can also view context help for the search results.

Additional documentation is available online at ni.com/manuals.

LabVIEW NXG Examples

Launch LabVIEW and click the Learning tab.

LabVIEW lessons are located in the Lessons tab, and LabVIEW Examples are located in the Examples tab. Follow the instructions in the lessons and examples.

IVI Compliance Package Functionality

NI-DCPower no longer installs IVI Compliance Package. NI-DCPower supports IVI configuration and runtime, but no longer supports the following features:

If you want to use the above features, you must install IVI Compliance Package separately, either from ni.com/downloads or from the NI Device Drivers 2018 DVD.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

Using NI Software with Microsoft Windows 10

Microsoft Windows 10 is the latest version of the Windows operating system and features significant changes compared to previous versions. Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. For more information about NI support for Windows 10, visit ni.com/windows10.

Using NI Software with Microsoft Windows 8.1

When you install NI software on Microsoft Windows 8.1, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher. For more information about NI support for Windows 8.1, visit ni.com/windows8.


Legal Information

Copyright

© 2007–2018 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.

375374K-01