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This document contains information about calibrating the National
Instruments 9217 module using NI-DAQmx. This calibration procedure is
intended for metrology labs.
This document does not discuss programming techniques or compiler
configuration. The NI-DAQmx driver contains online help files that have
compiler-specific instructions and detailed function explanations. You can
install these help files when you install NI-DAQmx on the calibration
computer.
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Conventions
The following conventions appear in this manual:
»

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.
This icon denotes a note, which alerts you to important information.

bold

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names and hardware labels.

italic

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

monospace

Monospace text denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

monospace italic

Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.

Software
Install NI-DAQmx 8.5 or later on the calibration computer. NI-DAQmx
includes high-level function calls to simplify the task of writing software to
calibrate devices. You must have the proper device driver installed on the
calibration system before calibrating the device.
Note NI recommends that you install the NI-DAQmx driver software before physically
installing the NI 9217. NI-DAQmx, available at ni.com/downloads, configures and
controls the NI 9217.

NI-DAQmx supports a number of programming languages, including
LabVIEW, LabWindows™/CVI™, Microsoft Visual C++ 6.0, Microsoft
Visual Basic 6.0, Microsoft .NET, and Borland C++.
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You can access the NI-DAQmx header file, NIDAQmx.h, like any standard
library. You can find examples of how to use the NI-DAQmx driver in the
Program Files\National Instruments\NI-DAQ\Examples

directory.

Documentation
You might find the following documentation helpful as you write the
calibration procedure:
•

NI-DAQmx Help—This help file contains general information about
measurement concepts, key NI-DAQmx concepts, and common
applications that apply to all programming environments. To access
this help file, select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx Help.

•

NI-DAQmx C Reference Help—This help file contains C reference and
general information about measurement concepts. To access this help
file, select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

•

DAQ Getting Started Guide for NI-DAQ 8.0 or later—This guide
describes how to install NI-DAQmx for Windows software and
NI-DAQmx-supported DAQ devices, and how to confirm that your
device is operating properly. To access this guide, select Start»
All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

Note The documents above are installed with NI-DAQmx. You can also download the
latest versions from the NI Web site at ni.com/manuals.

•

NI 9217 Operating Instructions and Specifications — This document
describes how to use the NI 9217 and includes specifications and
terminal assignments for the NI 9217. The limits you use to verify the
accuracy of this device are based on the specifications found in this
document. You can download the latest version of this document from
the NI Web site at ni.com/manuals.

Calibration Interval
The NI 9217 should be calibrated at a regular interval as defined by
the measurement accuracy requirements of your application. National
Instruments recommends that you routinely perform a complete calibration
at least once every year. You can shorten this interval based on the accuracy
demands of your application or requirements of your processes.
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Test Equipment
National Instruments recommends that you use the following equipment
for calibrating the NI 9217.
Table 1. Recommended Equipment

Equipment

Recommended Model

Requirements

DMM

NI 4070

If this instrument is unavailable, use a
multiranging 6 1/2 digit DMM with an
accuracy of at least 90 ppm.

Precision resistors

0 Ω, 100 Ω, 350 Ω∗

You must use resistors that
are <10 ppm/°C or better.

Chassis

NI cDAQ-9172

—

Connection accessory

NI 9939

—

are approximate values. Use resistor values as close to 100 Ω and 350 Ω as possible. For the 0 Ω resistor, use a short
piece of wire.

* These

Test Conditions
Follow these guidelines to optimize the connections and the environment:
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•

Keep connections to the device as short as possible. Long cables and
wires act as antennae, picking up extra noise that can affect
measurements.

•

Use shielded copper wire for all cable connections to the device.
Use twisted-pair wire to eliminate noise and thermal offsets.

•

Maintain an ambient temperature of 25 ±10 °C. The device
temperature will be greater than the ambient temperature.

•

Keep relative humidity below 80%.

•

Allow a warm-up time of at least 10 minutes to ensure that the
measurement circuitry is at a stable operating temperature.
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Calibration Procedure
This section provides instructions for verifying the performance of
the NI 9217.

Calibration Process Overview
The calibration process consists of the following steps:
1.

Initial Setup—Configure the device in NI-DAQmx.

2.

Verification Procedure—Verify the existing operation of the device.
This step confirms whether the device is operating within its specified
range and whether it needs adjustment.

3.

Adjustment—If the device does not fall within the desired
specifications, submit the device to NI for a factory calibration to
adjust the calibration constants.

4.

Verification Procedure— Perform another verification to ensure that
the device operates within its specifications after adjustment.

The first two steps are explained in the following sections.

Initial Setup
You must configure the device in Measurement & Automation Explorer
(MAX) to communicate with NI-DAQmx.
Complete the following steps to configure a device in MAX:
1.

Install the NI-DAQmx driver software.

2.

Make sure that no power is connected to the module terminals. If the
system is in a nonhazardous location, the chassis power can be on
when you install the module.

3.

Insert the module into an available slot in the cDAQ-9172 chassis.

4.

Launch MAX.

5.

Right-click the device name and select Self-Test to ensure that the
device is working properly.

Note When a device is configured with MAX, it is assigned a device name. Each function
call uses this device name to determine which DAQ device to calibrate. This document uses
dev1 to refer to the device name. In the following procedures, use the device name as it
appears in MAX.
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Verification Procedure
Verification determines how well the device is meeting its specifications.
By completing this procedure, you can see how the device has drifted over
time, which helps you determine the appropriate calibration interval for
your application. Table 2 in the Test Limits section shows all acceptable
settings for the device type. Throughout the verification process, use
Table 2 to determine if the device is operating within its specified range.
Complete the following steps to test the performance of the device:
1.

Acquire a 4-wire resistance measurement of each resistor (0 Ω, 100 Ω,
350 Ω) with a DMM. You must use the 4-wire resistance
measurements to calculate the 1-Year Limits shown in Table 2. The
Test Point Value in Table 2 refers to the 4-wire resistance measurement
of each resistor with a DMM.

2.

Connect a resistor from the previous step to the NI 9217. Connect EX0
and RTD0+ to one end of the resistor, and RTD0– and COM to the
opposite end of the resistor. Refer to Figure 1 for the terminal
assignments of the NI 9217.

EX0
RTD0+
RTD0–
COM
EX1
RTD1+
RTD1–
COM
EX2
RTD2+
RTD2–
COM
EX3
RTD3+
RTD3–
COM

0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15

Figure 1. NI 9217 Terminal Assignments
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3.

If you use C function calls, create a task using DAQmxCreateTask,
as shown in the following table. If you use LabVIEW, skip this step.
The task is created in step 4 in LabVIEW.

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxCreateTask with
the following parameters:

LabVIEW does not require this step.

taskName:
AIVerificationTask
taskHandle: &taskHandle

4.

Create and configure an AI resistance channel using the DAQmx
Create Virtual Channel VI, as shown in the following table. Use
Table 2 to determine the minimum and maximum values for the
device.

Throughout the procedure, refer to the NI-DAQmx function parameters for the
LabVIEW input values. Refer to the block diagram images for the correct instance to use
for polymorphic VIs.

Note

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxCreateAI
ResistanceChan with the
following parameters:
taskHandle: taskHandle
physicalChannel: dev1/ai0
nameToAssignToChannel:
myResistanceChannel

resistanceConfig:
DAQmx_Val_4Wire
minVal: 0
maxVal: 400
units: DAQmx_Val_Ohms
customScaleName: NULL

currentExcitSource:
DAQmx_Val_Internal
currentExcitValue: 0.001
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5.

Configure the timing properties for the resistance acquisition using the
DAQmx Timing VI, as shown in the following table.

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxCfgSampClkTiming
with the following parameters:
taskHandle: taskHandle
source: NULL
rate: 1
activeEdge:
DAQmx_Val_Rising

sampleMode:
DAQmx_Val_FiniteSamps
sampsPerChan: 10

6.

Start the acquisition using the DAQmx Start Task VI, as shown in the
following table.

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxStartTask with the
following parameter:
taskHandle: taskHandle
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7.

Acquire 10 points of resistance data using the DAQmx Read VI,
as shown in the following table.

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxReadAnalogF64 with
the following parameters:
taskHandle: taskHandle
numSampsPerChan: –1
timeout: 30.0
fillMode:
DAQmx_Val_GroupByChannel
readArray: data
arraySizeInSamples: 10
sampsPerChanRead: &read
reserved: NULL

8.

Average the resistance values that you acquired. Compare the resulting
average to the Upper Limit and Lower Limit values in Table 2. If the
result is between these values, the device passes the test.

9.

Clear the acquisition using the DAQmx Clear Task VI, as shown in the
following table.

LabVIEW Block Diagram

NI-DAQmx Function Call
Call DAQmxClearTask with the
following parameter:
taskHandle: taskHandle

10. Repeat steps 2 through 9 for all resistance values and all channels.
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Test Limits
Table 2 lists the specifications that the NI 9217 should meet if it has been
one year between calibrations. The following definitions describe how to
use the information from Table 2.

Range
Range refers to the minimum or maximum resistance range of an input
signal.

Test Point
The Test Point is the resistance value that is input or output for verification
purposes. This value is broken down into two columns—Location and
Value. Location refers to where the test value fits within the test range.
Value refers to the resistance value to be verified. Max refers to maximum
value, Min refers to minimum value, and Mid refers to mid-scale.

1-Year Limits
The 1-Year Limits column contains the Upper Limits and Lower Limits for
the test point value, and an Error column to help calculate the limits. When
the device is within its 1-year calibration interval, the test point value
should fall between these upper and lower limit values.
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Table 2. NI 9217 Verification Test Limits

Range (Ω)

1-Year Limits*

Test Point

Min

Max

Location

Value (Ω)†

Error

Lower
Limit (Ω)‡

Upper
Limit (Ω)‡

0

400

Max

DMM350 Ω

⎜DMM350 Ω – 100 Ω ⎜×
175 ppm + 16 mΩ

DMM350 Ω –
Error350 Ω

DMM350 Ω +
Error350 Ω

0

400

Mid

DMM100 Ω

⎜DMM100 Ω – 100 Ω ⎜×
175 ppm + 16 mΩ

DMM100 Ω –
Error100 Ω

DMM100 Ω +
Error100 Ω

0

400

Min

DMM0 Ω

⎜DMM0 Ω – 100 Ω ⎜×
175 ppm + 16 mΩ

DMM0 Ω –
Error0 Ω

DMM0 Ω +
Error0 Ω

* The 1-Year Limits are accurate assuming you have performed the verification procedure at an ambient temperature of
25 ±10 °C. Verification of the module against the 1-Year Limits guarantees operation within the range of –40 to 70 °C as
specified in the NI 9217 Operating Instructions and Specifications.
†

You must read this value using a DMM with the accuracy requirements displayed in Table 1.

‡ Use

the 25 ±10 °C maximum gain error of 175 ppm and maximum offset error of 16 mΩ to calculate the lower and upper
limits.

Appendix
You can convert the resistance values into temperature values using the
Callendar Van Dusen equations and common 100 Ω platinum RTD
constants.
Temperatures below 0 ºC:
2

3

R T = R 0 [ 1 + A × T + B × T + C × T × ( T – 100 °C ) ]
Temperatures above 0 ºC:
2

RT = R0 ( 1 + A × T + B × T )
where

T = temperature in degrees Celsius
RT = RTD resistance at temperature T
R0 = RTD nominal resistance at 0 ºC. For the NI 9217,
R0 is always equal to 100 Ω.
A = 3.9083 × 10–3
B = –5.775 × 10–7
C = –4.183 × 10–12
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Where to Go for Support
The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.
National Instruments corporate headquarters is located at
11500 North Mopac Expressway, Austin, Texas, 78759-3504.
National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni.com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:
Australia 1800 300 800, Austria 43 662 457990-0,
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,
Canada 800 433 3488, China 86 21 5050 9800,
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 358 (0) 9 725 72511, France 01 57 66 24 24,
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,
South Africa 27 0 11 805 8197, Spain 34 91 640 0085,
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151,
Taiwan 886 02 2377 2222, Thailand 662 278 6777,
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni.com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents.txt file on your CD, or
ni.com/patents.
© 2008 National Instruments Corporation. All rights reserved.
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