Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

NI-Industrial Communications for EtherCAT® 16.0 Readme

June 2016

This file contains important information about the NI-Industrial Communications for EtherCAT software, including installation instructions, new features, and known issues.

Overview

Supported Operating Systems

Installation Instructions

NI Software Support for Microsoft Windows 7, Windows Vista, Windows XP, and Windows Server 2003

Product Security and Critical Updates

New Features

Supported EtherCAT Masters

Driver Version Naming Changes

Known Issues

Accessing the Help

Finding Examples

Automating the Installation of NI Products

Using NI Software with Microsoft Windows 10

Using NI Software with Microsoft Windows 8.1

Legal Information


Overview

The NI-Industrial Communications for EtherCAT software provides an EtherCAT master driver to support the real-time EtherCAT network operations. Use the software with the LabVIEW Real-Time Module to configure the EtherCAT network and map the EtherCAT device signals to the LabVIEW I/O variables.

Supported Operating Systems

The NI-Industrial Communications for EtherCAT supports the following operating systems:

1 NI software installs VC2015 Runtime and .NET 4.6.1. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

2 NI software is signed with a SHA-256 certificate. Windows 7 SP1 and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Software Requirements

To install the NI-Industrial Communications for EtherCAT software, install the following prerequisite software.

Refer to the LabVIEW Readme for additional system requirements and supported operating systems for LabVIEW.

Notes  
  • NI 9144 is the only EtherCAT slave that has FPGA support in LabVIEW. To use the NI 9144 in FPGA Mode, install the LabVIEW 2012 FPGA Module or later on the host computer and then download a bitfile to the FPGA of the NI 9144. You can compile or copy a bitfile to download to the FPGA.
  • NI 951x Series drive interface modules require the LabVIEW 2012 SoftMotion Module or later to work for EtherCAT.

Installation Instructions

Before installing the NI-Industrial Communications for EtherCAT software, log on as Administrator or as a user with Administrator privileges. The NI-Industrial Communications for EtherCAT software setup program must have Administrator privileges because the program modifies the configuration registry of your system. Complete the following steps to install the NI-Industrial Communications for EtherCAT software:

  1. Insert the NI-Industrial Communications for EtherCAT software media. The installer launches automatically. If the installer does not launch automatically, navigate to the media and launch the autorun.exe file.
  2. Follow the installation wizard to install the NI-Industrial Communications for EtherCAT software.

Note  Refer to NI-Industrial Communications for EtherCAT® Installation Guide to learn how to install the NI-Industrial Communications for EtherCAT software on the real-time controller. This manual is available in printed-format shipped with the media.

NI-Industrial Communications for EtherCAT 16.0 Drops Support for Microsoft Windows 7 RTM, Windows Vista, Windows XP, and Windows Server 2003

With this release, NI-Industrial Communications for EtherCAT drops support for Microsoft Windows 7 RTM (with no service pack), Windows Vista, Windows XP, and Windows Server 2003. NI-Industrial Communications for EtherCAT 16.0 and later will not install or run on an unsupported OS. You cannot deploy or distribute applications that use NI-Industrial Communications for EtherCAT 16.0 to an unsupported OS. Additionally, after installing NI-Industrial Communications for EtherCAT 16.0, you cannot use any installers built on this computer with any version of LabVIEW, LabWindows™/CVI™, NI TestStand™, or Measurement Studio on an unsupported OS.

For more information about the changes to our OS support for 2016, refer to KB 79UC78LS, Why Does my LabVIEW, LabWindows/CVI, Measurement Studio, or TestStand Built Installer Fail on Windows XP/Vista and Server 2003?.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

New Features

Version 16.0

Version 15.0

Version 14.5

Version 14.0

Version 2.7

Version 2.6

Version 2.5

Version 2.4

Version 2.3

Version 2.2

Version 2.1

Version 2.0

Version 1.2

Version 1.1

Version 1.0.2

Version 1.0.1

Version 1.0

Supported EtherCAT Masters

NI CompactRIO Real-Time Controllers

Note  The NI CompactRIO real-time controllers have the following additional software requirements:

NI Single-Board RIO Controllers

Note  The NI Single-Board RIO controllers have the following additional software requirements:

NI CompactDAQ Real-Time Controllers

Note  The NI CompactDAQ real-time controllers have the following additional software requirements:

Note  NI does not recommend using cDAQ real-time controllers with the NI 9144 EtherCAT slave device in FPGA mode, because cDAQ real-time controllers cannot read user-defined variables from the NI 9144 EtherCAT slave device. When using a cDAQ real-time controller as the master device, you can only read EtherCAT device signals from the LabVIEW I/O Variable Functions. You cannot read directly from the LabVIEW I/O variables.

Embedded Real-Time Controllers with the NI PXI-8231, NI PXI-8232, or NI PXI-8234 Ethernet Interface

Embedded Real-Time Controllers with Two Built-in Ethernet Adapters

Note  NI PXI-8840 and NI PXIe-8840 require NI-Industrial Communications for EtherCAT 14.0 or later.

Real-Time Desktop Target with Any of the Following Ethernet Interfaces

Embedded Vision System

Compact Vision System

Note  NI CVS-1457RT requires NI-Industrial Communications for EtherCAT 14.0 or later. NI CVS-1458RT requires NI-Industrial Communications for EtherCAT 15.0 or later.

Rack Mount 1U Controllers

Industrial Controllers

Note  If you use NI Measurement & Automation Explorer (MAX) to install the NI-Industrial Communications for EtherCAT software on real-time controllers, some controllers, such as the Embedded Vision System, require you to install the controller driver software. Otherwise, MAX cannot discover the controllers.

Driver Version Naming Changes

NI-Industrial Communications for EtherCAT versions are now aligned with the versions of major NI application software products. This alignment gives you information about the year the driver was released and the most recent software version the driver was designed to work with. Driver versions now start with a two-digit year indicator: <ProductName><Year-BasedVersion>. For example, NI-Industrial Communications for EtherCAT 16.0 is the version released with LabVIEW 2016. The last version released under the old numbering scheme is NI-Industrial Communications for EtherCAT 2.7. The first version released under the new numbering scheme is NI-Industrial Communications for EtherCAT 14.0.

Known Issues

You can access the software and documentation known issues list online. Refer to the NI website for an up-to-date list of known issues in the NI-Industrial Communications for EtherCAT software.

Accessing the Help

Refer to the NI-Industrial Communications for EtherCAT® Help, available by selecting Help»NI-Industrial Communications for EtherCAT from LabVIEW, for information about the NI-Industrial Communications for EtherCAT software.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. Navigate to the Hardware Input and Output»NI-Industrial Communications»EtherCAT folder to access the examples.

You can also find the examples for NI-Industrial Communications for EtherCAT® in the labview\examples\indcomecat folder.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

Using NI Software with Microsoft Windows 10

Microsoft Windows 10 is the latest version of the Windows operating system and features significant changes compared to previous versions. Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. For more information about NI support for Windows 10, visit ni.com/windows10.

Using NI Software with Microsoft Windows 8.1

When you install NI software on Microsoft Windows 8.1, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, NI Measurement & Automation Explorer (MAX), and NI Launcher. For more information about NI support for Windows 8.1, visit ni.com/windows8.


Legal Information

Copyright

© 2008–2016 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.


Credits

This product includes components that use the Expat XML Parser. In regards to the Expat XML Parser, the following notice applies:

Copyright © 1998, 1999, 2000 Thai Open Source Software Center Ltd and Clark Cooper. Copyright © 2001, 2002, 2003, 2004, 2005, 2006 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

374786D-01