Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW 2014 Readme for Windows

Version 14.0.0

June 2014

This file contains important information about LabVIEW 2014 for Windows, including system requirements, installation instructions, known issues, and a partial list of bugs fixed for LabVIEW 2014.

Refer to the National Instruments website for the latest information about LabVIEW 2014.

Refer to the labview\readme directory for readme files about LabVIEW add-ons, such as modules and toolkits.

System Requirements

Installation Instructions

Product Security and Critical Updates

Known Issues

LabVIEW 2014 (64-bit)

Additions to the LabVIEW Help

Bug Fixes

Accessing the Help

Finding Examples

Automating the Installation of NI Products

How to Use NI Software with Microsoft Windows 8.x

NI Software Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003

Legal Information


System Requirements

Windows Run-Time Engine Development Environment
Processor Pentium III/Celeron 866 MHz (or equivalent) or later (32-bit)
Pentium 4 G1 (or equivalent) or later (64-bit)
Pentium 4M (or equivalent) or later (32-bit)
Pentium 4 G1 (or equivalent) or later (64-bit)
RAM 256 MB 1 GB
Screen Resolution 1024 x 768 Pixels 1024 x 768 Pixels
Operating System Windows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2012 R2 (64-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Windows 8.1/8/7/Vista (32-bit and 64-bit)
Windows XP SP3 (32-bit)
Windows Server 2012 R2 (64-bit)
Windows Server 2008 R2 (64-bit)
Windows Server 2003 R2 (32-bit)
Disk Space 500 MB 5 GB (includes default drivers from the NI Device Drivers media)
Color Palette N/A LabVIEW and the LabVIEW Help contain 16-bit color graphics. LabVIEW requires a minimum color palette setting of 16-bit color.
Temporary Files Directory N/A LabVIEW uses a directory for storing temporary files. National Instruments recommends that you have several megabytes of disk space available for this temporary directory.
Adobe Reader N/A You must have Adobe Reader installed to search PDF versions of all LabVIEW manuals.
Note  The following list describes restrictions for using LabVIEW on Windows:
  • LabVIEW does not support Windows 2000/NT/Me/98/95 or Windows XP x64.
  • You cannot access LabVIEW using a Guest account on Windows.

Installation Instructions

Depending on whether you are installing LabVIEW for the first time or upgrading from a previous version, refer to one of the following documents for information about installing LabVIEW:

You can access the LabVIEW Installation Guide and the LabVIEW Upgrade Notes at ni.com as well as on the installation media.

Note   If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.

LabVIEW Updates and Notifications

National Instruments posts information about critical updates and security notifications on ni.com. Visit ni.com/info and enter Info Code updates to access this information.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about National Instruments products. Visit ni.com/critical-updates for information about critical updates from National Instruments.

Known Issues

You can access the software and documentation known issues list online. Refer to the National Instruments website for an up-to-date list of known issues in LabVIEW 2014.

LabVIEW 2014 (64-bit)

When run on Windows (64-bit), LabVIEW 2014 (64-bit) provides access to more memory than a 32-bit operating system or a 32-bit application can provide. LabVIEW 2014 (64-bit) includes nearly all of the development environment features of LabVIEW 2014 (32-bit).

Refer to the National Instruments website for information about obtaining a copy of LabVIEW 2014 (64-bit).

Supported Hardware

LabVIEW 2014 (64-bit) supports many hardware devices. Refer to the National Instruments website for information about drivers compatible with LabVIEW 2014 (64-bit). For GPIB devices, you must use at least NI-488.2 2.6 for Windows. Refer to the specific hardware documentation for more information about compatibility with LabVIEW 2014 (64-bit).

Supported Modules

LabVIEW 2014 (64-bit) supports only the NI Vision Development Module. Refer to the Vision Development Module documentation for more information. No additional modules support LabVIEW 2014 (64-bit).

Additions to the LabVIEW Help

The following list contains additional changes to LabVIEW that are not included in the LabVIEW Help, the LabVIEW Upgrade Notes, or both:

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in LabVIEW 2014. This is not an exhaustive list of issues fixed in the current version of LabVIEW. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

ID Legacy ID Fixed Issue
46534 2QH9HKJ1 Enhance error filtering in the Clear Errors VI
122057
Joining numbers of different widths produces unexpected values
125936
Printing entire VI hierarchy does not include dynamic dispatch subVIs
187861
A VI snippet that contains a Property node for a front panel object results an invalid reference
201104
Toggling y-scale visibility with multiple scales causes unreadable display of data on waveform graphs
212845
When creating a VI snippet that contains a local variable, the VI snippet changes the variable to a Property Node and a reference
255617
Error 1502 can occur if dependencies are placed in non-executing Case structures
276765
Classic controls do not have distinct names in Quick Drop
276988
A large picture ring constant can cause fpsane.cpp line 442 error
277283
When creating a VI Snippet with code that contains a tab control, the snippet does not properly save the contents of each tab.
286661
Issue with the LabVIEW Icon Editor opening with a white background when it should be transparent
292652
VI snippet cannot be dragged from Chrome, Firefox or Safari
308748
Memory leak when using .NET TextBox Append Method
313075
In some cases, wiring a constant to a Case structure would result in the inability to build a LabVIEW executable with Error 1502
362970
Cannot link VI Context Help to an anchor in an HTML file
366169
Making a copy of a library using the "Save As" menu resets all VI icons in the new copy of the library to the default icon
367468
Wiring multiple inputs to the Split Signals VI causes LabVIEW to crash
368959
LabVIEW crashes by replacing a cluster constant that is being viewed as an icon with either a string or a Boolean constant
369119
Renaming a library that contains a class which contains a strictly typed VI refnum causes errors because the namespace in the refnum is not updated
371391
For a specific VI, enabling debugging caused an order of magnitude performance degradation
376763
Removing an item in an enum does not change focus to the next item in the list
377978
When compared to the Index Array function, Delete From Array function has performance overhead when using it to index the last value of an array
381960
LabVIEW runs out of images and crashes if you have large number of VIs in your user.lib palette
382652
It is possible to make changes to the items of a typedef enum constant in the properties menu, but the changes do not take effect
384551
A breakpoint inside the disabled case of a Conditional Disable structure is still hit when the VI executes
386963
Creating a typedef from a cluster that contains an empty array constant throws a DWarn 0x283E632F in replace.cpp
393436
Build VI does not return any generated files when running an installer build specification
397393
Internal Warnings 0xD1EED773 and 0x667BD7ED while changing name of a control
397845
In rare cases, LabVIEW hangs when merging VIs with missing subVIs
397918
Error 1502 sometimes occurs when building an application containing unreachable code in a Case structure with a constant wired to it
401646
Toggling the visibility of an axis on a Waveform Graph with multiple axes causes the axes to overlap
401731
Add valid "Window Run-Time Positions" from VI Properties to app builder Source File Settings - Customize VI Properties
403179
LabVIEW crashes when wiring a variant constant to a digital waveform graph and save the VI
403202
The Remote Front Panel Plugin for Chrome and Firefox needs to be installed on a repair
403213
Creating a source distribution does not allow you to have a mix of code that is source only and not source only
403263
Bookmark Manager shows bookmarks in the LabVIEW resource folder
404038
Unevenly Sampled Signal Spectrum VI uses incorrect sample weighting
404512
Compiler Error csrc=0x3F when Match Pattern VI is wired to a conditional tunnel
404637
Ctrl+z sometimes types a z character. The same behavior occurs for ctrl+c and ctrl+x
406710
LabVIEW crashes when inlined subVI with Feedback Node inside of parallel For Loop is called
407147
Opening the LabVIEW Icon Editor resets invisible layers to visible
407471
.NET invoke and property nodes do not always load or relink to the correct assembly version
408437
Mouse Wheel ButtonMods event data appears in English in French LabVIEW
408624
Rare LabVIEW crash when a FPGA target parent is drag-dropped and LabVIEW FPGA is not installed or not licensed
409889
Build All fails while building an installer when multiple build specifications are in a project
410733
Ramp Pattern VI does not produce expected results
410846
LabVIEW crashes when using concatenating tunnel mode on fixed-size array
412912
LabVIEW Crash when VI has string control wired to generate user-defined trace events is traced
413400
When configuring a new project in LabVIEW, the project root directory cannot be set to a network drive
413502
Desktop Execution Trace Toolkit does not accurately identify creation/destruction of Data Value References
417188
Officially support using VariantFlattenExp to flatten variants to previous versions
417953
LabVIEW will crash on run if array on connector pane is wired to Flatten to JSON primitive
418199
The reference to typedef objects returned by the FocusObj event structure terminal cannot be compared to regular object references
418330
Rare LabVIEW crash while quick-dropping a primitive onto the diagram
420007
Open URL in Default Browser VI does not correctly handle hashtags in Compiled Help Files
421458
Digital Waveform Graph can hang LabVIEW when writing badly overflown data
421739
Quick Drop ctrl+r needs to wire the To More Specific/Generic side terminal instead of center terminal
422283
Renaming specific .lvlibs in a project can cause typedef enum constants to revert to default values
422905
Attaching a comment to an object with a long label, the comment arrow will not point at the object
424616
Block diagram constants do not inherit a typedef's default data when a new element is added
425582
LabVIEW issues an internal warning when failing to save a VI in an unattended mode
426108
Using an annotation list to visualize labels and arrows with offset in a XY Graph the offset for the labels sometimes disappears
426280
Modifying the Minimum Value in the properties of a numeric control configured to Absolute Time can crash LabVIEW
426285
In rare cases, a corrupt listbox does not output correct values
426523
A specific large project fails to build with a GenIL error and then crashes if you do not select Disconnect Type Defs
426788
Reading LinkedControl.Label.Text property of an implicit property node crashes LabVIEW
426792
LabVIEW crashes when waveform graph cursors contain invalid scale values
427673
The Actor Framework cannot be packed into a packed library
428197
Creating an I8 array indicator/control for a property node adds a U8 array instead
428253
If LabVIEW 2013 is installed, Application Builder includes the LabVIEW 2013 Web Service installer when building from LabVIEW 2012
428273
Add High Resolution Relative Seconds VI to the Timing palette
428357
Comparisons fail between empty fixed sized arrays and compare aggregates
428767
Create SubVI does not respect the Options settings for terminal label position
428872
System State Publisher incorrectly reports cached memory as "used" memory on Linux Real-Time
429396
Application directory VI incorrectly returns paths when used within a .NET Assembly or LabVIEW-built DLL
429516
VI snippets not working as expected in certain browsers
429902
Application Builder lists Windows XP SP2 as the system requirements when the LabVIEW Readme requires XP SP3
430579
The Cubic Spline Fit does not output a linear function when the balance parameter is zero and the input arrays are less than seven elements
431956
Calling a LabVIEW Web service repeatedly causes a memory leak
432447
"Adapt to source" does not work for FXP inside a cluster
432614
Remote Front Panels in LabVIEW 2013 do not release the VxWorks targets after being disconnected
433514
Dragging and dropping groups of arrays between clusters will sometimes cause a rare LabVIEW crash
433551
LabVIEW crashes when deleting an Real-Time target target from a project without Real-Time support installed
433687
Application Builder does not provide a way to set the CFBundleIdentifier in the Info.plist file on Mac
435028
Array constant does not auto resize when inner control is edited and resizes
435029
Updating a typedef does not cause a block diagram constant to resize correctly
435259
LabVIEW dialogs sometimes display offscreen with multiple monitor setups
436784
Scripting method ClusterConstant.AutoSize crashes LabVIEW
437814
Open Sessions VI from visa.llb does not work properly in LabVIEW 2013
438550
Mouse Wheel events show the incorrect coordinates for Controls and Splitters
438646
LabVIEW sometimes crashes when viewing the context help and deleting an input wire to a polymorphic VI that automatically adapts to inputs
439026
Building an Application with Enable ActiveX server selected will crash all localized versions of LabVIEW
439041
Memory leak when using User Events
439642
LabVIEW 2013 SP1 on Mac has an incorrect installer warning claiming we do not support Mavericks
439710
Launching a right-click menu on an XControl causes an increase in CPU usage
440114
Executing a TestStand sequence with LabVIEW VIs in a user interface running in the LabVIEW 2013 Development System causes delays at the beginning of execution
441769
Long build path on Mac OS X results in temporary files that prevent build
441783
LabVIEW Class VIs loaded from an unexpected path can sometimes load broken
441892
Quick Drop shortcut Ctrl-T does not work correctly for matrix and array constants
441894
Moving the label of a typedef constant through scripting moves the constant instead of the label
442743
Cutting text from one free label and pasting into another with the autotool disabled crashes LabVIEW
444095
Remove Stacked Sequence Structure from the palette
444412
LabVIEW sometimes crashes with exception 0x558A98DB when searching a block diagram containing tab controls using the find dialog
445456
webservices.ini is not installed on Linux Real-Time
445981
A memory leak occurs when calling a custom ActiveX Control function which returns a UInt64
447072
Wait (ms) VI does not work on NI Linux Real-Time target if wait is longer than 30000 ms
449183
In specific cases, adding an XControl to LabVIEW library crashes LabVIEW
450094
The menu option Project»Create Project will sometimes open a File Explorer window to the template folder
450755
Modifying Meter, Gauge, or Knob dimensions in a tab control resizes controls incorrectly
451107
In some cases, LabVIEW asks to save code changes when no changes were made
451499
LabVIEW Run-Time Engine crashes when it loads a .lvproj containing Network Variables using strict TypeDefs
453896
Error message encountered during TestStand Deployment Utility build process may show incorrect list of VIs

Accessing the Help

Refer to the LabVIEW Help, accessible by selecting Help»LabVIEW Help from LabVIEW, for information about LabVIEW 2014.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information, refer to the following KnowledgeBase articles:

How to Use NI Software with Microsoft Windows 8.x

When you install National Instruments software on Microsoft Windows 8.x, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher.

Using NI Launcher

NI Launcher helps you find and launch installed NI products. It provides you with a method of finding NI products similar to the Start menu in previous versions of Microsoft Windows. To use NI Launcher, click the NI Launcher tile in the Apps view. NI Launcher launches the desktop and opens a menu containing a list of NI products. Click any NI product to launch it.

Note  NI MAX does not appear as a desktop shortcut when installed on Microsoft Windows 8.x. You can launch NI MAX either from the Apps view or from within NI Launcher.

Pinning Frequently Used Applications

For convenience, you can pin your most-used NI applications, such as NI MAX, to either the Start screen or the Taskbar on the desktop, as necessary:

Current ApplicationIcon LocationPin to Action
Windows 8.x DesktopDesktop TaskbarRight-click application and select Pin to Taskbar
Windows 8.x Desktop Start screenRight-click application and select Pin to Start
Windows 8.x Start screenDesktop TaskbarRight-click application and select Pin to taskbar from the menu bar on the bottom of the screen

Finding All Programs

If you want to find a particular application or related files, such as documentation files, from the Start screen, you can access all installed files from the Apps view. To get to the Apps view, right-click anywhere on the Start screen and select All apps (Windows 8) or click the down arrow on the bottom left of the screen (Windows 8.1).

For more information about NI support for Windows 8.x, visit ni.com/windows8.

NI LabVIEW Drops Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 in 2016

National Instruments LabVIEW will drop support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 as of July 1, 2016. Versions of LabVIEW that ship after July 1, 2016 will not install or run on Windows Vista, Windows XP, or Windows Server 2003. For detailed information about NI application software product life cycles, visit ni.com/info and enter one of the following Info Codes:

Product Info Code
NI LabVIEWlifecycle
NI LabWindows™/CVI™cvi_lifecycle
NI Measurement Studiomstudiolifecycle
NI TestStandtslcp
NI DIAdemddlcp
NI SignalExpressselcp
NI VeriStandnivslifecycle

Legal Information

Copyright

© 2004–2014 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on National Instruments trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.