Important Information

Warranty
The DIAdem is warranted against defects in materials and workmanship for a period of 90 days from the date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to be defective during the warranty period. This warranty includes parts and labor.

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected.

In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THEREFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. THIS LIMITATION OF THE LIABILITY OF NATIONAL INSTRUMENTS WILL APPLY REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT OR TORT, INCLUDING NEGLIGENCE. ANY ACTION AGAINST NATIONAL INSTRUMENTS MUST BE BROUGHT WITHIN ONE YEAR AFTER THE CAUSE OF ACTION ACCRUES. NATIONAL INSTRUMENTS IS NOT LIABLE FOR ANY DELAY IN PERFORMANCE DUE TO CAUSES BEYOND ITS REASONABLE CONTROL. THE WARRANTY PROVIDED HEREIN DOES NOT COVER DAMAGES, DEFECTS, MALFUNCTIONS, OR SERVICE FAILURES CAUSED BY OWNER’S FAILURE TO FOLLOW THE NATIONAL INSTRUMENTS INSTALLATION, OPERATION, OR MAINTENANCE INSTRUCTIONS; OWNER’S MODIFICATION OF THE PRODUCT; OWNER’S ABUSE, MISUSE, OR NEGLIGENT ACTS; AND POWER FAILURE OR SURGES, FIRE, FLOOD, ACCIDENT, ACTIONS OF THIRD PARTIES, OR OTHER EVENTS OUTSIDE REASONABLE CONTROL.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

In regards to components used in USI (Xerces C++, ICU, and HDF5), the following copyrights apply. For a listing of the conditions and disclaimers, refer to the USICopyrights.chm.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).
Copyright © 1999 The Apache Software Foundation. All rights reserved.

NCSA HDF5 (Hierarchical Data Format 5) Software Library and Utilities
Copyright 1998, 1999, 2000, 2001, 2003 by the Board of Trustees of the University of Illinois. All rights reserved.

Trademarks
National Instruments, NL, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help>Patents in your software, the patents.txt file on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN ANY LIFE SUPPORT SYSTEMS Whose FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO...
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
About This Manual


Complete DIAdem documentation is available as PDF files (Portable Document Format) on the DIAdem CD.

The DIAdem: Data Acquisition manual consists of two parts:

- Part I, Getting Started with DIAdem Data Acquisition, explains how to generate your first block diagram for data acquisition and visualization.
- Part II, Acquiring and Visualizing Data, explains the functions of DIAdem DAC and DIAdem VISUAL in more detail.

Conventions

The following conventions appear in this manual:

<>
Angle brackets indicate a key you press to perform a function, for example, <Ctrl>.

»
The » symbol leads you through nested menu items and dialog box options to a final action. The sequence File»Page Setup»Options directs you to pull down the File menu, select the Page Setup item, and select Options from the last dialog box.

💡 This icon denotes a tip, which alerts you to advisory information.

✍️ This icon denotes a note, which alerts you to important information.

⚠️ This icon denotes a caution, which advises you of precautions to take to avoid injury, data loss, or a system crash.

**bold**
Bold text denotes items that you must select or click in the software, such as menu items and dialog box options.

*italic*
Italic text denotes emphasis, a cross reference, or an introduction to a key concept.
About This Manual

monospace

Text in this font denotes text or characters that you should enter from the keyboard, formulas, sections of code, programming examples, and syntax examples. This font is also used for the proper names of disk drives, paths, directories, programs, subprograms, subroutines, device names, functions, operations, commands, variables, filenames and extensions, and code excerpts.

monospace bold

Bold text in this font denotes the messages and responses that the computer automatically prints to the screen. This font also emphasizes lines of code that are different from the other examples.

right-click

(Mac OS) Press <Command>-click to perform the same action as a right-click.

Related Documentation

The following documents contain information that you may find helpful as you read this manual:

• Getting Started with DIAdem
• DIAdem: Data Analysis and Report Generation
• DIAdem Help, available by selecting Help»Contents
Part I explains how to generate your first block diagram in DIAdem, for data acquisition and visualization.
Measuring and Visualizing with DIAdem

With the DIAdem DAC and DIAdem VISUAL panels you can acquire data, control processes, and visualize online data.

Acquiring Measurements with DIAdem DAC

With DIAdem DAC, you develop measurement and control solutions in a block diagram. You select necessary functions from an extensive function library and place function blocks into the workspace. You connect blocks logically by dragging wires with the mouse.

Measurement data come from data sources and go to processing blocks, display instruments, and output blocks. To create a block diagram with a simulated signal, complete the following steps:

Note  You can substitute simulation signals later with real data sources.

1. Select the DIAdem DAC panel.
2. Click Delete Block Diagram.
3. Click Simulation Input Blocks in the group bar.
4. Click Generator in the function bar. The block appears in the DIAdem DAC workspace. You can move a function block anywhere in the workspace with the mouse.
5. Click Display in the group bar.
6. Click Digits in the function bar.
7. Click the **Output** on the right side of the **Function Generator**. Depress the left mouse button and drag the green wire to the **Input** on the left side of the function block **Numeric1**. As soon as OK appears on the mouse pointer, you can release the left mouse button. The data source and the display instrument are now linked with a green data wire.

8. Click **Start Display**. The DIAdem VISUAL panel appears and displays the simulated sine values in the numeric instrument.

9. Click **Stop Measurement**.

10. Select **Window»Tile** to see the block diagram and the visualization panel parallel to each other.

![Figure 1-1. Defining Block Diagram with Function Generator and Numerical Display](image)

### Saving Measurement Data

The simulated signal values are only displayed and not saved. To document and verify the data, you must save the measurement values. To save data from your measurement, complete the following steps:

1. Click **System** in the group bar.

2. Click **Save Data** in the function bar.

3. Place the system block under the numerical display.

4. Click on the green **data wire** and press the mouse button while dragging a new wire onto the data input of the saving block.
5. Double-click the **Save Data** block.
6. Enter **1000** in the **No. of Values** field.
7. Click **Start measurement**. After a short time the measurement automatically discontinues because 1,000 values have been saved.
8. Select the **DIAadem NAVIGATOR** panel. The Data Portal appears and shows the new data channels *Time1* and *Generator1_1*.

**Monitoring Measurement Signals**

In control blocks you define conditions for controlling measurement tasks. Complete the following steps for DIAadem to save measurement values according to a condition.

1. Select the **DIAadem DAC** panel.
2. Click **Simulation inputs** in the group bar.
3. Click **Slider control** in the function bar. DIAadem DAC displays the **Slider1** block in the workspace.
4. Position the **Slider1** block below the Generator.
5. Click Control in the group bar.

6. Click Window condition in the function bar. DIAdem DAC displays the Window1 block in the workspace.

7. Position the Window1 block next to the Slider control.

8. Drag a green bus from the output on the Slider control to the input on the Window condition.

9. Double-click the Window1 block. Enter –5 as the lower limit, 5 as the upper limit, and Window exit as the window type. The Window dialog box should look like Figure 1-3.

![Figure 1-3. Defining the Condition in the Window1 Block](image)

10. Click OK.

11. Click the data bus between the Slider1 block and the Window1 block, and drag a new bus to the green bus between the Generator1 block and the Numeric1 block.

Note: The 2 at the input of the Numeric block indicates that two signals are on this block.

12. Drag a bus from the output on the Window condition to the second input at the top of the Save block. This creates a red control bus that DIAdem uses to trigger data storage.
The block diagram should look like Figure 1-4.

![Figure 1-4. Extended Block Diagram with Slider Control and Window Condition](image)

**Note**  
DIAdem displays control buses in red. You connect control buses at the top or at the bottom of a block.

13. Click **Start measurement**. The DIAdem VISUAL panel appears with the Slider control and the Numeric display.

14. Drag the Slider control. If you move the Slider control above the value 5 or below the value –5, DIAdem starts to save the measurement values.

15. Click **Stop measurement**. DIAdem stores the values of the measured signals to new channels in the Data Portal.
Visualizing Measurements with DIAdem VISUAL

DIAdem VISUAL is the visualization screen for DIAdem DAC. You can influence the actions of a measurement with control instruments. In DIAdem VISUAL, you can arrange and configure operation and display instruments during a measurement.

To load a block diagram created in DIAdem DAC and start the measurement, complete the following steps:

1. Select the **DIAdem VISUAL** panel.
2. Click **Load Block Diagram**.
3. Select the file `example.dac` and click **Open**.
4. Click **Start Display**.
5. Allow the measurement to run for a short period.
6. Click **Stop Measurement**.

Modifying a Visualization

To modify a visualization, you can insert new instruments and configure existing instruments.

**Note** The logical wiring of instruments takes place in DIAdem DAC.

To add a company logo to a visualization, complete the following steps:

1. Click **Graphics** in the group bar.
2. Click **Graphic1** in the function bar. A logo is inserted in the upper left corner of the workspace.
3. Place the logo under the building display.
4. Size the logo by dragging the small square blocks at the edges of the graphic.
5. Click the building graphic and size the graphic by dragging the square blocks at the edges of the graphic.
6. Click **Start Display**.
7. Allow the measurement to run for a short period.
8. Click **Stop Measurement**.
Chapter 1  Measuring and Visualizing with DIAdem

Summary

The following topics are a summary of the main concepts that you learned in this chapter.

DIAdem DAC

Using DIAdem DAC, you describe the measurement and operation assignments with a block diagram. From the large function library, select necessary functions that you place as function blocks in the workspace. The logical connection of the blocks occurs using connections that you draw as lines.

Data Acquisition

Blocks represent data sources such as A/D converter boards, front end devices, and other external measurement devices. You register the corresponding drivers in DIAdem DAC and configure the available signal inputs and outputs. Additional data sources can be input instruments, data files, and calculation results.

DIAdem VISUAL

Select instruments such as pointer, number, bar display, writer, or wiper displays for measurement values from the DIAdem VISUAL library. With control instruments such as switches, knobs, or slider controls, you can trigger and control during a measurement function. When designing a visualization, you can align and configure instruments as you like.

When you start a measurement, DIAdem automatically switches to the DIAdem VISUAL panel and starts the visualization.
Part II describes the functions for defining your block diagrams:

- Chapter 2, *Acquiring Data and Controlling Processes*, describes the basic elements of a block diagram. You connect simulation inputs to visualization instruments and control data storage with conditions.
- Chapter 3, *Visualizing and Operating*, describes the visualization and control elements, and explains how to set them.
- Chapter 4, *Using Hardware*, describes how to register and configure driver software for measurement hardware in DIAdem.
Acquiring Data and Controlling Processes

You can use DIAdem DAC to describe your measurement and control tasks. (DAC stands for Data Acquisition and Control.) This involves selecting function blocks, connecting them, and setting their parameters. The connections function as bus cables that can transport one or more signals.

Figure 2-1. The Block Diagram Describes the Measurement Task

The function blocks are arranged in groups with common themes. In the panel bar the input and output blocks provide features from the registered measurement hardware. The simulation inputs contain input instruments and generated signals. You can use the scaling blocks to convert incoming signals into physical values. The processing blocks contain blocks for online mathematics and closed loop control. The system blocks are used for defining clock rates and saving data. The control blocks are used to define conditions and display blocks are used to display all data in DIAdem VISUAL.
In DIAdem, the measured values are acquired, processed and visualized value by value. This is called single point processing. With packet processing, the data is grouped into packets for performing online classification or online FFT, for example. Single point and packet processing blocks can be combined in one block diagram.

The alarm and protocol system monitors signals for limit values. Alarm messages with different priorities can be generated, displayed, recorded, and sent over the Internet. The user administration enables authorized users to confirm alarms.

You get function blocks from the function bars, place them in the workspace, and define parameters for them. You can copy, exchange and delete blocks, and connect them using the signal inputs and outputs. You can connect blocks to blocks, blocks to cables, and cables to cables.

The toolbar contains the following functions for processing your block diagram.

- Measured value display without data storage
- Start a measurement, <Ctrl-F5>
- Stop the measurement, <Esc>
- Check the block diagram for syntax errors
- Zoom functions
- Alignment functions
- Grid
- Convert sections of a block diagram into a subblock diagram
- Unpack a subblock diagram
- Close a subblock diagram that has been loaded
- Block diagram info
- Interface monitor
- Editor for control files
Describing the Measurement Task

You describe the measurement task as a graphic block diagram, as shown in Figure 2-1, which is saved as a .DAC file. Block diagrams have a clear structure—you select the function blocks you need from the function bar, place them in the workspace, and connect them.

DIAdem distinguishes between different cable connection types that transport different types of signals. You can delete each of the cable types in the toolbar.

- **Yellow system cables** transport the clock rate.
- **Red control cables** transport control signals, for starting and stopping actions, for example.
- **Green data cables** transport measured values.
- **Green-black data cables** transport packet processing values.
- **Blue-black alarm cables** transport alarms.
- **Gray-black text cables** transport message texts.

Data, alarm, and text cables come into the function blocks on the left and go out from the right. The control and system cables are connected to the horizontal edges of the blocks. The inputs are at the top and the outputs are at the bottom. Figure 2-2 is an example of possible connections, which are listed in Table 2-1.

![Figure 2-2. Positions of All Cable Connections](image)
To connect function blocks, click on an output and drag the crosshair to the target input. You can only connect the same kinds of terminals and cables. An OK at the mouse cursor indicates that a connection can be made and a cross indicates the opposite. If a cable is already connected at a block terminal, no other cables can be connected. Click on the cable and create a branch instead.

A branch is displayed as a circle. All the connected cables contain the same signals.

An input point is displayed as a square. To input additional signals into a bus cable, place the end of a cable on an existing cable. The black triangles indicate which cables input signals.

Branches and input points can be shifted. Keeping the left mouse button pressed, pull a rubber band around the node. You can delete the marked cables and nodes with <Del>.

The cables can contain more than one signal. The number of transported signals is displayed by a black slash.

If you mark a cable, a signal list symbol appears at the mouse pointer. Double-click on the cable to open the signal list with the connected block outputs and all the signals contained. Click on the workspace to undo the marking.

---

**Table 2-1.** List of Cable Connection Types

<table>
<thead>
<tr>
<th>Cable Type</th>
<th>Number in Figure 2-2</th>
<th>Connector</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yellow system cables</td>
<td>1</td>
<td>Clock input</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>Clock output</td>
</tr>
<tr>
<td>Red control cables</td>
<td>2</td>
<td>Control input start</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>Control input stop</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>Reset control input</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>Clock release</td>
</tr>
<tr>
<td></td>
<td>9</td>
<td>Control output</td>
</tr>
<tr>
<td>Green data cables</td>
<td>6</td>
<td>Data input</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>Data output</td>
</tr>
</tbody>
</table>

---

To connect function blocks, click on an output and drag the crosshair to the target input. You can only connect the same kinds of terminals and cables. An OK at the mouse cursor indicates that a connection can be made and a cross indicates the opposite. If a cable is already connected at a block terminal, no other cables can be connected. Click on the cable and create a branch instead.

A branch is displayed as a circle. All the connected cables contain the same signals.

An input point is displayed as a square. To input additional signals into a bus cable, place the end of a cable on an existing cable. The black triangles indicate which cables input signals.

Branches and input points can be shifted. Keeping the left mouse button pressed, pull a rubber band around the node. You can delete the marked cables and nodes with <Del>.

The cables can contain more than one signal. The number of transported signals is displayed by a black slash.

If you mark a cable, a signal list symbol appears at the mouse pointer. Double-click on the cable to open the signal list with the connected block outputs and all the signals contained. Click on the workspace to undo the marking.
In complex block diagrams, cables may be continued in the background. The interrupt ends are indicated by a black point and the DIAdem cable designation, for example, D9.

The block diagram can be barred from modifications with Edit→Block parameterization. With Edit→Find, you can search for a function block in an extensive block diagram and request its properties and connections. Click Measure→Measurement (without display) for data acquisition without visualization.

Use Settings→Options→DAC to define basic properties of the measurement kernel and the block diagram editor. Specify the maximum number of blocks and signals for one block diagram in the measurement kernel. In the Editor, you can change the colors and labels for the appearance of the block diagram.

### Acquiring and Displaying Data

In the following example, you will generate a block diagram without measurement hardware so the example can be used on any PC. The simulation inputs function bar in Figure 2-3 contains function blocks like Random, Noise, and Function generator, which you can later exchange for hardware signal sources. You also can use input instruments, data files, single data channels, and calculation results without measurement hardware.

![Figure 2-3. Simulation Inputs Function Bar](image)

The function bar for the display blocks in Figure 2-4 provides various instruments for visualizing data signals.

![Figure 2-4. Display Function Bar](image)
Load a new block diagram and insert a **Random** simulation input. Select a **Digits** display block. Connect the two function blocks with a green data cable. Start the measured value display with the blue triangle as shown in Figure 2-5.

**Figure 2-5.** A Simple Measurement Task: Acquisition and Display

When you start the measurement, DIAdem automatically switches to the DIAdem VISUAL device and starts the visualization. For every display block in DIAdem DAC there is a related instrument in DIAdem VISUAL. In DIAdem VISUAL, you arrange and define the parameters for all the display instruments. Refer to Chapter 3, *Visualizing and Operating*, for specific information.

**Note** The two DIAdem panels in Figure 2-5 are set next to each other when you click **Window»Tile**. This illustrates that for every display block defined in DIAdem DAC there is a corresponding instrument in DIAdem VISUAL. It is usually sensible to use the entire workspace for one DIAdem panel.
Adding Signal Sources and Connecting Signals

Add a Noise simulation input to the block diagram in the example. Connect its data output to the existing green data cable. Select Graph display as the second display instrument. Connect the data cable to the Graph block data input.

Add the diagram of the measurement object as an illustration. Select the Graphic display block and enter DAC.wmf in the block dialog as Graphic File name. This graphic shows gears in a machine.

Enter the settings from Table 2-2 in the Random block dialog.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>List length</td>
<td>8</td>
</tr>
<tr>
<td>Block name</td>
<td>Temperature</td>
</tr>
</tbody>
</table>

In the Active column in Figure 2-6, you can deactivate single signals without having to disconnect them. These signals are retained in the signal list without transporting data.

Signals can be connected and disconnected at the block inputs, the same as for cable terminal panels. In the example, Noise is only to be displayed as a graph and the temperature only as a number. You have to disconnect the Noise signal from the numeric display and connect it as the only signal to the Graph display.
Open the signal list by double-clicking on the triangle at the data input on the Graph block, as shown in Figure 2-7. The block diagram in Figure 2-8 shows the result.

![Connect signal (Curves1)](image)

**Figure 2-7.** You Can Connect and Disconnect Signals

**Note** You can reconnect single signals in the dialog in Figure 2-7. Use the pop-up list to assign single signals and the **Connect signal** subdialog to connect multiple signals.

![Curves1 Display Block](image)

**Figure 2-8.** Only One Signal Is Connected to the Curves1 Display Block
After you have reassigned the display instruments in DIAdem VISUAL, start the *Measured value display*. The eight temperatures are displayed as numbers and the noise as a graph, as shown in Figure 2-9. The signal names are also activated as a *legend*.

![Figure 2-9. The Extended Visualization Includes a Graphic and the Signal Names](image)

### Saving Measured Data

So far measured signals have been simulated and displayed. To document and check processes, the measured values have to be stored. The *Save* block, for storing measured data, is in the System function bar.

Click on the **Save data with trigger system block** and connect it to the data cable, as shown in Figure 2-10.
Start a measurement with the *green start button* this time, so the measured values are also saved.

The measurement ends when the number of values to be saved, which is specified in the Save block, has been attained. The measured values are stored in the Data Portal, where you can use them for other calculations.

**Tip** You also can write measured values straight into a data file. The file is created in the DEMO\DAT directory and you can specify the file name in the Save block.
Monitoring Conditions

For the generation of control signals, the function bar for the control blocks in Figure 2-11 includes window, slope and time conditions, buttons, free formulas, and various links. The control signals are transported by red control cables, which are connected at the top and bottom of the function blocks.

Figure 2-11. Control Function Bar

In the example, the data will be saved when a limit value is exceeded, then it will be displayed on the screen. A slider control is monitored for limit values that have been defined in a window condition.

Click on the Window condition control block and open the block dialog, then enter the settings from Table 2-3.

Table 2-3. Configuring the Window Condition Block

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lower limit</td>
<td>–5</td>
</tr>
<tr>
<td>Upper limit</td>
<td>+5</td>
</tr>
<tr>
<td>Type of window</td>
<td>Window exit</td>
</tr>
</tbody>
</table>

Select a Slider control simulation input and position the slider control exactly above the Noise 1 block. Answer the question about exchanging the blocks with OK, then run a cable between the slider control and the window condition. Connect the bottom control output on the Window condition to the Start control inputs on the Save and Numeric blocks, as shown in Figure 2-12.
In DIAdem VISUAL, position the slider control to the left of the Graph display and start a measurement. As soon as you move the slider above or below the specified limit values of ±5, the numeric display appears, as shown in Figure 2-13, and storage begins.
Displaying Messages Online

You can use the Message display block to display warnings or information during the measurement. In the block dialog box, enter the message file to be read out by the block. Instead of texts, you also can display diagrams or play wave (.WAV) files. If you want to use combinations, for example, graphics and sound together, you should use two message blocks with different message files.

Click on the Message display block and enter the settings from Table 2-4 in the dialog.
Connect the start input on the Message block to the existing red control cable. Connect the data input to the slider signal. Position the yellow message window in DIAdem VISUAL and start a Measurement. If the slider signal leaves the range between –5 and +5, the message window appears, as shown in Figure 2-14.

Table 2-4. Configuring the Message Block

<table>
<thead>
<tr>
<th>Dialog Menu</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>General layout</td>
<td>Time display</td>
</tr>
<tr>
<td></td>
<td>Yellow</td>
</tr>
<tr>
<td>Display</td>
<td>Time format</td>
</tr>
<tr>
<td></td>
<td>Date time rec</td>
</tr>
<tr>
<td></td>
<td>Message file</td>
</tr>
<tr>
<td></td>
<td>Warning.ASC</td>
</tr>
<tr>
<td>Font</td>
<td>Arial</td>
</tr>
</tbody>
</table>

Connect the start input on the Message block to the existing red control cable. Connect the data input to the slider signal. Position the yellow message window in DIAdem VISUAL and start a Measurement. If the slider signal leaves the range between –5 and +5, the message window appears, as shown in Figure 2-14.

Figure 2-14. A Message Window Indicates That the Limit Values Have Been Exceeded
Scaling blocks convert electric signals into the original physical values, for example, a voltage into a temperature in degrees Fahrenheit.

The function bar for the scaling blocks in Figure 2-15 provides various scalings and thermolinearizations. With *Multi-point scaling*, you can define data points for any non-linear scaling in two data channels. The *thermolinearizations* (J, K, T, etc.) and the *Pt100 linearization* calculate the temperature from the measured voltage, and an external *preamplification* can be taken into account.

The function bar for the processing blocks in Figure 2-16 provides formula blocks for defining your own formulas, various *closed-loop control algorithms*, the *script block* for defining sequential runs, and help functions for copying or converting signals. Register the Script DAC driver with Settings»GPI-DLL Registration»Add»GFSVBSDR.DLL to obtain functions for determining the mean and bundling bits. Refer to Chapter 4, *Using Hardware*, for specific information.

With the formula block, you can perform calculations during a measurement. The formula interpreter functions connect data and control signals, providing a new output signal. For example, you can calculate the power during the measurement using the current and voltage signals.

There is another formula block with the control blocks. This block has a control output instead of the data output. For the control signal, define a formula that has a result of 0 or 1.

If your measurement hardware has outputs, you can output DIAdem DAC signals. You can access the PC loudspeaker for testing purposes.
The function bar for simulation outputs in Figure 2-17 includes loudspeaker output, display and deletion of activated Windows applications, and performance of external applications.

![Figure 2-17. Simulation Output Function Bar](image)

For the example, define the signal output to the PC loudspeaker. To turn signal output on and off manually, select a simulated input key. Enter the settings from Table 2-5 in the block dialog.

### Table 2-5. Configuring the Button

<table>
<thead>
<tr>
<th>Block Dialog</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block name</td>
<td>On/Off</td>
</tr>
<tr>
<td>Function</td>
<td>Switch</td>
</tr>
<tr>
<td>Display</td>
<td>Label On</td>
</tr>
<tr>
<td></td>
<td>Sound On</td>
</tr>
<tr>
<td></td>
<td>Label Off</td>
</tr>
<tr>
<td></td>
<td>Sound Off</td>
</tr>
<tr>
<td>Color On</td>
<td>Filling effects</td>
</tr>
<tr>
<td></td>
<td>Two-tone, Light gray to red, Up vertically</td>
</tr>
<tr>
<td>Color Off</td>
<td>Filling effects</td>
</tr>
<tr>
<td></td>
<td>Two-tone, Blue to dark gray, Up vertically</td>
</tr>
<tr>
<td>Font</td>
<td>Arial</td>
</tr>
<tr>
<td>General layout</td>
<td>Font Color</td>
</tr>
</tbody>
</table>

Select the Formula processing block and connect it with the key. Connect this data cable with the slider controller signal. Open the dialog for the formula block and enter the settings from Table 2-6.

### Table 2-6. Configuring the Formula Block

<table>
<thead>
<tr>
<th>Block Dialog</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Block name</td>
<td>Sounds</td>
</tr>
<tr>
<td>Terminal name</td>
<td>On/Off</td>
</tr>
<tr>
<td></td>
<td>Switch</td>
</tr>
<tr>
<td>Slider1</td>
<td>Signal</td>
</tr>
<tr>
<td>Formula</td>
<td>Switch*(1000+Signal*10)</td>
</tr>
</tbody>
</table>
The switch returns 1 or 0 and forwards the signal.

Select the PC Loudspeaker simulation output block, change the block name to Speaker, and connect the input to the Sound formula block, as shown in Figure 2-18.

In DIAdem VISUAL, position the switch below the yellow message window, as shown in Figure 2-19. Start a measurement. As soon as you activate a switch, you can modify the sound from the loudspeakers by moving the slider control.

Figure 2-18. You Control the Loudspeaker Output by a Switch

Figure 2-19. The Slider Control Specifies the Frequency for the Sound Output
Note It is not always necessary to use formula blocks to realize a condition, and using formula blocks slows performance. Requests can often be defined more simply with fixed condition blocks. They also can be processed much faster during a measurement than with formula blocks.

Setting System Clock and Measurement Modes

You are now familiar with the green data cables and the red control cables. The yellow system cables define the system clock and the measurement mode.

The default clock defines the sampling rate for the entire block diagram. All the blocks with a clock connection on the top left have the specified clock, unless a system cable is connected. You can modify the sampling rate with Settings » Single point processing » Default clock. Figure 2-20 shows the dialog.

![Figure 2-20. Default Clock Single Point Processing](image)

The system block function bar in Figure 2-21 provides the system clock for the definition of various clock systems, two memory blocks, the trigger sequence, and storage in DIAdem variables.

![Figure 2-21. System Function Bar](image)

Note If no control cables are connected, the system blocks work from the beginning of the measurement. The memory block is supposed to function as a data sink and is therefore connected to the same system clock as the input blocks.

The default clock applies for the entire block diagram, whereas you can realize partial systems with the system clock by connecting function blocks in a block diagram to various sampling rates.
Divide the example block diagram into two partial systems with different sampling rates. Create two system clock blocks and enter the settings from Table 2-7 in the block dialogs.

### Table 2-7. Defining Two Clock Systems

<table>
<thead>
<tr>
<th>Clock system</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System clock 1</strong></td>
<td>Block name: 20 Hz</td>
</tr>
<tr>
<td></td>
<td>Sampling rate: 20</td>
</tr>
<tr>
<td><strong>System clock 2</strong></td>
<td>Block name: 200 Hz</td>
</tr>
<tr>
<td></td>
<td>Sampling rate: 200</td>
</tr>
</tbody>
</table>

Draw a yellow system cable from the output in the 20 Hz clock block to the Temperature, Slider1, and Storage1 blocks, as shown in Figure 2-22. Connect the second clock block 200 Hz to the On/Off, Sounds, and Speaker blocks.

If you now start a measurement, the two partial systems will have different clock rates. The acquisition and display will be performed at a tenth of the speed of the loudspeaker output. The 20 Hz clock system ends when the maximum number of values has been reached. The loudspeaker output remains active because it runs independently of the acquisition and storage for the 20 Hz partial system.

![Image of the block diagram](image-url)
Selecting the Measurement Mode

There are several measurement modes available in DIAdem. You can set them in the system clock block dialog boxes, as shown in the Figure 2-23. The measurement controlled by the DAC kernel supports all the DIAdem DAC functions. The driver-supported measurement modes High Speed, Disk, and DMA Measurement limit some features in favor of faster measurements.

Measuring in DAC Kernel Mode

DAC kernel measurement is available with software and hardware clocks. If the DAC kernel performs the clock control for a measurement, it is generally controlled by a software clock. All the functions in DIAdem DAC are supported to the full extent. You can only solve complex open and closed loop control tasks in this mode.

With a hardware clock, the DAC kernel and the measurement hardware control the clock rate together. The clocking is done on the hardware. Not all drivers support this measurement mode. Hardware clock measurements are faster than software clock measurements, because the measured values are transferred in blocks.

Measuring in Driver Controlled Modes

In High Speed, DMA, and Disk measurements, the DAC driver or hardware control the clock rate. Depending on which driver and hardware are used, the signals can be output with a time delay. The function groups system, hardware inputs and outputs, linear scaling, and window and slope conditions, are supported.
The measurement modes described above, along with their settings, also apply for single point processing. Packet processing is another alternative for fast measurements.

### Acquiring Real-Time Data

The essence of real-time systems is fast and guarantees reactions to events, which means the guarantee that the sampling and output rates that have been set will be adhered to. This guaranteed time behavior is more important than an optimal processor load, which is usually the most essential criterion for system performance with Windows PCs.

To react to external events such as keyboard entries, the PC has interrupt mechanisms so the event does not have to be requested continually. Keyboard entries generate interrupt requests to the processor, which then interrupts the current calculation to process the function requested by the event.

However, as the processor first has to save the current status of the program when an interrupt request comes in, a certain period of time elapses between the arrival of an interrupt and its actually being processed. This delay is called the response time. For periodical tasks such as measurement or open and closed loop control, there is a different response time for each sampling step, because it is defined by the current status of the processor when the interrupt occurs. For example, there are 100 different response time values for a 1 second measurement with 100 Hz. The difference between the minimum and maximum response times is called the jitter.
Therefore, the jitter indicates the degree of precision of the periodicity of the clock times.

The acceptable jitter size and response time depends on the particular task at hand. In visualization tasks, tests have shown that for humans, delays of up to 100 ms are still experienced as “immediate.” On the other hand, the periods between the output times have to be precise in digital closed loop control. If the controller output is to be made with 1 kHz and the periodicity error of the output time is less than 5%, the maximum valid jitter is 100 ms.

Windows is not a real-time operating system and does not enable the user to set specific reaction times for separate programs (real-time reactions).

For measurement tasks, these requirements can be met by using PC plug-in boards or external devices with their own timer components. The task is controlled by the measurement hardware, which ensures that the sampling rate is adhered to.

For open and closed loop control tasks, the acquired values have to be processed immediately, and after a specific response time, the calculated values have to be output to the process. We recommend the use of intelligent process connection hardware here. DIAdem can remove time-critical sections of control tasks to the PC plug-in board or to external systems with their own processors, so they can be processed independently of Windows.

**Using the Real Time Kernel in DIAdem**

The DIAdem real time kernel enables you to perform complex automation tasks using simple process connection hardware without its own processor and operating system. Sampling rate generation by DIAdem also has the advantage that several boards can be used simultaneously and synchronously. In the hardware-clocked solutions, this can only be achieved with a synchronization cable between the various hardware components.

The DIAdem real time kernel can operate in different modes. You open the dialog of Figure 2-24 with Settings»Single point processing»Measurement parameters»Timer.
Depending on your hardware, the **Soft Timing** setting achieves channel sampling rates of over 1 kHz. The DIAdem DAC real-time kernel runs as the Windows system driver with the highest possible priority and controls the timing with interrupts. Data acquisition, online processing, and signal output are all executed at the kernel level of the operating system.

The **Windows Timing** setting achieves channel sampling rates of up to 1 kHz. DIAdem DAC uses a Multimedia timer from the computer for the timing. The computer gives data acquisition, online processing, and signal output higher priority than normal Windows applications. Unlike **Soft Timing**, timing is executed at the application level with a lower priority than system drivers that are running at the same time at the kernel level of the operating system.

### Grouping Partial Tasks in Subblock Diagram

If a block diagram is very extensive and complex, you can group partial tasks into subblock diagrams. This makes the overall diagram more readable and also allows you to take sections of the block diagram and incorporate them into others.

The following features for processing subblock diagrams are included in the toolbar.

- Group sections of a block diagram into a subblock diagram
- Unpack subblock diagram
- Close the subblock diagram, <Ctrl-F4>  
- Block diagram information

A subblock diagram appears in the block diagram as a function block that you can open with a double click. The same features are available for subblock diagrams as for block diagrams. You can add, delete, or set parameters for function blocks, as well as draw, extend, and delete cables. The zoom functions also can be used.
The subblock diagram is enclosed in *terminal connectors*, which import and export the various signal cables. You can move and extend the terminal connectors. Moving them enlarges the working area and extending them makes room for more connections.

You can save a subblock diagram as .SUB file under **File»Save subblock diagram**. Partial solutions such as visualizations or control can thus be saved as subblock diagrams. You can import subblock diagrams with **File»Load subblock diagram**. Subblock diagrams may contain subblock diagrams, providing several definition levels in one block diagram.

In the example, the two subsystems, each with a different sampling rate, are to be grouped into subblock diagrams. Mark the top partial system, which has a sampling rate of 20 Hz, and group it into a subblock diagram. Then group the lower partial system, with a sampling rate of 200 Hz, into a second subblock diagram. The original block diagram, consisting of 13 blocks, has now been reduced to two subblock diagrams.
Open the two subblock diagrams one by one and enter the settings from the Table 2-9 in the block diagram information.

**Table 2-9. Editing the Information of Two Subblock Diagrams**

<table>
<thead>
<tr>
<th>Subblock Diagram</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan1</td>
<td>Name: Sub_20Hz</td>
</tr>
<tr>
<td></td>
<td>Comment: Temperature-partial system clock with 20 Hz</td>
</tr>
<tr>
<td>Plan2</td>
<td>Name: Sub_200Hz</td>
</tr>
<tr>
<td></td>
<td>Comment: Sound-partial system clocked with 200 Hz</td>
</tr>
</tbody>
</table>

Define a second data output in the subblock diagram Sub_20Hz. Open this subblock diagram and then double-click on the Data export dialog. Set up an additional signal output with New Entry, as shown in Figure 2-26.

![Data export dialog](image)

**Figure 2-26. You Can Add Connections in Subblock Diagrams**

Connect the cable with nine signals at this output. Lead a yellow system cable to the exterior of the partial system 20 Hz.
Packet Processing for Fast Measurements and Online Processing

There are two data processing concepts in DIAdem DAC—single point processing and packet processing.

In *single point processing*, the data is acquired value by value. At every point in the block diagram, each value can be accessed, processed, and visualized. This allows you to combine all kinds of sampling rates easily and provides a great degree of flexibility for control tasks.

*Packet processing* groups values into data packets, which are forwarded to the next function block when they have attained the specified size. This is the concept of packet-oriented processing—functions only work with data packets. It decreases the amount of administration required and increases the throughput.

You can combine packet processing and single point processing in one block diagram. Decide which type of processing you use depending on your measurement task. Single point processing provides real-time features and a great degree of flexibility, and packet processing provides features for online calculation, fast data acquisition, and intelligent hardware.

There are four function bars for packet processing. The *Handling (Packet processing)* function bar in Figure 2-27 provides features for data handling, such as packing and unpacking, a multiplexer, and various types of scaling. You can use *complete selection* to include packet functions that are not included in any of the function bars in your block diagram.

![Figure 2-27. Handling Packet processing Function Bar](image)

The *Maths (Packet processing)* function bar in Figure 2-28 contains mathematical functions for online evaluations like FFT, statistics, or classification.

![Figure 2-28. Maths Packet Processing Function Bar](image)
The Display and I/O (Packet processing) function bar in Figure 2-29 provides input and display instruments such as the oscilloscope and the voltmeter. As opposed to the instruments in single point processing, they appear as separate windows.

![Figure 2-29. Display and I/O Packet processing Function Bar](image)

The Driver (Packet processing) function bar in Figure 2-30 provides packet hardware features that you configured when you registered the hardware. Apart from intelligent hardware functions, you also can assign frequently required processing functions to the function bar in this way. Refer to Chapter 4, Using Hardware, for specific information.

![Figure 2-30. Driver Packet processing Function Bar](image)

The black and green data cables transport measured value packets. Packet processing is clocked independently of single point processing. Set the packet default clock with Settings»Packet processing»Default clock.

![Figure 2-31. Packet Processing Default Clock](image)

The packet call clock in Figure 2-31 specifies the rate for calling the packet blocks. For each call, the program checks whether there is a data packet at the input. The block size specifies how many values are to be collected for each signal before the data packet is forwarded to other packet blocks.

Extend the example to include packet functions. Place a Pack block in the block diagram and connect it to the data output on the Sub_20Hz subblock diagram. The Pack block groups the single point signals into a data packet.

![Packing signals](image)
For online classification, select a Classification mathematics block and connect it to the Pack block.

To display the classification results, select an Oscilloscope display block and connect it to the classification block. Enter the settings from Table 2-10 in the oscilloscope window menus.

<table>
<thead>
<tr>
<th>Dialog Menu</th>
<th>Normal Display</th>
<th>Settings</th>
<th>Bars</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settings</strong></td>
<td>X-axis-scale</td>
<td>Range</td>
<td>Setting</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>0 to 20</td>
</tr>
<tr>
<td></td>
<td>Title</td>
<td>Text</td>
<td>Online classification</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td>Display Options</td>
<td>Activate title</td>
<td></td>
</tr>
</tbody>
</table>

Connect the clock output in the subblock diagram Sub_20Hz to the clock input of the Pack block. When you start the measurement, the oscilloscope window will appear in addition to the usual DIAdem VISUAL display, as shown in Figure 2-32. You can move the window during the measurement.

Figure 2-32. The Oscilloscope Shows the Classification as Histogram
Using the Alarm and Protocol System

With the alarm and log system you can monitor signals for exceeding limit values. Limit values can be defined in two levels to trigger alarms with differing levels. The alarms are displayed continuously on the screen and can also be recorded and commented online. The alarm log can function as an operation report that is sent to responsible parties informing them about alarms that occur.

The alarm and protocol system uses special cables to transport alarms and protocols—alarms are transported on the blue-black alarm cables and protocols on the gray-black text cables. Signals on the green-black packet cables are monitored.

Defining Alarms

The alarm and protocol system also allows you to confirm the exceeding of limit values. Alarms can only be confirmed by authorized users that have been granted the appropriate rights by the administrator in the DIAdem user management.

In the alarm definition, there is a distinction between static attributes, which the user specifies offline when the alarm system is configured, and dynamic attributes, which are defined during runtime. Global attributes are managed above the block level, as shown in Figure 2-33.
The function bar for the alarm and protocol system includes the following function blocks.

Alarm generator defines alarms for each input signal

Alarm table displays current alarms and alarm confirmation

Format for the protocolled alarms

Key entry for comments

Display all alarms during monitoring, with review

Save protocol in file ( .TXT, .HTM)

Transfer protocol through DDE or email (MS Outlook as OLE application)

Protocol transfer in a network

Multiplexer for alarms and texts

Log in for activated user management

Extend the example to include alarm functions. Select the Alarm generator and connect the green-black packet cable to the E input on the alarm generator. Enter the settings from Table 2-11 in the alarm generator dialog. The attributes for the marked row are edited beneath the alarm table.

<table>
<thead>
<tr>
<th>Dialog Menu</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>New entry</td>
<td></td>
</tr>
<tr>
<td>Channel number</td>
<td>1</td>
</tr>
<tr>
<td>HIHI alarm</td>
<td>5</td>
</tr>
<tr>
<td>LOLO alarm</td>
<td>-5</td>
</tr>
<tr>
<td>Channel name</td>
<td>Slider1</td>
</tr>
</tbody>
</table>
Adjust the block size of the data packets to be monitored to the acquisition rate. For the alarm generator to monitor one data packet per second, reduce the packet size in the Pack block to 20.

**Note** If the packet size is much larger than the acquisition rate in Hertz, the alarm generator will have a considerable wait for the data packet to be monitored. If, on the other hand, the packet size is much smaller than the acquisition rate, the alarm generator will have to monitor many small data packets.

Select an **alarm table** and connect **Input E to Output A** on the alarm generator. Enter the settings from Table 2-12 in the alarm table dialog.

<table>
<thead>
<tr>
<th>Dialog Menu</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column 2</td>
<td>Channel name</td>
</tr>
<tr>
<td>Line related background color</td>
<td>Priority</td>
</tr>
</tbody>
</table>

Select an **Alarms→Texts** converter block and connect it to the alarm table.

The alarms are to be recorded in two ways—displayed on the screen and stored in files.

Add a text display and a log file and connect them both to the Converter block. The gray color of the connecting cables indicates that the text level of the protocols is in use. Open the log file and enter `manual.txt` as the file name.

In DIAdem VISUAL, position the alarm table, the text display, and the oscilloscope one below the other on the right of the display, as shown in Figure 2-34. During the measurement you can click on the heading of the alarm table to select the attribute for sorting the alarms. If this attribute is the same for several alarms, they will be sorted in accordance with the time stamp.
Setting Up the User Management

To prevent all users from being able to confirm and perhaps oversee alarms, the administrator sets up user accounts with various rights in the user management. These user accounts are saved in the .ADM file and coded. The access rights are stored with the block diagram. When the measurement starts, DIAdem checks whether the user that is logged in has the rights required to execute the block diagram.

Only the DIAdem administrator has the rights for opening the user management by selecting Settings»User management. Table 2-13 lists the standard settings for logging. DIAdem makes no distinction between upper and lower-case letters.

<table>
<thead>
<tr>
<th>Questions</th>
<th>Entries</th>
</tr>
</thead>
<tbody>
<tr>
<td>User name</td>
<td>administrator</td>
</tr>
<tr>
<td>Password</td>
<td>diadem</td>
</tr>
</tbody>
</table>
Figure 2-35 shows the user management dialog.

Every time an .ADM file is saved, it is entered with its path in the Windows registry. In a network, several users can access the same administration file.

For the example, set up the Manual reader user account with New user, as shown in Table 2-14.

<table>
<thead>
<tr>
<th>Dialog Parameters</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login name</td>
<td>Manual</td>
</tr>
<tr>
<td>Full name</td>
<td>Manual reader</td>
</tr>
<tr>
<td>Password</td>
<td>diadem</td>
</tr>
<tr>
<td>Access rights</td>
<td>Alarm quit level operator 2</td>
</tr>
</tbody>
</table>
Grant the Administrator configuration rights. For the user management to be used, make the settings from Table 2-15 in the blocks mentioned.

**Table 2-15. Configuring Alarm Blocks**

<table>
<thead>
<tr>
<th>Alarm Block</th>
<th>Dialog Menu</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm generator</td>
<td>Global parameters</td>
<td>User management protect configuration and confirmation</td>
</tr>
<tr>
<td>Alarm 6 Slider 1</td>
<td>Quitlevel</td>
<td>Operator 2</td>
</tr>
<tr>
<td>Alarm 7 Slider 1</td>
<td>Quitlevel</td>
<td>Operator 2</td>
</tr>
<tr>
<td>Alarm table</td>
<td>Display</td>
<td>Display button for confirming alarms</td>
</tr>
<tr>
<td>Filter criteria</td>
<td>Alarm status</td>
<td>Existing and not confirmed</td>
</tr>
</tbody>
</table>

Connect input T in the alarm generator to output A in the alarm table. Before starting a measurement, log in as Manual under Settings>User log in/log out.

During the measurement, the alarms are displayed in the alarm table as they occur. As the Manual reader user, you can use the switch in the alarm table to confirm slider alarms after selecting the alarm in the table.
Visualizing and Operating

In DIAdem VISUAL, you load and run a block diagram that you have created in DIAdem DAC. In DIAdem DAC, you have defined the measurement, the control, the monitoring, and the controls and indicators. The visualization takes place in DIAdem VISUAL.

The controls and indicators you have chosen in DIAdem DAC are placed into the DIAdem VISUAL workspace and adjusted in size. The grid and other alignment features in the toolbar help you to align the instruments.
Opening a Block Diagram, Starting a Measurement

In DIAdem DAC, you choose and wire visualization blocks like all other function blocks. In DIAdem VISUAL, you design the instruments that are displayed during a measurement. All instruments in the workspace are stored in the block diagram.

This exercise assumes that the actual measurement task has been prepared and tested in DIAdem DAC. Opening DIAdem VISUAL loads the block diagram, example.dac, by default. You can modify the default settings in Settings » Options » VISUAL.

There are three icons for performing a measurement in the toolbar. The blue triangle starts a display only, the green dot starts a measurement with data storage, and the red square stops a display or a measurement.

⚠️ Caution  You can connect and disconnect signals only in DIAdem DAC. Do not modify the number of terminals in List length in DIAdem VISUAL. If you reduce the number of terminals, the terminals are disconnected. You can increase the number of terminals, but to rewire the terminals you have to change to the block diagram in DIAdem DAC.

Designing the Visualization

The design of the visualization is closely related to the set-up of the block diagram. You have to decide which signals to show with which instrument, and which time frame and events are to be used. If the instruments are to be visible at the same time, position them next to each other. If they are to replace each other so the occurrence of an event can be illustrated, place them on top of each other.

Positioning Instruments

Open the block diagram, visual1.dac. The necessary instruments have already been selected and wired to indicators. The instruments are placed in the workspace randomly. Delete the graphic that contains the text. Position the individual instruments as displayed in Figure 3-2 and adjust their size as needed. Do not bother with the design of the individual instruments yet.
As with axis systems in DIAdem REPORT, you can change the size and the position of instruments interactively. By default, you maintain the original ratio when resizing an instrument. By pressing the <Shift> key, you can resize an instrument without maintaining the ratio. By pressing the <Ctrl> key, you change the size of an instrument concentrically.

You can select multiple objects by pressing the <Ctrl> key. If you cannot select an instrument due to overlapping, you can select them individually using the <Tab> key until the desired instrument is visible.

Also, you can use the Sketch mode from the toolbar, shown in Figure 3-3, to display objects that are hidden behind the selected instrument. The Grid helps you by placing instruments more precisely on the workspace. Use the various alignment functions to align the instruments and to adjust their size.
Setting Instruments

Fine tuning refers to the layout and design of the instruments. Change the properties of an instrument on your workspace in **General layout** and **Display** of the instruments shortcut menu. Enter the following settings from Table 3-1.

### Table 3-1. Configuring Different Instruments

<table>
<thead>
<tr>
<th>Instrument</th>
<th>General Layout</th>
<th>Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric1</td>
<td>Display legend: bottom</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Frame filling: Fill effects; gray; horizontal from inside</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Display background: dark gray</td>
<td></td>
</tr>
<tr>
<td>Dial</td>
<td>Show block name</td>
<td>Dial color: yellow</td>
</tr>
<tr>
<td></td>
<td>Frame filling: Fill effects; gray; horizontal from top</td>
<td></td>
</tr>
<tr>
<td>Bars1</td>
<td>Frame filling: Fill effects; gray; horizontal from inside</td>
<td></td>
</tr>
</tbody>
</table>
| Graphics1    | Frame filling: Fill effects; dark gray; horizontal from top | Y-scaling: n systems [phys.]
|              |                        | Limit values: Display warning range and Display alarm range |
| Chart Recorder1 | Frame filling: Fill effects; gray; horizontal from inside |                                |
|              | Display background: dark gray |                                |

You can interact with a visualization by using the rotary switch, as shown in Figure 3-1. Color changes in the curve display exceeding or falling short of limit values.
Grouping Instruments

Selecting overlapping instruments is rather difficult. To avoid this, instruments can be grouped into VISUAL pages.

Load the block diagram dac7.dac. This block diagram contains overlapping instruments and two subblock diagrams. Click the View menu. You will find 10 VISUAL pages, of which the first three are assigned. **1st page:** Standard contains all instruments of a block diagram. For the two subblock diagrams, DIAdem automatically creates the VISUAL pages, **Sub_20Hz** and **Sub_200Hz**.

Uncheck **3rd page:** Sub_200Hz. None of the instruments from this subblock diagram are displayed anymore. The push button for sound is no longer visible.

You can create more VISUAL pages in View»Page management. To allocate an instrument to a page, choose the page from the Page menu in General layout.

Striking Visualization

This section briefly describes some of the tools for visualization.

Within the group Binary instruments, the Status instruments provide an important means of indicating certain conditions. In the simplest case, a binary instrument could be a lamp that changes its color depending on a given condition. When a particular status has been reached, a sound file also can be played as an acoustic warning signal.

A color matrix can be used to display the temperature distribution on a workpiece if the sensors/measurement points are arranged in a regular, rectangular grid network. The color palette defined for the range of values differentiates the size of the measured data in corresponding colors.

Containers display the filling level in the form of a bar. You can change the look of a container by choosing a different container graphic in the display menu. The clipart directory on the DIAdem CD contains various default container graphics. The containers can be used with the tubes and valves also available on the CD, along with the status display and any alarm displays for process visualization.
By default, the area that represents the filling level in containers is purple (RGB values: 255,0,255). DIAdem VISUAL displays this area as transparent. You can change the settings so that a different color represents transparency.

In the **Cylinder tachometer**, the scale moves instead of the pointer. The 3D effect can be highlighted by using shading for the background of the display in **General layout**.

You can load background graphics in General layout as well as in Display. In General layout, a background graphic is used for filling. In Display, it is used for the object on top, for example, a status instrument or a container.

**Tip** Starting a measurement, DIAdem VISUAL displays all control elements; for example, elements like toolbar and function bar. Press <Ctrl-U> to view only the workspace. Press <Ctrl-F5> to start the measurement and press <Esc> to stop the measurement. Press <Ctrl-U> again to change the screen mode to normal view pressing. You can write a script in DIAdem SCRIPT to automate the process.
Using Hardware

The block diagrams that you have generated consist of simulated signals. These block diagrams are hardware-independent and can be prepared and tested on any PC.

You can use hardware in a variety of ways in DIAdem DAC. The direct way is to register a DIAdem driver for the hardware. The indirect way is to use a DIAdem interface, such as the serial interface, or to register an OPC server.

Registering and Configuring Drivers

The function bars for inputs and outputs are not assigned. Measurement hardware is registered in the same way for single point processing and packet processing:

1. Installing hardware drivers
2. Registering DIAdem drivers
3. Configuring function bars for inputs and outputs

The hardware registration is saved automatically, with all the settings, in a parameter file that has the extension .par and has the same name as the desktop file.

Installing Hardware Drivers

Hardware manufacturers provide driver libraries with their hardware. These additional files are to be installed and configured before DIAdem is started. Refer to the manufacturer's instructions.

Assigning DIAdem Drivers

The DIAdem driver links the hardware driver to DIAdem DAC. DIAdem drivers include standard drivers, which are supplied with standard DIAdem and additional drivers from the hardware manufacturer.
Select the DIAdem driver with Settings ➤ Single point processing ➤ Configure driver ➤ New Entry.

### Assigning and Configuring Inputs/Outputs

DIAdem DAC has separate function bars for the DIAdem drivers used for single point processing, and for those used for packet processing. Use the Settings menu to select the DIAdem drivers for the function bars and to configure the available functions.

### Configuring Single Point Processing Drivers

When the driver is registered, you can assign its functions to the function bar and set the parameters. Do this with Settings ➤ Single point processing ➤ Configure driver ➤ New Entry.

Double-click on the registered device to open the list of supported inputs and outputs. You can alter the settings for each driver and all inputs and outputs. Specific device parameters, such as base address or input voltage range, have to be defined for some drivers.
Caution You must ensure that the settings in the device definition correspond to those for the measurement hardware, especially if jumpers have to be set on the measurement hardware. The specified addresses, interrupts, and DMA channels must be free.

The function bars for the inputs and outputs can each be assigned 15 function blocks. There are six icons for additional processing functions. If you have registered more function blocks with your DIAdem drivers, the function blocks at the bottom of the configuration list are not visible on the function bar. To avoid this, you can delete entries from the configuration list before you add new function blocks.

Configuring Packet Drivers

A separate function bar exists for packet processing in DIAdem DAC, and you can assign drivers to it. Apart from measurement hardware, you also can register calculation functions that are frequently used in packet processing: Settings»Packet processing»Configure driver»New entry.

![Figure 4-3. Configuration Dialog for the Input and Output Bar of the Packet Processing](image)

Apart from input and output functions, hardware manufacturers often provide special processing functions for packet processing. Intelligent hardware with its own processor and memory can work independently from the PC and take over special tasks without affecting the PC CPU.

Using, Interchanging, and Setting Parameters for Hardware Blocks

If you have configured the function bars for inputs, outputs, processing, and packet drivers, you can insert the blocks directly into a block diagram. Please notice the following:

- You can configure the blocks in the function bars with the presettings. The settings only apply to blocks subsequently included in the block diagram.
Chapter 4 Using Hardware

• As soon as a hardware block is used in a block diagram, all the related settings are saved with the block diagram and can only be altered there.
• If you delete a block from the configuration list, these blocks are not affected in any block diagrams.
• If you want to use other hardware, proceed as follows: reassign the function bars for inputs, outputs, and packet drivers. Then, choose the necessary hardware blocks and place them on top of the blocks that are already wired. This enables you to replace simulation blocks with hardware blocks.
• The list length in the function block may not exceed the number of terminals available on the hardware. The first terminal is generally number 1 (PIN 1).

Communicating through Interfaces

There are special function blocks for connecting devices on the function bars to inputs and outputs—communication through the DDE and OPC interface, the control file driver, and the Script DAC Driver.

![Interfaces](image1)

Figure 4-4. Interfaces

Using Online DDE

You can use the DDE interface to exchange data online with other programs running parallel with Windows. In the DDE block, you set the parameters for the DDE channel address.

![Addressing the DDE Channel in the DDE Input Block Dialog](image2)

Figure 4-5. Addressing the DDE Channel in the DDE Input Block Dialog
An address consists of three components:

- **Application**—Name of the DDE server or of the program that can be executed. With the entry `GfSoDDE`, you set up DIAdem DAC as an Online DDE Server.

- **Topic**—Data area the client accesses. With `GfSoDDE` the user can enter any topic.

- **Item**—Data element defined in the server.

### Using OLE for Process Control

OLE for Process Control (OPC) enables you to transfer data between hardware and software components in a PC or a network. With DIAdem as an OPC client, you can link your PC to field bus systems and other hardware if OPC servers are available as external drivers. DIAdem DAC can provide multiple access to an OPC server and access several OPC servers simultaneously.

Register the OPC server in the OPC function block. You can link DIAdem DAC to another PC or select a local OPC server.

![Figure 4-6. Registering OPC Servers](image)

When the OPC server is registered, you can select your measurement points or items in the OPC Browser. Drag and drop them into the signal list. You can configure the communication on the index cards **Parameter** and **OLE**.

### Data Exchange in the Internet/Intranet through TCP/IP

TCP/IP (Transmission Control Protocol/Internet Protocol) is the protocol that the Internet and Intranets are based on. The server may be a DIAdem data acquisition that provides its data to another DIAdem client application for visualization and archiving. Applications have been used in decentralized data acquisition, machine monitoring, process visualization, and the acquisition of environmental data.
In DIAdem DAC, the server and client blocks for transferring data packets using the TCP/IP protocol are located in the function bars of the alarm and protocol system and in packet processing. Data only can be exchanged between DIAdem applications.

In the client block, enter the computer or IP address for the TCP/IP server with which data is to be exchanged. Use the port number to set up several connections between the same PCs.

**Using Control File Driver**

The control file driver enables you to use DIAdem to access external measurement devices using the RS-232 interface or GPIB (General Purpose Interface Bus). The core of this communication is a simply structured text file in which a communication protocol for device linking is defined. Use the Example.ATR control file as an example.

A control file consists of three sections—the measurement preparations, the actual measurement, and the concluding tasks. The *Init procedure* prepares the communication and the *DeInit procedure* reverts it to the original status. The *Start procedure* initiates the measurement and the *Stop procedure* ends it. During the measurement, the *Input procedure*, for data input, and the *Output procedure*, for data output, are called cyclically in the specified measurement clock.
Using Script DAC Driver

To communicate with external measurement devices, the Script DAC Driver uses Visual Basic Script (VBS) for the acquisition, conditioning, processing, and output of data. With VBS, you can meet demanding requirements, for example, check sum calculations, which cannot be performed with the control file driver. You can design the scripts so flexibly that they can be used for various tasks without being modified.

Data is exchanged with the PC interfaces RS-232, GPIB, and TCP/IP through the interface-independent driver GFSUDI, which allows you to change interfaces later without reprogramming. Using VBS, other program modules such as ActiveX components can also be accessed.
In the Script DAC Driver block you define inputs and outputs.

Click **Script template** for an example of your script file, which provides you with a core definition with all the functions defined for the Script DAC Driver. You can extend the functions you need for your task and delete the unnecessary parts.
Testing Communication with the Interface Monitor

With the interface monitor in the toolbar, you can hold an interactive dialog with external devices using the serial interfaces COM1 to COM9 and using GPIB (DIN IEC 625 and IEEE 488). You can send character strings to a device and read the responses on the screen.

The interface monitor is useful for testing and commissioning programmable measurement devices and for programming control files. You will find all the control characters the device sends in the hexadecimal display mode.

For example, select Settings » Single point processing » Interfaces » CAN bus to configure the CAN interface. This requires the CAN driver to be registered under Settings » Single point processing » Configure driver » New Entry.
Visit the following sections of the National Instruments Web site at ni.com for technical support and professional services:

- **Support**—Online technical support resources at ni.com/support include the following:
  - **Self-Help Resources**—For answers and solutions, visit the award-winning National Instruments Web site for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on.
  - **Free Technical Support**—All registered users receive free Basic Service, which includes access to hundreds of Application Engineers worldwide in the NI Developer Exchange at ni.com/exchange. National Instruments Application Engineers make sure every question receives an answer.

For information about other technical support options in your area, visit ni.com/services or contact your local office at ni.com/contact.

- **Training and Certification**—Visit ni.com/training for self-paced training, eLearning virtual classrooms, interactive CDs, and Certification program information. You also can register for instructor-led, hands-on courses at locations around the world.

- **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact your local office or NI corporate headquarters. Phone numbers for our worldwide offices are listed at the front of this manual. You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.
Index

A
Alarm and Protocol System
  Defining alarms, 2-29
  User management, 2-32
Alignment functions, 3-3

B
Block diagram, 2-1
  Adding measurement hardware, 4-3
  Block parameterization, 2-5
  Editor, 2-5
  Measurement hardware, 4-1
  Saving as DAC file, 2-3
  Setting, 2-2
  Subblock diagram, 3-5
  Visualization, 2-6, 3-2

C
Cable connection
  Alarm cable, 2-29
  Branch, 2-4
  Bus system, 2-4
  Control cable, 2-14
  Deleting, 2-4
  Input point, 2-4
  Interrupt, 2-5
  Mouse cursor, 2-4
  Signal list, 2-4
  Subblock diagram, 2-24
  System cable, 2-18
  Text cable, 2-29
  Types, 2-3
  Classification, 2-28
  Conditions, 2-11, 2-18

Control, 2-18
  Button, 2-16
  Signals, 2-11
Control file driver, 4-6
conventions used in the manual, vii

D
DAC file, 2-3
DAC kernel measurement, 2-20
Data acquisition
  Alarm and Protocol system, 2-29
  Control, 2-1
  Measurement mode, 2-20
  Packet processing, 2-26
  Real-time system, 2-21
  Sampling rate, 2-18
  Saving data, 2-9
  Single point processing, 2-26
  Visualization, 3-1
  Without display, 2-5
DDE interface, 4-4
Default clock
  Packet processing, 2-27
  Single point processing, 2-18
DIAdem DAC
  Instruments legend, 2-9
  Interface monitor, 4-9
  Toolbar, 2-2
  User management, 2-32
DIAdem real time kernel, 2-22
DIAdem VISUAL
  Full screen mode, 3-6
  Toolbar, 3-3
diagnostic tools (NI resources), A-1
Disk measurement, 2-20
<table>
<thead>
<tr>
<th>Display, 2-5</th>
<th>Interfaces, 4-4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm protocols, 2-31</td>
<td>Loudspeaker, 2-17</td>
</tr>
<tr>
<td>Color matrix, 3-5</td>
<td>Message, 2-13</td>
</tr>
<tr>
<td>Containers, 3-5</td>
<td>OPC, 4-5</td>
</tr>
<tr>
<td>Cylinder tachometer, 3-6</td>
<td>Packet processing, 2-26</td>
</tr>
<tr>
<td>DIAdem VISUAL, 3-1</td>
<td>Processing, 2-15</td>
</tr>
<tr>
<td>Function blocks, 3-2</td>
<td>Saving data, 2-9</td>
</tr>
<tr>
<td>Instruments, 3-2</td>
<td>Scaling, 2-15</td>
</tr>
<tr>
<td>Message, 2-13</td>
<td>Setting a block diagram, 2-2</td>
</tr>
<tr>
<td>Packet processing, 2-27</td>
<td>Simulation input, 2-5</td>
</tr>
<tr>
<td>Screen mode, 3-6</td>
<td>Simulation output, 2-15</td>
</tr>
<tr>
<td>Status instruments, 3-5</td>
<td>Slider, 2-11</td>
</tr>
<tr>
<td>DMA measurement, 2-20</td>
<td>Subblock diagram, 2-23</td>
</tr>
<tr>
<td>documentation</td>
<td>System, 2-18</td>
</tr>
<tr>
<td>conventions used in manual, vii</td>
<td>TCP/IP, 4-5</td>
</tr>
<tr>
<td>NI resources, A-1</td>
<td></td>
</tr>
<tr>
<td>related documentation, viii</td>
<td></td>
</tr>
<tr>
<td>Driver controlled measurement, 2-20</td>
<td></td>
</tr>
<tr>
<td>drivers (NI resources), A-1</td>
<td></td>
</tr>
</tbody>
</table>

E

elements (NI resources), A-1

F

Formula, 2-15, 2-18

Full-screen mode, 3-6

Function blocks, 2-1

Alarm and protocol system, 2-30

Cable connection, 2-3

Combining single point and packet blocks, 2-27

Connect/disconnect signals, 2-7

Control, 2-11

DDE, 4-4

Deactivating signals, 2-7

Display, 2-5, 3-2

Graphic, 2-7

Input/Output connections, 2-3

Interchange, 4-3

G

GPIB, 4-6

H

Hardware

Defining, 4-1

DIAdem driver, 4-1

GPI DLL registry, 4-1

Manufacturer driver, 4-1

Packet processing, 4-3

Single point processing, 4-2

help, technical support, A-1

High Speed measurement, 2-20

I

Illustration, 2-7

Instrument drivers (NI resources), A-1

Instruments

Background graphics, 3-6

Color matrix, 3-5

Container, 3-5

Cylinder tachometer, 3-6
Index

General layout and display, 3-4
Settings, 3-2
Status, 3-5

Interfaces
Control file driver, 4-6
DDE, 4-4
GPIB, 4-6
Interface monitor, 4-9
OPC, 4-5
Script DAC Driver, 4-7
TCP/IP, 4-5

K
KnowledgeBase, A-1

L
Legend, 2-9
Limits monitoring, 2-11
Loudspeaker, 2-17

M
Measurement mode
DAC kernel, 2-20
Driver controlled, 2-20
Measurement task, 2-3
Message display, 2-13

N
National Instruments support and services, A-1

O
Online DDE, 4-4
Online mathematics, 2-28
OPC interface, 4-5
Oscilloscope, 2-27

P
Packet processing, 2-26
Default clock, 2-27
Display, 2-27
Hardware, 4-3
Partial systems, 2-18, 2-23
Processing, 2-15
Processing formulas, 2-15
programming examples (NI resources), A-1

R
Reading data files, 2-5
Real-time system, 2-21
DIAdem real time kernel, 2-22
Jitter, 2-21
related documentation, viii
RS-232, 4-6

S
Sampling rate, 2-18
Packet processing, 2-27
Saving data, 2-9, 2-10
Scaling
Multi-point, 2-15
Pt100 linearization, 2-15
Thermolinearization, 2-15
Screen mode, 3-6
Script DAC Driver, 2-15, 4-7
Settings
Block diagram editor, 2-5
Measurement kernel, 2-5
Signals
Connect/disconnect, 2-7
Control, 2-11
Enable/Disable, 2-7
Hardware, 2-5
List, 2-4, 2-7
Measurement hardware input, 4-1
Index

Simulated, 2-5
Simulation, 2-5
Simulation output, 2-15
Single point processing, 2-26
  Default clock, 2-18
  Hardware, 4-2
Slider, 2-11
software (NI resources), A-1
Subblock diagram, 2-23, 3-5
support
  technical, A-1
System blocks, 2-18
System clock
  Partial systems, 2-18
  Selecting measurement mode, 2-20

T
TCP/IP interface, 4-5
  technical support, A-1
Timing
  Soft Timing, 2-23
  Windows Timing, 2-23
Timing, DIAdem real time kernel, 2-22
Toolbar
  DIAdem DAC, 2-2
  DIAdem VISUAL, 3-3
training and certification (NI resources), A-1
troubleshooting (NI resources), A-1

U
User management, 2-32

V
Visualization, 2-5, 3-1
  Block diagram, 2-6
Voltmeter, 2-27

W
Web resources, A-1