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Introduction
The LabVIEW DSP Module 2.0 uses a project framework to help you 
manage and implement the components of a DSP application. Specifically, 
you must use a project to define a DSP target for which you can build and 
run a DSP application. 

The two examples in this manual assume you are familiar with basic 
LabVIEW concepts. Refer to the Getting Started with LabVIEW manual, 
available by selecting Start»All Programs»National Instruments»
LabVIEW»LabVIEW Manuals and opening 
LV_Getting_Started.pdf for exercises that teach you basic 
LabVIEW concepts.

™
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Example 1—Getting Started with DSP VIs and Projects
This example uses the Heterodyne project, located in the labview\
examples\EmbeddedDSP directory, and an NI SPEEDY-33 board. The 
VI in this project shows double-sideband modulation, also called signal 
heterodyining or signal mixing.

Note You also can use a Texas Instruments 6711 DSK, a Spectrum Digital 6713 DSK, 
or a Spectrum Digital 6416 DSK target with this example.

Launching LabVIEW and Opening a Project
You use a project to group together LabVIEW and non-LabVIEW files, 
to specify the hardware resources available on the DSP target, and to 
download a DSP application to a DSP target. When you save a project, 
LabVIEW creates a project file (.lvproj) that includes the target 
configuration, a link to the DSP VI, and a list of any subVIs. 

Note Saving the project file does not save the DSP VI. You must save the DSP VI 
separately or select File»Save All in the Project Explorer window to save the project and 
any open VIs.

Complete the following steps to launch LabVIEW and open the LabVIEW 
project, Heterodyne.lvproj. 

1. Launch LabVIEW.

2. In the Getting Started window, shown in Figure 1, select File»Open 
Project to open the Select the Project to Open dialog box.

Tip You also can click Open in the Files section of the Getting Started window to open 
a project or VI.
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Figure 1.  Getting Started Window

3. Navigate to the labview\examples\EmbeddedDSP directory and 
open Heterodyne.lvproj.

Note The same LabVIEW project file can contain information about more than one target. 
Notice that the Heterodyne project contains target information for five targets: My 
Computer, DSK6416, DSK6711, DSK6713, and SPEEDY-33. 
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4. Expand the target you are using in the Project Explorer window to see 
the items and VIs the project associates with that target, as shown in 
Figure 2.

Figure 2.  Targeting the SPEEDY-33 with the Heterodyne VI

The following items appear under each DSP target in this example: 
Analog Output, Heterodyne.vi, Dependencies, and Build 
Specifications.

The Analog Output folder contains the analog output resources 
available on the specific DSP target. Refer to the Adding Elemental I/O 
Nodes to the Block Diagram section of this manual for more 
information about adding input and output (I/O) resources for a DSP 
target. The Heterodyne VI, which contains the graphical code for the 
DSP application, only uses one analog output resource. 

The Dependencies item automatically lists any subVIs necessary for 
the DSP application to build and run properly on the DSP target. The 
Build Specifications item contains options for downloading to the 
flash memory on the DSP target and distributing the DSP application. 
Refer to the Using LabVIEW Projects topic in the LabVIEW Help, 
available by selecting Help»Search the LabVIEW Help, for more 
information about dependencies and build specifications.

Tip When searching for a specific topic in the LabVIEW Help from the Search tab, place 
a checkmark in the Search titles only checkbox and enter the topic title in the Type in the 
word(s) to search for textbox. This limits the number of topics that the LabVIEW Help 
finds so you can locate the topic more quickly.
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Opening a VI for a DSP Target 
You must open a DSP VI within a project to use the hardware resources 
available on the DSP target and to build and download the DSP application 
to the target.

Complete the following steps to open the Heterodyne VI in a DSP target 
application instance.

Tip Refer to the Working with Application Instances topic in the LabVIEW Help for more 
information about working with different targets.

1. Double-click Heterodyne.vi under the DSP target you are using in the 
Project Explorer window to open the front panel of the VI, shown in 
Figure 3. You create user interfaces for DSP VIs in the same way you 
create user interfaces in LabVIEW for Windows.

Figure 3.  Looking at the Heterodyne VI Front Panel

The waveform graph on the front panel displays the heterodyned 
signal. You can use the slider controls on the front panel to modify the 
carrier frequency and baseband frequency of the signal.

2. Select Window»Show Block Diagram and look at the VIs that the 
Heterodyne VI uses.

Tip Press the <Ctrl-E> keys to switch from the front panel to the block diagram or from 
the block diagram to the front panel.
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Figure 4 shows the block diagram of the Heterodyne VI. The following 
VIs are used in the Heterodyne VI:

• Simulate Signal Express VI—Generates sine waves. One instance 
generates the carrier frequency, and one instance generates the 
baseband frequency. The two sine waves are multiplied together, 
which results in a mixed signal. The product of these two signals 
is the input to the analog output Elemental I/O Node.

• Spectral Measurements Express VI—Computes the FFT with 
linear magnitude processing and displays the signal on a 
waveform graph on the front panel.

• Analog Output Elemental I/O Node—Writes data to the 
Digital-to-Analog (D/A) converter, also known as a CODEC 
(coder-decoder), on the SPEEDY-33 target. You can configure 
how the VI writes data to the analog output by right-clicking the 
AO0 item name in the Elemental I/O Node and selecting 
Properties from the shortcut menu.

Figure 4.  Looking at the Heterodyne VI Block Diagram
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Building, Downloading, and Running a DSP Application
Complete the following steps to build the Heterodyne VI into a DSP 
application and download and run the DSP application on the target.

1. Make sure the DSP target is connected to the host computer.

2. Make sure the DSP VI targets the correct application instance by 
looking in the bottom left corner of the front panel or block diagram 
window, as shown in Figure 5. 

Tip If you have more than one project open, the application instance shortcut menu 
displays the project name as well as the target. 

Figure 5.  Checking the Application Instance for the Correct Target

3. Click the Run button, shown at left, to build, download, and run the 
DSP application on the SPEEDY-33 target. When you click the Run 
button, the Build Status dialog box, shown in Figure 6, appears and 
displays the progress of the building and downloading of the DSP 
application on the SPEEDY-33 target.

Note The building and downloading process takes extra time the first time you build and 
download a DSP application because LabVIEW must initialize and load the compiler.
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Figure 6.  Building the DSP VI into a DSP Application

When the application is running on the DSP target, you can modify the 
carrier frequency and baseband frequency using the slider controls on 
the front panel. 

The waveform graph on the front panel displays the frequency 
response of the signal. If you plug in speakers or headphones to the 
analog output on the SPEEDY-33 target, you also can hear the changes 
to the carrier frequency and baseband frequency.

4. Click the Stop button on the front panel to stop the DSP application.

Example 2—Creating a New Project to Acquire and 
Analyze Signals

In this example, you will create a new project and program the SPEEDY-33 
to measure an analog input signal and turn on an LED when the DSP target 
reads a signal higher than a value you specify. Because this DSP VI uses 
Elemental Input/Output (I/O) Nodes to acquire the signal and light up the 
LED, you must add analog and digital I/O items to the DSP project. 

Note This example uses analog input so you need an external microphone if the target is 
not a SPEEDY-33. Alternatively, you can simulate an input signal using the Simulate 
Signal Express VI instead of an analog input Elemental I/O Node.

Creating the Project
This example uses the New DSP Project Wizard to guide you through 
creating a project. Complete the following steps to create a DSP project 
before you create the DSP VI.

1. Launch LabVIEW.
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2. In the Getting Started window, shown in Figure 7, select DSP 
Project from the Targets pull-down menu and click the Go button to 
open the New DSP Project Wizard.

Tip You also can select File»New, then select Project»Project from Wizard»DSP 
Project to open the New DSP Project Wizard.

Figure 7.  Getting Started Window
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3. Select the New DSP project, blank VI from the Project type 
pull-down menu on the Define project information page, shown in 
Figure 8, to create a new project with an empty VI. 

Tip Select New DSP project, existing VI from the menu if you want to create a project 
for an existing DSP VI. When you create a project with an existing VI, you must enter the 
path of the VI in the VI path text box or browse for the existing VI.

Figure 8.  Creating a New Project with a New VI

4. Click the Next button.

5. Select the target hardware you are using from the Target type 
pull-down menu on the Select target type and input/output 
resources page.
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6. Make sure there is a checkmark in the Analog Input and Digital 
Output checkboxes. By default, the wizard adds all the resources 
available to the target. You can remove the checkmarks from any of the 
input/output resources checkboxes that you do not need, as shown in 
Figure 9. 

Figure 9.  Specifying the DSP Target Hardware and Resources

Tip You can remove analog and digital input/output items from the Project Explorer 
window after you create the project if the VI does not need to access those resources. Refer 
to the Using Analog and Digital I/O Resources topic in the LabVIEW Help for more 
information about working with Elemental I/O resources.

7. Click the Finish button to close the wizard and create the DSP project 
with a blank VI. 

The Project Explorer window that appears contains the DSP target 
you selected in step 5. The blank VI appears under the DSP target in 
the Project Explorer window as Untitled x.
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Saving the DSP VI and the Project
Complete the following steps to create a DSP VI that reads a signal from 
an analog input channel on the DSP target and turns on an LED if the 
maximum value the DSP target reads is higher than a constant you specify.

1. Right-click the DSP target in the Project Explorer window and select 
Rename from the shortcut menu.

2. Enter DSP Target in the text box and press the <Enter> key to change 
the name of the target, as shown in Figure 10.

Figure 10.  Renaming the Target in the Project 

3. Expand DSP Target in the Project Explorer window to access the 
new, untitled VI.

4. Right-click Untitled x in the Project Explorer window and select 
Save from the shortcut menu to open the Name the VI dialog box. The 
number x varies depending on how many new VIs you open after you 
first launch LabVIEW.

5. Save the VI as Tutorial.vi, and click the OK button. You can save 
the VI anywhere on the computer.

6. Select File»Save in the Project Explorer window and save the project 
as Tutorial.lvproj. 

Note Saving the project does not save the VI. The project file and the VI are separate files. 
Select File»Save All to save the project and any open VIs. 
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The Project Explorer window now appears like Figure 11.

Figure 11.  Saving the DSP VI and the LabVIEW Project

Tip If you want to add additional blank DSP VIs to the project, right-click the DSP target 
in the Project Explorer window and select New»VI from the shortcut menu. To add a new 
VI to run on Windows, right-click My Computer and select New»VI.

Creating the Front Panel
Complete the following steps to create the DSP VI front panel.

1. Select View»Controls Palette in the front panel window to open the 
Controls palette.

Tip You also can right-click in the front panel window and click the thumbtack in the 
upper left corner to open and pin the Controls palette.

2. Place the following controls on the front panel window as shown in 
Figure 12.

• A waveform graph located on the Modern»Graph palette.

• A numeric control and numeric indicator located on the 
Modern»Numeric palette.

• A round LED indicator located on the Modern»Boolean palette.
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Figure 12.  Creating a Front Panel

Tip If you cannot find the object you are looking for, click the Search button on the 
Controls or Functions palette toolbar. Type the name of the object for which you want 
to search. LabVIEW searches as you type and displays any matches in the search results 
text box.

3. Rename the controls by double-clicking the labels and entering new 
names.

• Change the numeric control to Max Limit.

• Change the numeric indicator to Max Value.

• Change the round LED to Warning.

4. Right-click the y-axis of the waveform graph and remove the 
checkmark from AutoScale Y in the shortcut menu.

5. Click the 10 on the y-axis of the waveform graph and enter 4000.

6. Click the -10 on the y-axis of the waveform graph and enter -1000.

The waveform graph displays the analog signal the DSP target 
acquires and the Max Value numeric indicator displays the maximum 
value of the signal. You can use the Max Limit numeric control to 
specify the input signal level that turns on the LED on the DSP target 
and the front panel.
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7. Click the 100 on the x-axis of the waveform graph and enter 128. The 
front panel window now appears as shown in Figure 13.

Figure 13.  Renaming Controls and Indicators on the Front Panel

Adding Elemental I/O Nodes to the Block Diagram
Use Elemental I/O Nodes to access the analog input capabilities or to use 
the LEDs on the DSP target. Complete the following steps to add Elemental 
I/O Nodes to the DSP VI block diagram.

1. Press the <Ctrl-E> keys to switch to the block diagram window.

2. Select View»Functions Palette to open the Functions palette.

Note The items on the Functions palette change depending on the application instance. 

Tip If you use the Simulate Signal Express VI instead of an analog input Elemental I/O 
Node to create a signal, skip to step 5.

3. Place an Analog Input node located on the Programming»
Elemental IO palette on the block diagram.

The analog input item in the Elemental I/O Node appears on the block 
diagram with orange text because analog input is a floating-point 
numeric data type. The text is not black because you selected analog 
input resources when you created the new project in step 6 of the 
Creating the Project section. 

Note If the terminal text appears in black, you must add the Elemental I/O item to the 
project by right-clicking DSP Target in the Project Explorer window and selecting 
New»Elemental I/O from the shortcut menu. You can add the appropriate resources in the 
New Elemental I/O dialog box.
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4. You can configure the analog input by right-clicking the analog input 
item in the Elemental I/O Node on the block diagram and selecting 
Properties from the shortcut menu. 

Use the Elemental I/O Node Properties dialog box to configure 
analog input to the DSP target. Configuration options differ between 
DSP targets and can include the sample rate, framesize, and gain.

Leave the default values in the Elemental I/O Node Properties dialog 
box, as shown in Figure 14, and click the OK button.

Figure 14.  Configuring the Analog Input for SPEEDY-33

5. (Optional) If you use the Simulate Signal Express VI instead of the 
analog input on the DSP target, you must configure the Simulate 
Signal Express VI so you can see the signal on the waveform graph. 
Complete the following to configure the Simulate Signal Express VI:

a. Double-click the Simulate Signal Express VI to open the 
Configure Simulate Signal dialog box. 

b. Enter 3000 in the Amplitude text box.

c. Place a checkmark in the Add noise checkbox.

d. Select Uniform White Noise in the Noise type drop down menu.

e. Enter 1000 in the Noise amplitude textbox.
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6. Place a DSP LED node located on the Programming»Elemental I/O 
palette on the block diagram as shown in Figure 15.

Figure 15.  Adding the Elemental I/O Nodes to the Block Diagram

Tip You can change which LED lights up when you run the application by dragging the 
top or bottom handle of the Elemental I/O Node to expose different LEDs. You also can 
click the terminal name and select a different LED from the Digital Output shortcut menu.

Completing the Block Diagram
Complete the following steps to finish the block diagram as shown in 
Figure 16.

Figure 16.  Finishing the Block Diagram

1. Select Help»Show Context Help to display the Context Help 
window. The Context Help window displays basic information about 
LabVIEW objects when you move the cursor over each object.
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Tip You also can press <Ctrl-H> to open and close the Context Help window.

2. Place a While Loop located on the Programming»Structures palette 
around the controls and indicators on the block diagram. 

While Loops repeat the subdiagram inside it until the conditional 
terminal, which is an input terminal, receives a particular Boolean 
value. Notice that when you place the While Loop from the Structures 
palette, there is a Stop Boolean already wired to the conditional 
terminal. 

a. Double-click the Stop Boolean to locate the Stop button on the 
front panel.

b. Move the Stop button on the front panel to the right of the 
Warning LED.

c. Press <Ctrl-E> to return to the block diagram.

3. Place an Array Max & Min function located on the 
Programming»Array palette on the block diagram.

4. Wire the analog input item in the Elemental I/O Node to the waveform 
graph and the array input of the Array Max & Min function.

Note Wire the signal output from the Simulate Signal Express VI to the waveform graph 
if you use the Simulate Signal Express VI instead of the Elemental I/O Node.

5. Place a Greater? function located on the Programming»Comparison 
palette on the block diagram.

6. Wire the max value output of the Array Max & Min function to the 
Max Value indicator and the x input of the Greater? function.

7. Wire the Max Limit control to the y input of the Greater? function.

8. Wire the x > y? output of the Greater? function to the Warning 
indicator and the DSP LED item in the Elemental I/O Node.

9. Save the VI.
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Building, Downloading, and Running a DSP Application
Complete the following steps to build, download, and run the DSP 
application on the DSP target and interact with the DSP target application 
using controls and indicators on the front panel.

1. Click the Run button, shown at left, on the front panel window or 
block diagram window to build, download, and run the DSP 
application on the DSP target.

Tip You also can right-click the VI in the Project Explorer window and select Run from 
the shortcut menu.

2. Whistle or snap your fingers into the microphone on the DSP target 
and watch the waveform graph update. If the amplitude of the sound 
goes higher than the maximum limit you set in Max Limit, the LED 
lights up on the DSP target and the front panel. 

Note If you use the Simulate Signal Express VI instead of the Elemental I/O Node, 
right-click the y-axis of the waveform graph while the VI is running and place a checkmark 
next to AutoScale Y in the shortcut menu.

3. Enter a new value in Max Limit and repeat step 2.

4. While the DSP application is running, right-click DSP Target in the 
Project Explorer window and select Utilities»Target Information 
from the shortcut menu to open the Target Information dialog box 
shown in Figure 17. The Target Information dialog box provides 
information about memory usage on the DSP target.

Figure 17.  Viewing Memory Usage While the DSP Application Is Running

5. Click the Close button to close the Target Information dialog box.

6. Click the Stop button on the front panel to stop the application.
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, India 91 80 41190000, 
Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 
Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28, 
Malaysia 1800 887710, Mexico 01 800 010 0793, 
Netherlands 31 0 348 433 466, New Zealand 0800 553 322, 
Norway 47 0 66 90 76 60, Poland 48 22 3390150, 
Portugal 351 210 311 210, Russia 7 095 783 68 51, 
Singapore 1800 226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
United Kingdom 44 0 1635 523545


	Getting Started with the LabVIEW DSP Module
	Contents
	Introduction
	Example 1-Getting Started with DSP VIs and Projects
	Launching LabVIEW and Opening a Project
	Figure 1. Getting Started Window
	Figure 2. Targeting the SPEEDY-33 with the Heterodyne VI

	Opening a VI for a DSP Target
	Figure 3. Looking at the Heterodyne VI Front Panel
	Figure 4. Looking at the Heterodyne VI Block Diagram

	Building, Downloading, and Running a DSP Application
	Figure 5. Checking the Application Instance for the Correct Target
	Figure 6. Building the DSP VI into a DSP Application


	Example 2-Creating a New Project to Acquire and Analyze Signals
	Creating the Project
	Figure 7. Getting Started Window
	Figure 8. Creating a New Project with a New VI
	Figure 9. Specifying the DSP Target Hardware and Resources

	Saving the DSP VI and the Project
	Figure 10. Renaming the Target in the Project
	Figure 11. Saving the DSP VI and the LabVIEW Project

	Creating the Front Panel
	Figure 12. Creating a Front Panel
	Figure 13. Renaming Controls and Indicators on the Front Panel

	Adding Elemental I/O Nodes to the Block Diagram
	Figure 14. Configuring the Analog Input for SPEEDY-33
	Figure 15. Adding the Elemental I/O Nodes to the Block Diagram

	Completing the Block Diagram
	Figure 16. Finishing the Block Diagram

	Building, Downloading, and Running a DSP Application
	Figure 17. Viewing Memory Usage While the DSP Application Is Running


	Where to Go for Support



