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Important Information

Warranty

S Series devices are warranted against defects in materials and workmanship for a period of one year from the date of shipment, as evidenced
by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to be defective during the
warranty period. This warranty includes parts and labor.

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in
materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments
will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects
during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any
equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by
warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In
the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document
without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National
Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of
the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against
National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service
failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the
product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside
reasonable control.

Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other
intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only
to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

Trademarks

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section
on ni .com/legal for more information about National Instruments trademarks.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United
States and other countries. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency,
partnership, or joint-venture relationship with National Instruments.

Patents

For patents covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software,
the patents. txt file on your media, or the National Instruments Patent Notice at ni .com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY,
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES,
TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR
ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF
HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY
UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH,
THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES,
INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION
DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY
RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER
NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT
LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Contents

About This Manual
CONVENTIONS 1.ttt Xi
Related DOCUMENTALION. .......ceviiireiiirireereee s Xii
Chapter 1
Getting Started
INSLAIlING NT-DAQIMX ..ottt 1-1
Installing Other SOTIWAIE...........cov i 1-1
INStalling the HAardWAIE.........cooeiiiiii e 1-1
Device Self-CalibDration ...........cooviiiiiiice e e 1-1
(Yol = T 0 T 1-2
DeVice SPECITICALIONS ......cviviiiiiiitiitee bbb s 1-2
Chapter 2
DAQ System Overview
DAQ HAaIOWAIE ......veeiiiieie ettt be e s te s ae e te e e sbeera e neenee s 2-1
DAQ-STC .ttt bbbt bbbttt bbb 2-2
CaliDration CIFCUILIY ....o.oeeeeee ettt st e 2-3
Internal or Self-Calibration.............cooi i 2-3
External Calibration.............ccooi i 2-3
SIgNAl CONAITIONING ....eviiiieieiee ettt neeae 2-4
SENSOrS AN TTANSAUCETS.......cueieeiteteie ettt sttt ettt ae b e et e ee e e eneas 2-4
Programming Devices in SOTtWAIE ..........ccoeoiiiiriiriieee s 2-5
Chapter 3
I/0 Connector
1/0 Connector Signal DeSCIIPLIONS ........cccveiiiieiesie et se e 3-1
Terminal Name EQUIVAIENTS ........ccvoiiie e 3-4
F5 V POWET SOUICE ...ttt e 3-6
Chapter 4
Analog Input
Analog Input Terminal Configuration ............ccoeceriiiiiiiieiie e 4-2
INPUt POlarity and RANGE .....c.oiveiiiiiieie e e 4-3
WOrking VOItage RANGE .........cviiiiiiiiiieee e 4-4
Al Data ACQUISITION MENOGS .........c.eiiiiiiiiirieiiee s 4-4

© National Instruments Corporation v S Series User Manual



Contents

ANAIOG INPUL THGYEIING ....cveiiveiiteiiieiee bbb 4-6
Connecting Analog INPUL SIGNAIS.........cooeiiiiii e 4-6
Types Of SIgNal SOUICES........coviriiiieiee e 4-7
Differential Connections for Ground-Referenced Signal Sources.................. 4-8
Common-Mode Signal Rejection Considerations.............c.ccoeceenen. 4-8
Differential Connections for Floating Signal SOUICes .........ccocecvreierveninennn 4-9
DC-COUPIE......oiiiiieiiiieiciee s 4-9

AC-COUPIE......coiiiiiiicie i 4-10

Pseudodifferential Connections for Ground-Referenced Signal Sources....... 4-11

Common-Mode Signal Rejection Considerations.............c.ccococeeiaen. 4-12

Pseudodifferential Connections for Floating Signal Sources ............c.cccueenae 4-13

Field Wiring ConsSiderations .........cc.cocerierinennennecsee e 4-15

Minimizing Drift in Differential MOde..........ccocooorviniiniineeee 4-15

Analog INput TIMING SIGNAIS .....cc.eiiiiiiie e 4-16

Al Sample CIOCK SigNal........cccceiiiiiiiiiie s 4-17

Using an INternal SOUMCE ........coviveireiieiiieeseesee e 4-18

Using an EXternal SOUICE ........ccoviviiiieniieincesieese e 4-18

Outputting the Al Sample Clock Signal ..., 4-18

Other Timing REQUIFEMENTS ........coovriiiicerese e 4-19

Al Sample Clock Timebase Signal ..........ccoeoveiniiniineeeeecee 4-20

Al Start Trigger SIgNal.......ccooiiiiine s 4-20

Using a Digital SOUICE.......ccoviiiiiiieiieeeee e 4-21

USINgG an ANAlOG SOUICE .....ceiveiirieiirieiiriee s 4-21

Outputting the Al Start Trigger Signal .........cccovevveriiiieineeen 4-21

Al Reference Trigger Signal ..o 4-22

Using @ Digital SOUICE.......ccuvivviiirire et 4-23

UsiNg an ANalog SOUICE ......ccviviierieierieieieesese e seeseeseesie e seennenens 4-24

Outputting the Al Reference Trigger Signal ........ccccecvvevervcvennnene, 4-24

Al Pause Trigger SIgNal......ccccceieieieisieiisese e s 4-24

Using @ Digital SOUICE.......ccuvivvriirire e ene 4-24

UsiNg an ANalog SOUICE ......ccvivrierieriesieieieesese e e seeseesee e seeneenens 4-25

Master Timebase SIgNal........c.cccveviivrieiieneriere e 4-25

External Strobe Signal .........c.ccvoe i 4-26

Getting Started with Al Applications in SOftWAre .........cccceveveieriiie s 4-26

Chapter 5
Analog Output

Minimizing Glitches on the Output Signal..........ccccooiiiiiiiii e 5-2
AO Data Generation MethOdS..........coeieiiieeiece e e 5-2
ANAIOY OULPUL THGGEITNG .ottt sttt ettt sttt saesne e e 5-4
Connecting Analog OUtPUL SIGNaAIS ........ceiiiiiiiiirec e 5-4

S Series User Manual vi ni.com



Contents

Waveform Generation Timing SignalS ... 5-5
AO Sample ClocK Signal..........coooiiiiiiiiie e 5-5
Using an INternal SOUICE........coeviiiriiiriete s 5-5
Using an EXternal SOUMCE..........ccurieriiriniiicseeese s 5-6
Outputting the AO Sample Clock Signal.........cccooeeviviineinniencenn 5-6
Other Timing REQUIFEMENTS. ........coviireieee e 5-7
AO Sample Clock Timebase Signal..........cccoviiieniinieniee e 5-7
AO Start Trigger SIgNal.......c.ccooiiiriienieeee e 5-8
Using a Digital SOUICE .........ccooviiriiiiiiiccce s 5-8
UsSing an ANalog SOUFCE ......c.eviiiiiiiieinieeeiesie s 5-9
Outputting the AO Start Trigger Signal.........cccocevvrviinvinninsienne, 5-9
AO Pause Trigger SIgNal........ccciiiriiiee e 5-10
Using a Digital SOUICE .........ccovviiriiiiiiicccc s 5-10
Using an ANalog SOUFCE .....coueiiiirieirieiriceseeesee s 5-10
Master Timebase SIgNal ..o 5-10
Getting Started with AO Applications in SOftWAre ... 5-11
Chapter 6
Digital 1/0
STALIC DIO ..ttt 6-2
Digital Waveform Generation ... e 6-2
DO Sample CIOCK SIgNal..........cccoiiiiieiieeec e 6-2
Using an INternal SOUICE.......cccoiuevirieieere e 6-3
Using an EXternal SOUICE........cocvieiuerieieieeeeeieeee s 6-3
Digital Waveform ACQUISTTION. ..o 6-3
DI Sample CIOCK SigNal ........ccooiieiiiiiieie s 6-4
Using an INternal SOUICE.........oueiiiireireiere e 6-4
Using an EXternal SOUICE..........ccoviriiiiiieicc e 6-4
/O PROECTION. ...ttt ettt ettt et 6-5
POWET=0N SEALES .....viiviicicececesr e 6-5
Connecting Digital I/O SIgNalS..........ccuoiiiiiniieee e 6-5
Getting Started with DIO Applications in SOftWare ..., 6-6
Chapter 7
Counters
(@0 TU] g1 (= I T To < g T S SPPTSSS 7-1
IS L A I o o =T USSR 7-1
e TR I I T o T SRR 7-2

© National Instruments Corporation vii S Series User Manual



Contents

Counter TIMING SIGNAIS......c..oiriiiiieree e e 7-2
Counter 0 SOUrCE SIgNAl .......c.ooveiiiiiiiieee s 7-4
Counter 0 Gate SIgNal........covvveiiiiiiie s 7-4
Counter 0 Internal Output Signal...........coveiiiiiini s 7-5
(O I 00 1 I I = o SR 7-6
Counter 0 Up/DOWN SIgNal........ccooeiiiiiiiineiieseseseesee s 7-7
Counter 1 SoUrce SigNal ........ccovieriiiiiiiieee e 7-7
Counter 1 Gate SIgNal........ccoveiriiiiiieieee e 7-8
Counter 1 Internal Output Signal..........ccoveiiiiiini s 7-8
Counter 1 Up/DOWN SIgNal........coooiiiiiiiiiinisesieseseesee s 7-9
Frequency OUtpUt SIgNAl ..........coviiiiie e 7-10
Master TiImebase SigNal.........ccccoiiiririiiiee e 7-10
Getting Started with Counter Applications in SOftware..........ccoovvevviennieneiensene, 7-11
Chapter 8
Programmable Function Interfaces (PFI)
PRI INPULES ettt ettt et b e b be e be s eesbeebeennean 8-1
PRI OULPULS. ..ot ettt b et b et b e sbe e eesbeenbenbeans 8-1
Chapter 9
Digital Routing
TIMING SIGNAI ROULING ...vevvcevceiecesese et sne e naens 9-1
Connecting Timing SIGNalS ........ccveieieiiiie e sre s 9-4
Routing Signals in SOfWAIE ........cccccvieiec e e 9-5
Chapter 10
Real-Time System Integration Bus (RTSI)
RT ST TIIGOETS .tttk b e ettt b ettt et sb bbb et e 10-1
DeVvice and RTSI CIOCKS ........ciiiiiiiiiiieiiriee s 10-4
Synchronizing MUILIPIE DEVICES .......ccvieiiiiiiiiieiree e e 10-4
Chapter 11
Bus Interface
MITE and DAQ-PINP ...ttt bbb 11-1
Using PXI with CompactPCl ... 11-1
Data Transfer MEthOGS ..........cooii e e 11-2
Changing Data Transfer Methods between DMA and IRQ..........c.ccoceeovienene 11-2

S Series User Manual viii ni.com



Contents

Chapter 12
Triggering
Triggering wWith @ Digital SOUICE ........cccciiiiiiiiice s 12-2
Triggering With an ANalog SOUICE..........oiiiiuieiie e 12-3
PFI O/AI START TRIG PNttt 12-4
Analog INPUt ChanNEl.........ccooiii s 12-4
ANAIOY TrIgGEr ACHIONS...c.eiieeieiietiete et 12-4
F AN gt Lo o I g oo =T g I o L= SRRSO UR PSP 12-4
LEVEI THIQQEITNG . vetiieeeeee ettt 12-4
Level Triggering With HYSEEreSisS ........ccovvriireiniiseseeee e, 12-5
WINAOW TTIGGEING «.vevvvinitiicteeete e 12-6
ANAIOG TTIGYEN ACCUIACY ....vuveviveririeiisietesiete sttt sttt sb et se et se bbbt eb e eb e sbeseene e 12-7
Appendix A
Device-Specific Information
Appendix B
Technical Support and Professional Services
Glossary
Index

Device Pinouts

Figure A1, NIBLLI0 PINOUL ....ccveieeeii et s A-3

Figure A-2.  NIBLLL PINOUL ....ccviieiie ettt A-4

Figure A-6. NI 6115/6120 PINOUL .....ccvoiiieiiieiiiieicrieisice et A-11
Figure A-9. NI B122 PINOUL ....oviviiiiiiieiisieiiieic ettt A-17
Figure A-10. NI B123 PINOUL ....ovoveiiiiiieiiiciiieie et A-18
Figure A-13. NI B132 PINOUL ....ovcveiiiiieiiieii e A-24
Figure A-14. NI G133 PINOUL ....ovcviiiiiiieiiiieie et A-25
Figure A-17. NIEBLA3 PINOUL ....ovoviiiiiiieiiiieicieic et A-31

© National Instruments Corporation ix S Series User Manual



About This Manual

The S Series User Manual contains information about using the National
Instruments S Series data acquisition (DAQ) devices with NI-DAQmx 8.8
and later.

Conventions

The following conventions appear in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represent
a range of values associated with a bit or signal name—for example,
AO <3..0>.

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

@ This icon denotes a note, which alerts you to important information.

A This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash. When this symbol is marked on a
product, refer to the Read Me First: Safety and Electromagnetic
Compatibility document for information about precautions to take.

bold Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Platform Text in this font denotes a specific platform and indicates that the text
following it applies only to that platform.

© National Instruments Corporation Xi S Series User Manual



About This Manual

Related Documentation

Each application software package and driver includes information about
writing applications for taking measurements and controlling measurement
devices. The following references to documents assume you have
NI-DAQmx 8.8 or later, and where applicable, version 7.1 or later of the
NI application software.

NI-DAQmx for Windows

The DAQ Getting Started Guide describes how to install your NI-DAQmMx
for Windows software, how to install your NI-DAQmx-supported DAQ
device, and how to confirm that your device is operating properly. Select
Start»All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

The NI-DAQ Readme lists which devices are supported by this version of
NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQ Readme.

The NI-DAQmx Help contains general information about measurement
concepts, key NI-DAQmMXx concepts, and common applications that are
applicable to all programming environments. Select Start»All Programs»
National Instruments»NI-DAQ»NI-DAQmMx Help.

NI-DAQmx for Linux

The DAQ Getting Started Guide describes how to install your
NI-DAQmx-supported DAQ device and confirm that your device is
operating properly.

The NI-DAQ Readme for Linux lists supported devices and includes
software installation instructions, frequently asked questions, and known
issues.

The C Function Reference Help describes functions and attributes.

The NI-DAQmx for Linux Configuration Guide provides configuration
instructions, templates, and instructions for using test panels.

@ Note All NI-DAQmx documentation for Linux is installed at /usr/local/natinst/
nidagmx/docs.

S Series User Manual
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NI-DAQmx Base (Linux/Mac 0S X)

(N1611x/6120/6143 Only) The NI-DAQmXx Base Getting Started Guide
describes how to install your NI-DAQmx Base software, your NI-DAQmMX
Base-supported DAQ device, and how to confirm that your device is
operating properly. In Windows, select Start»All Programs»National
Instruments»NI-DAQmx Base»Documentation»Getting Started
Guide.

Getting Started with NI-DAQmx Base for Linux and Mac Users describes
how to install your NI-DAQmx Base software, your NI-DAQmXx
Base-supported DAQ device, and how to confirm that your device is
operating properly on your Mac/Linux machine.

The NI-DAQmx Base Readme lists which devices are supported by this
version of NI-DAQmx Base. In Windows, select Start»All Programs»
National Instruments»NI-DAQmx Base»DAQmx Base Readme.

The NI-DAQmx Base VI Reference Help contains VI reference and general
information about measurement concepts. In LabVIEW, select Help»
NI-DAQmx Base VI Reference Help.

The NI-DAQmx Base C Reference Help contains C reference and general
information about measurement concepts. In Windows, select Start»All
Programs»National Instruments»NI-DAQmx Base»Documentation»
C Function Reference Help.

@ Note All NI-DAQmx Base documentation for Linux is installed at Zusr/local/
natinst/nidagmxbase/documentation.

@ Note All NI-DAQmx Base documentation for Mac OS X is installed at
/Applications/National Instruments/NI-DAQmx Base/documentation.

LabVIEW

If you are a new user, use the Getting Started with LabVIEW manual to
familiarize yourself with the LabVIEW graphical programming
environment and the basic LabVIEW features you use to build data
acquisition and instrument control applications. Open the Getting Started
with LabVIEW manual by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals or by navigating to the
labview\manuals directory and opening LV_Getting_Started.pdf.

Use the LabVIEW Help, available by selecting Help»Search the
LabVIEW Help in LabVIEW, to access information about LabVIEW
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LabWindows/CVI

programming concepts, step-by-step instructions for using LabVIEW, and
reference information about LabVIEW Vs, functions, palettes, menus, and
tools. Refer to the following locations on the Contents tab of the LabVIEW
Help for information about NI-DAQmX:

*  Getting Started with LabVIEW»Getting Started with
DAQ—Includes overview information and a tutorial to learn how to
take an NI-DAQmMx measurement in LabVIEW using the DAQ
Assistant.

* VI and Function Reference»Measurement 1/O Vs and
Functions—Describes the LabVIEW NI-DAQmx Vs and properties.

e Taking Measurements—Contains the conceptual and how-to
information you need to acquire and analyze measurement data in
LabVIEW, including common measurements, measurement
fundamentals, NI-DAQmXx key concepts, and device considerations.

The Data Acquisition book of the LabWindows/CVI Help contains
measurement concepts for NI-DAQmx. This book also contains Taking an
NI-DAQmx Measurement in LabWindows/CVI, which includes
step-by-step instructions about creating a measurement task using the DAQ
Assistant. In LabWindows™/CVI™, select Help»Contents, then select
Using LabWindows/CVI»Data Acquisition.

The NI-DAQmx Library book of the LabWindows/CVI Help contains
API overviews and function reference for NI-DAQmXx. Select Library
Reference»NI-DAQmx Library in the LabWindows/CVI Help.

Measurement Studio

S Series User Manual

If you program your NI-DAQmx-supported device in Measurement Studio
using Visual C++, Visual C#, or Visual Basic .NET, you can interactively
create channels and tasks by launching the DAQ Assistant from MAX or
from within Visual Studio .NET. You can generate the configuration code
based on your task or channel in Measurement Studio. Refer to the DAQ
Assistant Help for additional information about generating code. You also
can create channels and tasks, and write your own applications in your
ADE using the NI-DAQmx API.

For help with NI-DAQmx methods and properties, refer to the NI-DAQmXx
.NET Class Library or the NI-DAQmx Visual C++ Class Library included
in the NI Measurement Studio Help. For general help with programming in
Measurement Studio, refer to the NI Measurement Studio Help, which is
fully integrated with the Microsoft Visual Studio .NET help. To view

Xiv ni.com
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this help file in Visual Studio. NET, select Measurement Studio»
NI Measurement Studio Help.

To create an application in Visual C++, Visual C#, or Visual Basic .NET,
follow these general steps:

1. In Visual Studio .NET, select FilexNew»Project to launch the New
Project dialog box.

2. Find the Measurement Studio folder for the language you want to
create a program in.

3. Choose a project type. You add DAQ tasks as a part of this step.

ANSI C without NI Application Software

The NI-DAQmXx Help contains API overviews and general information
about measurement concepts. Select Start»All Programs»National
Instruments»NI1-DAQ»NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library
functions, which you can use with National Instruments data acquisition
devices to develop instrumentation, acquisition, and control applications.
Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

.NET Languages without NI Application Software

With the Microsoft .NET Framework version 1.1 or later, you can use
NI-DAQmx to create applications using Visual C# and Visual Basic .NET
without Measurement Studio. You need Microsoft Visual Studio

.NET 2003 or Microsoft Visual Studio 2005 for the API documentation to
be installed.

The installed documentation contains the NI-DAQmx API overview,
measurement tasks and concepts, and function reference. This help is fully
integrated into the Visual Studio .NET documentation. To view the
NI-DAQmx .NET documentation, go to Start»Programs»National
Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand

NI Measurement Studio Help»NI Measurement Studio .NET Class
Library»Reference to view the function reference. Expand

NI Measurement Studio Help»NI Measurement Studio .NET Class
Library»Using the Measurement Studio .NET Class Libraries to view
conceptual topics for using NI-DAQmx with Visual C# and

Visual Basic .NET.
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To get to the same help topics from within Visual Studio, go to Help»
Contents. Select Measurement Studio from the Filtered By drop-down
list and follow the previous instructions.

Device Documentation and Specifications

Training Courses

The following specifications documents contain contains all specifications
for the following S Series devices:

e NI PCI-6110/6111 Specifications
¢ NI 6115/6120 Specifications

* NI 6122/6123 Specifications

e NI 6132/6133 Specifications

* NI 6143 Specifications

Documentation for supported devices and accessories, including PDF and
help files describing device terminals, specifications, features, and
operation are on the NI-DAQmx media that includes Device
Documentation. Insert the media, open the Device Documentation
directory, and double-click the Device Documents shortcut for your
language to find, view, and print device documents.

If you need more help getting started developing an application with NI
products, NI offers training courses. To enroll in a course or obtain a
detailed course outline, refer to ni .com/training.

Technical Support on the Web
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For additional support, refer to ni .com/support or zone.ni .com.

DAQ specifications and some DAQ manuals are available as PDFs. You
must have Adobe Acrobat Reader with Search and Accessibility 5.0.5 or
later installed to view the PDFs. Refer to the Adobe Systems Incorporated
Web site at www . adobe . com to download Acrobat Reader. Refer to the
National Instruments Product Manuals Library at ni .com/manuals for
updated documentation resources.
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Getting Started

S Series devices discussed in the S Series User Manual are simultaneous
sampling multifunction 1/0 devices that use the DAQ-STC ASIC.

Before installing your DAQ device, you must install the software you plan
to use with the device.

Installing NI-DAQmx

The DAQ Getting Started Guide, which you can download at ni .com/
manuals, offers NI-DAQmx users step-by-step instructions for installing
software and hardware, configuring channels and tasks, and getting started
developing an application.

Installing Other Software

If you are using other software, refer to the installation instructions that
accompany your software.

Installing the Hardware

The DAQ Getting Started Guide contains non-software-specific
information about how to install PCI and PXI devices, as well as
accessories and cables.

Device Self-Calibration

NI recommends that you self-calibrate your S Series device after
installation and whenever the ambient temperature changes.
Self-calibration should be performed after the device has warmed up for the
recommended time period. Refer to the device specifications to find your
device warm-up time. This function measures the onboard reference
voltage of the device and adjusts the self-calibration constants to account
for any errors caused by short-term fluctuations in the environment.
Disconnect all external signals when you self-calibrate a device.
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Chapter 1 Getting Started

You can initiate self-calibration using Measurement & Automation
Explorer (MAX), by completing the following steps.

1. Launch MAX.

2. Select My System»Devices and Interfaces»NI-DAQmMX
Devices»your device.

3. Initiate self-calibration using one of the following methods:
e Click Self-Calibrate in the upper right corner of MAX.

* Right-click the name of the device in the MAX configuration tree
and select Self-Calibrate from the drop-down menu.

@ Note You can also programmatically self-calibrate your device with NI-DAQmX,

as described in Device Calibration in the NI-DAQmx Help or the LabVIEW Help in
version 8.0 or later.

Device Pinouts

Refer to Appendix A, Device-Specific Information, for S Series device
pinouts.

Device Specifications

Refer to the specifications for your device, available on the NI-DAQ Device
Document Browser or ni .com/manuals, for more detailed information
about S Series devices:

e NI PCI-6110/6111 Specifications
e NI 6115/6120 Specifications

* NI 6122/6123 Specifications

e NI 6132/6133 Specifications

* NI 6143 Specifications

S Series User Manual 1-2 ni.com



DAQ System Overview

Figure 2-1 shows a typical DAQ system setup, which includes transducers,
signal conditioning, cables that connect the various devices to the
accessories, the S Series device, and the programming software. Refer to
Appendix A, Device-Specific Information, for a list of S Series devices and
their compatible accessories.

1 Sensors and Transducers 4 DAQ Hardware
2 Signal Conditioning 5 PC or PXI Chassis and DAQ Software

3 Cable Assembly

Figure 2-1. Typical DAQ System

DAQ Hardware

DAQ hardware digitizes signals, performs D/A conversions to generate
analog output signals, and measures and controls digital 1/O signals. The
following sections contain more information about specific components of

the DAQ hardware.
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Chapter 2 DAQ System Overview

Figure 2-2 shows the components common to most S Series devices.

A\

Analog Input
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1/0 Connector
A
\
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A
Y

Analog Output
__ Digital Bus <«
Digital /0 Routing Interface > Bus
Counters
RTSI
PFI

DAQ-STC
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Figure 2-2. S Series Block Diagram

S Series devices use the National Instruments DAQ system timing
controller (DAQ-STC) for time-related functions. The DAQ-STC consists
of the following three timing groups:

e Al—Two 24-bit, two 16-bit counters
e AO—Three 24-bit, one 16-bit counter
e General-purpose counter/timer functions—Two 24-bit counters

You can independently configure the groups for timing resolutions of 50 ns
or 10 ps. With the DAQ-STC, you can interconnect a wide variety of
internal timing signals to other internal blocks. The interconnection scheme
is flexible and completely software-configurable.

The DAQ-STC offers PFI lines to import external timing and trigger signals
or to export internally generated clocks and triggers. The DAQ-STC also
supports buffered operations, such as buffered waveform acquisition,
buffered waveform generation, and buffered period measurement. It also
supports numerous non-buffered operations, such as single pulse or pulse
train generation, digital input, and digital output.
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Chapter 2 DAQ System Overview

Calibration Circuitry

Calibration is the process of making adjustments to a measurement device
to reduce errors associated with measurements. Without calibration, the
measurement results of your device will drift over time and temperature.
Calibration adjusts for these changes to improve measurement accuracy
and ensure that your product meets its required specifications.

DAQ devices have high precision analog circuits that must be adjusted to
obtain optimum accuracy in your measurements. Calibration determines
what adjustments these analog circuits should make to the device
measurements. During calibration, the value of a known, high precision
measurement source is compared to the value your device acquires or
generates. The adjustment values needed to minimize the difference
between the known and measured values are stored in the EEPROM of the
device as calibration constants. Before performing a measurement, these
constants are read out of the EEPROM and are used to adjust the calibration
hardware on the device. NI-DAQmx determines when this is necessary and
does it automatically. If you are not using NI-DAQmX, you must load these
values yourself.

You can calibrate S Series devices in two ways—through internal
(or self-calibration) or through external calibration.

Internal or Self-Calibration

Self-calibration is a process to adjust the device relative to a highly accurate
and stable internal reference on the device. Self-calibration is similar to the
autocalibration or autozero found on some instruments. You should
perform a self-calibration on a regular basis whenever environmental
conditions, such as ambient temperature, change significantly. To perform
self-calibration, use the self-calibrate function or VI that is included with
your driver software. Self-calibration requires no external connections.

External Calibration

External calibration is a process to adjust the device relative to a traceable,
high precision calibration standard. The accuracy specifications of your
device change depending on how long it has been since your last external
calibration. National Instruments recommends that you calibrate your
device at least as often as the intervals listed in the accuracy specifications.
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Chapter 2 DAQ System Overview

For a detailed calibration procedure for S Series devices, refer to the
B/E/M/S Series Calibration Procedure for NI-DAQmx, which you can find
at ni.com/calibration and selecting Manual Calibration
Procedures.

Signal Conditioning

Many sensors and transducers require signal conditioning before a
computer-based measurement system can effectively and accurately
acquire the signal. The front-end signal conditioning system can include
functions such as signal amplification, attenuation, filtering, electrical
isolation, simultaneous sampling, and multiplexing. In addition, many
transducers require excitation currents or voltages, bridge completion,
linearization, or high amplification for proper and accurate operation.
Therefore, most computer-based measurement systems include some form
of signal conditioning in addition to plug-in data acquisition DAQ devices.

Sensors and Transducers

S Series User Manual

Sensors can generate electrical signals to measure physical phenomena,
such as temperature, force, sound, or light. Some commonly used sensors
are strain gauges, thermocouples, thermistors, angular encoders, linear
encoders, and resistance temperature detectors (RTDs).

To measure signals from these various transducers, you must convert them
into a form that a DAQ device can accept. For example, the output voltage
of most thermocouples is very small and susceptible to noise. Therefore,
you may need to amplify or filter the thermocouple output before digitizing
it. The manipulation of signals to prepare them for digitizing is called
signal conditioning.

For more information about sensors, refer to the following documents:

»  For general information about sensors, visit ni .com/sensors.

e If you are using LabVIEW, refer to the LabVIEW Help by selecting
Help»Search the LabVIEW Help in LabVIEW and then navigate to
the Taking Measurements book on the Contents tab.

* If you are using other application software, refer to Common Sensors
in the NI-DAQmx Help or the LabVIEW Help in version 8.0 or later.
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Chapter 2 DAQ System Overview

Programming Devices in Software

National Instruments measurement devices are packaged with NI-DAQmXx
driver software, an extensive library of functions and VIs you can call from
your application software, such as LabVIEW or LabWindows/CVI, to
program all the features of your NI measurement devices. Driver software
has an application programming interface (API), which is a library of Vs,
functions, classes, attributes, and properties for creating applications for
your device.

NI-DAQmx includes a collection of programming examples to help you get
started developing an application. You can modify example code and save
it in an application. You can use examples to develop a new application or
add example code to an existing application.

To locate LabVIEW, LabWindows/CVI. Measurement Studio, Visual
Basic, and ANSI C examples, refer to the KnowledgeBase document,
Where Can | Find NI-DAQmx Examples?, by going to ni .com/info and
entering the info code dagmxexp.

For additional examples, refer to zone.ni . com.
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1/0 Connector

This chapter contains information about the S Series 1/O connectors.

Refer to Appendix A, Device-Specific Information, for the 1/0 connector
pinout for your device.

I/0 Connector Signal Descriptions

Table 3-1 describes the signals found on the 1/0 connectors for S Series
devices. For more information about these signals, refer to the
specifications for your device.

Table 3-1. S Series Device Signal Descriptions

1/0 Connector Pin Reference Direction Signal Description

Al <0..7> GND — — Analog Input Channels 0 through 7 Ground—These
pins are the bias current return point for differential
measurements.

Al <0..7> + Al <0..7> GND Input Analog Input Channels 0 through 7 (+)—These pins are
routed to the (+) terminal of the respective channel
amplifier.

Al <0..7> - Al <0..7>GND | Input Analog Input Channels 0 through 7 (-)—These pins are
routed to the (=) terminal of the respective channel
amplifier.

AO <0..1> AO GND Output Analog Output Channels 0 through 1—These pins
supply the voltage output of analog output channels 0 and 1.

AO GND — — Analog Output Ground—The AO voltages and the
external reference voltage are referenced to these pins.

D GND — — Digital Ground—These pins supply the reference for the
digital signals at the 1/0 connector and the +5 VVDC supply.

P0.<0..7> D GND Input or Digital 1/0 Channels 0 through 7—You can individually

Output configure each signal as an input or output. P0.6 and P0.7
can also control the up/down signal of Counters 0 and 1,
respectively.

5V D GND Output +5 Power Source—These pins provide +5 V power. For
more information, refer to the +5 V Power Source section.
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Table 3-1. S Series Device Signal Descriptions (Continued)

1/0 Connector Pin Reference Direction Signal Description

EXT STROBE* D GND Output External Strobe Signal—This output can be toggled under
software control to latch signals or trigger events on
external devices. This signal is not available for use with
NI-DAQmx. For more information, refer to the External
Strobe Signal section of Chapter 4, Analog Input.

PFI 0/AI START TRIG | D GND Input PF1 0—As an input for digital signals, this pin is a
general-purpose input terminal. As an input for analog
signals, this pin is the source for the hardware analog
trigger. This is the default input for the Al Start Trigger
signal. For more information about PFI signals, refer to
Chapter 8, Programmable Function Interfaces (PFI).

Output Al Start Trigger Signal—As an output, this pin emits the
Al Start Trigger signal. A low-to-high transition of this
signal indicates the start of an acquisition. For more
information, refer to the Al Start Trigger Signal section of
Chapter 4, Analog Input.

PFI 1/Al REF TRIG D GND Input PFI 1—As an input, this is a general-purpose input
terminal. This is the default input for the Al Reference
Trigger signal.
Output Al Reference Trigger Signal—As an output, this pin

emits the Al Reference Trigger signal. This is a low-to-high
transition signal. For more information, refer to the Al
Reference Trigger Signal section of Chapter 4, Analog

Input.
PFI 2/Al CONV CLK D GND Input PFI1 2—As an input, this pin is a general-purpose input
terminal.
Output Al Convert Clock Signal—This pin reflects the internal

signal connected to Al Sample Clock. This signal is only
available internally

PFI3/CTR1SOURCE | D GND Input PF1 3—As an input, this pin is a general-purpose input
terminal. This is the default input for the Ctr1Source signal.

Output Counter 1 Source Signal—As an output, this pin emits the
selected Ctr1Source signal. This signal reflects the actual
source signal connected to Counter 1. For more
information, refer to the Counter 1 Source Signal section of
Chapter 7, Counters.
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Table 3-1. S Series Device Signal Descriptions (Continued)

1/0 Connector Pin

Reference

Direction

Signal Description

PFI 4/CTR 1 GATE

D GND

Input

PFI1 4—As an input, this pin is a general-purpose input
terminal. This is the default input for the Ctr1Gate signal.

Output

Counter 1 Gate Signal—As an output, this pin emits the
selected CtrlGate signal. This signal reflects the actual gate
signal connected to Counter 1. For more information, refer
to the Counter 1 Gate Signal section of Chapter 7,
Counters.

CTR10UT

D GND

Output

Counter 1 Output Signal—This pin emits the
CtrlinternalOutput signal. For more information, refer to
the Counter 1 Internal Output Signal section of Chapter 7,
Counters.

PFI 5/A0 SAMP
CLK*

D GND

Input

PF1 5—As an input, this pin is a general-purpose input
terminal.

Output

AO Sample Clock Signal—As an output, this pin emits the
AO Sample Clock signal. A high-to-low transition of this
signal indicates a new sample is being generated. For more
information, refer to the AO Sample Clock Signal section of
Chapter 5, Analog Output.

PFI 6/AO START
TRIG

D GND

Input

PF1 6—As an input, this pin is a general-purpose input
terminal. This is the default input for the AO Start Trigger
signal.

Output

AO Start Trigger Signal—As an output, this pin emits the
AQ Start Trigger signal. A low-to-high transition of this
signal indicates the start of a generation. For more
information, refer to the AO Start Trigger Signal section of
Chapter 5, Analog Output.

PFI 7/Al SAMP CLK

D GND

Input

PFI 7—As an input, this pin is a general-purpose input
terminal.

Output

Al Sample Clock Signal—As an output, this pin emits the
Al Sample Clock signal. A low-to-high transition of this
signal indicates the start of the sample. For more
information, refer to the Al Sample Clock Signal section of
Chapter 4, Analog Input.

PFI 8/CTR 0 SOURCE

D GND

Input

PF1 8—As an input, this pin is a general-purpose input
terminal and can also be used to route signals directly to the
RTSI bus. This is the default input for the CtrOSource
signal.

Output

Counter 0 Source Signal—As an output, this pin emits the
CtrOSource signal. This signal reflects the actual source
signal connected to Counter 0. For more information, refer
to the Counter 0 Source Signal section of Chapter 7,
Counters.

© National Instruments Corporation
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Chapter 3 I/0 Connector

Table 3-1. S Series Device Signal Descriptions (Continued)

1/0 Connector Pin

Reference Direction

Signal Description

PFI 9/CTR 0 GATE

D GND Input

PF1 9—As an input, this pin is a general-purpose input
terminal and can also be used to route signals directly to the
RTSI bus. This is the default input for the CtrOGate signal.

Output

Counter 0 Gate Signal—As an output, this pin emits the
CtrOGate signal. This signal reflects the actual gate signal
connected to Counter 0. For more information, refer to the
Counter 0 Gate Signal section of Chapter 7, Counters.

CTROOUT

D GND Input

Counter 0 Output Signal—As an input, this pin can be
used to route signals directly to the RTSI bus. For more
information, refer to the Counter 0 Internal Output Signal

section of Chapter 7, Counters.

Output

As an output, this pin emits the CtrOInternalOutput signal.

FREQ OUT

D GND Output

Frequency Output Signal—This output is from the
frequency generator. For more information, refer to the
Frequency Output Signal section of Chapter 7, Counters.

Terminal Name Equivalents

S Series User Manual

With NI-DAQmx, National Instruments has revised its terminal names so

they are easier to understand and more consistent among National

Instruments hardware and software products. The revised terminal names

used in this document are usually similar to the names they replace.

Table 3-2 lists the Traditional NI-DAQ (Legacy) terminal names and their

NI-DAQmx equivalents.

Table 3-2. Terminal Name Equivalents

Traditional NI-DAQ (Legacy) NI-DAQmMX
ACH# Al#
ACH# + Al #+
ACH# - Al #—
ACHGND Al GND
ACK# PFI #
AIGND Al GND
AISENSE Al SENSE
AISENSE2 Al SENSE 2
AOGND AO GND

34

ni.com



Chapter 3 I/0 Connector

Table 3-2. Terminal Name Equivalents (Continued)

Traditional NI-DAQ (Legacy)

NI-DAQmMx

CONVERT* Al CONV CLK or Al CONV
DACOOUT AO 0

DAC10UT AO1

DGND D GND

DIO_# PO.#

DIO# PO.#

DIOA#, DIOB#, DIOCH... PO.#, P1#, P2.4#...

EXTREF AO EXT REF or EXT REF
EXT_STROBE EXT STROBE

EXT_TRIG EXT TRIG

EXT_CONV EXT CONV

FREQ_OUT FREQ OUT or F OUT
GPCTRO_GATE CTR 0 GATE

GPCTRO_OUT CTROOUT
GPCTR0O_SOURCE CTR 0 SOURCE or CTR 0 SRC
GPCTR1_GATE CTR 1 GATE

GPCTR1_OUT CTR10UT

GPCTR1_SOURCE

CTR 1SOURCE or CTR 1 SRC

PA#, PB#, PCH... PO.#, P1.#, P2.4#...

PFI# PFI #

PFI_# PFI #

PCLK# PFI #

REQ# PFI #

SCANCLK Al HOLD COMP or Al HOLD
SISOURCE Al Sample Clock Timebase
STARTSCAN Al SAMP CLK or Al SAMP
STOPTRIG# PFI #

TRIG1 Al START TRIG or Al START
TRIG2 Al REF TRIG or REF TRIG
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Table 3-2. Terminal Name Equivalents (Continued)

Traditional NI-DAQ (Legacy) NI-DAQmMX
UISOURCE AO Sample Clock Timebase
UPDATE AO SAMP CLK or AO SAMP
WFTRIG AO START TRIG or AO START

+5 V Power Source

The +5 V pins on the 1/O connector supply +5 V power. You can use these
pins, referenced to D GND, to power external circuitry.

Newer revision S Series devices have a traditional fuse to protect the supply
from overcurrent conditions. This fuse is not customer-replaceable; if the
fuse permanently opens, return the device to NI for repair.

Older revision S Series devices have a self-resetting fuse to protect the
supply from overcurrent conditions. This fuse resets automatically within a
few seconds after the overcurrent condition is removed. For more
information about the self-resetting fuse and precautions to take to avoid
improper connection of +5 V and ground terminals, refer to the
KnowledgeBase document, Self-Resetting Fuse Additional Information,
by going to ni .com/info and entering the info code pptc.

Power rating (most devices): +4.65to +5.25 VDC at 1 A

To find your device’s power rating, refer to the specifications document for
your device.

A Caution Never connect these +5 V power pins to analog or digital ground or to any other
voltage source on the S Series device or any other device. Doing so can damage the device
and the computer. NI is not liable for damage resulting from such a connection.

S Series User Manual
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Analog Input

Figure 4-1 shows the analog input circuitry of each channel of an S Series

device.
Input Instrumentation
Coupling Amplifier Filter
Al+ —
\ ADC - AIFIFO (— Al Data
Al— —  Mux
— CAL
Analog o )
Trigger —— Al Timing Signals
Figure 4-1. S Series Analog Input Block Diagram
@ Note Figure 4-1 offers a general overview of the analog input circuitry for most S Series

devices. Refer to Appendix A, Device-Specific Information, for a diagram of the specific
elements that comprise the analog input circuitry of your device.

On S Series devices, each channel uses its own instrumentation amplifier,
FIFO, multiplexer (mux), and A/D converter to achieve simultaneous data
acquisition. The main blocks featured in the S Series analog input circuitry
are as follows:

e Mux—BYy default, the mux is set to route Al signals to the analog front
end. When you calibrate your device, the state of the mux switches.
You can manually switch the state of the mux to measure Al GND.

*  Input Coupling—(NI 611x/6120 Only) You can configure these S Series
devices for either AC or DC input coupling on a per-channel basis. Use
AC coupling when the AC signal contains a large DC component. If
you enable AC coupling, you remove the large DC offset for the input
amplifier and amplify only the AC component. This configuration
makes effective use of the ADC dynamic range.
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e Instrumentation Amplifier—The instrumentation amplifier can
amplify or attenuate an Al signal to ensure that you get the maximum
resolution of the ADC. NI 611x/6120/6123/6133 devices provide
programmable instrumentation amplifiers that allow you to select the
input range.

* Filter—The filter on the S Series device minimizes high frequency
noise without attenuating signals of interest within the Nyquist
bandwidth.

e A/D Converter—The analog-to-digital converter (ADC) digitizes the
Al signal by converting the analog voltage into a digital number.

e Al FIFO—A large first-in-first-out (FIFO) buffer holds data during
AJ/D conversions to ensure that no data is lost. S Series devices can
handle multiple A/D conversion operations with DMA, interrupts, or
programmed 1/O.

« Analog Trigger—For information about the trigger circuitry of
S Series devices, refer to the Analog Input Triggering section.

e Al Timing Signals—For information about the analog input timing
signals available on S Series devices, refer to the Analog Input Timing
Signals section.

Analog Input Terminal Configuration

S Series User Manual

S Series devices support only differential (DIFF) input mode. The channels
on S Series devices are true differential inputs, meaning both positive and
negative inputs can carry signals of interest. For more information about
differential input, refer to the Connecting Analog Input Signals section,
which contains diagrams showing the signal paths for differential input
mode.

(NI 611x/6120 Only) The channels on these S Series devices are
pseudodifferential inputs. The input signal of each channel, Al <0..x> +, is
connected to the positive input of the instrumentation amplifier, and each
reference signal Al <0..x> —, is connected to the negative input of the
instrumentation amplifier. The inputs are differential only in the sense that
ground loops are broken. The reference signal, Al <0..x> —, is not intended
to carry signals of interest but only to provide a DC reference point for
Al <0..x> + that may be different from ground.

Pseudodifferential signal connections reduce noise pickup and increase
common-mode noise rejection. This connection type also allows input
signals to float within the common-mode limits of the PGIA.
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A Caution Exceeding the differential and common-mode input ranges distorts the input
signals. Exceeding the maximum input voltage rating can damage the device and the
computer. NI is not liable for any damage resulting from such signal connections. The
maximum input voltage ratings can be found in the specifications document for each
S Series device.

Input Polarity and Range

Input range refers to the set of input voltages that an analog input channel
can digitize with the specified accuracy. On some S Series devices, you can
individually program the input range of each Al channel.

The input range affects the resolution of the S Series device for an Al
channel. Resolution refers to the voltage of one ADC code. For example, a
16-hit ADC converts analog inputs into one of 65,536 (= 216) codes,
meaning one of 65,536 possible digital values. These values are spread
fairly evenly across the input range. So, for an input range of -5V to 5V,
the voltage of each code of a 16-bit ADC is:

S5V-(5V) _ (53 Ry,
216

S Series devices support bipolar input ranges. A bipolar input range means
that the input voltage range is between =V s and V.

The instrumentation amplifier applies a different gain setting to the Al
signal depending on the input range. Gain refers to the factor by which the
instrumentation amplifier multiplies (amplifies) the input signal before
sending it to the ADC.

On S Series devices with programmable input ranges, choose an input
range that matches the expected input range of your signal. A large input
range can accommodate a large signal variation, but reduces the voltage
resolution. Choosing a smaller input range improves the voltage resolution,
but may result in the input signal going out of range. For more information
about programming these settings, refer to the NI-DAQmx Help or the
LabVIEW Help in version 8.0 or later.
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Working Voltage Range

On most S Series devices, the PGIA operates normally by amplifying
signals of interest while rejecting common-mode signals under the
following three conditions:

The common-mode voltage (Vn,), which is equivalent to subtracting
Al <0..x> GND from Al <0..x> —, must be less than +10 V. This V,
is a constant for all range selections.

The signal voltage (Vy), which is equivalent to subtracting Al <0..x> +
from Al <0..x> —, must be less than or equal to the range selection of
the given channel. If V is greater than the range selected, the signal
clips and information are lost.

The total working voltage of the positive input, which is equivalent to
(Vem t+ Vs), or subtracting Al <0..x> GND from Al <0..x> +, must be
less than +11 V.

If any of these conditions are exceeded, the input voltage is clamped until
the fault condition is removed.

@ Note All inputs are protected at up to £42 V.

(N1 6143 Only) The instrumentation amplifier operates normally by
amplifying signals of interest while rejecting common-mode signals under
one condition. The total voltage, (V.y, + Vs), present at the positive and
negative input terminals must be less than the working voltage, which is
7 V.

Al Data Acquisition Methods

S Series User Manual

When performing analog input measurements, there are several different
data acquisition methods available. You can either perform software-timed
or hardware-timed acquisitions:

Software-Timed Acquisitions—With a software-timed acquisition,
software controls the rate of the acquisition. Software sends a separate
command to the hardware to initiate each ADC conversion. In
NI-DAQmX, software-timed acquisitions are referred to as having on
demand timing. Software-timed acquisitions are also referred to as
immediate or static acquisitions and are typically used for reading a
single point of data.

Hardware-Timed Acquisitions—With hardware-timed acquisitions,
a digital hardware signal controls the rate of the acquisition. This
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signal can be generated internally on your device or provided
externally.

Hardware-timed acquisitions have several advantages over
software-timed acquisitions:

—  The time between samples can be much shorter.
— The timing between samples can be deterministic.

— Hardware-timed acquisitions can use hardware triggering. For
more information, refer to Chapter 12, Triggering.

Hardware-timed operations can be buffered or non-buffered. A buffer
is a temporary storage in the computer memory where acquired
samples are stored.

—  Buffered—In a buffered acquisition, data is moved from the DAQ
device’s onboard FIFO memory to a PC buffer using DMA or
interrupts before it is transferred to ADE memory. Buffered
acquisitions typically allow for much faster transfer rates than
non-buffered acquisitions because data is moved in large blocks,
rather than one point at a time. For more information about DMA
and interrupts, refer to the Data Transfer Methods section of
Chapter 11, Bus Interface.

One property of buffered 1/0 operations is the sample mode. The
sample mode can be either finite or continuous:

»  Finite sample mode acquisition refers to the acquisitions of a
specific, predetermined number of data samples. After the
specified number of samples has been collected into the
buffer, the acquisition stops. If you use a reference trigger,
you must use finite sample mode. Refer to the Al Reference
Trigger Signal section for more information.

»  Continuous acquisition refers to the acquisition of an
unspecified number of samples. Instead of acquiring a set
number of data samples and stopping, a continuous
acquisition continues until you stop the operation. A
continuous acquisition is also referred to as double-buffered
or circular-buffered acquisition.

If data cannot be transferred across the bus fast enough, the
data in the FIFO will be overwritten and an error will be
generated. With continuous operations, if the user program
does not read data out of the PC buffer fast enough to keep up
with the data transfer, the buffer could reach an overflow
condition, causing an error to be generated.
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— Non-Buffered—In non-buffered acquisitions, data is read directly
from the FIFO on the device. Typically, hardware-timed
non-buffered operations are used to read single samples with
known time increments between them and small latency.

Analog Input Triggering

Connecting Analog Input Signals

Analog input supports three different triggering actions: start, reference,
and pause. An analog or digital hardware trigger can initiate these actions.
All S Series devices support digital triggering, and some also support
analog triggering. To find your device’s triggering options, refer to the
specifications document for your device.

The Al Start Trigger Signal, Al Reference Trigger Signal, and Al Pause
Trigger Signal sections contain information about the analog input trigger

signals.

Refer to Chapter 12, Triggering, for more information about triggers.

Table 4-1 summarizes the recommended input configuration for different
types of signal sources for S Series devices.

Table 4-1. S Series Analog Input Signal Configuration

Floating Signal Sources
(Not Connected to Earth Ground)

Ground-Referenced Signal Sources

Input

Examples:
* Ungrounded thermocouples

« Signal conditioning with isolated
outputs

 Battery devices

Example:

* Plug-in instruments with
non-isolated outputs

Differential
(DIFF)

&%

Vi

AlO+
N
Al Q- >

S Series User Manual
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Refer to the Analog Input Terminal Configuration section for descriptions
of the input modes.

Types of Signal Sources

When configuring the input channels and making signal connections, first
determine whether the signal sources are ground-referenced or floating:

© National Instruments Corporation

Ground-Referenced Signal Sources—A ground-referenced signal
source is connected in some way to the building system ground and is,
therefore, already connected to a common ground point with respect to
the device, assuming that the computer is plugged into the same power
system as the source. Non-isolated outputs of instruments and devices
that plug into the building power system fall into this category.

The difference in ground potential between two instruments connected
to the same building power system is typically between 1 mV and
100 mV, but the difference can be much higher if power distribution
circuits are improperly connected. If a grounded signal source is
incorrectly measured, this difference can appear as measurement error.
Follow the connection instructions for grounded signal sources to
eliminate this ground potential difference from the measured signal.

Floating Signal Sources—A floating signal source is not connected in
any way to the building ground system, and instead has an isolated
ground-reference point. Some examples of floating signal sources are
outputs of transformers, thermocouples, battery-powered devices,
optical isolators, and isolation amplifiers. An instrument or device that
has an isolated output is a floating signal source. You must connect the
ground reference of a floating signal to the Al ground of the device to
establish a local or onboard reference for the signal. Otherwise, the
measured input signal varies as the source floats outside the
common-mode input range.
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Differential Connections for Ground-Referenced Signal Sources

Figure 4-2 shows how to connect a ground-referenced signal source to a
channel on an S Series device.

Ground-
Referenced
Signal
Source

Common-
Mode Noise
and Ground

Potential

L S Series Device

Al O + Instrume_n_tatlon
Amplifier
AlO- _ Measured
M Voltage
) —
Al 0 GND

L

1/0 Connector

Al 0 Connections Shown

S Series User Manual

Figure 4-2. Differential Connection for Ground-Referenced Signals

With these types of connections, the instrumentation amplifier rejects both
the common-mode noise in the signal and the ground potential difference
between the signal source and the device ground, shown as V., in the
figure.

Common-Mode Signal Rejection Considerations

The instrumentation amplifier can reject any voltage caused by ground
potential differences between the signal source and the device. In addition,
the instrumentation amplifier can reject common-mode noise pickup in the
leads connecting the signal sources to the device. The instrumentation
amplifier can reject common-mode signals as long as V+;, and V—;, (input
signals) are both within the working voltage range of the device.
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Differential Connections for Floating Signal Sources

Figure 4-3 shows how to connect a floating, or non-referenced, signal
source to a channel on an S Series device.

l S Series Device
_|AIO+
Instrumentation
Floating i Amplifier
Signal Q;
Source /
o Al O - v.. Measured
7Y _ m
Bias Voltage
Current )
Return
P?(
Bias
Resistor \0 Al 0 GND
1/0 Connector T
Al 0 Connections Shown

Figure 4-3. Differential Connection for Floating Signals

Figure 4-3 shows a bias resistor connected between Al 0 — and the floating
signal source ground. This resistor provides a return path for the bias
current. A value of 10 kQ to 100 kQ is usually sufficient. If you do not use
the resistor and the source is truly floating, the source is not likely to remain
within the common-mode signal range of the instrumentation amplifier, so
the instrumentation amplifier saturates, causing erroneous readings. You
must reference the source to the respective channel ground.

DC-Coupled

You can connect low source impedance and high source impedance
DC-coupled sources:

»  Low Source Impedance—You must reference the source to Al GND.
The easiest way to make this reference is to connect the positive side
of the signal to the positive input of the instrumentation amplifier and
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connect the negative side of the signal to Al GND as well as to the
negative input of the instrumentation amplifier, without using resistors.
This connection works well for DC-coupled sources with low source
impedance (less than 100 Q).

* High Source Impedance—For larger source impedances, this
connection leaves the differential signal path significantly off balance.
Noise that couples electrostatically onto the positive line does not
couple onto the negative line because it is connected to ground. Hence,
this noise appears as a differential-mode signal instead of a
common-mode signal, and the instrumentation amplifier does not
reject it. In this case, instead of directly connecting the negative line to
Al GND, connect the negative line to Al GND through a resistor that
is about 100 times the equivalent source impedance. The resistor puts
the signal path nearly in balance, so that about the same amount of
noise couples onto both connections, yielding better rejection of
electrostatically coupled noise. This configuration does not load down
the source (other than the very high input impedance of the
instrumentation amplifier).

You can fully balance the signal path by connecting another resistor of
the same value between the positive input and Al GND. This fully
balanced configuration offers slightly better noise rejection but has the
disadvantage of loading the source down with the series combination
(sum) of the two resistors. If, for example, the source impedance is

2 kQ and each of the two resistors is 100 kQ, the resistors load down
the source with 200 kQ and produce a —1% gain error.

AC-Coupled

Both inputs of the instrumentation amplifier require a DC path to ground in
order for the instrumentation amplifier to work. If the source is AC-coupled
(capacitively coupled), the instrumentation amplifier needs a resistor
between the positive input and Al GND. If the source has low-impedance,
choose aresistor that is large enough not to significantly load the source but
small enough not to produce significant input offset voltage as a result of
input bias current (typically 100 kQ to 1 MQ). In this case, connect the
negative input directly to Al GND. If the source has high output
impedance, balance the signal path as previously described using the same
value resistor on both the positive and negative inputs; be aware that there
is some gain error from loading down the source.
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Pseudodifferential Connections for Ground-Referenced Signal Sources

(N1 6115/6120 Only) Figure 4-4 shows how to connect a ground-referenced
signal source to a channel on the NI 6115.

| Nie6115
Common-Mode AC Coupling
A0+ Choke
) S . Instrumentation

Ground- + ! o | Amplifier

Referenced ' ,
vV WA *
Signal C; LY gt 100pF
Source - [ S s
Measured
AlO - \oltage
Common-
Mode +

Noise and @D

Ground —

Potential

77
o *10kQ 40 pF for ranges > +10 V
Al 0 GND
1/0 Connector —I_
Al 0 Connections Shown

Figure 4-4. Pseudodifferential Connection for Ground-Referenced Signals on
NI 6115 Devices
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Figure 4-5 shows how to connect a ground-referenced signal source to a
channel on the NI 6120.

il

NI 6120 .
AC Coupling

Instrumentation

Ground-
Referenced
Signal
Source

Common-
Mode
Noise and
Ground
Potential

1/0 Connector

H

A0+ Amplifier

: o

: i 100 pF*

: . P *  Measured

E . Vim 5 Voltage
AlO— | Ay e ! T

[ __ High-Frequency <N

Common-Mode Choke

Al0GND *10 kQ 40 pF for ranges > +10 V

17

Al 0 Connections Shown
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Figure 4-5. Pseudodifferential Connection for Ground-Referenced Signals on
NI 6120 Devices

With this type of connection, the instrumentation amplifier rejects both the
common-mode noise in the signal and the ground potential difference
between the signal source and the device ground, shown as V., in these
figures.

Common-Mode Signal Rejection Considerations

The instrumentation amplifier can reject any voltage caused by ground
potential differences between the signal source and the device. In addition,
the instrumentation amplifier can reject common-mode noise pickup in the
leads connecting the signal sources to the device. The instrumentation
amplifier can reject common-mode signals as long as V+;, and V—;, (input
signals) are both within the working voltage range of the device.

Like any amplifier, the common-mode rejection ratio (CMRR) of the PGIA
is limited at high frequency. A common-mode choke on each channel of the
NI 6115/6120 compensates for this limitation.
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(N1 6115 Only) The purpose of the 10 nF capacitance on the Al <0..3> -
connection of the NI 6115 is to provide an impedance for this choke to
work against at high frequency, which improves the high-frequency
CMRR. Depending on your application and the type of common noise at
your source, it is possible to gain further common-noise rejection by
placing a 0.1 uF ceramic bypass capacitor between Al —and Al 0 GND.

Pseudodifferential Connections for Floating Signal Sources

(NI 6115/6120 Only) Figure 4-6 shows how to connect a floating, or
non-referenced, signal source to a channel on the NI 6115.

1

NI 6115

Common-Mode

Floating +
Signal @;
Source

AlO+ Choke

AC Coupling

Instrumentation
Amplifier

+
Measured

Bias
Current
Return
Paths

Bias /

Resistor
(see text)

1/0O Connector

[

Al O —

Vi Voltage

Al 0 GND

%7 *10kQ 40 pF for ranges > +10 V

Al 0 Connections Shown

Figure 4-6. Pseudodifferential Connection for Floating Signals on NI 6115 Devices
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Chapter4  Analog Input
Figure 4-7 shows how to connect a floating signal source to a channel on
the NI 6120.
J_ NI 6120 _
AC Coupling
Instrumentation
Al O+ Amplifier
Floating + N IR i
Signal PR ! 100 pF*
Source _ ° P * Measured
. : Vm  _ Voltage
i t Al O - . S22 v v ~ —©°
CBIaS [ * ! High-Frequency ~
o C -Mode Choke
Return ommon-Mode
Paths
/ )
Bias
Resistor
(see text) 50Q ;L 0.1 uF
AIOGND *10 kQ 40 pF for ranges > +10 V

1/0 Connector

Al 0 Connections Shown
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Figure 4-7. Pseudodifferential Connection for Floating Signals on NI 6120 Devices

The figures show a bias resistor connected between Al 0 — and the floating
signal source ground. This resistor provides a return path for the bias
current. A value of 10 kQ to 100 kQ is usually sufficient. If you do not use
the resistor and the source is truly floating, the source is not likely to remain
within the common-mode signal range of the instrumentation amplifier, so
the instrumentation amplifier saturates, causing erroneous readings. You
must reference the source to the respective channel ground.

Common-mode rejection might be improved by using another bias resistor
from the Al 0 + input to Al 0 GND. This connection gives a slight
measurement error due to the voltage divider formed with the output
impedance of the floating source, but it also gives a more balanced input for
better common-mode rejection.

If a signal source is truly floating, you can use a bias resistor with a smaller
value to reduce noise. You can further reduce noise by putting a capacitor
in parallel with the bias resistor.
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Field Wiring Considerations

Environmental noise can seriously affect the measurement accuracy of the
S Series device if you do not take proper care when running signal wires
between signal sources and the device. The following recommendations
apply mainly to Al signal routing, although they also apply to signal
routing in general.

Minimize noise pickup and maximize measurement accuracy by taking the
following precautions.

e Use differential Al connections to reject common-mode noise.

e Use individually shielded, twisted-pair wires to connect Al signals to
the device. With this type of wire, the signals attached to the Al + and
Al —inputs are twisted together and then covered with a shield. You
then connect this shield only at one point to the signal source ground.
This kind of connection is required for signals traveling through areas
with large magnetic fields or high electromagnetic interference.

» Route signals to the devi