Compatibilité entre les outils de compilation Xilinx et le matériel NI FPGA

Aperçu

Afin de compiler votre code LabVIEW FPGA pour votre matériel NI FPGA (RIO, Série R, etc.) à partir de votre ordinateur, vous devez installer la version compatible des outils de compilation Xilinx localement sur votre ordinateur. En général, la version des outils de compilation Xilinx dont vous avez besoin dépend de votre version de LabVIEW et du FPGA intégré à votre périphérique RIO.


Pour déterminer les outils de compilation Xilinx dont vous avez besoin, vous pouvez soit utiliser l’outil de la section 1, soit corréler manuellement les versions logicielles appropriées à l’aide des tableaux des sections 2 et 3.

 

  • Pour utiliser l’outil, sélectionnez simplement votre matériel, puis choisissez la version de LabVIEW avec laquelle vous effectuerez le développement.
  • Pour déterminer la version des outils de compilation Xilinx requise, utilisez d’abord le tableau de la section pour vérifier la version des outils de compilation requise en fonction de la version de LabVIEW installée sur votre machine de développement. Recherchez ensuite la version minimale des outils de compilation Xilinx prenant en charge votre appareil dans le tableau de la section 3. Les outils sont répertoriés de haut en bas de la nouvelle à la plus ancienne version de l’outil. Le premier tableau (section 2) indique la version des outils de compilation Xilinx que vous devez télécharger en fonction de votre version de LabVIEW. Le deuxième tableau (section 3) indique la version minimale des outils de compilation Xilinx requise pour la prise en charge de votre matériel. La liste peut être incomplète.
     

Nous vous recommandons d’utiliser la version la plus récente des outils de compilation Xilinx compatibles avec votre périphérique.
 

Remarque : Cet article remplace l’élément 73AI806R de la base de connaissances : De quelle version des outils de compilation Xilinx ai-je besoin pour compiler mon code LabVIEW FPGA ?. Certains manuels NI peuvent encore faire référence à ce précédent document.

Sélecteur de compatibilité du matériel FPGA avec LabVIEW

Remarque : Si vous utilisez Windows 10, veuillez vous reporter au white paper Compatibilité du module LabVIEW FPGA avec Windows 10 avant de poursuivre. Les outils de compilation Xilinx pour le module LabVIEW FPGA pour ISE ne sont pas pris en charge par Windows 10. Seules certaines versions de l’outil de compilation Xilinx pour le module LabVIEW FPGA pour Vivado sont prises en charge.

 

Haut de page

Version de LabVIEW et support des outils de compilation Xilinx correspondants

Version de LabVIEW Version des outils de compilation Systèmes d’exploitation supportés
LabVIEW 2020​ Vivado 2019.1, ISE 14.7, ISE 10.1 Windows (Vivado 2019.1), Windows (ISE 14.7), Windows (ISE 10.1), Linux (ISE 14.7)
LabVIEW 2019​ Vivado 2017.2, ISE 14.7, ISE 10.1 Windows (Vivado 2017.2), Linux (Vivado 2017.2), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2018 Vivado 2017.2, ISE 14.7, ISE 10.1 Windows (Vivado 2017.2), Linux (Vivado 2017.2), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2017 SP1 Vivado 2015.4, ISE 14.7, ISE 10.1 Windows (Vivado 2015.4), Linux (Vivado 2015.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2017 Vivado 2015.4, ISE 14.7, ISE 10.1 Windows (Vivado 2015.4), Linux (Vivado 2015.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2016 Vivado 2015.4, ISE 14.7, ISE 10.1 Windows (Vivado 2015.4), Linux (Vivado 2015.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2015 SP1 Vivado 2014.4, ISE 14.7, ISE 10.1 Windows (Vivado 2014.4), Linux (Vivado 2014.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2015 Vivado 2014.4, ISE 14.7, ISE 10.1 Windows (Vivado 2014.4), Linux (Vivado 2014.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2014 SP1 Vivado 2013.4, ISE 14.7, ISE 10.1 Windows (Vivado 2013.4), Linux (Vivado 2013.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2014 Vivado 2013.4, 14.7, ISE 10.1 Windows (Vivado 2013.4), Linux (Vivado 2013.4), Windows (ISE 14.7), Linux (ISE 14.7), Windows (ISE 10.1)
LabVIEW 2013 SP1 ISE 14.4, ISE 10.1 Windows (ISE 14.4), Linux (ISE 14.4), Windows (ISE 10.1)
LabVIEW 2013 ISE 14.4, ISE 10.1 Windows (ISE 14.4), Linux (ISE 14.4), Windows (ISE 10.1)
LabVIEW 2012 SP1 ISE 13.4, ISE 10.1 Windows (ISE 13.4), Linux (ISE 13.4), RHEL 5.6 (ISE 13.4), Windows (ISE 10.1)
LabVIEW 2012 ISE 13.4, ISE 10.1 Windows (ISE 13.4), Linux (ISE 13.4), Windows (ISE 10.1)
LabVIEW 2011 SP1 ISE 12.4, ISE 10.1 Windows (ISE 12.4), Windows (ISE 10.1)
LabVIEW 2011 ISE 12.4, ISE 10.1 Windows (ISE 12.4)
LabVIEW 2010 SP1 ISE 11.5, ISE 10.1 Windows (ISE 11.5)
LabVIEW 2010 ISE 11.5, ISE 10.1 Windows (ISE 11.5)

 

Haut de page

Outils de compilation Xilinx et support matériel NI correspondant

Version minimale des outils de compilation Périphériques supportés

<tdwidth="50%"> </tdwidth="50%">

Vivado 2019.1 PCIe-6593
PXIe-659x
PXIe-786X
PXIe-799x
sbRIO-9603
sbRIO-9608
sbRIO-9609
sbRIO-9628
sbRIO-9629
sbRIO-9638
sbRIO-96x7
Vivado 2017.2 ELVIS III
cRIO-9053
cRIO-9054
cRIO-9056
cRIO-9057
PXIe-5774
PCIe-5774
PCIe-5763
PCIe-5764
PCIe-5775
PCIe-5785
PXIe-5745
PXIe-5775
PXIe-5785
PCIe-7846
PCIe-7856
PCIe-7857
PCIe-7858
Vivado 2015.4 PXIe-79115
PXIe-79125
PXIe-79155
PXIe-57635
PXIe-57645
cRIO-90405
cRIO-90415
cRIO-90425
cRIO-90435
cRIO-90455
cRIO-90465
cRIO-90475
cRIO-90485
cRIO-90495
NI-9145
Module de contrôle/commande ELVIS RIO
PXIe-5164
PXIe-7846R
PXIe-7847R
PXIe-7856R
PXIe-7857R
PXIe-7858R
PCIe-7820R
PCIe-7821R
PCIe-7822R
PXIe-7867R
PXIe-7868R
Vivado 2014.4 cRIO-9032
cRIO-9037
IC-317x
PXIe-5840
PXIe-793xR
PXIe-7902R
sbRIO-9607
sbRIO-9627
sbRIO-9637
Vivado 2013.4 NI-9147
NI-9149
cRIO-9030
cRIO-9031
cRIO-9033
cRIO-9034
cRIO-9035
cRIO-9036
cRIO-9038
cRIO-9039
cRIO-9063
cRIO-9064
cRIO-9065
cRIO-9066
cRIO-9067
PXIe-5170R
PXIe-5171R
PXIe-5624R
PXIe-6591R
PXIe-6592R
PXIe-7971R
PXIe-7972R
PXIe-7976R
PXIe-7820R
PXIe-7821R
PXIe-7822R
RoboRIO
sbRIO-9651
USRP-RIO 294x
USRP-RIO 295x
ISE 14.7 CVS-1457
NI-9144
ISE 14.4 myRIO-19004
myRIO-19504
cRIO-90684
PXIe-5646R
PXIe-7975R4
USB-7845R4
USB-7846R4
USB-7855R4
USB-7856R4
ISE 13.4 NI-9154
NI-9155
PXIe-5641R
PXIe-5644R
PXIe-5645R
ISE 12.4 cRIO-9081
cRIO-9082
PXIe-7966R
ISE 11.5 NI-9146
NI-9148
NI-9157
NI-9159
cRIO-9075
cRIO-9076
PCIe-1473R
sbRIO-9605
sbRIO-9606
sbRIO-9623
sbRIO-9626
sbRIO-9633
sbRIO-9636
ISE 10.1 (cibles non Virtex II) 2 cRIO-9072
cRIO-9073
cRIO-9074
cRIO-9111
cRIO-9112
cRIO-9113
cRIO-9114
cRIO-9116
cRIO-9118
PCIe-7841R
PCIe-7842R
PCIe-7851R
PCIe-7852R
PXI-7841R
PXI-7842R
PXI-7851R
PXI-7852R
PXI-7853R
PXI-7854R
PXI-7951R
PXI-7952R
PXI-7953R
PXI-7954R
PXIe-7961R
PXIe-7962R
PXIe-7965R
sbRIO-9601
sbRIO-9602
sbRIO-9611
sbRIO-9612
sbRIO-9631
sbRIO-9632
sbRIO-9641
sbRIO-9642
ISE 10.1 (cibles Virtex II uniquement) 1 cRIO-910x7
PCI-7811R
PCI-7813R
PCI-7830R6
PCI-7831R6
PCI-7833R6
PCIe-8255R
PXI-7811R7
PXI-7813R7
PXI-7830R6
PXI-7831R6
PXI-7833R6

 

Haut de page

Remarques
 
  1. Installez vos outils de compilation Xilinx ISE 10.1 uniquement si votre périphérique FPGA contient un circuit intégré Virtex II. Dans le cas contraire, utilisez la version la plus récente des outils de compilation Xilinx compatibles avec votre périphérique.
    Pour déterminer quelle est la puce Xilinx contenue dans votre périphérique, reportez-vous à la page produit de votre périphérique et consultez le document Puces FPGA Xilinx pour les périphériques RIO de NI.
  2. Les périphériques RIO utilisant le circuit intégré Spartan 6 requièrent LabVIEW 2010 SP1 ou une version ultérieure.
  3. Les matériels RIO utilisant des puces Virtex 6, Kintex 7 ou Virtex 7 doivent être compilés sur un système d’exploitation 64 bits.
  4. Depuis LabVIEW 2014, les outils de compilation Xilinx Vivado sont requis pour Virtex 7, Zynq et Kintex-7. Toutes les autres puces prises en charge dans les outils de compilation Xilinx ISE 14.4 nécessitent les outils de compilation Xilinx ISE 14.7.
  5. Reportez-vous au fichier Readme du driver pour plus d’informations sur la compatibilité. Ces cibles prennent en charge LabVIEW 2017 (ou version ultérieure) ou LabVIEW 2017 SP1 (ou version ultérieure). La version des outils Xilinx Vivado (2015.4) livrée avec le module LabVIEW 2017 FPGA était identique à celle livrée avec le module LabVIEW 2016 FPGA.
  6. La prise en charge de ce matériel a été abandonnée dans LabVIEW 2017.
  7. La prise en charge de ce matériel a été abandonnée dans LabVIEW 2019.
     

Plusieurs outils de compilation peuvent coexister sur le même ordinateur. LabVIEW choisira automatiquement les outils de compilation Xilinx appropriés et nécessaires en fonction du matériel. Toutefois, il faudra vous assurer que les outils de compilation Xilinx sont compatibles avec votre périphérique.

 

Haut de page

Ressources supplémentaires