Modèles Multisim pour les blindages Arduino personnalisés

Aperçu

Ce document comprend des fichiers modèles pour Multisim et Ultiboard afin de définir et de personnaliser les blindages Arduino.

Contenu

Introduction

Les utilisateurs de cartes Arduino qui doivent concevoir des blindages personnalisés peuvent désormais accélérer le développement en utilisant des modèles prédéfinis dans Multisim et Ultiboard. Chaque modèle comprend un schéma Multisim avec des connecteurs pour définir les entrées et les sorties, ainsi qu’une structure Ultiboard avec le mappage des broches et le contour de la carte.

Voici une liste des modèles disponibles :

  • Arduino Uno
  • Arduino Due
  • Arduino Pro
  • Arduino Ethernet
  • Arduino Leonardo
  • Arduino Mega 2560
  • Arduino MEGA ADK
  • Arduino Micro
  • Arduino Mini 05


Bien que ces fichiers soient conçus pour être aussi précis que possible et qu’ils aient été vérifiés par les ingénieurs d’applications de NI, veuillez noter qu’il est recommandé de vérifier attentivement la documentation fournie avec le matériel acheté. Il est toujours suggéré de consulter les documents associés au matériel pour vérifier les affectations adéquates des broches, les directives de structure et l’espacement des broches.

Exigences

Logiciel

Vous aurez besoin de Circuit Design Suite (Multisim et Ultiboard) version 13.0 (ou ultérieure) pour pouvoir utiliser les ressources jointes.

Modèles et bibliothèque de composants

Accédez à la section Téléchargements (Downloads) et téléchargez le fichier arduinotemplates.zip. Décompressez ce fichier. Vous trouverez une bibliothèque de composants (UsrComp.usr) comprenant des symboles et des encombrements personnalisés, ainsi que tous les fichiers de modèle (extension *.mst13).

Pour installer la bibliothèque de composants :

  • Lancez Multisim.
  • Sélectionnez Outils » Base de données » Fusionner la base de données (Tools » Database » Merge database).
  • Sélectionnez votre Base de données utilisateur (User Database) comme Base de données cible (Target Database).
  • Cliquez sur le bouton Sélectionner un nom de base de données de composants (Select a Component Database Name).
  • Parcourez le fichier de base de données UsrComp.usr, puis cliquez sur Ouvrir (Open).
  • Cliquez sur le bouton Démarrer (Start).
  • Sélectionnez l’option Renommer automatiquement (Auto-Rename).
  • Cliquez sur OK.
  • Une fois le statut « Terminé » (Done), cliquez sur le bouton Fermer (Close).

 

Utilisation des modèles

Suivez les étapes suivantes pour utiliser les fichiers de modèle afin de créer des blindages Arduino personnalisés avec Multisim et Ultiboard.

  1. Lancez Multisim.
  2. Accédez à Fichier » Ouvrir (File » Open), puis sélectionnez l’un des fichiers de modèle. Pour cet exemple, nous utiliserons le modèle Arduino Due Shield Template.mst13. Multisim décompresse le contenu du modèle et crée un schéma dans Multisim et une structure dans Ultiboard, comme illustré ci-dessous :

Figure 1. Modèle de blindage Arduino dans Multisim et Ultiboard

D’une part, le schéma Multisim comprend tous les connecteurs nécessaires pour les différentes broches d’entrée et de sortie. D’autre part, le fichier Ultiboard comprend le contour de la carte et les encombrements des connecteurs placés à des coordonnées précises.

  1. Enregistrez les fichiers Multisim et Ultiboard sous le même nom.
  2. Saisissez vos circuits personnalisés dans Multisim. Veuillez noter que vous pouvez utiliser des connecteurs locaux (Placer » Connecteurs [Place » Connectors]) pour créer des connexions virtuelles aux broches appropriées, comme illustré en Figure 2.

Figure 2. Capturer votre schéma dans Multisim

Une fois votre schéma terminé, vous mettrez à jour les modifications apportées à la structure à l’aide de l’Annotation directe.

  1. Sélectionnez Transférer » Annotation directe vers Ultiboard » Annotation directe vers Ultiboard 13.0 (Transfer » Forward annotate to Ultiboard » Forward annotate to Ultiboard 13.0).
  2. Enregistrez le fichier netlist (*.ewnet).
  3. Vérifiez les modifications dans la fenêtre Annotation directe (Forward Annotation), puis cliquez sur OK. Les pièces seront placées en dehors du contour de la carte.
  4. Placez les pièces et acheminez la carte.

Figure 3. Conception du blindage Arduino dans Ultiboard

Si vous devez apporter des modifications à votre conception, ouvrez simplement le schéma Multisim, effectuez les modifications et utilisez l’Annotation directe pour mettre à jour la structure.

Enfin, voici une vue 3D du blindage personnalisé. Vous pouvez ouvrir cette vue en sélectionnant Aperçu » Vue 3D (View » 3D Preview).

Figure 4. Vue 3D de la carte personnalisée

Ressources supplémentaires

Téléchargements