How to Upgrade or Revert a VI to a Different Version of LabVIEW

Publish Date: Sep 25, 2013 | 55 Ratings | 3.76 out of 5 |  PDF


I created a VI in one version of LabVIEW and would like to open it in another version of LabVIEW.  Sometimes I receive error 1126 (0x466): VI version is too early to convert to the current LabVIEW version.

How can I upgrade or revert my VI?


Your situation depends on the version of LabVIEW you use to save the VI and the version of LabVIEW you use to open the VI. The table below summarizes all possible combinations.

 LabVIEW Conversion Kit Needed
 Intermediate Version Needed for Conversion
 Conversion Kit and Intermediate Version Needed
 VI Opens Successfully
 Save to Previous Version Available
 Multiple Versions Needed to Revert

There are six possible cases:

 LabVIEW Conversion Kit Needed

To load a VI from LabVIEW 3.x or earlier, you must use the LabVIEW VI Conversion Kit.  This is available free of charge from National Instruments. The part number of this kit for Windows and Macintosh is 776874-03.

VIs from UNIX must be transferred to a Mac or PC where the VI can be converted to LabVIEW 4.0 and then transferred back to UNIX. The LabVIEW VI Conversion Kit is not available in the online catalog. Please contact the National Instruments Sales Department directly to request this free conversion kit.

Converting VIs is a multi-step process where VIs are mass compiled in one version of LabVIEW after another.  Both LabVIEW 3.1.1 and LabVIEW 4.0.1 are available on the LabVIEW VI Conversion Kit CD for the PC and Mac, and you can run both directly from the CD.

Because many VIs have changed over time, you can expect to manually replace some of the VIs in the code.

  Intermediate Version Needed for Conversion

To open a VI created before LabVIEW 6 in LabVIEW 8.5 or later, you must convert the VI to any LabVIEW version from 6 to 8.2.  National Instruments recommends upgrading to LabVIEW 8.2.1 because it is the version of LabVIEW closest to the current version. Contact your local NI representative or NI Support to acquire a free evaluation version of LabVIEW 8.2.1.

If you only have a few VIs to upgrade, open the VIs you wish to upgrade in LabVIEW 8.2.1 and save the files.  You can use File»Save All to save all opened VIs.  If you have many files to upgrade, the mass compile functionality in LabVIEW can be used. A single file or an entire directory can be selected for mass compile and the items will be opened in the new version, saved, and then closed. To access this utility select Tools»Advanced»Mass Compile. Refer to the LabVIEW 2010 Help: Mass Compile Dialog Box for more information on the Mass Compile utility.

 Conversion Kit and Intermediate Version Needed

To convert a VI from LabVIEW 2.x or 3.x up to version 8.5 or later, both a Conversion Kit and intermediate version are needed. Use the steps outlined above for the Conversion Kit to move the VI from LabVIEW 2.x or 3.x up to LabVIEW 4.0.1, then use the steps outlined above for intermediate versions to convert the VI from LabVIEW 4.0.1 up to version 8.5 or later.

 VI Opens Successfully

The more recent version of LabVIEW can open the VI, but there is no guarantee that the VI will run properly without editing. Please check the upgrade notes for the version of LabVIEW you are trying to upgrade to for more information.

 Save to Previous Version Available

The VI can be saved for a previous version of LabVIEW.  In LabVIEW 8 or later, select File»Save for Previous Version. In LabVIEW 7 or earlier, select File»Save with Options and then Save for Previous.

There are many factors to consider when reverting LabVIEW code.  Please see the KnowledgeBase 203EDCXC: Can I Save VIs in My Current LabVIEW Version for Use in a Previous Version? for more information.

 Multiple Versions Needed to Revert

Your destination version is not directly available in your current version. You must use multiple versions of LabVIEW to revert more than one revision.  For example, to move a LabVIEW 8.6 VI to LabVIEW 7.1, you must save to LabVIEW 8.0 first.  See Table 1 for the LabVIEW versions required to revert your VIs.

Related Links:
KnowledgeBase 203EDCXC: Can I Save VIs in My Current LabVIEW Version for Use in a Previous Version?
NI LabVIEW 2010 Help: Converting VIs
NI LabVIEW 2010 Help: Mass Compile Dialog Box
Upgrading to the Latest Version of LabVIEW 

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit