NI-Sync Supported Versions for NI-PXI Devices and Modules

綜覽

This page shows the supported versions of NI-Sync are required with NI-PXI Devices and Modules. Reference this information to ensure you install the correct driver version when upgrading or updating your system, when migrating or porting code to a new system, or after the purchase and installation of new NI hardware. Using incompatible versions may result in errors, the inability for your operating system to recognize or detect and then find a driver for your device, or missing devices in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 4SH9J31V: NI-Sync Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

NI-Sync Supported Versions for NI-PXI Devices and Modules

Use this table to compare NI-Sync and NI-PXI Compatibility
NI PXI Device NI-Sync Version
3.1 3.2.2 3.3 3.3.5 3.4 14.0 14.5 15.0 15.0.1 16.0 17.0 18.0 18.6 19.0 19.1
PXI-6651
PXI-6652
PXI-6653
PXI-6672
PXIe-6674    
PXIe-6674T  
PCI-1588
PXI-6682
PXI-6682H
PXI-6683        
PXI-6683H        


Compatible

 

 

For more information on getting started with NI-Sync or NI-Sync compatibility see the PXI NI-Sync User Manual. To find which versions of NI-Sync are compatible with LabVIEW Real-Time see the Readme for your NI-Sync version.

Additional Resources