NI Package Builder 20.0 Bug Fixes

Visão geral

The following items are notable issues fixed between the release of NI Package Builder 19.6 and NI Package Builder 20.0, including additional patches and service packs. If you have an issue ID, you can search this list to validate that the issue has been fixed. This is not an exhaustive list of issues fixed in the current version of NI Package Builder 20.0.

 

Bug Number

Legacy ID

Description

Details

897464

Solution fails to load when input file or directory is specified using a network path

Opening a solution errors when the solution contains an input file or directory that is specified using a network path, i.e. \\server\share.

Workaround:

Create a mapped drive letter, i.e. SUBST T: \\server\share\, and configure the input item to use the mapped drive for the input file or directory, e.g. T:\directory\file.ext. Edit the solution file contents to change the network path to mapped drive path before opening the solution file.

Reported Version:

NI Package Builder 19.0

Resolved Version:

NI Package Builder 20.0

Added:

Nov 21, 2019

897669

Solution Load Error Occurs When Package Installer Contains Packages from Unavailable Network Locations

If a package Installer in a solution contains packages from a network location and the network location is not accessible, loading the solution fails and reports an error stating "An error occurred while loading the solution".

Workaround:

There is currently no known workaround for this issue.

Reported Version:

NI Package Builder 19.0

Resolved Version:

NI Package Builder 20.0

Added:

Nov 21, 2019

943901

Properties Pane Does Not Always Update when Selecting a File in the Dependencies View of the Input Pane

The properties pane does not update appropriately when selecting an item in the Input pane if the previous item displayed in the properties pane is a file in a package editor, a package, a package installer, or a local repository.

Workaround:

Select any file in the File System View of the Input pane before selecting file in the Dependencies View of the Input Pane.

Reported Version:

NI Package Builder 19.1

Resolved Version:

NI Package Builder 20.0

Added:

Dec 12, 2019

948257

Package Builder Crashes when Dragging a Package from an Installer to a Target Installer that Already has One Item

Dragging a package between package installers can cause Package Builder to crash if the target installer has at least one item. 

Workaround:

Add packages to installer using "Add Packages" dialog.

Reported Version:

NI Package Builder 19.6

Resolved Version:

NI Package Builder 20.0

Added:

Dec 12, 2019

948258

Drag Copy of Packages Between Installers does Nothing if One of the Packages Already Exists in the Target Installer

In 19.1, and 19.6, if you attempt to drag multiple packages from one installer to another and one of the packages is already in the target installer, nothing will be copied over. The same operation in 19.0.1 crashes.

Workaround:

Drag only package from the source package that are not already in target package.

Reported Version:

NI Package Builder 19.0

Resolved Version:

NI Package Builder 20.0

Added:

Dec 12, 2019

252677

Edit Menu Commands Incorrectly Operate on the Input Pane Instead of the Active Editor Pane

Some global application commands, such as the Edit menu commands, act on selected items in the active pane. In some instances when the Editor pane is activate, the commands incorrectly operate on the selected items in the Input pane.

Workaround:

There is currently no known workaround for this issue.

Reported Version:

NI Package Builder 19.1

Resolved Version:

NI Package Builder 20.0

Added:

Mar 31, 2020

985058

Package Builder Crashes when Discovering Dependencies for a LabVIEW NXG Project if TestStand 2019 is Installed After LabVIEW NXG

Package Builder will crash while discovering dependencies of a LabVIEW NXG project if TestStand 2019 was installed after LabVIEW NXG was installed.

Workaround:

Repair the LabVIEW NXG installation.

Reported Version:

NI Package Builder 19.6

Resolved Version:

NI Package Builder 20.0

Added:

Mar 31, 2020

976329

"Build Specification Cannot be Updated" Error When Building Package with Sequence File Configured to Overrides Module Settings

Package Builder reports the error "Build Specification Cannot be Updated" if a LabVIEW step in a TestStand sequence is configured to override the VI call module settings using the Override Module Settings Window.

Workaround:

There is currently no known workaround for this issue.

Reported Version:

NI Package Builder 19.6

Resolved Version:

NI Package Builder 20.0

Added:

Mar 31, 2020

977012

Error Log Entry for Exceeding the Maximum Path Length Doesn't Populate with Expected Information

When building a solution which has a file or path name that exceeds the maximum path length a build error will occur. The error log entry is not populated with the specific error information. The error log string reported is:
"The product '%1%' failed to export one or more packages. A file name or path is too long. All paths for deployment output files or directories must be less than %1% characters: %2%".

Workaround:

Reduce the length of the file or path name in order to remove the error. 

Reported Version:

NI Package Builderr 19.6

Resolved Version:

NI Package Builder 20.0

Added:

Mar 31, 2020

Additional Patch Information

These patches currently do not have any special instructions.