NI Circuit Design Suite

Getting Started with NI Circuit Design Suite
Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

Except as specified herein, National Instruments makes no warranties, express or implied, and specifically disclaims any warranty of merchantability or fitness for a particular purpose. Customer’s right to recover damages caused by fault or negligence on the part of National Instruments shall be limited to the amount therefore paid by the customer. National Instruments will not be liable for damages resulting from loss of data, profits, use of products, or incidental or consequential damages, even if advised of the possibility thereof. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

BSIM3 and BSIM4 are developed by the Device Research Group of the Department of Electrical Engineering and Computer Science, University of California, Berkeley, and copyrighted by the University of California.

The ASM51 cross assembler bundled with Multisim MCU is a copyrighted product of MetaLink Corp. (www.metaice.com).

MPASM™ macro assembler and related documentation and literature is reproduced and distributed by Electronics Workbench under license from Microchip Technology Inc. All rights reserved by Microchip Technology Inc. MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE IS PROVIDED “AS IS.” WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL MICROCHIP BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE SOFTWARE OR FIRMWARE OR THE USE OF OTHER DEALINGS IN THE SOFTWARE OR FIRMWARE.

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2004 Maxim Shemanarev (McSeem)

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears in all copies. This software is provided “as is” without express or implied warranty, and with no claim as to its suitability for any purpose.

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2005 Maxim Shemanarev (McSeem)

1. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

2. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

3. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

This software is provided by the author “as is” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the author be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.
Trademarks
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section on ni.com/legal for more information about National Instruments trademarks.
Electronics Workbench, Multisim and Ultiboard are trademarks of National Instruments.
Portions of this product obtained under license from Bartels Systems GmbH.
Other product and company names mentioned herein are trademarks or trade names of their respective companies.
Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.
Some portions of this product are protected under United States Patent No. 6,560,572.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.
(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS’ TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options to a final action. The sequence **Tools**\(\rightarrow\)**Clear ERC Markers**\(\rightarrow\)**Entire design** directs you to pull down the **Tools** menu, select the **Clear ERC Markers** item, and select **Entire design** from the resulting dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

**bold**

Bold text denotes items that you must select or click in the software, such as menu items and dialog box options. Bold text also denotes parameter names.

**italic**

Italic text denotes variables, emphasis, a cross-reference, or an introduction to a key concept. Italic text also denotes text that is a placeholder for a word or value that you must supply.

**monospace**

Text in this font denotes text or characters that you should enter from the keyboard, sections of code, programming examples, and syntax examples. This font is also used for the proper names of disk drives, paths, directories, programs, subprograms, subroutines, device names, functions, operations, variables, filenames, and extensions.
# Contents

## Chapter 1
**Introduction to NI Circuit Design Suite**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>NI Circuit Design Suite Product Line</td>
<td>1-1</td>
</tr>
<tr>
<td>The Tutorials</td>
<td>1-1</td>
</tr>
</tbody>
</table>

## Chapter 2
**Multisim Tutorial**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to the Multisim Interface</td>
<td>2-1</td>
</tr>
<tr>
<td>Overview</td>
<td>2-3</td>
</tr>
<tr>
<td>Schematic Capture</td>
<td>2-4</td>
</tr>
<tr>
<td>Opening and Saving the File</td>
<td>2-4</td>
</tr>
<tr>
<td>Placing the Components</td>
<td>2-5</td>
</tr>
<tr>
<td>Wiring the Circuit</td>
<td>2-9</td>
</tr>
<tr>
<td>Simulation</td>
<td>2-12</td>
</tr>
<tr>
<td>Virtual Instrumentation</td>
<td>2-12</td>
</tr>
<tr>
<td>Analysis</td>
<td>2-14</td>
</tr>
<tr>
<td>The Grapher</td>
<td>2-15</td>
</tr>
<tr>
<td>The Postprocessor</td>
<td>2-16</td>
</tr>
<tr>
<td>Reports</td>
<td>2-16</td>
</tr>
<tr>
<td>Bill of Materials</td>
<td>2-17</td>
</tr>
</tbody>
</table>

## Chapter 3
**Ultiboard Tutorial**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to the Ultiboard Interface</td>
<td>3-1</td>
</tr>
<tr>
<td>Opening the Tutorial</td>
<td>3-3</td>
</tr>
<tr>
<td>Creating a Board Outline</td>
<td>3-4</td>
</tr>
<tr>
<td>Placing Parts</td>
<td>3-8</td>
</tr>
<tr>
<td>Dragging Parts from Outside the Board Outline</td>
<td>3-8</td>
</tr>
<tr>
<td>Dragging Parts from the Parts Tab</td>
<td>3-9</td>
</tr>
<tr>
<td>Placing the Tutorial Parts</td>
<td>3-10</td>
</tr>
<tr>
<td>Placing Parts from the Database</td>
<td>3-11</td>
</tr>
<tr>
<td>Moving Parts</td>
<td>3-12</td>
</tr>
<tr>
<td>Placing Traces</td>
<td>3-13</td>
</tr>
<tr>
<td>Placing a Manual Trace</td>
<td>3-14</td>
</tr>
<tr>
<td>Placing a Follow-me Trace</td>
<td>3-17</td>
</tr>
<tr>
<td>Placing a Connection Machine Trace</td>
<td>3-17</td>
</tr>
<tr>
<td>Auto Part Placement</td>
<td>3-19</td>
</tr>
<tr>
<td>Autorouting Traces</td>
<td>3-20</td>
</tr>
</tbody>
</table>
## Contents

Preparing for Manufacturing/Assembly ................................................................. 3-21  
Cleaning up the Board ....................................................................................... 3-21  
Adding Comments ............................................................................................. 3-22  
Exporting a File .................................................................................................. 3-22  
Viewing Designs in 3D ...................................................................................... 3-22

### Chapter 4
**Multisim MCU Tutorial**

- Overview .................................................................................................................. 4-1  
- About the Tutorial .................................................................................................... 4-2  
- Understanding the Assembly Program ..................................................................... 4-4  
- Working with the MCU Debugging Features .......................................................... 4-7  
  - Debug View Overview ......................................................................................... 4-7  
  - Adding a Breakpoint ............................................................................................ 4-10  
  - Break and Step .................................................................................................. 4-11  
  - Break and Step Out ........................................................................................... 4-13  
  - Break and Step Into ........................................................................................... 4-13  
  - Break and Step Over ........................................................................................ 4-13  
  - Run to Cursor .................................................................................................. 4-13

### Appendix A
**Technical Support and Professional Services**

**Index**
Introduction to NI Circuit Design Suite


NI Circuit Design Suite Product Line

National Instruments Circuit Design Suite is a suite of EDA (Electronics Design Automation) tools that assists you in carrying out the major steps in the circuit design flow.

Multisim is the schematic capture and simulation program designed for schematic entry, simulation, and feeding to downstage steps, such as PCB layout. It also includes mixed analog/digital simulation capability, and microcontroller co-simulation.

Ultiboard is used to design printed circuit boards, perform certain basic mechanical CAD operations, and prepare them for manufacturing. It also provides automated parts placement and layout.

The Tutorials

This book contains the following step-by-step tutorials:

- Multisim Tutorial—Introduces you to Multisim and its many functions.
- Ultiboard Tutorial—Shows you how to place the components and traces for the circuit described in the Multisim Tutorial chapter. You will also learn how to autoplace parts and then autoroute them.
- Multisim MCU Tutorial—Leads you through the process of simulating and debugging a circuit that contains a microcontroller.

For more detailed information on the features discussed in these chapters, refer to the Multisim Help or the Ultiboard Help.
Multisim Tutorial

This chapter contains a tutorial that introduces you to Multisim and its many functions.


Introduction to the Multisim Interface

Multisim is the schematic capture and simulation application of National Instruments Circuit Design Suite, a suite of EDA (Electronics Design Automation) tools that assists you in carrying out the major steps in the circuit design flow. Multisim is designed for schematic entry, simulation, and feeding to downstage steps, such as PCB layout.
Multisim’s user interface consists of the following basic elements:

1. **Menu Bar**: is where you find commands for all functions.
2. **Design Toolbox**: is where you navigate through the different types of files in a project (schematics, PCBs, reports), view a schematic’s hierarchy and show or hide different layers.
3. **Component toolbar**: contains buttons that you use to select components from the Multisim databases for placement in your schematic.
4. **Standard toolbar**: contains buttons for commonly-performed functions such as Save, Print, Cut, and Paste.

The **Menu Bar** is where you find commands for all functions.

The **Design Toolbox** is where you navigate through the different types of files in a project (schematics, PCBs, reports), view a schematic’s hierarchy and show or hide different layers.

The **Component toolbar** contains buttons that you use to select components from the Multisim databases for placement in your schematic.

The **Standard toolbar** contains buttons for commonly-performed functions such as Save, Print, Cut, and Paste.
The **View** toolbar contains buttons for modifying the way the screen is displayed.

The **Simulation** toolbar contains buttons for starting, stopping, and other simulation functions.

The **Main** toolbar contains buttons for common Multisim functions.

The **In Use List** contains a list of all components used in the design.

The **Instruments** toolbar contains buttons for each instrument.

The **Circuit Window** (or workspace) is where you build your circuit designs.

The **Spreadsheet View** allows fast advanced viewing and editing of parameters including component details such as footprints, RefDes, attributes and design constraints. You can change parameters for some or all components in one step and perform a number of other functions.

---

**Overview**

This tutorial leads you through the circuit design flow, from schematic capture, through simulation and analysis. After following the steps outlined on the following pages, you will have designed a circuit that samples a small analog signal, amplifies it and then counts the occurrences of the signal on a simple digital counter.

Helpful tips are indicated by the presence of an icon in the left column, as in:

![Tip](image)

**Tip** You can access the online help at any time by pressing <F1> on your keyboard, or by clicking on the **Help** button in a dialog box.

When you get to the wiring section of this tutorial, you can carry on with the circuit you created in the component placement section.

Alternatively, you can open `Getting Started 1.ms11`, found at `...\samples\Getting Started\`. This file has all of the components properly placed.

When you arrive at the simulation section, you can carry on with the circuit you wired, or open `Getting Started 2.ms11`, which has all of the components properly wired.
Chapter 2  Multisim Tutorial

Schematic Capture

In this section, you will place and wire the components in the circuit shown below.

Opening and Saving the File

Complete the following step to launch Multisim:


Complete the following steps to save the file with a new name:

1. Select File→Save As to display a standard Windows Save dialog.
2. Navigate to the location where you wish the file to reside, enter MyGettingStarted as the filename, and click the Save button.
Tip To guard against accidental loss of data, set up a timed auto-backup of the file in the Save tab of the Global Preferences dialog box.

Complete the following step to open an existing file:

1. Select File>Open, navigate to the location where the file resides, highlight the file, and click on the Open button.

Tip To view files from earlier versions of Multisim, select the desired version in the Files of Type drop-down in the Open dialog.

Placing the Components

Complete the following steps to start placing components:

1. Open MyGettingStarted.ms11 as described above.
2. Select Place>Component to display the Select a Component dialog box, navigate to the 7-segment LED display as shown below and click OK. The component appears as a “ghost” on the cursor.

Tip Once you have selected the desired Group and Family, start typing the component’s name in the browser’s Component field. As you type, the string appears in the Searching field at the bottom of the browser. In the example below, type seven_seg_decimal_com_a_blue. Matches are displayed as you type.
3. Move the cursor to the bottom-right of the workspace and left-click to place the component. Notice that the Reference Designator for this component is “U1”.
4. Place the remaining components in the Digital Counter area as shown below.

**Note** When placing resistors, inductors, or capacitors (RLC components), the Select a Component dialog box has slightly different fields than for other components. When placing these components, you can choose any combination of: the component’s value (for example, the resistance value); type (for example, carbon film); tolerance; footprint and manufacturer. If you are placing a component that will be ultimately exported to PCB layout, and become part of a Bill of Materials, you must be careful that the combination of values that you select in the Select a Component dialog box are available in a real-world, purchaseable component.

**Tip** When placing RLC components, type the value of the device that you want to place in the field at the top of the Component list. The value does not need to appear in the list to be placed on the schematic.

**Tip** While placing the 200 Ω resistor, rotate it to a vertical orientation by pressing <Ctrl-R> on your keyboard.

**Tip** Reference Designators (for example, U1, U2) are assigned in the order the components are placed. If you place components in a different order than in the original circuit, the numbering will differ. This will not affect the operation of the circuit in any way.
5. Place the components in the Counter Control section. After placement, right-click on each of the SPDT switches and select **Flip Horizontal**.

![Diagram of SPDT switches](image)

**Tip** The SPDT switches are in the **Basic** group, **Switch** family.

**Tip** When a component is on the workspace and you want to place the same component again, highlight it and select **Edit»Copy**, then **Edit»Paste**. You can also select it from the **In Use List** and click to place it on the workspace.

6. Place the components in the Analog Amplifier section as shown below, rotating as needed.

![Diagram of Analog Amplifier](image)

After you place the AC voltage signal source, double-click on it. Change the **Voltage (Pk)** to 0.2 V and click **OK** to close the dialog.
7. Place the components in the Bypass Capacitors section as shown below.

8. Place the header and associated components as shown below.

**Tip** J3 is in the Basic Group; Connectors Family.

**Tip** Once you have wired a circuit, you can drop two-pinned components like resistors directly onto a wire. The connection is automatically made by Multisim.

**Wiring the Circuit**

All components have pins that you use to wire them to other components or instruments. As soon as your cursor is over a pin, Multisim knows you want to wire and the pointer changes to a crosshair.

**Tip** You can wire the circuit that you placed on the workspace or you can use Getting Started 1.ms11 from the Getting Started folder (found inside the samples folder).
Complete the following steps to wire the circuit:

1. Click on a pin on a component to start the connection (your pointer turns into a crosshair) and move the mouse. A wire appears, attached to your cursor.

2. Click on a pin on the second component to finish the connection. Multisim automatically places the wire, which conveniently snaps to an appropriate configuration, as shown below. This feature saves a great deal of time when wiring large circuits.

Tip: You can also control the flow of the wire by clicking on points as you move the mouse. Each click “fixes” the wire to that point.
3. Finish wiring the Digital Counter section as shown below.

**Tip** Use *Bus Vector Connect* to wire multi-pinned devices like U3 and R4 together in a bus. Refer to the *Multisim Help* for details.

**Tip** *Virtual Wiring*—To avoid clutter, you can use virtual connections between the Counter Control and Digital Counter sections. When two nets have the same net name, they are virtually connected.
4. Finish wiring the circuit as shown below.

Simulation

Simulating your circuits with Multisim catches errors early in the design flow, saving time and money.

Virtual Instrumentation

In this section, you will simulate the circuit with the virtual oscilloscope.

Tip: You can also use Getting Started 2.ms11 from the Getting Started folder (found inside the samples folder).

1. J1, J2 and R2 are interactive components.
   Set up the interactive keys for J1, J2 and R2 by double-clicking on each and selecting the Value tab. In the Key field, enter “E” for J1, “L” for J2, and “A” for R2.

2. Press <E> on the keyboard to enable the counter, or just click on the widened switch arm that appears when you hover the cursor over J1.

3. Select Simulate » Instruments » Oscilloscope to place the oscilloscope on the workspace. Wire the instrument as shown in step 5.
Tip To easily differentiate between traces on the oscilloscope, right-click on the wire connected to the scope’s “B” input and select **Color Segment** from the context menu that displays. Select a color that differs from the wire connected to the “A” input, for example blue. (Changing wire color or performing any other editing function cannot be done while simulation is running).

4. Double-click on the scope’s icon to show the instrument face. Select **Simulate»Run**. The output of the opamp appears on the scope.

5. Adjust the Timebase to 2 ms/Div and Channel A’s Scale to 500 mV/Div. You will see the following displayed on the scope.

As the circuit simulates, the 7-segment display counts up and the LED flashes at the end of each count cycle.

6. Press <E> on your keyboard while the simulation is running to enable or disable the counter. Enable is Active Low.
   Press <L> to load zeros into the counter. Load is Active Low.
   Press <Shift-A> to observe the effect of decreasing the potentiometer’s setting. Repeat, pressing A to increase.

Tip Instead of pressing the above-mentioned keys, you can directly manipulate the interactive components on the schematic with your mouse.
Analysis

In this section, you will use AC Analysis to verify the frequency response of the amplifier.

Complete the following steps to perform an AC Analysis at the output of the opamp:

1. Double-click on the wire that is attached to pin 6 of the opamp, and change the net name to analog_out in the Net dialog box.
2. Select Simulate⇒Analyses⇒AC Analysis and click on the Output tab.

3. Highlight $V(\text{analog\_out})$ in the left column and click Add. $V(\text{analog\_out})$ moves to the right column. This will display the voltage at node $V(\text{analog\_out})$. 
4. Click **Simulate**. The results of the analysis appear in the **Grapher**.

---

**The Grapher**

The **Grapher** is a multi-purpose display tool that lets you view, adjust, save and export graphs and charts. It is used to display the results of all Multisim analyses in graphs and charts and a graph of traces for some instruments (for example the results of the oscilloscope).
Complete the following steps to view results of a simulation on the
**Grapher**:

1. Run the simulation as described earlier.
2. Select **View»Grapher**.

---

**The Postprocessor**

Use the **Postprocessor** to manipulate the output from analyses performed on a circuit and plot the results on a graph or chart. Types of mathematical operations that can be performed on analysis results include arithmetic, trigonometric, exponential, logarithmic, complex, vector and logic.

---

**Reports**

You can generate a number of reports in Multisim: **Bill of Materials** (BOM), **Component Detail Report**, **Netlist Report**, **Schematic Statistics**, **Spare Gates** and the **Cross Reference** Report. This section uses the BOM as an example for the tutorial circuit.
Bill of Materials

A bill of materials lists the components used in your design and therefore provides a summary of the components needed to manufacture the circuit board. Information provided includes:

- quantity of each component needed.
- description, including the type of component (example: resistor) and value (example: 5.1 kohm).
- Reference Designator of each component.
- package or footprint of each component.

Complete the following step to create a BOM (bill of materials) for your circuit:


   The report appears, looking similar to this:

   ![Bill of Materials View](image)

   To print the Bill of Materials, click the Print button. A standard Windows print dialog box appears, allowing you to choose the printer, number of copies, and so on.

   To save the Bill of Materials to a file, click the Save button. A standard Windows file save dialog box appears, where you specify the path and file name.
Because the **Bill of Materials** is primarily intended to assist in procurement and manufacturing, it includes only “real” components—it excludes components that are not real or available for purchase, such as sources or virtual components. Components without assigned footprints do not appear in the **Bill of Materials**.

To see a list of components in your circuit that are not “real” components, click the **Virtual** button. A separate window appears, showing these components only.

Detailed information on this and other reports can be found in the *Multisim Help*. 
Ultiboard Tutorial

The tutorial in this chapter places the parts and traces for the circuit described in the Multisim Tutorial chapter.

Tip  For instructions on exporting a design from Multisim to Ultiboard, refer to the Multisim Help and the Ultiboard Help.

Some of the described features may not be available in your edition of Ultiboard. Refer to the NI Circuit Design Suite Release Notes for a description of the features available in your edition.

Introduction to the Ultiboard Interface

Ultiboard is the PCB layout application of National Instruments Circuit Design Suite, a suite of EDA (Electronics Design Automation) tools that assists you in carrying out the major steps in the circuit design flow.

Ultiboard is used to lay out and route printed circuit boards, perform certain basic mechanical CAD operations, and prepare them for manufacturing. It also provides automated parts placement and layout.

Ultiboard’s user interface is made up of several elements.
The **Menu Bar** is where you find commands for all functions.

The **Standard toolbar** contains buttons for commonly-performed functions such as Save, Print, Cut, and Paste.

As you add more parts and traces to a board, it can become difficult to select only those which you want to use. The **Select toolbar** contains buttons used to control selections.

The **Draw Settings toolbar** is where you select the layer, thickness and unit of measure of a line or object that is being drawn. It also contains buttons for functions that control the appearance of lines and shapes drawn on a layer.
Chapter 3  Ultiboard Tutorial

The View toolbar contains buttons for modifying the way the screen is displayed.

The Main toolbar contains buttons for common board design functions.

The Autoroute toolbar contains autorouting and part placement functions.

The Status Bar displays useful and important information.

The Workspace is where you build your design.

The Spreadsheet View allows fast advanced viewing and editing of parameters including part details such as shapes, Reference Designators, attributes and design constraints.

The Design Toolbox lets you show, hide, or dim elements of your design.

The 3D Preview shows you a three-dimensional preview of the board.

The Birds Eye View shows you the design at a glance and lets you easily navigate around the workspace.

Opening the Tutorial

Complete the following steps to open the tutorial file:

1. Select Start»All Programs»National Instruments»Circuit Design Suite 11.0»Ultiboard 11.0 to launch Ultiboard.
2. Select File»Open Samples and double-click on the Getting Started folder to open it.
3. Select `Getting Started.ewprj` and click **Open**. The project file is loaded into Ultiboard.

4. To select a design from the project (for example, GS1), either click on its tab, or click on its name in the **Projects** tab of the **Design Toolbox**.

**Creating a Board Outline**

There is already a board outline, however, you can create one that is a more suitable size for the parts in this design in one of the following ways:

- Draw a board outline using the drawing tools.
- Import a DXF file.
- Use the **Board Wizard**.
Complete the following steps to experiment with the **Board Wizard**:

1. Double-click on **Board Outline** in the **Layers** tab to make it the active layer.
2. Click on the existing board outline in the GS1 design and press <Delete> on the keyboard.
3. Choose **Tools»Board Wizard**.

4. Enable the **Change the layer technology** option to make the other options available.

5. Choose **Multi-layers constructed with double-sided boards and single layer stack-ups**, and click Next.
6. The next dialog box is where you define the **Lamination settings** for the board. (For this tutorial you will not change settings).

![Board Wizard - Copper Layers dialog box](image)

7. **Click Next.**
   - In the **Board Wizard - Shape of Board** dialog box:
     - make sure the **Reference Point** is set to **Bottom-left** for **Alignment**.
     - make sure the **Rectangular** option is selected.
     - set the **Width** to 3000 and the **Height** to 2000 (a more suitable size for the parts in this design).
     - set the **Clearance** to 5.00000. This is the distance from the edge of the board that is to be kept free of any other elements.

8. **Click Finish.** The board outline is placed on your design.

**Note**  For complete details on the **Board Wizard**, refer to the **Ultiboard Help**.
Complete the following steps to move the board outline:

1. Double-click on **Board Outline** in the **Layers** tab.
2. Click anywhere on the board outline in the workspace and drag the board to a location just below the row of parts.

Complete the following steps to change the reference point:

1. Select **Design»Set Reference Point**. The reference point is attached to your cursor.
2. Move the cursor to the lower-left corner of the board outline and click to place it.
Placing Parts

You can place parts on your GS1 design file in several different ways:

- select one or more parts from outside the board outline and drag them into place.
- use the Parts tab in the Spreadsheet View to locate parts and place them.
- select parts from the database.

Tip Use the Place→Unplace Parts command to quickly remove all non-locked parts from the PCB and experiment with a different placement technique.

Dragging Parts from Outside the Board Outline

By default, parts are placed outside the board outline when you open a netlist from Multisim or another schematic capture program.

Before you begin, double-click the Copper Top layer in the Design Toolbox to make it the active layer.

Complete the following steps to drag U1 from outside the board outline:

1. Find U1 in the collection of parts outside the board outline. To make this easier, zoom in (press <F8>) until you can see U1.

Tip You can also search for a part with the Edit→Find command. While this command works much like a Find function in other applications, it also allows you to search for a part by name, number, shape, value, or by all variables. Refer to the Ultiboard Help for details.
2. Click on U1 (the 7-segment display) and drag it to the location shown in the figure below.

![Diagram showing part placement](image)

U1 remains selected. This is an important point for Ultiboard that holds throughout the application—you need to explicitly end any particular action. In this case, simply clicking somewhere else de-selects the part. Right-clicking also ends the current action.

3. Go to the **Parts** tab in the **Spreadsheet View** and scroll to U1. You will notice that the green light beside the part is slightly brighter—this indicates that the part has been placed.

### Dragging Parts from the Parts Tab

Complete the following steps to drag parts from the **Parts** tab:

1. In the **Parts** tab, scroll down until you see J3.
2. Click on J3 and drag it from the Parts tab onto the workspace. J3 is attached to your mouse pointer.

3. Drop J3 on the left edge of the board, roughly in the middle. As before, in the Parts tab J3’s green light is slightly brighter, indicating that the part has been placed.

**Placing the Tutorial Parts**

Using any method or combination of methods, make your layout look like the illustration below. You can also simply open the next design file in the project, GS2, which has already been set up this way.

Your design should look like this:
Placing Parts from the Database

In addition to placing parts imported as part of your design file, you can place parts directly from the database. The following uses this method to place the mounting holes.

Complete the following steps to place parts from the database:

1. Choose **Place→From database**. The **Get a Part From the Database** dialog box opens.

2. In the **Database** panel, expand the **Through Hole Technology Parts** category and navigate to the **Holes** category. The parts appear in the **Available parts** panel.

3. In the **Available parts** panel, select the **Hole35** part. The part displays in the **Preview** panel.

4. Click **OK**. The **Get a Part From the Database** dialog box disappears, and you are prompted to enter the **RefDes** and **Value**.

5. Enter the hole’s reference designator (H1) and value (HOLE) and click **OK**.

6. Move the pointer over the board. The part is attached to the pointer.
7. When the hole is in position in the top-left corner, click to drop it on the board.

8. The Enter Reference Designation for Part dialog box reappears, with the reference designator automatically incremented to H2.

9. Enter the value (HOLE) and click OK to place the next mounting hole in the top right corner, and repeat to place H3 in the bottom right corner, and H4 in the bottom left corner.

10. Click Cancel to stop, and click Cancel again to close the Get a Part From the Database dialog box.

### Moving Parts

You can use the same methods for moving parts as you do for placing them. To select a part already on the board, simply click on it. To specify the X/Y coordinates to which the selected part is to move, press the <*> key on the numeric keypad. Alternatively, in the Parts tab, select a placed part (indicated by a bright green light beside it) and drag it to a new location.
Tip The part’s label is a separate element from its shape. When selecting a part on the board, be sure to select the whole part, not just the label. Try using the Selection Filters to assist with this. Refer to the Ultiboard Help for more information.

Tip Once a part is selected, you can also move it around on the board by pressing the arrow keys on your keyboard.

You can also select a group of parts and move them together. To do this, you can do one of the following:

- hold down the <Shift> key and click on more than one part.
- drag a box around several parts.

All the selected parts will move together when you drag the cursor.

Tip These are temporary groups—once you select another part, the group connection is lost. To make a group that remains until you remove it, you can use the Group Editor. For details, refer to the Ultiboard Help.

Another option for moving parts is to use the Edit→Align commands to align the edges of selected parts or to space them relative to each other.

Use the Edit→Align commands to align the mounting holes you just placed:

1. Select H1 and hold down the Shift key to select H2.
2. Choose Edit→Align→Align Top. If H2 was not originally placed exactly in line with H1, you will see it move.
3. Click on an empty space on the board, then select H2 and H3.
4. Choose Edit→Align→Align Right.
5. Continue in this manner to align the bottoms of H3 and H4, and the left sides of H1 and H4.

### Placing Traces

You have the following options for placing traces:

- manual trace.
- follow-me trace.
- connection machine trace.

A manual trace is placed exactly as you specify, even running through a component or trace if that is the path you set out. A follow-me trace automatically draws a legal trace between the pins you select with your
mouse movements—you can move from pin to pin, leaving a legal trace. A
connection machine trace automatically joins two pins by the most efficient
route, though you have the option of changing it.

As you place a trace, and before you click to fix it in place, you can always
remove a segment by backing up over it. Each time you click while placing
a manual trace, or each time a follow-me trace or connection machine trace
changes direction, a separate segment of that trace is created. When
performing operations on traces, be sure to select either the appropriate
segment or, if you wish, the whole trace.

**Placing a Manual Trace**

You can continue with the design you have been working on, or open GS3.
Be sure you are on the **Copper Top** layer before beginning—**Copper Top**
should be highlighted in red in the **Layers** tab of the **Design Toolbox**.

**Tip** If necessary, press <F7> to show the whole design.

Complete the following steps to place a trace manually:

1. Choose **Place»Line**.

**Tip** The **Line** command is used to create a line on any layer. The results differ depending
on the layer selected. For example, if the selected layer is silkscreen, you will create a line
on the silkscreen layer of the PCB. If the selected layer is a copper layer, then the “line” is
actually a trace.
2. Locate J3, toward the left-hand part of the board. Find the start pin shown below:

Tip You can turn off or dim the Force Vectors to see the nets more clearly. Do this using the Force Vectors checkbox in the Layers tab of the Design Toolbox. Refer to the Ultiboard Help for more information about Force Vectors.

Tip If you have trouble locating the part, use the Find function of the Parts tab. Select the part in the Parts tab, then click the Find and select the part button. The part is shown in the workspace. If necessary, zoom in further using <F8>.

3. Click on the pin specified in the above step. Ultiboard highlights all the pins that are part of the same net as the pin you clicked on with an X. (The color of the highlighting can be changed in the Colors tab of the Global Preferences dialog box). This is how you know where to connect to pins to match the connectivity from your schematic.
4. Move the cursor in any direction. A green line (the trace) is attached to the selected pin. Each time you click you anchor the trace segment, as shown in the figure below (2).

5. Click on the destination pin.

6. Right-click to stop placing traces.

7. Click the **Select** button on the **Main** toolbar to exit line-placing mode.
Placing a Follow-me Trace

Complete the following steps to place a follow-me trace:

1. Choose Place>Follow-me.
2. Click on the top pin of J3.
3. Click on the second pin from the bottom in the left column of U4.
4. Ultiboard draws the connection for you.

Tip You do not need to click exactly on a pin—you can also start by clicking on a ratsnest line.

Placing a Connection Machine Trace

Complete the following steps to place a Connection Machine trace:

1. Choose Place>Connection Machine.
2. Click on the segment of the ratsnest indicated below.

3. Move your cursor—Ultiboard suggests various trace placement options routed around obstacles.
4. When you see the route you want, click to fix the trace. You don’t have to click on the ratsnest or the destination pin.

5. Right-click to end trace placement.

**Auto Part Placement**

As well as placing parts as described earlier in this chapter, you can use Ultiboard’s advanced automatic part placement functionality.

**Tip** Before autoplacing parts, pre-place and lock any parts that you do not wish to be moved during the autoplacement process. (The mounting holes, and U1, J1, J2, J3, and LED 1 in GS5 have been pre-placed and locked). For details on locking parts, refer to the *Ultiboard Help*. 
Chapter 3  Ultiboard Tutorial

Complete the following steps to autoplace the parts in Getting Started.ewprj:

1. Open the GS5 design in Ultiboard.
2. Select Autoroute>Start Autoplacement. The parts are placed on the circuit board.

Autorouting Traces

You can place traces in Ultiboard using the methods described earlier in this chapter, or automatically route the traces as described below.

Complete the following steps to autoroute the traces in Getting Started.ewprj:

1. Open the GS3 design in Ultiboard.
2. Select Autoroute>Start/Resume Autorouter. The workspace switches to Autorouter Mode and trace autorouting begins.
   As autorouting proceeds, you will see traces being placed on the board. When autorouting is complete, Autorouter Mode closes and you are returned to the workspace.
3. Optionally, select Autoroute>Start Optimization to optimize the placement of the traces.
The autorouter can be stopped at any time and you can make manual changes as desired. When you restart the autorouter, it will continue with the changes you made. Remember to lock any traces that you have placed manually and do not wish to be moved by the autorouter.

**Tip** Use the Routing Options dialog box to modify autoplacement and autorouting options. Refer to the Ultiboard Help for details.

## Preparing for Manufacturing/Assembly

Ultiboard can produce many different output formats to support your production and manufacturing needs. This section explains the functions performed to output your board for production and documentation purposes.

### Cleaning up the Board

Before sending the board for manufacturing, you should clean up any open trace ends (trace segments that do not have any terminating connections in the design) and unused vias that have been left on the board.

To delete open trace ends, make sure the GS4 design is open and choose **Edit»Copper Delete»Open Trace Ends**. This deletes all open trace ends in the design.
To delete any unused vias, make sure the design is open and choose **Design»Remove Unused Vias** to delete all vias that do not have any trace segments or copper areas connected to them.

### Adding Comments

Comments can be used to show engineering change orders, to facilitate collaborative work among team members, or to allow background information to be attached to a design.

You can “pin” a comment to the workspace, or directly to a part. When a part with an attached comment is moved, the comment also moves.

For details, refer to the *Ultiboard Help*.

### Exporting a File

An exported file contains complete information describing how a finished board is to be manufactured. Files that can be exported include Gerber RS-274X and RS-274D files.

For complete details, refer to the *Ultiboard Help*.

### Viewing Designs in 3D

Ultiboard lets you see what the board looks like in three dimensions at any time during the design. For complete details, refer to the *Ultiboard Help*.

**Tip** You can use the **Internal View** to look between the layers of a multi-layer PCB. For details, refer to the *Ultiboard Help*. 
Multisim MCU Tutorial

The tutorial in this chapter leads you through the process of simulating and debugging a circuit that contains a microcontroller.


Overview

The files used for this tutorial install with your NI Circuit Design Suite software at ...\samples\Getting Started.

This tutorial uses *Getting Started MCU.mst1*, which accesses the contents of folder *LCDWorkspace* as required.

The LCD Graphical Display circuit example demonstrates the use of a PIC microcontroller to control a graphical LCD display component in Multisim based on a combination of the Toshiba T6963C controller and an external display RAM. To control the LCD display, the microcontroller sends signals to the LCD through the LCD’s data and control lines. A software program written for the microcontroller determines the logic behind setting the lines on its pins to high or low to send commands and data to the LCD display.
Chapter 4  Multisim MCU Tutorial

About the Tutorial

The data lines of LCD U2 are connected to pins RB0 – RB7 on microcontroller U1. The control lines of the LCD are connected to RA0 - RA2 on the microcontroller. The MCU U1 communicates with the LCD U2 via these wires. Data is sent to U2 in parallel and signals on the control lines determine the timing and type of data being sent (that is, address or data).

The LCD Graphical Display can operate in three modes: text mode, graphical mode and a combination text and graphical mode. This example demonstrates the controlling of the LCD Graphical Display in a combination text and graphical mode. The software that the MCU runs is contained in an MCU workspace that displays in the Design Toolbox as LCDWorkspace. The workspace contains one project project1 that consists of a single source code file main.asm.
Complete the following to view the file:

1. Double-click on `main.asm` in the **Design Toolbox**. A tab appears in the schematic capture workspace called `main.asm` that displays the assembly program.

   ![Design Toolbox](image)

   ![Assembly Code](image)

   To display the line numbers, select **MCU»Show Line Numbers**.

Complete the following to run this circuit:

1. Select **Simulate»Run**. If you did not build your program beforehand, a dialog box displays stating that the configuration is out of date and asks if you would like to build it. Click **Yes**. The results of the build display in the **Results** tab of the **Spreadsheet View**.

   Switch back to the design tab. The program displays the line “Graphical LCD T6963C for Multisim” characters in text mode; the LCD then switches to graphical mode and draws an inverted “V” dot-by-dot on top of the text.

   Once the lines are drawn, the text scrolls right and then left. This is achieved by moving the start address of the text buffer of the LCD display. This also demonstrates that there are two buffers in the LCD, one for storing graphics and another for storing text. Other features of the LCD such as text flashing and erasing of characters are also demonstrated.

   The LCD display program continues to cycle through each of these effects.

To stop the simulation, select **Simulate»Stop**.
Understanding the Assembly Program

Constants and data

Switch back to `main.asm`.

To make the program easier to understand, the LCD display commands and temporary buffers for storing addresses and data in the MCU are predefined in constants at the start of the program:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATA_BUFFER</td>
<td>0x20</td>
<td></td>
</tr>
<tr>
<td>DATA_BUFFER2</td>
<td>0x21</td>
<td></td>
</tr>
<tr>
<td>CMD_BUFFER</td>
<td>0x22</td>
<td></td>
</tr>
<tr>
<td>RET_BUFFER</td>
<td>0x24</td>
<td></td>
</tr>
<tr>
<td>ADDR_INDEX</td>
<td>0x25</td>
<td>STARTING ADDRESS IN EEPROM</td>
</tr>
<tr>
<td>ADDR_L</td>
<td>0x26</td>
<td>STARTING ADDRESS L</td>
</tr>
<tr>
<td>ADDR_H</td>
<td>0x27</td>
<td>STARTING ADDRESS H</td>
</tr>
<tr>
<td>COUNTER_INDEX</td>
<td>0x29</td>
<td>COUNTER</td>
</tr>
<tr>
<td>BIT_INDEX</td>
<td>0x2A</td>
<td>BIT INDEX</td>
</tr>
<tr>
<td>CMD_SET_CURSOR</td>
<td>21H</td>
<td>SET_CURSOR</td>
</tr>
<tr>
<td>CMD_TXMODE</td>
<td>40H</td>
<td>SET TXT ENS ADD</td>
</tr>
<tr>
<td>CMD_TXAREA</td>
<td>41H</td>
<td>SET TXT AREA</td>
</tr>
<tr>
<td>CMD_GRMODE</td>
<td>42H</td>
<td>SET GR IM ADD</td>
</tr>
<tr>
<td>CMD_GRAREA</td>
<td>43H</td>
<td>SET GR AREA</td>
</tr>
<tr>
<td>CMD_OFFSET</td>
<td>22H</td>
<td>SET OFFSET ADD</td>
</tr>
<tr>
<td>CMD_ADPSR</td>
<td>24H</td>
<td>SET ADD PTR</td>
</tr>
<tr>
<td>CMD_SETDATA_INC</td>
<td>00H</td>
<td>WRITE DATA AND INCREASE ADP</td>
</tr>
<tr>
<td>CMD_AUTOON</td>
<td>0BH</td>
<td>SET AUTO WRITE MODE</td>
</tr>
<tr>
<td>CMD_AUTOFF</td>
<td>0BH</td>
<td>RESET AUTO WRITE MODE</td>
</tr>
</tbody>
</table>

The text to be displayed on the LCD display is stored in data tables for some microcontrollers, but there is no PIC assembly instruction that allows you to directly address a data value in the program memory space. Instead, you can load literal values into the W register so you can write a routine that returns a value in your string based on an index. The `RETLW` instruction loads a constant value into the W register and executes a `RETURN` in one instruction.

The `TXPRT` routine retrieves the text data to be displayed on the LCD display. The character codes for the LCD display are defined in the T6963C controller reference manual (for example, 0x27 is the code for the letter “G”, 0x52 for “r”, and so on):
Initialization

The initialization code begins at the `START` label as shown in the excerpt below. The pins in the microcontroller are set up as output pins, and the values are reset. The LCD display component is initialized by the microcontroller and set to graphical and text mode. The home addresses for the internal graphical and text buffers in the LCD display component are set to 0x0000 and 0x2941 respectively, which determines where on the display the LCD starts to display the buffer data. Finally, the control signals are set up for the proper read/write operation on the LCD display.

```
; DATA
DATA NUM EQU 20H

; Text data "Graphical LCD T6963C for Multisim"

ADDWF PCL, 1
RETlw 0x27
RETlw 0x52
RETlw 0x91
RETlw 0x60
RETlw 0x48
RETlw 0x49
RETlw 0x43
RETlw 0x81
RETlw 0x4c
RETlw 0x00
RETlw 0x2C
.
```

```
START

BCF STATUS, RP0 ; BANK 0
CLRF PORTA
CLRF PORTB

BCF STATUS, RP0 ; BANK 1
MOVlw 0x80
;

MOVWF OPTION_REG
MOVlw 0x00
;

MOVWF TRISA
MOVlw 0x00
;

MOVWF TRISB

BCF STATUS, RP0 ; BANK 0
MOVlw 0x0F
;

MOVWF PORTA

; 1 SET DISPLAY MODE to GRAPH + TEXT mode, cursor off
MOVlw 0x5C
MOVWF COND_BUFFER
;

CALL CMD
```

..
Drawing Text and Graphics
The rest of the program sends commands to the LCD graphical display via the control lines through MCU pins RA0 to RA2 and data through the data lines:

```
; define string
MOVLW 0x7D
MOVWF DATA_BUFFER
MOVLW 0x29
MOVWF DATA_BUFFER ; external CG start at: 1400h
CALL ST2
MOVLW CMD_ADDRSET
MOVWF CMD_BUFFER
CALL CMD

MOVLW CMD_AWRON
MOVWF CMD_BUFFER
CALL CMD

MOVLW 0x00 ; Initial the counter
MOVWF ADDR_INDEX

LOOP_READ_DATA2
    MOVF ADDR_INDEX,0 ; STARTING data ADDRESS
    CALL TXPRT

    MOVWF DATA_BUFFER ; LOAD CHAR data TO U
    CALL ADT

    INCF ADDR_INDEX,1

    MOVWF ADDR_INDEX,0
    SUBWF DATA_NUM ; 35 chars
    TESTS STATUS, Z
    GOTO LOOP_READ_DATA2

MOVLW CMD_AUROFF
MOVWF CMD_BUFFER
CALL CMD
```

For example, the above excerpt from the main loop in the program sends the characters defined in the TXPRT subroutine to be displayed in text mode on the graphical LCD.

The following sets the LCD to auto write mode:

```
MOVLW CMD_AWRON
MOVWF CMD_BUFFER
CALL CMD
```

At this point, the program starts counting, and executes through the loop LOOP_READ_DATA2 35 times. This loop calls TXPRT to retrieve the text
data and load it into the W register. It then calls to the subroutine `ADT`, which calls `SEND_DATA`, which writes the values in the W register to port B, to be sent to the data lines of the LCD display. Once the data is sent, the proper value on port A of the microcontroller is sent to the control pins of the LCD display to let it know that the data is ready to be read. The subroutines all return at the end to the instruction just after the call to them and the same thing happens until all 35 characters have been transmitted. The final three instructions in the excerpt turn off the auto write mode in the LCD display after exiting the loop:

```
MOVLW CMD_AWROFF
MOVWF CMD_BUFFER
CALL CMD
```

The next few instructions draw the horizontal and sloped lines in graphical mode:

```
; 6 draw wave once
MOVF ADDR_L, 0
BTFSC STATUS, Z
CALL DRAW_WAVE
```

### Working with the MCU Debugging Features

This section provides a step-by-step walkthrough of Multisim’s MCU debugging features. It is important to follow the steps exactly as scripted, otherwise, the descriptions will no longer apply. Once you understand the breakpoint and single stepping features you can explore the possibilities of advanced MCU debugging.

### Debug View Overview

To write a program for a microcontroller either in C or assembly, you create source code files (.asm, .inc, .c, .h) as part of the MCU workspace, which can in turn be edited in the source code view.

Complete the following to access the source code view:

1. Double-click on the file item (for example, `main.asm`) shown in the MCU workspace hierarchy in the Design Toolbox.

During simulation, additional debugging information displays to help you understand what is happening inside the MCU. For example, you can switch between viewing events happening in the high level source and at
the assembly instruction level which also displays the actual opcodes for each instruction that are being executed by the MCU.

The source code view is not capable of displaying all this extra information. Instead, each MCU component in the circuit design has its own Debug View that displays debugging information.

Complete the following to access the Debug View:

1. Select MCU ➔ MCU PIC 16F84A U1 ➔ Build.

   **Note** The Debug View is available only after you have successfully built your code, so the preceding step is only necessary once.

2. Select MCU ➔ MCU PIC 16F84A U1 ➔ Debug View.

   Or

   Use the right-click context menu on an item in the MCU workspace of the Design Toolbox.

   ![Debug View](image)

Another tab opens in the schematic capture workspace called Debug(<reference designator of MCU>), in this case Debug(U1).
Use the drop-down list at the top of the Debug View to select between the disassembly instructions generated internally by Multisim and the listing file generated by the assembler or compiler (the format of the listing file is dependant on the tool that you choose to build your code).

In the LCD graphical display example, the code was written in assembly and built by the Microchip assembly tools. The Microchip assembler generates a listing file (.lst) that contains all of the opcodes generated for each assembly instruction. The debug listing view displays information from this listing file. Multisim generates the disassembly format using its internal disassembler to disassemble the opcodes into assembly instructions.

This format is not necessary for this example since the debug listing contains all of the information needed. In cases where an MCU project loads only the machine code (.hex) file, the disassembly view shows the disassembled opcode instructions so that you can see what’s happening in the MCU. Since no listing file for MCU projects of this type is available, the disassembly view is very useful.
Adding a Breakpoint

You can add breakpoints in the source code view when simulation has stopped, as well as during simulation. You can add breakpoints to a microcontroller project in two ways.

One way is to add them in the source code view. In this example, the main.asm tab in the schematic capture workspace is the only source code view available.

Note  If your MCU design contains more than one file, there will be a source code view for each of your source code files.

You can also set a breakpoint in the Debug View window. You can set breakpoints in the disassembly view or the debug listing view, but for this example, you will only use the debug listing view.

Complete the following to add a breakpoint in the source code view:

1. Open the Debug View for U1.
2. Double-click on main.asm in the Design Toolbox.
3. Scroll to the line just below the START label: BCF STATUS, RPO.
4. Double-click on the first (grey) column on the left side of the main.asm window next to the line BCF STATUS, RPO. A red circle appears at that location indicating that a breakpoint has been set at that line.
5. Select Simulate»Run. The simulation automatically pauses at the breakpoint that you have just set. The Debug View automatically displays with a yellow arrow showing where the MCU program execution is paused.

Complete the following to remove the breakpoint:

1. Double-click on the breakpoint in the Debug View or the main.asm source code view.

   Or

   Select MCU»Remove all breakpoints to remove all breakpoints.

   Note You can add and remove breakpoints in the Debug View in the same manner as the source code view.

Break and Step

1. Select MCU»Remove all breakpoints to remove all breakpoints.

2. Go to the circuit design view (the Getting Started MCU tab) and select Simulate»Run. The words “Graphical LCD T6963CC for Multisim” start to display on the graphical LCD component.

3. Select Simulate»Pause.

4. Go to the Debug View for U1 and notice that the line of code in the debug listing view where the MCU has stopped its execution is indicated by a yellow arrow in the left-most column.
5. Select MCU U1 Memory View to view the current state of the memory inside the microcontroller U1. Notice that the value of the program counter PC in the IROM section is one higher than the address value of the line the yellow arrow is pointing to. In the example in the above figure, the address in the Debug View is 192 and the PC value in the Memory View is 193.

Note: If the MCU has not finished executing the current command when you pause the simulation, the value in the program counter will be the same as the address value.

You can also look at the other sections of the Memory View to see the values inside the other parts of memory in the microcontroller.

6. Click the Step into button in the Simulation tool bar.

7. The current instruction is executed and the simulation pauses at the next instruction.

8. Select Simulate Stop.
Break and Step Out

1. Place a breakpoint in the SEND_DATA subroutine at MOVWF PORTB.
2. Select Simulate►Run. The simulation pauses at the breakpoint.
3. Click the Step out button in the Simulation toolbar to step out of the SEND_DATA subroutine.
4. The simulation executes all of the remaining instructions in the SEND_DATA subroutine and pauses at the first instruction after the call to the SEND_DATA subroutine.

Break and Step Into

1. Select MCU►Remove All Breakpoints.
2. Place a breakpoint at the call to SEND_DATA where you had just stepped out of just above the yellow arrow.
3. Select Simulate►Run. The simulation pauses at breakpoint that you just placed.
4. Click the Step Into button on the Simulation toolbar. The simulation pauses inside the SEND_DATA subroutine.

Break and Step Over

1. Select Simulate►Run. The simulation pauses at the same breakpoint that you set previously at the call to the subroutine SEND_DATA.
2. Click the Step Over button on the Simulation toolbar. The entire SEND_DATA subroutine is executed and the simulation pauses at the instruction after the CALL SEND_DATA instruction.

Run to Cursor

1. Select MCU►Remove All Breakpoints.
2. Click on a line inside the SEND_DATA subroutine since we know that this subroutine will be called again to send data to the LCD display.
3. Click the Run to Cursor button in the Simulation toolbar. The simulation runs until the MCU hits the instruction that you clicked on inside the SEND_DATA subroutine. It then pauses and places the yellow arrow next to that line.
Technical Support and Professional Services

Visit the following sections of the award-winning National Instruments Web site at ni.com for technical support and professional services:

- **Support**—Technical support at ni.com/support includes the following resources:
  - **Self-Help Technical Resources**—For answers and solutions, visit ni.com/support for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on. Registered users also receive access to the NI Discussion Forums at ni.com/forums. NI Applications Engineers make sure every question submitted online receives an answer.
  - **Standard Service Program Membership**—This program entitles members to direct access to NI Applications Engineers via phone and email for one-on-one technical support as well as exclusive access to on demand training modules via the Services Resource Center. NI offers complementary membership for a full year after purchase, after which you may renew to continue your benefits.

For information about other technical support options in your area, visit ni.com/services, or contact your local office at ni.com/contact.

- **Training and Certification**—Visit ni.com/training for self-paced training, eLearning virtual classrooms, interactive CDs, and Certification program information. You also can register for instructor-led, hands-on courses at locations around the world.

- **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.
If you searched ni.com and could not find the answers you need, contact your local office or NI corporate headquarters. Phone numbers for our worldwide offices are listed at the front of this manual. You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.
Index

Numerics
3D designs in Ultiboard, 3-22

A
analysis, 2-14
assembly program, 4-4
autoplacement, 3-19
autorouting, 3-20

B
bill of materials, 2-17
board clean-up, 3-21
board outline, 3-4
BOM, 2-17
break and step, 4-11
break and step into, 4-13
break and step out, 4-13
break and step over, 4-13
breakpoint, 4-10

C
comments, 3-22
connection machine trace, 3-17
conventions used in the manual, v

D
diagnostic tools (NI resources), A-1
documentation
   conventions used in the manual, v
   NI resources, A-1
dragging parts, 3-8, 3-9
drivers (NI resources), A-1

E
examples (NI resources), A-1
exporting files from Ultiboard, 3-22

F
follow-me trace, 3-17

G
grapher, 2-15

H
help, technical support, A-1

I
instrument drivers (NI resources), A-1
interface elements, 2-1, 3-1

K
KnowledgeBase, A-1

M
manual trace, 3-14
manufacturing/assembly, 3-21
MCU debugging features, 4-7
MCU debugging overview, 4-7
MCU tutorial, 4-2
MCU tutorial overview, 4-1
moving parts in Ultiboard, 3-12
Multisim tutorial overview, 2-3
Index

N
National Instruments support and services, A-1
NI support and services, A-1

O
opening Multisim files, 2-4
opening Ultiboard tutorial, 3-3

P
placing components in Multisim, 2-5
placing parts in Ultiboard, 3-8, 3-10
placing traces in Ultiboard, 3-13
placing Ultiboard dB parts, 3-11
postprocessor, 2-16
products, 1-1
programming examples (NI resources), A-1

R
reports, 2-16
run to cursor, 4-13

S
saving Multisim files, 2-4
schematic capture, 2-4
simulation, 2-12
software (NI resources), A-1
support, technical, A-1

T
technical support, A-1
training and certification (NI resources), A-1
troubleshooting (NI resources), A-1
tutorial descriptions, 1-1
two-pinned components
dropping directly onto a wire, 2-9

U
user interface
   elements, 2-1

V
virtual instruments, 2-12

W
Web resources, A-1
wiring components in Multisim, 2-9