USER GUIDE

NI USB-6000
USB Multifunction DAQ Device
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ni.com/manuals

This user guide describes how to use the National Instruments USB-6000 data acquisition
(DAQ) device.
The NI USB-6000 is a USB device that provides eight single-ended analog input (AI) channels,
four digital input/output (DIO) channels, and a 32-bit counter.
Figure 1. NI USB-6000 Top and Back Views

1

1
2

Screw Terminal Connector Plug
LED Indicator

3

2

3

Micro-B USB Connector

Contents
Safety Guidelines ...................................................................................................................... 3
Electromagnetic Compatibility Guidelines...............................................................................3
Unpacking ................................................................................................................................. 4
Packing List ...................................................................................................................... 4
Setting Up the Device ............................................................................................................... 4
Installing the Software ...................................................................................................... 4
Preparing the Hardware .................................................................................................... 5
Verifying the Installation .................................................................................................. 5
Using the NI USB-6000 in an Application ...............................................................................6
Features ..................................................................................................................................... 7
Block Diagram .................................................................................................................. 7
LED Indicator ................................................................................................................... 7
Cables and Accessories............................................................................................................. 8
Pinout and Signal Descriptions................................................................................................. 9
Analog Input ............................................................................................................................. 10
Connecting Analog Input Signals ..................................................................................... 11
Wiring Considerations .............................................................................................. 12
AI Start Trigger................................................................................................................. 13
Digital I/O ................................................................................................................................. 14
Power-On States ............................................................................................................... 14
Source/Sink Information...................................................................................................14
I/O Protection.................................................................................................................... 15
PFI 0 and PFI 1 ......................................................................................................................... 16
Using PFI 0 as a Counter Source ...................................................................................... 16
Using PFI 1 to Trigger an Analog Input Acquisition ....................................................... 16
Where to Go from Here ............................................................................................................ 16
Example Programs............................................................................................................ 16
Related Documentation..................................................................................................... 16
Where to Go for Support .......................................................................................................... 19

2

|

ni.com

|

NI USB-6000 User Guide

Safety Guidelines
Operate the NI USB-6000 only as described in this document.
Refer to the Read Me First: Safety and Electromagnetic Compatibility
document for important safety and electromagnetic compatibility information. To
obtain a copy of this document online, visit ni.com/manuals and search for the
document title.

Caution

Caution Do not operate the device in a manner not specified in this document.
Misuse of the device can result in a hazard. You can compromise the safety protection
built into the device if the device is damaged in any way. If the device is damaged,
contact National Instruments for repair.
Caution Do not substitute parts or modify the device except as described in this
document. Use the device only with the chassis, modules, accessories, and cables
specified in the installation instructions.
Caution Do not operate the device in an explosive atmosphere or where there may
be flammable gases or fumes. If you must operate the device in such an environment,
it must be in a suitably rated enclosure.

Electromagnetic Compatibility Guidelines
This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) stated in the product specifications. These requirements
and limits provide reasonable protection against harmful interference when the product is
operated in the intended operational electromagnetic environment.
This product is intended for use in industrial locations. However, harmful interference may
occur in some installations, when the product is connected to a peripheral device or test object,
or if the product is used in residential or commercial areas. To minimize interference with radio
and television reception and prevent unacceptable performance degradation, install and use this
product in strict accordance with the instructions in the product documentation.
Furthermore, any modifications to the product not expressly approved by National Instruments
could void your authority to operate it under your local regulatory rules.
To ensure the specified EMC performance, the length of any wire or cable
connected to the screw terminal connector must be no longer than 0.5 m (20 in.).
Caution
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Unpacking
The NI USB-6000 ships in an antistatic package to prevent electrostatic discharge (ESD). ESD
can damage several components on the device.
Caution

Never touch the exposed pins of connectors.

To avoid ESD damage in handling the device, take the following precautions:
•

Ground yourself with a grounding strap or by touching a grounded object.

•

Touch the antistatic package to a metal part of your computer chassis before removing the
device from the package.

Remove the device from the package and inspect it for loose components or any other signs of
damage. Notify NI if the device appears damaged in any way. Do not install a damaged device
in your computer.
Store the device in the antistatic package when the device is not in use.

Packing List
The NI USB-6000 is shipped in a box that contains:
•

NI USB-6000

•

Screw terminal connector plug

•

Hi-Speed USB Cable

•

NI-DAQmx DVD

•

NI USB-6000 Quick Start

Setting Up the Device
Complete the following steps to get started with the device.
Note For instructions applicable to all NI DAQ devices, refer to ni.com/
gettingstarted.

Installing the Software
1.

Install the application software, as described in the installation instructions that accompany
your software. Refer to Table 1 for available application software you can use with your
device.

2.

Install NI-DAQmx, version 9.8 or later.

3.

Register your products when the NI Product Registration Wizard appears.
Note
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Latest NI software releases are available for download at ni.com/support.
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Preparing the Hardware
1.

Insert the screw terminal connector plug into the connector jack on the device. Refer to
Figure 2.

2.

The Hi-Speed USB cable has two different connectors on each end. Plug the smaller
Micro-B USB connector into the device, and plug the larger USB connector into a
USB port. Refer to Figure 2.
Figure 2. Hardware Setup for NI USB-6000
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Verifying the Installation
1.

Launch Measurement & Automation Explorer (MAX) by double-clicking the NI MAX
icon on the desktop, or (Windows 8) by clicking Measurement & Automation Explorer
from NI Launcher.

2.

Expand My System»Devices and Interfaces and verify that the NI USB-6000 is listed.
If your device does not appear, press <F5> to refresh the view in MAX. If your device is
still not recognized, refer to ni.com/support/daqmx for troubleshooting information.

3.

Right-click your device and select Self-Test. When the self-test finishes, a message
indicates successful verification or if an error occurred. If an error occurs, refer to
ni.com/support/daqmx.

4.

Connect the wires (1.31 to 0.08 mm2, or 16 to 28 AWG) to the screw terminals by stripping
6.35 mm (0.25 in.) of insulation, inserting the wires into the screw terminals, and securely
tightening the screws. Refer to Figure 4 for the NI USB-6000 pinout.

5.

Right-click your device and select Test Panels. A test panel appears.

6.

Click Start to test the device functions, or Help for operating instructions. If an error
message is displayed, refer to ni.com/support/daqmx.

7.

Click Close to exit the test panel.
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Using the NI USB-6000 in an Application
You can use the DAQ Assistant through many NI application software programs to configure
virtual and measurement channels. Table 1 lists DAQ Assistant tutorial locations for NI
applications.
Table 1. DAQ Assistant Tutorial Locations

NI Application
Software

Tutorial Location

LabVIEW

Go to Help»LabVIEW Help. Next, go to Getting Started with
LabVIEW»Getting Started with DAQ»Taking an NI-DAQmx
Measurement in LabVIEW.

LabWindows™/CVI™

Go to Help»Contents. Next, go to Using LabWindows/CVI»
Data Acquisition»Taking an NI-DAQmx Measurement in
LabWindows/CVI.

Measurement Studio

Go to NI Measurement Studio Help»NI Measurement Studio
Help. Next, go to Developing Projects with Measurement
Studio»Getting Started with the Measurement Studio Class
Libraries»Measurement Studio Walkthroughs»
Walkthrough: Creating a Measurement Studio NI-DAQmx
Application.

SignalExpress

Go to Help»Taking an NI-DAQmx Measurement in
SignalExpress.

Refer to the Where to Go from Here section for information about programming examples for
NI-DAQmx.
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Features
Block Diagram
Figure 3 shows key functional components of the NI USB-6000.
Figure 3. NI USB-6000 Block Diagram
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LED Indicator
The NI USB-6000 has a blue LED indicator that indicates device status, as listed in Table 2.
Table 2. LED State/Device Status

LED State

Device Status

Off

Device not connected or in suspend.

On, not blinking

Device connected and functioning normally.

Blinking

Device has encountered an error. Wait 10 seconds to allow the
device to attempt to recover from the error. If the LED keeps
blinking, disconnect and reconnect the device. If the error
persists, contact National Instruments. Refer to the Where to
Go for Support section for contact information.
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Cables and Accessories
Table 3 contains information about cables and accessories available for the NI USB-6000.
Note For a complete list of accessories and ordering information, refer to the
pricing section of the NI USB-6000 product page at ni.com.

Table 3. NI USB-6000 Cables and Accessories

Accessory

8

Part Number

Description

USB-6000 Accessory Kit

782703-01

Four additional screw-terminal connectors
and a screwdriver

USB-6000 Series
Prototyping Accessory

779511-01

Unshielded breadboarding accessory for
custom-defined signal conditioning and
prototyping.

Hi-Speed USB Cable,
A to Micro-B, 1 m

782909-01

—

Hi-Speed USB Cable,
A to Micro-B, 2 m

782909-02

—
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Pinout and Signal Descriptions
Figure 4 shows the pinout of the NI USB-6000. Refer to Table 4 for a detailed description of
each signal.
Figure 4. NI USB-6000 Pinout
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Table 4. Signal Descriptions

Signal
Name

Reference

Direction

Description

D GND

—

—

Digital Ground—The reference point for
digital signals.

AI GND

—

—

Analog Input Ground—The reference
point for analog input measurements.

P0.<0..3>

D GND

Input or
Output

Port 0 Digital I/O
Channels 0 to 3—Configure each signal
individually as an input or output.
Refer to the Digital I/O section for more
information.

PFI 0

D GND

Input

PFI 0—An edge counter input. Refer to the
Using PFI 0 as a Counter Source section for
more information.
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Table 4. Signal Descriptions (Continued)

Signal
Name

Reference

Direction

Description

PFI 1

D GND

Input

PFI 1—A digital trigger input. Refer to the
Using PFI 1 to Trigger an Analog Input
Acquisition section for more information.

AI <0..7>

AI GND

Input

Analog Input Channels 0 to 7—Analog
input voltage channels. Refer to the Analog
Input section for more information.

Analog Input
The NI USB-6000 has eight ±10 V fixed-range analog input channels for single-ended analog
input measurements.
Figure 5 shows the analog input circuitry of the NI USB-6000.
Figure 5. NI USB-6000 Analog Input Circuitry
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1 MΩ
MUX

AMP

ADC

AI FIFO

AI 7
1 MΩ

The main blocks featured in the analog input circuitry are as follows:
•

MUX—The multiplexer (MUX) routes one AI channel at a time to the amplifier (AMP).

•

AMP—The amplifier (AMP) buffers analog input signal, before the signal is sampled by
the analog-to-digital converter (ADC).

•

ADC—The analog-to-digital converter (ADC) digitizes the AI signal by converting the
analog voltage into digital code.

•

AI FIFO—The NI USB-6000 can perform both single and multiple analog-to-digital
conversions of a fixed or infinite number of samples. A first-in-first-out (FIFO) buffer
holds data during AI acquisitions to ensure that no data is lost.
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Connecting Analog Input Signals
To connect voltage signals to the NI USB-6000, connect the positive voltage signal to an
AI terminal, and the ground signal to an AI GND terminal, as shown in Figure 6.
Figure 6. Connecting a Referenced Single-Ended Voltage Signal
AI

Voltage
Source

NI USB-6000

AI GND

Signals of ±10 V at any analog input pin with respect to AI GND are accurately measured.
Beyond ±10 V, the input signal will begin clipping as shown in Figure 7. Typically, this clipping
begins at ±10.5 V.
Figure 7. Exceeding ±10 V on AI Returns Clipped Measurement Result
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Wiring Considerations
The following sections describe how to wire floating and ground-referenced signals to minimize
measurement errors.
Table 5. Analog Input Configurations

Floating Signal Sources
(Not Connected to Building Ground)

Examples:
• Ungrounded thermocouples
• Signal conditioning with isolated outputs
• Battery devices

Ground-Referenced Signal Sources

Example:
• Plug-in instruments with non-isolated
outputs

Signal Source
Signal Source

NI USB-6000

NI USB-6000
AI

+
–

AI

+
–

+

+
–

–

VA

VB

AI GND

AI GND

Ground-loop potential (VA – VB) are added
to measured signal.

Floating Signal Sources
A floating signal source is not connected to the building ground system, but instead has an
isolated ground-reference point, as shown in Table 5. Some examples of floating signal sources
are outputs of transformers, thermocouples, battery-powered devices, optical isolators, and
isolation amplifiers. An instrument or device that has an isolated output is a floating signal
source.

Wiring Floating Signal Sources
The AI channels on the NI USB-6000 share a common reference point, AI GND. This type of
AI is known as Referenced Single-Ended (RSE). For input signals that requires a separate
ground-reference point or return signal, consider using an NI DAQ device with differential
inputs.
Noise coupling is one of the main error sources in measurements. Electrostatic and magnetic
noise coupling are the result of differences in the signal path. Magnetic coupling is proportional
to the area between the two signal conductors. Electrical coupling is a function of how much the
electric field differs between the two conductors. To reduce these noises, NI recommends the
following wiring methods:
•

Reduce the wire length between leads connecting the signals to the device.

•

Twist each input signal with an AI GND to minimize the area between conductors.
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When using RSE connections with floating signal sources, the AMP rejects both the
common-mode noise in the signal and the ground potential difference between the signal source
and the device ground.
Refer to the NI Developer Zone document, Field Wiring and Noise Considerations for Analog
Signals, for more information. To access this document, go to ni.com/info and enter the Info
Code rdfwn3.

Ground-Referenced Signal Sources
A ground-referenced signal source is a signal source connected to the building system ground,
as shown in Table 5. It is already connected to a common ground point with respect to the device,
assuming that the computer is plugged into the same power system as the source. Non-isolated
outputs of instruments and devices that plug into the building power system fall into this
category.
The difference in ground potential between two instruments connected to the same building power
system is typically between 1 and 100 mV, but the difference can be much higher if power
distribution circuits are improperly connected. If a grounded signal source is incorrectly measured,
this difference can appear as measurement error. Follow the connection instructions for grounded
signal sources to eliminate this ground potential difference from the measured signal

Wiring Ground-Referenced Signal Sources
The AI channels on the NI USB-6000 share a common reference point, AI GND. This type of
AI is known as Referenced Single-Ended (RSE).
When using RSE connections with ground-referenced signal sources, there can be a potential
difference between AI GND and the ground of the sensor as shown in the bottom-rightmost cell
of Table 5. This ground loop causes measurement errors, and care must be taken to minimize
this error.
For static ground loop error, measuring the potential difference between AI GND (VB) and the
ground of the sensor (VA) prior to signal measurement and then subtracting it from the signal
measurement helps to minimize the error.
For dynamic ground loop errors, using an NI DAQ product that has differential input capability
helps to fully minimize the error.
Refer to the NI Developer Zone document, Field Wiring and Noise Considerations for Analog
Signals, for more information. To access this document, go to ni.com/info and enter the Info
Code rdfwn3.

AI Start Trigger
You can configure PFI 1 as the AI Start Trigger for analog input tasks. Refer to the Using PFI 1
to Trigger an Analog Input Acquisition section for more information.

NI USB-6000 User Guide
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Digital I/O
The NI USB-6000 has four digital lines, P0.<0..3>. D GND is the ground-reference signal for
digital I/O. You can individually program each line as input or output.
All digital I/O updates and samples are software-timed.
Figure 8 shows P0.<0..3> connected to signals configured as digital inputs and digital outputs.
Figure 8. Example of Connecting a Load
NI USB-6000

+5 V

D GND
Switch

P0.0

1

P0.1

LED

2

P0.2
+5 V

3

P0.3
LED

4

I/O Connector
1
2
3
4

P0.0 configured as a digital input receiving a 0 V or 5 V signal from a switch
P0.1 configured as an active drive digital output driving an LED
P0.2 configured as a digital input receiving a TTL signal
P0.3 configured as an open collector digital output driving an LED

Exceeding the maximum input voltage ratings or maximum output
ratings, which are listed in the NI USB-6000 Specifications document, can damage
the device and the computer. National Instruments is not liable for any damage
resulting from such signal connections.
Caution

Power-On States
At system startup and reset, the hardware sets all DIO lines to high-impedance inputs. The DAQ
device does not drive the signal high or low. Each line has a weak pull-down resistor connected
to it.

Source/Sink Information
The default configuration of the digital I/O ports is active drive, allowing 3.3 V operation, with
a source/sink current limit of ±4 mA.
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The ports can be configured as open collector using NI-DAQmx API, allowing operation with a
different voltage level when used in conjunction with an external user-provided pull-up resistor.
The connection for such a situation is as shown in Figure 9.
Figure 9. Example of Connecting an External User-Provided Resistor
Vpull-up
(User Provided, ≤5 V)

VCC
External
Load
GND

External
Pull-Up
Resistor
Rpull

P0.0 with Output Drive Type
Set to Open Collector

47.5 kΩ
Onboard
Pull-Down
Resistor

NI USB-6000
Note: Ensure that the current flowing across Rpull does not violate the maximum sinking current specifications
(4 mA).

For more information about how to set the DIO configuration, refer to the KnowledgeBase
document, Configuring NI Devices to be Open-Drain (Open Collector) or Push-Pull (Active
Drive). To access this document, go to ni.com/info and enter the Info Code ex52sp.

I/O Protection
To protect the NI USB-6000 against overvoltage, undervoltage, and overcurrent conditions, as
well as ESD events, you should use the following guidelines:
•

If you configure a DIO line as an output, do not connect it to any external signal source,
ground signal, or power supply.

•

If you configure a DIO line as an output, understand the current requirements of the load
connected to these signals. Do not exceed the specified current output limits of the DAQ
device.
National Instruments has several signal conditioning solutions for digital applications
requiring high current drive.

•

If you configure a DIO line as an input, do not drive the line with voltages outside of its
normal operating range. The DIO lines have a smaller operating range than the AI signals.

•

Treat the DAQ device as you would treat any static-sensitive device. Always properly
ground yourself and the equipment when handling the DAQ device or connecting to it.

NI USB-6000 User Guide

|

© National Instruments

|

15

PFI 0 and PFI 1
Using PFI 0 as a Counter Source
You can configure PFI 0 as a source for counting digital edges. In this mode, rising- or
falling-edges are counted using a 32-bit counter. For more information, refer to the NI USB-6000
Specifications document.

Using PFI 1 to Trigger an Analog Input Acquisition
You can configure an analog input task to wait for an edge on PFI 1 before starting the
acquisition. To do this, configure the AI Start Trigger source to be PFI 1 and specify either
rising- or falling-edge.

Where to Go from Here
This section lists where you can find example programs for the NI USB-6000 and relevant
documentation.

Example Programs
NI-DAQmx driver software includes example programs to help you get started programming
with the NI USB-6000. Modify example code and save it in an application, or use examples to
develop a new application, or add example code to an existing application.
To locate NI software examples, go to ni.com/info and enter the Info Code daqmxexp.
For additional examples, refer to zone.ni.com.
To run examples without the device installed, use an NI-DAQmx simulated device. For more
information, in Measurement & Automation Explorer (MAX), select Help»Help Topics»
NI-DAQmx» MAX Help for NI-DAQmx and search for simulated devices.

Related Documentation
Note

You can download these documents at ni.com/manuals.

Each application software package and driver includes information about writing applications
for taking measurements and controlling measurement devices. The following references to
documents assume you have NI-DAQmx 9.8 or later, and where applicable, version 8.5 or later
of the NI application software.

NI USB-6000
The NI USB-6000 Quick Start packaged with the NI USB-6000 describes how to install
NI-DAQmx and NI application software, install the device, and confirm that your device is
operating properly.
The NI USB-6000 Specifications lists the specifications to which the device complies with.
16
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NI-DAQmx
The NI-DAQ Readme lists which devices, ADEs, and NI application software are supported by
this version of NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQ Readme.
The NI-DAQmx Help contains API overviews, general information about measurement
concepts, key NI-DAQmx concepts, and common applications that are applicable to all
programming environments. Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx Help.

LabVIEW
If you are a new user, use the Getting Started with LabVIEW manual to familiarize yourself with
the LabVIEW graphical programming environment and the basic LabVIEW features you use to
build data acquisition and instrument control applications. Open the Getting Started with
LabVIEW manual by selecting Start»All Programs»National Instruments»LabVIEW»
LabVIEW Manuals or by navigating to the labview\manuals directory and opening
LV_Getting_Started.pdf.
Use the LabVIEW Help, available by selecting Help»LabVIEW Help in LabVIEW, to access
information about LabVIEW programming concepts, step-by-step instructions for using
LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, and
tools. Refer to the following locations on the Contents tab of the LabVIEW Help for information
about NI-DAQmx:
•

Getting Started with LabVIEW»Getting Started with DAQ—Includes overview
information and a tutorial to learn how to take an NI-DAQmx measurement in LabVIEW
using the DAQ Assistant.

•

VI and Function Reference»Measurement I/O VIs and Functions»DAQmx - Data
Acquisition VIs and Functions—Describes the LabVIEW NI-DAQmx VIs and functions.

•

Property and Method Reference»NI-DAQmx Properties contains the property
reference.

•

Taking Measurements—Contains the conceptual and how-to information you need to
acquire and analyze measurement data in LabVIEW, including common measurements,
measurement fundamentals, NI-DAQmx key concepts, and device considerations.

LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains Taking an NI-DAQmx
Measurement in LabWindows/CVI, which includes step-by-step instructions about creating a
measurement task using the DAQ Assistant. In LabWindows/CVI, select Help»Contents, then
select Using LabWindows/CVI»Data Acquisition. This book also contains information about
accessing detailed information through the NI-DAQmx Help.
The NI-DAQmx Library book of the LabWindows/CVI Help contains API overviews and
function reference for NI-DAQmx. Select Library Reference»NI-DAQmx Library in the
LabWindows/CVI Help.

NI USB-6000 User Guide
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Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio using Visual C# or
Visual Basic .NET, you can interactively create channels and tasks by launching the DAQ
Assistant from MAX or from within Visual Studio. You can use Measurement Studio to generate
the configuration code based on your task or channel. Refer to the DAQ Assistant Help for
additional information about generating code.
The NI Measurement Studio Help is fully integrated with the Microsoft Visual Studio help. To
view this help file from within Visual Studio, select Measurement Studio»NI Measurement
Studio Help. For information related to developing with NI-DAQmx, refer to the following
topics within the NI Measurement Studio Help:
•

For step-by-step instructions on how to create an NI-DAQmx application using the
Measurement Studio Application Wizard and the DAQ Assistant, refer to Walkthrough:
Creating a Measurement Studio NI-DAQmx Application.

•

For help with NI-DAQmx methods and properties, refer to NationalInstruments.DAQmx
namespace and NationalInstruments.DAQmx.ComponentModel namespace.

•

For conceptual help with NI-DAQmx, refer to Using the Measurement Studio NI-DAQmx
.NET Library and Creating Projects with Measurement Studio NI-DAQmx.

•

For general help with programming in Measurement Studio, refer to Getting Started with
the Measurement Studio Class Libraries.

To create an NI-DAQmx application using Visual Basic .NET or Visual C#, follow these general
steps:
1.

In Visual Studio, select File»New»Project to launch the New Project dialog box.

2.

Choose a programming language (Visual C# or Visual Basic .NET) then select
Measurement Studio to see a list of project templates.

3.

Select NI DAQ Windows Application. You add DAQ tasks as part of this step.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information about measurement
concepts. Select Start»All Programs»National Instruments»NI-DAQ»NI-DAQmx Help.
The NI-DAQmx C Reference Help describes the NI-DAQmx Library functions, which you can
use with National Instruments data acquisition devices to develop instrumentation, acquisition,
and control applications. Select Start»All Programs»National Instruments»NI-DAQ»
Text-Based Code Support»NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
You can use NI-DAQmx to create .NET applications in Visual C# and Visual Basic .NET
without installing Measurement Studio. You install NI-DAQmx .NET support from the
NI-DAQmx installer. Expand the Application Development Support feature and enable the
.NET Framework [version] Languages Support sub-feature to install this support on your
machine. To view the NI-DAQmx .NET documentation, go to Start»All Programs»National
Instruments»NI-DAQ»Text-Based Code Support. The documentation includes the
NI-DAQmx API overview, measurement tasks and concepts, and function reference. For
18
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function reference, refer to the NationalInstruments.DAQmx namespace and
NationalInstruments.DAQmx.ComponentModel namespace topics. For conceptual help, refer to
the Using the Measurement Studio NI-DAQmx .NET Library and Developing with Measurement
Studio NI-DAQmx sections.

Training Courses
If you need more help getting started developing an application with NI products, NI offers
training courses. To enroll in a course or obtain a detailed course outline, refer to ni.com/
training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.
Many DAQ specifications and user guides/manuals are available as PDFs. You must have Adobe
Reader 7.0 or later (PDF 1.6 or later) installed to view the PDFs. Refer to the Adobe Systems
Incorporated Web site at www.adobe.com to download Acrobat Reader. Refer to the National
Instruments Product Manuals Library at ni.com/manuals for updated documentation
resources.

Where to Go for Support
The National Instruments Web site is your complete resource for technical support. At
ni.com/support you have access to everything from troubleshooting and application
development self-help resources to email and phone assistance from NI Application Engineers.
A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European
Communities using the manufacturer’s declaration of conformity. This system affords the user
protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC
for your product by visiting ni.com/certification. If your product supports calibration,
you can obtain the calibration certificate for your product at ni.com/calibration.
National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world to
help address your support needs. For telephone support in the United States, create your service
request at ni.com/support and follow the calling instructions or dial 512 795 8248. For
telephone support outside the United States, visit the Worldwide Offices section of
ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact
information, support phone numbers, email addresses, and current events.

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for more information on National Instruments trademarks. Other
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