LabWindows™ /CVI™ Release Notes
Version 2009
These release notes introduce the beta version of LabWindows™/CVI™ 2009. Refer to this document for
system requirements, installation and activation instructions, and information about new features in
LabWindows/CVI.
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Minimum System Requirements
To run LabWindows/CVI, you must have the following:
•

Personal computer using a Pentium 1 GHz or higher microprocessor

•

Microsoft operating systems:
–

Windows 7 (32-bit and 64-bit)

–

Windows Vista (32-bit and 64-bit)

–

Windows XP (32-bit)

–

Windows 2000 Service Pack 3 or later

Note

LabWindows/CVI 2009 is the last major release to support Windows 2000.

•

1024 × 768 resolution (or higher) video adapter

•

Minimum of 128 MB of RAM, 512 MB recommended

•

1.1 GB free hard disk space for full installation, which includes the Interface to Win32 Application
Programmatic Interface (API).
Note

•

Installing the Documentation from MSDN Library requires additional disk space.

Microsoft-compatible mouse

Installation Instructions
The LabWindows/CVI Platform DVD includes LabWindows/CVI and the following modules and
toolkits.
Modules
•

Real-Time Module

•

Vision Development Module

Toolkits
•

Execution Profiler Toolkit

•

PID Toolkit

•

Real-Time Execution Trace Toolkit

•

Signal Processing Toolkit

•

SQL Toolkit
Note

The LabWindows/CVI Platform DVD also includes the Documentation from MSDN Library.

If you purchased any of these modules or toolkits, you can install them using the LabWindows/CVI
Platform DVD. If you want to evaluate any of these modules or toolkits before purchasing them, you
can install these add-ons from the LabWindows/CVI Platform DVD and try them for free for 30 days.
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Complete the following steps to install LabWindows/CVI:
Note If you already have a different version of LabWindows/CVI installed on your computer,
be sure to install version 2009 in a different directory. If you want to install to an existing directory,
uninstall the other version before installing LabWindows/CVI 2009.

1.

Insert the LabWindows/CVI media into the disk drive. If the media does not run automatically,
open Windows Explorer, right-click the disk drive icon, and select AutoPlay.

2.

On installation startup, the National Instruments LabWindows/CVI 2009 screen appears.
Click Install LabWindows/CVI, Modules, and Toolkits.

3.

In the Product List panel, select all the products you want to install. Select Install to install
products using default options. Selecting Install with customization opens additional dialog
boxes that require your input.

4.

In the Product Information panel, determine whether to allow the installer to contact National
Instruments to search for new notifications, such as critical updates, on the products you are
installing. The checkbox is enabled by default.

5.

In the User Information panel, enter your name and organization.

6.

Enter the serial number, from the Certificate of Ownership card in the software kit, in the
appropriate field for each product you install. LabWindows/CVI uses this serial number when you
run the NI Activation Wizard. Leave the Serial Number field blank to evaluate the product.
Note

To activate a National Instruments product after you evaluate it, refer to the Activation
Instructions section of this document.

7.

Continue to follow the instructions on the screen.
Note

If you selected Device Drivers in the Product List, after installing LabWindows/CVI and any
selected modules and toolkits, the LabWindows/CVI installer prompts you to insert the National
Instruments Device Drivers DVD. Follow the instructions on the screen to install the device drivers.

Activation Instructions
You can activate licenses you have purchased for LabWindows/CVI, modules, and toolkits during
installation. If you do not activate a valid license for LabWindows/CVI or any modules and toolkits that
you install, the unlicensed product operates in evaluation mode. After you install the product, the
evaluation begins the first time you launch the product and lasts 30 consecutive days. When the
evaluation period expires, you must activate a valid license to continue using the product.
You can activate LabWindows/CVI or any module or toolkit in the following ways:
•

During installation, as described in the Installation Instructions section of this document.

•

After installation, by enabling the Run License Manager to activate the product(s) checkbox on
the Installation Summary panel of the LabWindows/CVI Platform DVD installer.

•

After you launch LabWindows/CVI for the first time with any product in evaluation mode,
click the Activate Products button in the LabWindows/CVI Message dialog box.

•

Select Help»Activate LabWindows/CVI while LabWindows/CVI is running in evaluation mode
or select Start»All Programs»National Instruments»NI License Manager to launch the
NI License Manager.
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If you do not activate LabWindows/CVI or any modules and toolkits during installation,
LabWindows/CVI prompts you to activate when you launch LabWindows/CVI. After you activate
the licenses for all LabWindows/CVI products you installed, you no longer see this prompt.
Once you choose your activation method and launch the NI Activation Wizard, complete the following
steps to activate LabWindows/CVI and any modules or toolkits:
1.

Select the Automatically activate through a secure Internet connection option and click Next.
Your computer must be connected to the Internet for this option to work. If you do not have Internet
access, refer to the instructions following these steps.

2.

Enter the serial numbers for the products you want to activate. Click Next.

3.

Fill in the necessary information and click Next.

4.

Check the option and enter an email address if you would like to receive a confirmation email of
your activation and click Next.

5.

After a brief moment, a message appears, indicating whether LabWindows/CVI has been activated.
Click Next.

6.

Continue to follow the instructions on the screen.

7.

When you successfully activate LabWindows/CVI and any modules or toolkits, click Finish.
LabWindows/CVI displays a window indicating when your license expires.

If you do not have Internet access, complete the following steps to activate LabWindows/CVI:
1.

Select the Use a web browser, email client, telephone, or fax machine to acquire an activation
code option to acquire an activation code. Click Next.

2.

Select Use a Web browser on this or another computer. If you have multiple NI products
installed on your computer, you may need to select the version of LabWindows/CVI and any
modules or toolkits you want to activate. Click Next.

3.

Verify the serial number and correct it as necessary, click Next, then click Save this information
to save the serial number, computer ID, product, and version number in a text file. You will need
this information for the following steps.

4.

On a computer that has internet access, go to the NI License Activation Web page at
ni.com/activate.

5.

Select the product you want to activate and specify the version number. Then click the GO button.

6.

Fill out the form with the information required and click Continue. This step generates the
activation code for you.

7.

Go back to the LabWindows/CVI activation dialog box and enter that activation code to activate
LabWindows/CVI.

8.

Complete steps 4 through 7 for each product you want to activate.
Note If you are unable to activate LabWindows/CVI, refer to the NI License Activation Web page
at ni.com/activate.
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What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI 2009.
Note The Real-Time features require the LabWindows/CVI 2009 Real-Time Module. Additionally,
the Execution Profiler features require the LabWindows/CVI Execution Profiler Toolkit.

Installing LabWindows/CVI
With LabWindows/CVI 2009 you can install LabWindows/CVI and select toolkits from the
LabWindows/CVI Platform DVD.
Additionally, LabWindows/CVI ships both the Base Package and Full Development System on the same
DVD. Depending on the serial number you enter during installation, the NI License Manager activates
either the Base Package or the Full Development System.

LabWindows/CVI Execution Profiler Toolkit
The LabWindows/CVI Execution Profiler Toolkit is available with the LabWindows/CVI 2009 release
of products. You must purchase the Execution Profiler Toolkit separately. Use the Execution Profiler
Toolkit to analyze and optimize the run-time performance of your application.
If you install the Execution Profiler Toolkit, select Start»All Programs»National Instruments»
LabWindows CVI Execution Profiler Toolkit to access the following toolkit documentation:
•

LabWindows/CVI Execution Profiler Toolkit Readme—Contains important information about the
toolkit, including installation and activation instructions and known issues.

•

LabWindows/CVI Execution Profiler Toolkit Help—Describes how to use the toolkit to analyze
code from your LabWindows/CVI application.

Creating 64-bit Applications
Use LabWindows/CVI to build and distribute executables and DLLs that take full advantage of 64-bit
systems. 64-bit applications have more memory capacity, which might improve application performance
because more data is loaded into memory.
To create a 64-bit application, select Build»Configuration»Release x64 or Build»Configuration»
Debug x64. To create a 64-bit distribution, select 64-bit Windows Installer in the New Distribution
dialog box. You can build 64-bit applications on any system, but you can only run or install 64-bit
applications on Windows 7 64-bit or Windows Vista 64-bit.
You must make certain modifications to your existing code to ensure that it adheres to 64-bit
programming guidelines. For more information about porting your code, refer to the Programmer
Reference»Creating 64-bit Applications Versus 32-bit Applications»Porting 32-bit Code to 64-bit Code
topic in the LabWindows/CVI Help.
For more information about creating 64-bit applications, refer to the Programmer Reference»Creating
64-bit Applications Versus 32-bit Applications book in the LabWindows/CVI Help.

Attribute Browser
Use the Attribute Browser to update panel and control attributes. The Attribute Browser contains a tree
view of the attributes and values of the attributes related to the selected panels and controls in the
active .uir. When you select or open a .uir file in the Window Confinement Region, the Attribute
Browser appears in place of the Library Tree.
You can select and edit the attributes of multiple controls simultaneously; however, only the attributes
that the controls have in common are available for edit in the Attribute Browser.
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For more information about using the Attribute Browser, refer to the Using LabWindows/CVI»
LabWindows/CVI Workspace»Workspace Window Overview»Attribute Browser topic in the
LabWindows/CVI Help.

Progress Bar Control
Use the progress bar instrument driver, available in the Tools Library, to create and customize progress
bars. The progress bar is also available as a custom control in the User Interface Editor. Select
Create»Custom Controls»Toolslib Controls»Progress Bar to include a progress bar custom control
on the GUI.
For more information about the progress bar, refer to the Tools Library»Progress Bar Control book in
the LabWindows/CVI Help.

Extended Data in the Variables and Watch Windows
The Variables and Watch windows display extended information for certain data types that you can use
when debugging your LabWindows/CVI application. Some LabWindows/CVI-defined data types
automatically display extended data. For example, a variable of ListType displays the number of list
items. You also can expand the variable to view the contained list items. For other data types, you can
choose to interpret the variable as a specific data type. For example, to interpret a panel handle variable,
which is an integer value, as a true panel handle, right-click the variable and select Specific Type»Panel
Handle from the context menu. LabWindows/CVI then displays the title of the panel next to the integer
value.
The context menu for the windows includes the following new options:
•

Specific Type—Use this option to identify a variable as a conceptual type, like Panel Handle, that
LabWindows/CVI cannot otherwise infer from the declared type.

•

Element Type—Use this option to view contained elements for some aggregate data types, such
as ListType and CMTTSQHandle, as typed objects rather than generic memory blocks.

You can disable the extended data display in the Variables and Watch windows by deselecting the
Enable extended Variables/Watch window displays checkbox in the Environment dialog box.
The Enable extended Variables/Watch window displays checkbox is enabled by default.
For more information about debugging techniques using the Variables and Watch windows, refer to the
Using LabWindows/CVI»Debugging Tools»Using the Variables and Watch Windows book in the
LabWindows/CVI Help.

Importing and Exporting LabWindows/CVI Preferences between Versions
Use the Import/Export Settings Wizard to transfer LabWindows/CVI environment settings to different
installation versions of LabWindows/CVI, restore customized environment settings, or reset some or all
of the environment settings to the default state. Select Import/Export Settings from the Tools menu or
select Start»All Programs»National Instruments»LabWindows CVI 2009»Tools»Import-Export
Settings to open the Import/Export Settings Wizard. You can transfer settings such as fonts, macros,
colors, and shortcut keys, among others.
For more information about the Import/Export Settings Wizard, refer to the Using LabWindows/CVI»
Wizards and Tools»Importing and Exporting LabWindows/CVI Settings topic in the LabWindows/CVI
Help.

LabWindows/CVI Release Notes

6

ni.com

Generating Documentation from Code Comments
You can generate XML or HTML documentation from code comments in .c files while in debug
configuration. To insert template comment tags you can edit and then use to generate documentation,
place the cursor before a function definition in the Source window and select Edit»Insert Construct»
Function Documentation Tags or use the <Ctrl-Shift-G> shortcut key.
The template tags inserted are /// HIFN, /// HIRET, and ///HIPAR. LabWindows/CVI customizes
the tags for the function.
To generate documentation from code comments, select one of the following from the Generate help
from source pull-down menu in the Target Settings dialog box:
•

None (default)

•

XML

•

HTML

•

HTML & XML

For more information about generating documentation from code comments, refer to the Using
LabWindows/CVI»Writing Source Code»Editing a Source File»Documentation Tags for Source Code
topic in the LabWindows/CVI Help.

NI Distributed System Manager
LabWindows/CVI 2009 includes the NI Distributed System Manager that replaces the Variable
Manager as the unified tool to manage network variables. Use the System Manager to create and monitor
variables, processes, and I/O servers. Also, use the System Manager to interact with the
Shared Variable Engine and to manage security and aliases.

TDMS Performance Improvements
LabWindows/CVI 2009 includes TDMS 2.0, which you can use to log data more quickly using
NI-DAQ 9.0 and later. In addition, you can use new functions to create and open TDMS files with
Windows system buffering disabled or enabled, to perform asynchronous writes, specify the byte order
to use when you create new TDMS files, convert between TDMS 1.0 and 2.0 files, and more.
You also can use the following new functions:
•

TDMS_AppendDataValuesMultiChannel

•

TDMS_AppendDataValuesMultiChannelTimestampComponents

•

TDMS_CreateFileEx

•

TDMS_ConvertFileFormat

•

TDMS_GetChannelByName

•

TDMS_GetChannelGroupAndChannelByName

•

TDMS_GetChannelGroupByName

•

TDMS_GetFileFormat

•

TDMS_OpenFileEx

UDP Multicast Support (Real-Time)
The LabWindows/CVI UDP Library multicast functions, UDPMulticastSubscribe and
UDPMulticastUnsubscribe, are supported in RT applications.
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Additional LabWindows/CVI Enhancements
LabWindows/CVI 2009 includes the following additional enhancements. Refer to the LabWindows/CVI
Help for more information about these features.

Functions
The following functions are new in LabWindows/CVI 2009.
Advanced Analysis
•

NonLinearFitWithWeight

•

NormalizeCorrelate

Toolbar
•

Toolbar_GetToolbarInItemEvent

Toolbox
•

BinStrToUInt

•

DelayWithEventProcessing

•

GetDragAndDropData

•

GetRoutedWinMsgParams

•

ListApplyToEachEx

•

StrToLongLong

•

StrToULongLong

•

SetRoutedWinMsgResult

•

UIntToBinStr

•

ULongLongToBinStr

User Interface
You can create string, ring, combo box, button, checkbox, color picker, and horizontal bar cell types in
the Tree Control. Use the following functions to configure these cells:
•

DeleteTreeCellRingItems

•

GetActiveTreeCell

•

GetNumTreeCellRingItems

•

GetTreeCellRingIndexFromValue

•

GetTreeCellRingValueFromIndex

•

GetTreeCellRingValueLengthFromIndex

•

InsertTreeCellRingItem

Additional User Interface Functions

•

GetTimerTickData

Attributes
The following attributes are new in LabWindows/CVI 2009.
Network Variable Connection
•
CNVVariableDescriptionAttribute
•

CNVVariablePrototypeAttribute
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User Interface
•
ATTR_COLOR_PICKER_VALUE
•

ATTR_HORIZONTAL_BAR_VALUE

•

ATTR_MENU_WIDTH

•

ATTR_USE_PROGRESS_BAR_VISUAL_STYLES

•

ATTR_TREE_EDITABLE_CELLS

Toolslib
•
ASYNC_ATTR_TIMER_TIME
•

ASYNC_ATTR_DELTA_TIME

•

ATTR_PATH_CTRL_AUTOCOMPLETE_PATH

•

ATTR_PATH_CTRL_SHOW_HISTORIC_FILES

•

ATTR_PATH_CTRL_TAB_COMPLETES_PATH

Events
The following events are new in LabWindows/CVI 2009.
User Interface
•
EVENT_BEGIN_EDIT_TREE_CELL
•

EVENT_TREE_CELL_ACTIVE_ITEM_CHANGE

•

EVENT_TREE_CELL_BEGIN_MENU

•

EVENT_TREE_CELL_COMMIT

•

EVENT_TREE_CELL_VAL_CHANGED

Menus and Context Menu Changes
•

•

The All Installation Locations context menu item on the Files tab of the Edit Installer directory
includes two new options:
–

[Program Data]—On Windows XP/2000, a typical value for this directory
is C:\Documents and Settings\All Users\Application Data.
On Windows 7/Vista, a typical value for this directory is C:\ProgramData.

–

[Public Documents]—On Windows XP/2000, a typical value for this directory is
C:\Documents and Settings\All Users\Documents. On Windows 7/Vista,
a typical value for this directory is C:\Users\Public\Documents.

The All Installation Locations context menu item on the Files tab of the Edit Installer directory
includes two changed options:
–

[CVIPUBDOCSDIR] is [CVI Public Documents]

–

[CVISHAREDDIR] is [CVI Shared]

•

The Files tab of the Edit Installer dialog box includes the Make Writable for All Users context
menu option. Use this option to unlock subdirectories of the Program Files, Program Data, and
Public Documents directories, excluding any National Instruments and Microsoft subdirectories.

•

The Registry Keys tab of the Edit Installer dialog box includes the Make Writable for
All Users context menu option. Use this option to unlock subkeys of the
HKEY_CLASSES_ROOTS\Software and HKEY_LOCAL_MACHINE\Software keys,
excluding any National Instruments and Microsoft subkeys.
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•

The Watch window includes the Remove Watch Expression and Options context menu options.
Use these options to remove watch expressions from the window, specify data types for extended
data display, and specify other configuration options, respectively.

•

The Variables window includes the Specific Type and Options context menu options. Use these
options to specify data types for extended data display and specify other configuration options
respectively.

•

In the Memory Display window, select a contiguous memory range, right-click and select Add
Memory Watch Expression from the shortcut menu to add a memory-specific expression to the
Watch window.

•

Select a control then select Edit»Delete in the Function Panel Editor to delete a control from a
function panel. You also can select the control and press the <Delete> key to remove the control.
Undo is not available when you delete a control.

•

Select Test 32-bit IVI Specific Driver or Test 64-bit IVI Specific Driver from the Tools Menu
to test IVI drivers. These options are available only on 64-bit systems with the IVI Specific Driver
Test Suite and IVI Installer Creator installed.

•

To open the Find or Replace dialog boxes with the Multiple files checkbox enabled automatically,
select Find in Files or Replace in Files from the Edit menu of the Source or Interactive Execution
windows.

•

In the Source window, you can close and open a currently selected block of code and its contained
blocks of code by selecting from one of the following options:
–

Select View»Collapsible Regions»Collapse/Expand Region and Subregions in the Source
window.

–

Right-click the plus/minus sign of the collapsible region and select Collapse/Expand Region
and Subregions.

Dialog Box Changes
•

Select 64-bit Windows Installer (.msi) in the Type pull-down menu of the New Distributions
dialog box to create an installer for 64-bit Windows systems.

•

The Windows Installer (.msi) option in the Type pull-down menu of the New Distributions dialog
box is renamed 32-bit Windows Installer (.msi).

•

The Advanced tab of the Edit Installer dialog box includes the Install custom Run-Time Engine
message file option. Use this option to install a custom run-time engine message file; for example,
use this option to include a localized version of the run-time engine.

•

The Advanced tab of the Edit Installer dialog box includes the Sign Installer Executable option.
Use this option to sign an installer and configure options for the certificate.

•

The General tab of the Edit Installer dialog box includes the Allow installation directory
selection option. Disable this option to prevent the user from selecting an alternate installation
directory.

•

The General tab of the Edit Installer dialog box includes the Upgrade Behavior section. Select
Use Installer Version or Side-by-Side (Do Not Upgrade) to set the upgrade behavior of the
installer.

•

General improvements to the Edit Installer dialog box, such as expanding the size, listing file types,
and repositioning controls to allow for ease-of-use.

•

The Environment Options dialog box includes the Default to project directory when opening
files option. Use this option to set the current project directory as the directory location that
LabWindows/CVI defaults to when looking for files to open.
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•

Use the Find or Filter text box in the Select Attribute Constant dialog box to search for text in the
attribute name column and, depending on the setting, find the text in the tree or filter the results
respectively. Click Find or Filter to change the functionality.

•

Enable the Show all control types checkbox in the Select UIR Constant dialog box to view a list
of all constant names in the selected .uir file. If the Show all control types checkbox is disabled,
LabWindows/CVI displays only the constant names applicable to the function panel.

•

When you select Controls from Constant type in the Select UIR Constant dialog box, you can
enable the Show all control types checkbox to view a list of all constant names in the selected
.uir file. If the Show all control types checkbox is disabled, LabWindows/CVI displays only the
constant names applicable to the function panel.

•

You can select Vertical Bar or Base Zero Vertical Bar from the Trace Style pull-down menu
of the Edit Traces dialog box to create bar plots. You also can set the plot style attribute to
VAL_VERTICAL_BAR or VAL_BASE_ZERO_VERTICAL_BAR.

•

After you click OK in the main Create LabWindows/CVI .NET Controller dialog box,
LabWindows/CVI launches a renaming dialog box. Remove the checkmark from a checkbox in the
.NET Identifier column of the renaming dialog box to exclude the .NET identifier from the
generated wrapper. LabWindows/CVI selects all identifiers by default.

•

The Text Information section of the Version Info dialog box includes the following symbolic
variables:
–

%rel_dbg—Expands to Release or Debug

–

%arch—Expands to x86 or x64

Additional Features
•

Starting with this version of LabWindows/CVI, major versions align with the year in which they
release. For example, this version of LabWindows/CVI is called LabWindows/CVI 2009. You can
find installed files in the CVI2009 folder in the various locations where LabWindows/CVI installs
files. The registry keys corresponding to this version of LabWindows/CVI are located in CVI\9.1
in the registry.

•

The Variables and Watch windows preserve the format and expansion state of the variable in the
window during the debugging session.

•

The Variables and Watch windows display values in red text if the variable value changed from the
last time the program was suspended.

•

LabWindows/CVI defines the following predefined macros: CVI_Base if you activate the
LabWindows/CVI Base package or CVI_FDS if you activate the LabWindows/CVI Full
Development System.

•

LabWindows/CVI defines the NDEBUG macro if you enable Build»Configuration»Release or
Release x64.

•

LabWindows/CVI recognizes the extern "C" keyword. LabWindows/CVI allows you to use
extern "C" with blocks of code at file scope. LabWindows/CVI treats functions and variables
using extern "C" as extern declarations.

•

Use the /// INCL file comment tag in the .h file to include the specified header file when
LabWindows/CVI generates the function tree.

•

Use the /// NUM comment tag in the .h file to define a numerical control.

•

Use the VAL_NON_LEAF mask in the stateCriteria parameter of the GetNumTreeItems,
GetTreeItem, GetTreeItemFromLabel, GetTreeItemFromValue functions to search
among items that have children.
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•

Strip charts support ATTR_YLOOSE_FIT_AUTOSCALING and
ATTR_YLOOSE_FIT_AUTOSCALING_UNIT for the y axis.

•

The Resource Tracking window supports tracking graph plot resources.

•

Use the Find text box in the Library Tree to locate functions.

•

LabWindows/CVI displays function prototypes when you hover the mouse cursor over a function
in the Library Tree.

•

The status bar in the Source window has moved to the bottom of the Workspace window. The status
bar displays information including line number, column number, text selection mode, configuration
mode, and so on.

•

LabWindows/CVI supports the _Pragma keyword from the C99 specification.

•

LabWindows/CVI supports Intel C++ 11.1 as an external compiler.

•

LabWindows/CVI includes the following 64-bit data types:
–
–
–
–
–

size_t
ssize_t
ptrdiff_t
unintprt_t
intprt_t

•

LabWindows/CVI supports the following format modifiers for formatting functions: z, t, and b0.

•

You can create Microsoft Compiled Help files (.chm) from function trees, and then use the .chm
file to link help topics to type libraries.

Launching Examples from the LabWindows/CVI Function Help
You can launch examples from LabWindows/CVI function topics in the LabWindows/CVI Help and the
function panel help. Click the Open example button ( ) to launch an example demonstrating the use
of the function.

Deprecated Features
The following features are deprecated in LabWindows/CVI 2009.
•

The Options»Translate LW/DOS Program options is deprecated.

•

LabWindows/CVI no longer supports Borland C/C++ as an external compiler.

•

Projects created from the New»Project option no longer include _dbg in the file name in debug
configuration.

LabWindows/CVI Resources
How do I get started?
Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for learning basic
LabWindows/CVI program development techniques.
Are there known issues or late-breaking information?
Refer to the LabWindows/CVI Readme, which you can access from Start»All Programs»
National Instruments»LabWindows CVI 2009»LabWindows CVI 2009 Readme. The readme file
contains information about known issues.
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Where can I find reference information?
The LabWindows/CVI Help contains complete reference information. The help file includes the
following sections:
•

Using LabWindows/CVI describes the LabWindows/CVI development environment and features.

•

Library Reference provides information about functions you can call in LabWindows/CVI.

•

Programmer Reference provides information to help you develop applications.

•

Tools Library provides information about the LabWindows/CVI Toolslib controls.

•

LabWindows/CVI Real-Time Module Help includes an introduction to the LabWindows/CVI
Real-Time Module, programming considerations for RT applications, and function reference
information for the LabWindows/CVI Real-Time Utility Library.

•

LabWindows/CVI Execution Profiler Toolkit Help includes an introduction to the
LabWindows/CVI Execution Profiler Toolkit and information about using the toolkit to profile
your applications.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For information
about how to use the search functionality, refer to the Using Help»Searching Help topic of the
LabWindows/CVI Help.
Where can I find examples?
Find examples with the NI Example Finder, which you can access by selecting Help»Find Examples.
LabWindows/CVI example programs are located in the following location on Windows 7/Vista:
C:\Users\Public\Documents\National Instruments\CVI2009\samples.
On Windows XP/2000, example programs are located in the following location: C:\Documents and
Settings\All Users\Documents\National Instruments\CVI2009\samples.
Is there a list of LabWindows/CVI documentation?
The Guide to LabWindows/CVI Documentation topic provides links to LabWindows/CVI
documentation, including manuals, application notes, and white papers. You can access the Guide
to LabWindows/CVI Documentation topic through the LabWindows/CVI Help.
Where else can I go for LabWindows/CVI information?
Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most up-to-date
information about LabWindows/CVI.

© National Instruments Corporation

13

LabWindows/CVI Release Notes

CVI, National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments
Corporation. Refer to the Terms of Use section on ni.com/legal for more information about
National Instruments trademarks. The mark LabWindows is used under a license from Microsoft
Corporation. Windows is a registered trademark of Microsoft Coporation in the United States and other
countries. Other product and company names mentioned herein are trademarks or trade names of their
respective companies. For patents covering National Instruments products/technology, refer to the
appropriate location: Help»Patents in your software, the patents.txt file on your media, or the
National Instruments Patent Notice at ni.com/patents. For copyright notices, conditions, and
disclaimers including information regarding certain third-party components used in LabWindows/CVI,
refer to the Copyright topic in the LabWindows/CVI Help.
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