LabWindows™ /CVI™ Release Notes
Version 9.0
These release notes introduce LabWindows™/CVI™ 9.0. Refer to this document for system
requirements, installation and activation instructions, and information about new features in
LabWindows/CVI.
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Minimum System Requirements
To run LabWindows/CVI, you must have the following:
•

Personal computer using a Pentium 1 GHz or higher microprocessor

•

Microsoft Windows Vista/XP/2000 Service Pack 3 or later

•

1024 × 768 resolution (or higher) video adapter

•

Minimum of 128 MB of RAM, 512 MB recommended

•

200 MB free hard disk space for full installation

•

Microsoft-compatible mouse

Installation Instructions
Complete the following steps to install LabWindows/CVI:
Note If you already have a different version of LabWindows/CVI installed on your computer, be
sure to install version 9.0 in a different directory or uninstall the other version before installing
LabWindows/CVI 9.0.

1.

Insert the LabWindows/CVI CD into the CD drive. If the CD does not run automatically, open
Windows Explorer, right-click the CD drive icon, and select AutoPlay.

2.

On installation startup, the National Instruments LabWindows/CVI 9.0 screen appears. Click the
Next button if you are not taken automatically to the User Information panel of the dialog box.

3.

In the User Information panel, enter your name and organization. Select one of the following
options:
•

Install this product using the following serial number

•

Install this product for evaluation

If you choose to enter a serial number, enter the serial number found on your Certificate of
Ownership card. LabWindows/CVI uses this serial number when you run the NI Activation
Wizard.
4.

Continue to follow the instructions on the screen.
Note For installation instructions for the LabWindows/CVI Real-Time Module, refer to the
LabWindows/CVI Real-Time Module Readme.

Activation Instructions
You can activate LabWindows/CVI when the installation completes, or you can activate when
you launch LabWindows/CVI. To activate at the end of the installation, click Next to launch the
NI Activation Wizard. To activate later, deselect the Activate this version of LabWindows/CVI now
option. If you choose to activate later, a dialog box prompts you to activate a LabWindows/CVI license
or run in evaluation mode when you first launch LabWindows/CVI. Click Activate in this dialog box to
launch the NI Activation Wizard.
Complete the following steps to activate LabWindows/CVI:
1.

Select the Automatically activate through a secure Internet connection option and click Next.
Your computer must be connected to the Internet for this option to work. If you do not have Internet
access, refer to the instructions following these steps.

2.

LabWindows/CVI populates the textbox with the serial number you entered during installation.
Click Next.

3.

Fill in the necessary information and click Next.

4.

Check the option and enter an email address if you would like to receive a confirmation email of
your activation and click Next.

5.

After a brief moment, a message appears, indicating whether LabWindows/CVI has been activated.
Click Next.

6.

Continue to follow the instructions on the screen.

7.

When you successfully activate LabWindows/CVI, click Finish. LabWindows/CVI displays a
window indicating when your license expires.
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If you do not have Internet access, complete the following steps to activate LabWindows/CVI:
1.

Select the Use a web browser, email client, telephone, or fax machine to acquire an activation
code option to acquire an activation code. Click Next.

2.

Select Use a Web browser on this or another computer. If you have multiple NI products
installed on your computer, you may need to select the version of LabWindows/CVI you want to
activate. Click Next.

3.

Keep the default serial number, click Next, and click Save this information to save the serial
number, computer ID, product, and version number in a text file.

4.

Go to the NI License Activation Web page at ni.com/activate.

5.

Select LabWindows/CVI as the Product to Activate, 9.0 as the Product Version, and click the
GO button.

6.

Fill out the form with the information required and click Continue. This step generates the
activation code for you.

7.

Go back to the LabWindows/CVI activation dialog box and enter that activation code to activate
LabWindows/CVI.

8.

If you are unable to activate LabWindows/CVI, refer to the NI License Activation Web page at
ni.com/activate.
Note

For activation instructions for the LabWindows/CVI Real-Time Module, refer to the
LabWindows/CVI Real-Time Module Readme.

What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI 9.0.
Note

The Real-Time features require the LabWindows/CVI 9.0 Real-Time Module.

Resource Leak Detection
Use the Resource Tracking window to locate potential memory leaks in your LabWindows/CVI
program. Select Extended as the Debugging level in the Debugging Options section of the Build
Options dialog box to enable resource tracking interactively. You also can enable, disable, and detect
resource tracking programmatically using the SetEnableResourceTracking and
GetEnableResourceTracking functions located in the Utility Library.
Note

The Resource Tracking window and associated functions are available only in the
LabWindows/CVI Full Development System.

For more information about the Resource Tracking window, refer to the Using LabWindows/CVI»
Debugging Tools»Resource Tracking Window topic of the LabWindows/CVI Help.

Precompiled Header Files and Faster Build Times
Decrease the amount of time required to compile a large project by using precompiled headers. When
you enable the Compile with precompiled include file option in the Build Options dialog box,
LabWindows/CVI precompiles a prefix header file that references frequently referenced header files.
When compiling, LabWindows/CVI loads the precompiled header file instead of the header files listed
in the prefix header file.
For more information about using precompiled header files, refer to the Programmer Reference»
LabWindows/CVI Compiler Overview»Precompiled Headers topic of the LabWindows/CVI Help.
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Compiler Extensions
LabWindows/CVI supports the following C99 extensions:
•

Mixed declarations and statements

•

For loop variable declarations

•

Variable-length arrays

•

Designated initializers

•

atoll, snprintf, strtoll, strtoull, and vsnprintf functions

•

Variable argument macros

•

Non-constant initializers for aggregate types

•

long long integers

•

__func__ identifier

•

inline and restrict keyword recognition
Note

C99 extensions might not be supported in external compilers.

For more information about C99 extensions, refer to the Programmer Reference»LabWindows/CVI
Compiler Overview»C Language Extensions»C99 Extensions Supported in LabWindows/CVI topic of
the LabWindows/CVI Help.

Updated Interface to Win32 API
This version of LabWindows/CVI installs an updated version of the Interface to Win32 Application
Programmatic Interface (API), known in previous versions of LabWindows/CVI as the Windows SDK.
For more information about the import libraries in the Full Development System, refer to the
Programmer Reference»Compiler/Linker Issues»Calling Interface to Win32 API Functions in
LabWindows/CVI topic of the LabWindows/CVI Help.
Note The Interface to Win32 API is based on the Windows Server 2003 R2 Platform SDK. The
Windows Server 2003 R2 Platform SDK was released in March 2006 and does not include tools or
functionality added in later versions of the SDK, such as support for functionality specific to
Windows Vista.

National Instruments Binary Time Format
The CVI Time functions in the Utility Library and the Time Conversions functions in the Programmer’s
Toolbox provide the ability to interact with the National Instruments Binary Time Format (NI-BTF).
Use the CVI Time functions to manipulate absolute calendar times and time intervals. The Time
Conversions functions convert LabWindows/CVI ANSI C Library, User Interface Library, Network
Variable Library, and FILETIME time values to and from NI-BTF.
Use NI-BTF if you need a finer resolution than other date-time types, need a platform-neutral date-time
type, or want to share date-time information with other NI application development environments.

Mixed Character Sets in a Single User Interface
Use the following functions and attributes to display text in multiple languages with different character
sets in the same user interface. You also can use these functions and attributes to ensure that text
containing non-Western characters displays correctly, independent of the operating system settings.
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Functions
•

CreateMetaFontWithCharacterSet

•

GetMetaFontInfoWithCharacterSet

•

SetPanelCharacterSet

Attributes
•

ATTR_ANNOTATION_CAPTION_CHARACTER_SET

•

ATTR_LABEL_CHARACTER_SET

•

ATTR_MENU_BAR_CHARACTER_SET

•

ATTR_TEXT_CHARACTER_SET

•

ATTR_TITLE_CHARACTER_SET

•

ATTR_XLABEL_CHARACTER_SET

•

ATTR_XYNAME_CHARACTER_SET

•

ATTR_YLABEL_CHARACTER_SET

You also can set these attributes in the Edit Control dialog boxes in the User Interface Editor.

Updated Icon Editor
The Icon Editor supports 48 × 48 and 256 × 256 icons, 32-bit color depth, and.png-based images with
compression and alpha-blending. The Icon Editor also contains a Color Eyedropper Tool.
Select Tools»Icon Editor to open the Icon Editor. For more information about the Icon Editor, refer to
the Using LabWindows/CVI»Wizards and Tools»Icon Editor topic of the LabWindows/CVI Help.

Editing Instrument Drivers on Windows Vista
LabWindows/CVI can assist you in editing instrument drivers installed to directories on Windows Vista
that require administrator privileges to modify files. If you attempt to edit an instrument driver in a
write-protected IVI or VXIplug&play framework directory, LabWindows/CVI prompts you for
permission to copy the files to a directory with write access. If you accept, LabWindows/CVI copies the
files to a directory with write access and creates a project DLL to allow you to edit and build the
instrument. To replace the files in the original location with the edited copies, click the Deploy button
in the Edit Instrument dialog box, select the Deploy Instrument context menu item in the Library Tree,
or follow the prompts when you unload the project.
For more information about the editing instrument drivers in write-protected directories, refer to the
Using LabWindows/CVI»Instrument Drivers»Editing Instrument Drivers in Write-Protected
Directories topic of the LabWindows/CVI Help.

Reliance File System Support (Real-Time)
The Reliance™ file system provides quick disk access and data preservation in the event of a power
failure. The LabWindows/CVI Real-Time Module supports the Reliance file system on desktop PC
real-time (RT) targets.

NI-Watchdog for Real-Time Targets (Real-Time)
The LabWindows/CVI Real-Time Module includes support for watchdog timer hardware on supported
PXI real-time targets. Use the NI-Watchdog functions in the Real-Time Utility Library to detect and
respond to failure conditions in your application, even if your software becomes unresponsive.
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Internet Library Support (Real-Time)
The LabWindows/CVI Internet Library is supported on RT targets. The Internet Library includes
functions to access the services of FTP, Telnet, POP3, and SMTP servers from your RT applications.

Additional LabWindows/CVI Enhancements
LabWindows/CVI 9.0 includes the following additional enhancements. Refer to the LabWindows/CVI
Help for more information about these features.

Functions
Analysis
•

ConvolveEx

•

CorrelateEx

•

CxMatrixVectorMul

•

MatrixVectorMul

Interface to Win32 API (Real-Time)
•

ReadConsoleOutputA

•

SetConsoleTextAttribute

LabWindows/CVI ActiveX Server Interface
•

GetCurrentProject

•

GetCVIVersion

•

SetManifestFile

•

SetWorkingDirectory

Miscellaneous Programmer’s Toolbox
•

HostIsBigEndian

•

HostIsLittleEndian

•

ToBigEndian16

•

ToLittleEndian16

•

ToOtherEndian16

TCP Support
•

GetTCPHostConnectionAddr

User Interface
•

FontSelectPopupEx

•

GetBitmapFromFileEx

•

GetLegendItemFromPoint

•

GetNumImagesInFile

•

SetColumnWidthToWidestCellContents
Note

The SetColumnWidthToWidestCellContents is new for table controls. It existed for
tree controls in previous versions of LabWindows/CVI.

•

SetFontPopupDefaultsEx

•

SetRowHeightToTallestCellContents

•

SetTextCtrlHeight
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Windows Registry
•

RegEnumerateKey

•

RegRemoveKey

•

RegRemoveValue

Additional Function Changes
•

The Runtime Error Report class is renamed to Debugging and Runtime Error Reporting.

User Interface Attributes
•

ATTR_ENABLE_DRAG_DROP

•

ATTR_ENABLE_CHARACTER_MASKING

•

ATTR_FIRST_PLOT

•

ATTR_FIXED_PLOT_AREA

•

ATTR_FORCE_SMOOTH_DRAGGING

•

ATTR_FRAME_ACTUAL_HEIGHT

•

ATTR_FRAME_ACTUAL_WIDTH

•

ATTR_MASK_CHARACTER

•

ATTR_MENU_ARROW_HEIGHT

•

ATTR_MENU_ARROW_WIDTH

•

ATTR_NEXT_PLOT

•

ATTR_NUM_PLOTS

•

ATTR_SLIDE_INCDEC_LENGTH

•

ATTR_SNAP_COLUMN_WIDTHS_TO_CTRL_WIDTH

•

ATTR_TITLEBAR_ACTUAL_THICKNESS

Menus and Context Menu Changes
•

The Specify External Process menu item on the Run menu is now the Specify Executable to
Debug menu item.

•

The Switch Execution Target menu item on the Run menu is now the Select Execution Target
for Debugging menu item.

•

Functionality from the Select Target with Options dialog box is now accessible through Run»
Select Execution Target for Debugging»New Execution Target and Run»Select Execution
Target for Debugging»Manage Execution Targets.

•

Move the cursor to the previous or next region boundary in the Source window by selecting
View»Collapsible Regions»Go to Previous Region Boundary and View»Collapsible Regions»
Go to Next Region Boundary.

•

Right-click within the References tab in the Source Code Browser window and select Find to open
the Find dialog box. You then can search for text in the Results column in the Source Code
Browser.

•

Select Edit»Select All in the Help Editor to select all text in the Help Editor window and position
the keyboard cursor at the end of the file.

•

The Run»Threads and Run»Loaded Modules menu items are now Window»Threads and
Window»Modules respectively. LabWindows/CVI displays the windows in the Debugging
Region.
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Microsoft Visual Studio 2008 Support
You can use Microsoft Visual Studio 2008 to create a new Visual C++ project that uses
LabWindows/CVI libraries or converts an existing LabWindows/CVI project into a Visual C++ project.
You also can use Visual Studio 2008 as the release configuration compiler from within the
LabWindows/CVI environment.

Color Picker Control
Use the Color Picker Control, available in the Tools Library, and associated functions to select colors.
Functions
•

ColorPicker_Convert

•

ColorPicker_GetActiveColorCell

•

ColorPicker_GetAreaFromPoint

•

ColorPicker_GetAttribute

•

ColorPicker_GetColor

•

ColorPicker_GetCustomColor

•

ColorPicker_GetCustomColors

•

ColorPicker_GetFixedColor

•

ColorPicker_GetFixedColors

•

ColorPicker_InstallCallback

•

ColorPicker_Revert

•

ColorPicker_SetActiveColorCell

•

ColorPicker_SetAttribute

•

ColorPicker_SetColor

•

ColorPicker_SetCustomColor

•

ColorPicker_SetCustomColors

•

ColorPicker_SetFixedColor

•

ColorPicker_SetFixedColors

•

ColorPicker_SizeChanged

HyperLink Control
Use the HyperLink Control, available in the Tools Library, and associated functions to create and
manage hyperlinks.
•

NewHyperLinkCtrl

•

SetHyperLinkCtrlAttribute

•

GetHyperLinkCtrlAttribute

•

RevertHyperLinkCtrlAttribute
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Dialog Box Changes
•

Select Custom directory in the Where to copy DLL pull-down menu of the Target Settings dialog
box to copy the DLL into a directory of your choice when the DLL is built.

•

Select IVI standard root directory + VXIplug&play directory in the Where to copy DLL
pull-down menu of the Target Settings dialog box to copy the DLL to both the to both the bin
directory under the IVI framework directory and the bin directory under the VXIplug&play
framework directory.

•

You can specify a working directory to use for debugging in the one of following ways:
–

Select Run»Command Line and designate a working directory in the Working Directory
field.

–

If the project is a DLL project, select Run»Specify Executable to Debug and designate a
working directory in the Working Directory field.

•

Select the Automatically save copy of UIR as TUI file option in the Editor Preferences dialog box
to save a .uir file as an ASCII text formatted .tui file automatically.

•

When you build an installer that includes additional installers or components, you might be
prompted with the Distributions Needed dialog box if LabWindows/CVI cannot locate the installer
you selected or any of the dependencies of the installer.

•

Edit the font of all windows that appear in the Workspace window using the Environment Font
Preferences dialog box.

•

Click the Build Steps button in the Manage Distributions dialog box to launch a Build Steps dialog
box. Use this dialog box to add pre- and post-build steps for each distribution in the Manage
Distributions dialog box.

•

Select Mark Files in Project or Mark Files in Workspace in the Find dialog box to quickly select
files only in the project or workspace respectively to include in your search.

Additional Features
•

Use the IgnoreUnreferencedIdentifiers pragma to set specific symbol names to ignore.

•

Use the EVENT_MOUSE_WHEEL_SCROLL event data parameter for horizontal scroll events.

•

The Watch window includes a Scope column that contains the scope information for the watch
expression.

•

In the Graphical Array View, you now can edit the minimum and maximum axis label, zoom and
pan the graph, and return the graph to its original state by right-clicking it and selecting Reset
graph from the context menu.

Submitting Feedback on LabWindows/CVI Help
All topics in the LabWindows/CVI Help include a Submit feedback on this topic link. Click this link
to submit feedback and suggestions for improvement on specific topics in the LabWindows/CVI Help.
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LabWindows/CVI Resources
How do I get started?
Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for learning basic
LabWindows/CVI program development techniques.
Are there known issues or late-breaking information?
Refer to the LabWindows/CVI Readme, which you can access from Start»All Programs»
National Instruments»LabWindows CVI 9.0»LabWindows CVI 9.0 Readme. The readme file
contains information about known issues.
Where can I find reference information?
The LabWindows/CVI Help contains complete reference information. The help file includes the
following sections:
•

Using LabWindows/CVI describes the LabWindows/CVI development environment and features.

•

Library Reference provides information about functions you can call in LabWindows/CVI.

•

Programmer Reference provides information to help you develop applications.

•

Tools Library provides information about the LabWindows/CVI Toolslib controls.

•

LabWindows/CVI Real-Time Module Help includes an introduction to the LabWindows/CVI
Real-Time Module, programming considerations for RT applications, and function reference
information for the LabWindows/CVI Real-Time Utility Library.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For information
about how to use the search functionality, refer to the Using Help»Searching Help topic of the
LabWindows/CVI Help.
Where can I find examples?
Find examples with the NI Example Finder, which you can access by selecting Help»Find Examples.
LabWindows/CVI example programs are located in the following location on Windows Vista:
C:\Users\Public\Documents\National Instruments\CVI90\samples. On
Windows XP/2000, example programs are located in the following location: C:\Documents and
Settings\All Users\Documents\National Instruments\CVI90\samples.
Is there a list of LabWindows/CVI documentation?
The Guide to LabWindows/CVI Documentation topic provides links to LabWindows/CVI
documentation, including manuals, application notes, and white papers. You can access the Guide
to LabWindows/CVI Documentation topic through the LabWindows/CVI Help.
Where else can I go for LabWindows/CVI information?
Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most up-to-date
information about LabWindows/CVI.
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National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni.com/legal for more information about National
Instruments trademarks. The mark LabWindows is used under a license from Microsoft Corporation.
Windows is a registered trademark of Microsoft Coporation in the United States and other countries.
Reliance™ is a trademark of Datalight, Inc. Copyright 1989-2008 Datalight, Inc., All Rights Reserved.
Datalight® is a registered trademark of Datalight, Inc. Other product and company names mentioned
herein are trademarks or trade names of their respective companies. For patents covering
National Instruments products/technology, refer to the appropriate location: Help»Patents in your
software, the patents.txt file on your media, or the National Instruments Patent Notice at
ni.com/patents.
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