
RELEASE AND UPGRADE NOTES

LabVIEW  FPGA Module
Version 2014

This document provides system requirements, installation instructions, descriptions of new 
features, and information about upgrade and compatibility issues for the LabVIEW 2014 FPGA 
Module. Refer to the resources listed at the end of this document for information about 
developing applications with LabVIEW and the FPGA Module.
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System Requirements
The development computer is a PC or NI PXI/PXI Express system on which you install 
LabVIEW and the LabVIEW FPGA Module. You also can install the Xilinx compilation tools 
on your development computer to compile LabVIEW FPGA VIs locally. However, if the FPGA 
design or target requires more than 2 GB of memory, National Instruments recommends 
installing the Xilinx compilation tools on a separate computer. This computer is referred to as 
the remote compile worker. Refer to the Remote Compile Server and Compile Worker section 
for more information about the requirements for setting up a separate computer to be either a 
remote compile server or a remote compile worker.

Refer to ni.com/info and enter the Info Code XilinxCompileTools for more information 
about the NI hardware supported by each Xilinx compilation tool.

Development Computer
• LabVIEW 2014 Full or Professional Development Systems (32-bit)

• 1.2 GHz Pentium processor or equivalent

• 11 GB additional disk space

• Memory1:

– At least 3 GB of RAM for Virtex-5 and earlier FPGA targets

– At least 4 GB of RAM for Virtex-6 and later2 FPGA targets

• One of the following operating systems:

– Windows 7 (32-bit)

– Windows 7 (64-bit with 32-bit LabVIEW installed)

– Windows Vista (32-bit)

– Windows Vista (64-bit with 32-bit LabVIEW installed)

– Windows XP Pro (Service Pack 3)

– Windows Server 2003 R2 (32-bit)3

– Windows Server 2008 R2 (64-bit with 32-bit LabVIEW installed)

– Windows Server 2012 R2 (64-bit with 32-bit LabVIEW installed)

Note The LabVIEW 2014 FPGA Module does not support Windows 8 or 
Windows 8.1.

Note National Instruments recommends a 64-bit OS for the computer on which you 
install the Xilinx compilation tools.

1   Memory requirements vary according to both the FPGA target and the FPGA VI you create for that target. 
To determine your memory needs, monitor the memory usage of the xst.exe process in the Windows 
Task Manager. 

2   You must use a 64-bit OS to address 4 GB of RAM.
3   The LabVIEW FPGA Module does not support the Windows Server non-R2 editions.

http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
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• FPGA device

• Device driver software—To program most devices with the LabVIEW 2014 
FPGA Module, install the NI-RIO 14.0 driver software. Refer to the hardware 
documentation for different requirements for a specific device.

Remote Compile Server and Compile Worker
If you install the FPGA Compile Farm Server on a separate computer, you can configure that 
computer to be a remote compile server. If you install the Xilinx compilation tools on a separate 
computer, you can configure that computer to be a remote compile worker. Refer to ni.com/
info and enter the Info Code XilinxCompileTools for more information about the 
NI hardware supported by each Xilinx compilation tool.

The remote compile server must meet the following specifications:

• 35 MB free disk space 

• 1 GB RAM

• One of the following operating systems:

– Windows 7 (32-bit or 64-bit)

– Windows XP Pro (Service Pack 3)

– Windows Vista (32-bit or 64-bit)

• Web browser for accessing compile job queues via the NI Web-based Configuration & 
Monitoring Service FPGA Compile Farm Console

Each computer that you want to use as a compile worker must meet the following specifications:

• 11 GB of disk space for the complete set of Xilinx compilation tools

• One of the following operating systems:

– Windows 7 (32-bit or 64-bit)

– Windows XP Professional (32-bit or 64-bit)

– Windows Vista (32-bit or 64-bit)

– Red Hat Enterprise Linux 6.3

Note National Instruments recommends a 64-bit OS for the computer on which you 
install the Xilinx compilation tools.

Note If you are upgrading from the 2012 version of the compile worker for Linux, 
you must install Red Hat Enterprise Linux 6.3. Refer to ni.com/info and enter the 
Info Code FPGAcwl for more information on how to upgrade. 

http://digital.ni.com/express.nsf/bycode/FPGAcwl
http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
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Installation
The following sections provide information about installing the LabVIEW FPGA Module and 
related components.

Note If you are upgrading from a previous version of LabVIEW, you must 
install LabVIEW 2014 before you install the LabVIEW 2014 FPGA Module to 
mass compile existing VIs successfully. If you mass compile existing FPGA VIs 
before you install the LabVIEW FPGA Module, some FPGA-specific VIs might 
have mutation issues.

Installing the LabVIEW FPGA Module on a 
Development Computer
Complete the following steps to install LabVIEW and the FPGA Module:

1. Log in as an administrator or as a user with administrative privileges.

2. Insert the LabVIEW Platform media.

To request additional LabVIEW 2014 Platform media, refer to ni.com/info and enter 
the Info Code RequestDVD. If you purchased this product with an NI Software Suite or 
NI Product Bundle, use the installation media that shipped with your purchase to install this 
product. 

Tip If the installer does not start automatically, double-click setup.exe from the 
media to launch the installer.

3. Follow the instructions on the screen to install and activate the following software in this 
order:

• LabVIEW

• FPGA Module 

• Xilinx Compilation Tools—Install these compilation tools on the development 
computer to compile your LabVIEW FPGA VIs locally. You must install these tools 
on your development computer if you plan to create simulation exports, configure the 
IP Integration Node, incorporate Xilinx IP, or use the Configure Component-Level IP 
wizard. Refer to your hardware documentation for information about the FPGA chip 
in your device and install the appropriate set of tools. Refer to ni.com/info and 
enter the Info Code XilinxCompileTools for more information about the NI 
hardware supported by each Xilinx compilation tool.

– Xilinx Compilation Tools for Windows—Install these compilation tools if you 
will compile your FPGA VIs on a Windows computer. The Xilinx compilation 
tools for Windows includes Vivado 2013.4 and ISE 14.7.

– Xilinx Compilation Tools for Linux—Install these compilation tools if you will 
compile your FPGA VIs on a Linux computer. The Xilinx compilation tools for 
Linux includes Vivado 2013.4 and ISE 14.7.

http://digital.ni.com/express.nsf/bycode/RequestDVD
http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
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– Xilinx 10.1 Compilation Tools—Install the Xilinx 10.1 compilation tools if your 
FPGA device contains a Xilinx Virtex II chip. To download the Xilinx 10.1 
compilation tools, refer to ni.com/info and enter the Info Code 
FPGATool101.

Note To configure the IP Integration Node, or use the Configure 
Component-Level IP wizard on Virtex-II devices, you also must install the Xilinx 
ISE 14.7 compilation tools. Xilinx IP and simulation exports are not supported on 
Virtex-II FPGA devices.

• (Optional) FPGA Compile Farm Server—Use the FPGA Compile Farm Server 
to distribute FPGA VI compile jobs across multiple remote computers. The FPGA 
Compile Farm Server automatically installs locally with installation of the LabVIEW 
FPGA Module. You must install the FPGA Compile Farm Server separately on any 
computer that you want to use as a remote compile server.

Note Use the LabVIEW FPGA Compile Cloud Service to increase your 
development efficiency by offloading compile jobs to multiple computers in a cloud 
environment.

• (Optional) Real-Time Module—Use the LabVIEW Real-Time Module to program 
the real-time OS on NI PXI, NI PXI Express, NI CompactRIO, and NI Single-Board 
RIO devices. You have a temporary license for this product.

• Device Drivers—NI-RIO 14.0 is the device driver software for most FPGA targets. 
Refer to your hardware documentation for information about additional or different 
device drivers you need.

In addition to installing program files and documentation in the LabVIEW directory, the installer 
also puts files from Xilinx in the x:\NIFPGA directory, where x is the drive on which you 
installed LabVIEW. The LabVIEW FPGA Module uses these files to compile FPGA VIs into 
code that runs on an FPGA target.

Installing the Xilinx Compilation Tools on a Separate 
Computer
If you install the Xilinx compilation tools on a remote computer, you can compile FPGA VIs 
remotely using one or more remote compile workers.

Setting Up a Remote Compile Server or Compile Worker
FPGA Compile Farm Server—NI recommends installing the FPGA Compile Farm Server to 
offload compiles to dedicated computers. You must install the FPGA Compile Farm Server 
separately on any remote machine that you want to use to manage your compilations. Also, you 
must install the Xilinx compilation tools on any machine that you want to use as a remote 
compile worker. Refer to ni.com/info and enter the Info Code XilinxCompileTools for 
more information about the NI hardware supported by each Xilinx compilation tool.

http://digital.ni.com/express.nsf/bycode/FPGATool101
http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
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LabVIEW FPGA Compile Cloud Service—NI also offers the LabVIEW FPGA Compile 
Cloud Service to increase your development efficiency by offloading compile jobs to multiple 
computers in a cloud environment. Refer to ni.com/trycompilecloud for information 
about the LabVIEW FPGA Compile Cloud Service.

• Windows—Refer to ni.com/info and enter the Info Code fpgakb1rcs for 
information about installing the Xilinx compilation tools on a remote computer.

• Linux—Refer to ni.com/info and enter the Info Code FPGAcwl for information about 
setting up a remote compile worker.

Installing the Compilation Tools for Linux
Install the Xilinx Compilation Tools for Linux on a remote computer running Red Hat Linux 6.3 
to use the remote computer to compile FPGA VIs:

1. Log into the system as root.

2. Insert the 2014 Xilinx Compilation Tools for Linux installation media. Use mount 
/mnt/cdrom to mount the media. On some Linux systems, the media mounts 
automatically.

3. To change the current directory to the mounted media, enter the following command(s):

cd /mnt/cdrom/CWXILINX14 or cd /mnt/cdrom/CWVIVADO2013

4. To run the installation script, enter the following command:

sh ./INSTALL

Activating the LabVIEW FPGA Module
The LabVIEW FPGA Module relies on licensing activation. You have a temporary license that 
includes both the FPGA Module and the Xilinx compilation tools that the FPGA Module uses. 
When the evaluation period expires, you must activate a valid FPGA Module license to continue 
using the software. Activating the FPGA Module license also activates the license for the Xilinx 
compilation tools. You must create an ni.com User Profile to activate your software.

Use the NI License Manager, available in the National Instruments\NI License 
Manager directory, to activate NI products. Refer to the National Instruments License Manager 
Help, available by selecting Help»Contents in the NI License Manager, for more information 
about activating NI products.

Version 2014 Features and Changes
The LabVIEW 2014 FPGA Module includes the following new features. Refer to the 
LabVIEW Help, available by selecting Help»LabVIEW Help in LabVIEW, for more 
information about these features.

Updates to the Xilinx Compilation Tools
The LabVIEW 2014 FPGA Module release includes the addition of a new suite of Xilinx 
compilation tools, Vivado 2013.4. Refer to ni.com/info and enter the Info Code 
XilinxCompileTools for more information about the NI hardware supported by each Xilinx 
compilation tool.

https://lumen.ni.com/nicif/us/requestaccess/content.xhtml
http://digital.ni.com/express.nsf/bycode/fpgakb1rcs
http://digital.ni.com/express.nsf/bycode/FPGAcwl
http://digital.ni.com/express.nsf/bycode/XilinxCompileTools
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The LabVIEW FPGA Module Now Includes FPGA 
IP Builder
The LabVIEW FPGA Module now includes FPGA IP Builder. You do not need additional 
licensing to use FPGA IP Builder. You can use FPGA IP Builder to efficiently implement your 
LabVIEW algorithms for FPGA targets and to generate FPGA code that meets specific 
performance requirements. FPGA IP Builder does not require that you place LabVIEW FPGA 
code inside a single-cycle Timed Loop.

Improvements to FPGA IP Builder
FPGA IP Builder now supports variable-size arrays and case structures. Additionally, FPGA IP 
Builder also supports the Last Value, Indexing, and Concatenating loop tunnel modes and the 
use of conditional terminals when using the Indexing loop tunnel mode.

The LabVIEW FPGA Module Now Includes the FPGA 
Compile Farm Server 
The LabVIEW FPGA Module now includes the FPGA Compile Farm Toolkit as the FPGA 
Compile Farm Server. You do not need additional licensing to use the FPGA Compile Farm 
Server on remote machines.

LabVIEW FPGA Compile Cloud Service
Use the LabVIEW FPGA Compile Cloud Service to increase your development efficiency by 
offloading compile jobs to multiple computers in a cloud environment. Refer to ni.com/
trycompilecloud for information about the LabVIEW FPGA Compile Cloud Service.

Handshaking Interface for FPGA FIFOs
Target-scoped, peer-to-peer, and DMA FIFOs now include a handshaking interface for use 
within single-cycle Timed Loops. Selecting this interface facilitates communication between 
upstream and downstream nodes in high throughput applications and saves development time by 
automatically implementing the four-wire handshaking protocol.

Improvements to the FFT Express VI
You now can process multiple samples from one channel during each cycle using the Single 
Channel, Multiple Samples Input Format of the FFT Express VI. If you use hardware that 
outputs multiple samples per data clock cycle, this option allows you to process the data directly 
from the FPGA I/O node.

Advanced Settings for Memory Items Using Block 
Memory
You now can adjust the latency of the Read (Memory Method) for memory items implemented 
using block memory. A higher number of cycles of latency results in an increase in internal 
pipelining, which also can increase maximum frequency of your compiled design.

https://lumen.ni.com/nicif/us/requestaccess/content.xhtml
https://lumen.ni.com/nicif/us/requestaccess/content.xhtml
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Upgrade and Compatibility Issues
The following sections provide information about upgrading from the LabVIEW 2013 FPGA 
Module to the LabVIEW 2014 FPGA Module. Refer to previous versions of the LabVIEW 
FPGA Module Release and Upgrade Notes, available on ni.com/manuals, for changes in 
previous versions of the FPGA Module.

Note NI recommends you test all FPGA designs after upgrading. Upgrading the 
LabVIEW FPGA Module requires upgrading to a new version of the Xilinx 
compilation tools. This upgrade can change the timing or resource utilization 
characteristics of FPGA VIs you developed in previous versions or cause these VIs 
to fail to compile.

VIs that Contain an IP Integration Node
If you open a VI saved in a previous version of LabVIEW that contains an IP Integration 
Node, you must regenerate support files for the IP. To complete this task, select Tools»
FPGA Module»Regenerate Support Files for IP Integration Nodes in LabVIEW 2014. 
Follow the on-screen instructions to generate the support files for LabVIEW 2014.

Note LabVIEW might not be able to update all support files. In this situation, 
re-add the IP Integration Node to the VI and generate the support files for the new 
node.

Known Issues
Refer to the National Instruments website at ni.com/info and enter the Info Code 
LVFPGA2014KI to access the known issues for the LabVIEW 2014 FPGA Module.

Where to Go from Here
NI provides many resources to help you succeed with your NI products. Use the following 
resources as you start exploring LabVIEW and the FPGA Module. 

Documentation and Examples
Use the following resources to learn more about using LabVIEW and the FPGA Module:

• LabVIEW Help—Available by selecting Help»LabVIEW Help in LabVIEW. Browse 
the FPGA Module book in the Contents tab for an overview of the FPGA Module and 
hardware-specific information. Browse the FPGA Interface book in the Contents tab for 
an overview of the FPGA Interface information.

• Context Help Window—Available by pressing <Ctrl-H>. This window provides brief 
descriptions of VIs, functions, and dialog boxes along with a link to more detailed 
information.

http://digital.ni.com/express.nsf/bycode/rdbp02
http://digital.ni.com/express.nsf/bycode/LVFPGA2014KI
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• Hardware-Specific Documentation—Refer to the documentation that came with the 
FPGA target hardware for information about that hardware. The documentation might be 
installed on disk instead of printed.

• Examples—The driver software for many FPGA targets includes corresponding examples. 
Refer to the specific hardware documentation for information about whether the FPGA 
target you use comes with corresponding examples. 

You can start with an existing example and use it as a starting point for developing 
FPGAVIs and host VIs. From LabVIEW, launch the NI Example Finder by selecting 
Help»Find Examples. Browse the examples by directory or by task.

• Sample Projects—The NI-RIO driver software installs several sample projects that are 
designed as starting points for common applications. You can adapt these sample projects 
to your own applications. Access these sample projects by selecting File»Create Project 
in LabVIEW.

National Instruments Website
Refer to ni.com/info and enter the Info Code LabVIEW_FPGA for the latest articles, 
examples, and support information for the FPGA Module.

Refer to ni.com/info and enter the Info Code fpgatrn to access online training for the 
FPGA Module.

Where to Go for Support
The National Instruments website is your complete resource for technical support. At ni.com/
support you have access to everything from troubleshooting and application development 
self-help resources to email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, and 
other services.

Visit ni.com/register to register your National Instruments product. Product registration 
facilitates technical support and ensures that you receive important information updates from NI. 

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, 
Texas, 78759-3504. National Instruments also has offices located around the world. For telephone 
support in the United States, create your service request at ni.com/support or dial 
1 866 ASK MYNI (275 6964). For telephone support outside the United States, visit the Worldwide 
Offices section of ni.com/niglobal to access the branch office websites, which provide 
up-to-date contact information, support phone numbers, email addresses, and current events.

http://digital.ni.com/express.nsf/bycode/LabVIEW_FPGA
http://digital.ni.com/express.nsf/bycode/fpgatrn
http://www.ni.com/register
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/services
http://www.ni.com/support
http://www.ni.com/niglobal
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