
Citadel™, FieldPoint™, LabVIEW™, Lookout™, National Instruments™, NI™, ni.com™, and NI-DAQ™ are trademarks of National Instruments Corporation.
Product and company names mentioned herein are trademarks or trade names of their respective companies. For patents covering National
Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your CD, or ni.com/patents.

322470D-01 © 1999, 2001 National Instruments Corp. All rights reserved. December 2001

RELEASE NOTES

LOOKOUT 5 RELEASE NOTES
Welcome to Lookout 5.0. This edition of the Lookout HMI/SCADA
package introduces the new Historical Data Viewer along with new
Lookout objects, the ability to run Lookout as an NT service, and
easy-to-configure serial communications debugging.

The Historical Data Viewer is a new feature of National Instruments
Measurement and Automation Explorer (MAX).With this new tool you can
view your Lookout data or alarms and events, creating custom views that
you can then save for easy reference. You can archive data, combine
data from different databases, and export your data using default or
custom-made export templates (including an HTML template that exports
your data into an easy-to-browse Web page). Consult the Historical Data
Viewer Online Help for more information on using this powerful new
addition to Lookout.

The following new Lookout objects are included in this version:

• ActiveX Combobox: an option selection tool

• ActiveX Listbox: both an option selection tool and an advanced way
to implement stacks or queues

• ActiveX Webbrowser: an easy-to-use Web browsing tool

• GE Fanuc Versamax driver: a protocol driver for GE Versamax PLCs

• Thermocouple: an object for converting thermocouple measurements
into temperatures

With the new ability to run Lookout as an NT service, you can ensure that
Lookout will start up and run if your Windows 2000/NT/XP computer
restarts, even when there is no operator available to log in.

Serial port configuration now includes easy debugging options.

Lookout documentation has been consolidated into one printed
volume for developers to use in addition to the online help reference
for Lookout objects.

™
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This version of Lookout features a number of improved examples
with step-by-step instructions to help you understand the Lookout
configurations involved.

For detailed information on the new features in Lookout 5, consult your
online and printed documentation. For the latest information not included
in this document, refer to the readme.txt file on your Lookout CD.

The Lookout 5 Release Notes contain the following information:

• Installation

• Known issues

• Bug fixes

• Compatibility and conversion issues

For the most recent Lookout news and updates, point your browser to
http://www.ni.com/lookout/.
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Installation
Installing Lookout is more than just copying files to your computer.
You must register Lookout for long-term use of your I/O points, and for
instances of Lookout that are intended to run server processes, you must
also register to activate your client connections. There are also a number
of Lookout system configuration options you should set when you install.
If you plan on networking with Lookout, you should also test to make sure
TCP/IP is present and running on all the computers you intend to use.

For detailed information about requirements, installation steps and options,
registration, keycodes, and licenses, refer to Chapter 1, Introduction to
Lookout, in the Lookout Developer’s Manual.
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Installing onto Computers with Existing Versions of Lookout
• Lookout 3.8 or earlier: Avoid installing Lookout 5 over Lookout 3.8

or earlier. Either uninstall Lookout 3.8, or put Lookout 5 in a new
directory. You can then move or copy Lookout 3.8 process files
to the Lookout 5 directory.

• Lookout 4 and Lookout 4.5: You can run Lookout 4.0 and Lookout 5
on the same computer.

• Lookout 5 beta: If you were using a pre-release version of Lookout 5,
you should uninstall before installing the release version of Lookout 5.

Using Registration Information from Previous Lookout Versions
If you are replacing your current copy of Lookout with Lookout 5, and your
previous version was purchased from National Instruments, your earlier
registration keycode will work to maintain your I/O licensing. However,
you must register your client connections separately. Get your client
connection keycode (and an upgraded I/O point keycode as well, if
necessary) by registering Lookout with National Instruments. Refer to
Chapter 1, Introduction to Lookout, of the Lookout Developer’s Manual for
more information about registering Lookout and getting your keycode.

Uninstalling Lookout
To uninstall Lookout, first stop the NI Windows services. Then select
Start»Settings»Control Panel, and double-click Add/Remove
Programs. In that window, you can uninstall Lookout.

When you install Lookout, you install portions of related National
Instrument software to enable the full functionality of Lookout's features.
If you uninstall Lookout, you may want to uninstall this other software
as well.

Because this software may be shared by other National instruments
programs and hardware, such as the LabVIEW Datalogging and
Supervisory Control module, VI Logger, NI-DAQ, and so on, you
may want to leave the shared software installed.

These shared applications include the following items in Add/Remove
Programs:

• NI DSC Common Tools

• NI Historical Data Viewer

• NI Logos

• NI Measurement & Automation Explorer

• NI Server Explorer
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Known Issues
The following known issues exist for Lookout 5. Internal tracking codes are
shown in parentheses for applicable issues.

FieldPoint Alias with Japanese Characters
Lookout crashes when attempting to import FieldPoint aliases using
Japanese characters. Lookout does not support international character sets
at this time. Attempting to import Japanese characters from FieldPoint
configuration files will fail. (21K5CU6S)

Administrator Access Needed to Download Lookout Player
If you want to use the Lookout Web Client feature on a computer running
Windows 2000/NT/XP, you must have administrator privileges to install
the Lookout Player component of the Web Client. After the Lookout Player
is installed, administrator privileges are not necessarily required to use the
Lookout Web Client successfully.

Using ActiveX Controls in Web Client Processes
At this time the only ActiveX controls you can use in a process you intend
to export for use by a Lookout Web Client are the National Instruments
Recommended ActiveX controls provided as a part of Lookout.

Lookout Control Sources and Refresh Value Operations
A Lookout control with a Local source and a direct connection will not
change if something acts to alter the value or status of the PLC or object it
is connected to. Instead, Lookout will restore the control's value to the PLC
or object in the following circumstances:

• When the driver object is modified or I/O is reconfigured

• When the process is reloaded

• When communication is restored after a communications failure

• After 100 polls in some cases (this varies from driver to driver and may
depend on .ini file settings)

If you operate a Lookout control with a Remote source connection, and the
PLC register it is connected to cannot or does not change when Lookout
writes the new value out to the PLC, the control snaps back to display the
actual PLC register value or status. Whether or not this problem occurs
depends on data transmission time between your Lookout computer and the
field hardware. To prevent this problem, Lookout has built-in delays for
most driver objects.



Lookout 5 Release Notes 6 ni.com

The following driver objects do not have a built-in delay:

• AdvantechPCL

• DeltaTau

• Dynamic

• ProfibusDP

• ProfibusL2

• Reliance

• Sixnet

• Wizdom

The following two driver objects do not support remote source connections
at all, because the underlying protocols themselves do not allow this sort of
connection:

• Aquatrol

• DeviceNet

Another way to correct snap-back problems caused by slow
communication is to adjust the SnapDelay setting that is available with
some control objects. For Switch and Pushbutton objects, use the
SnapDelay data member; for the Pot object, use the SnapDelay
lookout.ini setting.

Connection Browser Open with No Processes Visible
Occasionally the Connection Browser may open with no processes visible
in the window. Close the Connection Browser and then reopen it. This will
usually clear the problem. If for some reason it does not, close the
Connection Browser again and make sure you select a process in your
Object Explorer before reopening the Connection Browser.

CWUI ActiveX 3-D Control License Problems
If you load a Lookout 5 process with Lookout CWUI ActiveX 3-D controls
and attempt to edit those controls, you can develop a problem with the
license for those controls. To avoid this difficulty, load the Lookout 5
process and immediately save it in order to force the control license to
update. You can then edit the controls with no problem.

Missing Aggregate Definitions
If you load a process that includes an Aggregate object, but the
corresponding aggregate definition is unavailable, the Aggregate will not
function properly. It will appear in the Object Explorer as expandable, but
it will not expand. (270DIAYZ)
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FieldPoint Network Module Alarms
If you use the FieldPoint object to access the FieldPoint FP-2010 network
module, you may receive transient bad data quality warnings that can fill
your Alarms Window. We recommend accessing FieldPoint Ethernet
network modules using National Instruments proprietary Logos protocol,
by locating them in your Object Explorer or Expression Editor tree view.
(28I7TN7M)

Logger Object and X Traces
There have been reports of the Lookout Logger object creating X
traces—a trace that looks like an X—when logging over an extended
period of time using large time zone offsets. (28FGMBBD)

Creating Control Object Displays with Direct
Connections
When you right-click, drag, and drop a data member to create a control
object display, the connection between the new display and the data
member is a remote connection. If you do not want a remote connection to
this data member, create the control object manually and connect it to the
data member using Object»Edit Connections. (28QCRA9L)

Saving a Process with a Read-Only LKS File
If you attempt to save a process with a read-only .lks file, you will
(correctly) get a message saying Lookout cannot save. If you were closing
the process, the process close is aborted. The asterisk next to the process
name at the top left of the Lookout workspace disappears, and if you
attempt to close the process again, Lookout will close without prompting
you to save your recent changes. (270DANYZ)

Using Flat Browsing when Lookout is an OPC Server
If you are using Lookout as an OPC server, you must use OPC flat
browsing to connect to Lookout protocol and driver objects when using the
Lookout OPCClient object in a second instance of Lookout. Hierarchical
browsing in these circumstances does not work. (2BF9MRE9)

Using Symbolic Links Correctly
NI recommends that you do not create a connection between two Symbolic
Links. If you connect a Symbolic link in one process to a Symbolic Link in
a process running in a different instance of Lookout, the connection will not
work at all. Connecting a Symbolic Link to a Symbolic Link in another
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process when both processes are running in the same instance of Lookout
can work initially but will fail under a number of different circumstances.
You should only connect to a Symbolic Link from within the process that
contains it. (24KFEPAO)

Using the ! and NOT Expression Functions
In Lookout expressions, the ! function has a transient TRUE value, but the
NOT function does not. To negate an expression without a glitch, use NOT
rather than !. (239957E9)

Loader Pushbuttons and Action Verification
If you use a pushbutton to trigger a Loader object to unload a process,
the unload will fail if you have entered text in the Verify on text field.
The pop-up verification message aborts the unload operation.
(261DOCCM)

Aggregate Problems with Incorrect Computer Name
If you have the incorrect computer name entered in the System Options
dialog box and you drag and drop an Aggregate data member on a panel,
you get bad quality (a red X) for the data member. Additionally, you may
find that some data members you did not intend to expose in the Aggregate
are visible in the Object Explorer. Select Options»System and make sure
the computer name matches the name in your Windows networking
configuration. (246FA49L)

Creating Control Object Displays with Direct
Connections
No matter what URL you enter in the Web Client export options, the
slashes are always shown as forward slashes in a Web Client Alert. If you
use back slashes with an http URL, the URL will not work, but the Lookout
alert message displays the correct URL with forward slashes. If you are
confused because the URL looks correct in an alert message, check the
direction of the slashes in your export options. (28B9OI9L)

Connecting OPCClient Object to the
LookoutOPCServer
You cannot connect the Lookout OPCClient object to the
LookoutOPCServer. Lookout will hang if you do. (2D0AOOJT)
(2DCDQKMV)
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Using the Correct Date Format in Pot Objects
You can enter dates into the Lookout Pot object, but it does not accept dates
entered as yyyy-mm-dd. You must use the form yyyy/mm/dd instead.
(2CG6TKTS) (2EE851E9)

Expression Displays that Automatically Resize
Lookout resizes expression displays when reopening a project. If an
expression value has more characters than can be displayed in the given
size of the expression's display, it shows ####. If you close the project and
reopen it, Lookout automatically resizes the expression display so that the
string stored in the state file fits. This can be a significant problem if,
for example, an expression is displaying input that is several hundred
characters long. (2AJCJQTM)

Accessing Microsoft Internet Explorer Home from
Lookout Web Client
There have been reports that Microsoft Internet Explorer hangs when sent
Home from Lookout Web Client. This is an erratic problem that only rarely
occurs. (28FGJNBD)

Including Custom Graphics when You Deploy
Remember that graphics are not included in Lookout source files (.lks).
When you move processes from one computer to another you must include
all graphics, including custom graphics. (2D6F3BDF)

OPCClient Fails with Remote Connection to
OPC Server in Asynchronous Mode
The Lookout OPCClient object does not work if you have a remote
connection to a remote Lookout OPC server in asynchronous mode.
Disable the use asynchronous OPC connection setting to fix this problem.
(2CG9HCE9)

PID Object Sample Pulse Parameter Type
The Sample Pulse parameter of the PID object uses logical values.
You can connect a numeric value, but the PID object will treat the input
as a logical, pulsing every time it updates. (27K8EEYZ)
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Pulse Object Erratic Behavior
The Lookout Pulse object may operate erratically, including missing some
pulses, if you use period or duration numbers that are not simple. Using an
expression to calculate a pulse period or duration is one way to encounter
this problem; using too precise a number such as 1.26 seconds is another
way. (28B89NBD)

Access to Network Security Settings from Edit Object
Connections Dialog Box
The right-click menu for a process or object in the Edit Object Connections
dialog box contains an option to Configure Network Security. This
feature is not available from this location, however, and selecting it does
not invoke the security configuration dialog box. (2C88R2SP)

Scaling Data Members with Single Quotes
and a Colon (:)
For driver object data members with a colon (:), Lookout places single
quotes on the URL. Scaling does not work on these URLs. To address this
problem, configure the data member to use an alias, where scaling works
with no problems. (2EL94MB4)

Web Clients and the Sequencer Object
If you use the Web Client to browse a Lookout process that uses a
Sequencer, and you browse to another URL while the Sequencer is active,
Lookout may stop the process and reset the Sequencer, inserting a huge
wait value in the active sequence step. Avoid using the Web Client with
Lookout processes that use a Sequencer. (28FGCNBD)

Sequencer Stuck when Created with Dependencies
in the Wrong State
There have been reports that the Sequencer object can get stuck in a state if
certain dependencies are in the wrong condition at the time you create the
object. This problem has not been successfully reproduced, however. If you
do encounter this condition, creating the connection Seq1.Goto1 = \

..\$keyboard.f10 will allow you to restart the Sequencer by pressing
the <F1> key, which should result in proper functioning. (1WBC2EM6)
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ModbusDaniel Communication Failure Messages
Problems have been reported with the update and CommFail data
members of the ModbusDaniel object. When using the ModbusDaniel
object without a Modbus Daniel device attached to the serial port, you
can get the following error message instead of a CommFail alert:

Garbled communications response from Modbus 
secondary(0):Response too short. 

Additionally, the update data member may not update when the data is
updated. Reverting to an earlier version of the ModbusDaniel object solves
this problem. (2DOH63B4)

ToshibaTSeries Sets PLC Values to 0
If the ToshibaTSeries object does a write before a read, it sets all the PLC
values to 0. (1V5HS5M0)

Invalid (expression) Object Entries
There have been reports that using an invalid entry in an (expression) object
can cause Lookout to crash. This has not been a reproducible error.
(2ASFRFNE)

Stopping NI Services Manually Before Uninstalling
Lookout
If your NI Windows services do not shut down when trying to uninstall
Lookout, the uninstall may fail. Right-click the NI services icon in the
system tray of the Windows taskbar, stop all services, then retry the
uninstallation. (27KCBNYZ)

Lookout Webbrowser Visibility Problems
A switch connected to the Lookout Webbrowser ActiveX control Visible
property can make the Web browser invisible, but it will not restore it to
visibility. However, once the switch is on, you can type in a new URL and
the browser will become visible again. (2CRI6MBD)

Pot Connected to an FP-2010 Can Fluctuate
When you change the value of a Pot object that is remotely connected to a
published data member of the FieldPoint FP-2010, the Pot can fluctuate in
value before it reaches its final state. To address this problem, try changing
the SnapDelay setting in the lookout.ini file. Consult your Lookout
documentation for more information on this setting. (28I89I7M)
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Bug Fixes
The following bugs have been fixed for Lookout 5:

• Lookout 5.0 features extended ranges for the I, Q, M, AI, AQ and R
data members for GE_Series90 driver object. (28GFGLD8)

• The Hitachi driver objects has been improved so that address spaces
WR200–WRF1FF and DR1FF–DRF1FE are now accessible.
(27CDD4MV)

• The Omron driver object now supports baud rates of 56700 and
115200. (281EM0QU)

• A number of small difficulties with the Lookout OPC connection
to FieldPoint modules have been repaired (28MFNR9L, 28NB199L,
28MCDR9L, 28MG229L, 28MGAU9L):

– Lookout does not hang when some item is no longer available
on FieldPoint OPC, nor will it generate a continuing stream
of alarms.

– Lookout is now able to reconnect with OPC FieldPoint in
synchronous mode after the connection has been broken
and restored.

– FieldPoint OPC error messages in Lookout now include
item names.

• The IDEC driver objects now have an OffHook data member.

• The DNP object had data member addressing offset by the PLC. This
addressing problem has been corrected. (26KCSJCM)

• A problem in the Mitsubishi and Mitsubishi_CLM driver objects
with communication retries has been fixed. When the driver loses
communication and retries, it no longer returns corrupted data frames.
(29ADJNNE)

• Lookout now supports filtering of FieldPoint channel-specific error 2
as well as channel-specific error 1. This includes support for serial
FieldPoint as well. (28TBJDEB)

• Several small difficulties with the Aggregate object have been fixed.
Events created by an aggregate definition process now show up as
having been logged by the Aggregate that owns them. A small memory
leak that occurred when using an Aggregate that logs events has been
fixed.

• A problem with the Report object leaking memory when it generated
its HTML pages has been fixed. (299EF69L)

• Under some circumstances Lookout crashed when trying to copy
and paste a HyperTrend display. This crash has been eliminated.
(2B9BL39L)
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• Under some circumstances the DNP driver object could crash when it
returned an invalid object response. The object is now able to handle
error frames and no longer crashes Lookout. (2AIG6UMV)

• In some cases on some OPC servers, the Lookout OPCClient object
was unable to use hierarchical browsing. This difficulty has now been
fixed, and you should be able to browse any OPC server hierarchically,
if the server supports such browsing. (2ABDPRKF)

• Under some circumstances, a windowed ActiveX control kept focus
even after someone clicked on the panel or a native Lookout control.
This difficulty has been fixed. (2BUE3SBD)

• A dialog box bug in Modbus and ModbusSlave involving the 115200
baud rate has been fixed.

• Under some circumstances, data logged from an OPCClient object
created a “stair step” appearance when viewed with the HyperTrend.
The Lookout OPC Client now returns “asynchronous” for its data
members so that Lookout interpolates when trending. (2C096HMV)

• The 115U model PLC has been removed from the S5_AS511 object.
(1MKAIT9C)

• At times Lookout could crash if you deleted a connection to a data
member in an Aggregate, if the data member in the definition process
it represents was connected to a constant. This bug has been fixed.
(2CL9AR9L)

• Under some circumstances, Lookout could crash if a process changed
the HyperTrend’s active group while the process was loading. This
condition has been fixed. (2977RHKF)

• The Lookout cursor sometimes flickered when someone was using
windowed ActiveX controls. This bug has been fixed. (2CL976MO)

• The National Instruments category of ActiveX controls has been
removed. When you create an ActiveX control, you will now see only
the categories Recommended and Other. Recommended controls are
those controls that have been tested by National Instruments and which
are known to work well with Lookout. (28A7REX4)

Additionally, an ActiveX version of the HyperTrend has been added
to the list of Recommended ActiveX controls installed by Lookout.
(28A7REX4)

• The Microsoft Webbrowser ActiveX control has been removed from
the Recommended category. A version of this control inside a
Lookout ActiveX wrapper has been substituted. This version of the
control makes control properties available as Lookout data members
for improved ease of use. (28A7REX4)
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• A bug in which a remoted Switch was not updating anything connected
to its value data member during initialization has been fixed.
(2CTASVTS)

• A bug that sometimes resulted in Lookout failing to import certain data
members from a FieldPoint .iak file has been fixed. (2DABT59L)

• If you had a HyperTrend object with certain parameters left blank or of
the wrong type, Lookout could crash while compiling the .lks file.
This problem has been fixed. (2DN880UQ)

• The background color of the XBarR and XChart objects was changing
when the line color changed. This unwanted behavior has been
eliminated. (2AIBCMMV)

• Lookout would sometimes crash if you had a process with nested
Symbolic Links in an expression such as ([a]/[b]) This difficulty
has been fixed. (2CTASVTS)

• Several difficulties have been resolved in the Modbus driver.

– A sporadic crash during reconfiguration that resulted from
uninitialized variables has been fixed.

– The occasional improper startup when the remote connection
was used with Modbus ethernet has been fixed.

– The Modbus optimized write feature has been enabled.
(2DPAJJ9L, 2A3BD4PJ, 2BUFRK85)

• Under some circumstances Lookout could crash when attempting to
compile a .lks file that contained an ActiveX object. The underlying
cause for this crash has been fixed. (2CUD5IEO)

• A possible memory leak that occurred when creating or modifying a
HyperTrend with a large number of groups and traces has been fixed.

• The event message that is generated when a Lookout user is
automatically logged off has been reformatted to make it easier
to understand. (2CJ82DY5)

• The National Instruments User Account Manager now correctly
displays Japanese characters in Japanese versions of Microsoft
Windows. (24I8IJFN)

• You can now set a security level for whether a user is allowed to exit
Lookout, in the Options»System dialog box. (2F5G1MUQ)

• A bug in which a variable display copied from one panel failed
to function when pasted onto another panel has been fixed.
(2F4BHUMV)

• Under some circumstances, Lookout could crash when attempting
to open a process (.l4p) file that had been corrupted. Lookout now
handles corrupt process files more gracefully. (29ME2M9L)
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• A bug that prevented Lookout from appending the .l4p extension
to the file name while saving on Windows 9x, if file extensions were
turned off in the Windows Explorer, has been fixed. (2FDF1EMV)

• If a Lookout source file (.lks) contained a certain kind of invalid path,
Lookout would crash while compiling the file. This bug has been fixed,
and Lookout now returns an error message about the path problem
instead of crashing. (29LDF5KF)

• If the message parameter of the Alarm object had not received a value
by the time the first alarm happened, Lookout could crash. This bug
has been fixed.

• The order in which graphics appear in the Insert»Graphic dialog box
is now alphabetical. (2749A2BD)

• Lookout now warns you if you attempt to display a data member in the
HyperTrend and that data member is not being logged. (2BJAHB9L)

• You can now export the Lookout Combobox, Listbox, and
Webbrowser ActiveX controls to a Web Client. (2CQFQDE9)

• Lookout now incorporates .iak file support for FP-2000, FP-2010,
FP-1601, and FP-SG-140.

• A bug which prevented the Group deadband from displaying correctly
in the Lookout OPCClient object has been fixed.

• A crash that sometimes happened after renaming a process has been
fixed. (2AS9A3E9)

• Under some circumstances, an ActiveX control on a popup panel could
fail to redraw and show new values. This problem has been fixed.
(2E9AO8E9)

• The ActiveX Webbrowser control did not properly display in a Report
object HTML page because it is a windowed ActiveX control. Printing
and report generation has now been fixed for ActiveX controls.
(2F6984E9)

• A problem with disabled ActiveX verbs for certain ActiveX controls
has been fixed. Also, some ActiveX verbs that were being called
incorrectly are now working properly. (2FFHNIZU)

• If you changed recipes in the runtime version of Lookout, it would
appear to enable the Save feature and cause other inconsistent
behavior. This has been fixed. (23CEHM9L)

• License changes now do not take effect until after you restart Lookout.
This prevents small anomalous behaviors.

• A problem that could cause Lookout running on a multi-processor
computer to crash while editing a process in the Connection Browser
has been fixed. (2FP9FTMO)
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Compatibility and Conversion Issues

Opening Older Process Files in Lookout 5
Lookout 4.5 process files: If you are upgrading from Lookout 4.5, you
should be able to open the .l4p process file without recompiling.

Lookout 4.0 process files: To open Lookout 4.0 processes in Lookout 5,
open the .lks file instead of the .l4p file when you load a process.
As soon as the process opens, save it to update the .l4p file.

Lookout 3.8 process files: If you are upgrading from Lookout version 3.8,
open the .lks file in Lookout 5, then save the process to create a new .l4p

file. Some minor adjustments may have to be made in some processes, and
you will have to change redundancy using backup computers. Refer to
the following sections for more information about compatibility and
conversion issues when upgrading from Lookout 3.8.

Lookout 3.8 and Lookout 5 Compatibility
The following list contains known compatibility issues and fixes for
Lookout 5 that may affect Lookout 3.8 users who are upgrading.

• Lookout 5 does not run on Windows NT version 3.51 or earlier—you
must be using Windows NT 4.0 or later.

• Earlier versions of Lookout process files used the file extension .lkp,
and state files used the extension .lst. Lookout now uses the .l4p
extension for process files and .l4t for state files.

If you want to continue to run your old 3.8 processes in a 3.8 version,
save backups of the files. Otherwise, recompiling a 3.8 process in
Lookout 4 or greater will create (if you save) new .lks, .l4p, and
.l4t files. Lookout also creates new security files using the extension
.lka.

• Avoid installing Lookout 5 over Lookout 3.x.xx. Either uninstall your
previous version of Lookout, or put Lookout 5 in a new directory,
transferring or copying files for conversion.

• Lookout 3.x.xx can run on the same computer with Lookout 5, and a
process in one can be networked to a process in the other using DDE.
If you intend to run both versions at one time, start the earlier version
of Lookout first.

• Lookout 3.8 Citadel files cannot be used by Lookout 5. You should
maintain old Citadel files separately from Lookout 5 database files.

• Events are now stored with alarms and process data in the Citadel
database.
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• The default location for data logged with the Spreadsheet object is the
Lookout directory. The Lookout directory is also the default for any
spreadsheet files you might export from the DataTable object or .csv
(comma separated value) files you might create with the Print Alarms
dialog box. If you do not want these files to be created in the Lookout
directory, enter a complete path (including file name) for the location
where you want the file created.

Converting Lookout 3.8 Processes to Lookout 5
To load a Lookout 3.8 process file in Lookout 5, select File»Open and
set the Files of type to Lookout Source Files (*.lks), as shown in the
following illustration.

Select the file you want to convert and click the Open button
(or double-click the file name). Lookout uses the built-in CBL compiler
to recompile the 3.8 source file into a Lookout 5 process file.

Converting 3.8 files may require the following adjustments:

• Lookout 3.8 versions of the Pot, Switch, Pushbutton, and TextEntry
objects that are remoted convert as L3Pot, L3Switch, and so on, and
continue to function as they formerly did. You cannot create new 3.8
objects like these through Lookout 5.

Because remote position source connections have changed in response
to the demands of networking, you may find you want to replace L3
versions of these controls with the new Lookout 5 versions, especially
if you want these controls to operate over a network. Delete the old
controls and replace them with new controls using the same names.
The Connection Browser and Object Explorer can help you track all
the connections that may need to be re-established if you decide to
make these replacements.

• ODBC/SQL limitations: With the introduction of networking and
hierarchical arrangement of objects within processes, it is easy to
exceed the 62 character limit that exists in Microsoft Access and
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Microsoft Query. Even fully-compliant ODBC programs are limited
to 126 characters, so some consideration of these limitations when
assigning computer, process, and object names is necessary, if you
intend to use SQL queries.

• The old LKSwap CBX no longer works. If you used this special object
from the old Lookout Evaluation Guide, you will have to replace it
with the Lookout Loader object, which is more flexible and powerful
than the old LKSwap object. Lookout 5 can run multiple processes, so
it is not necessary to shut one process down before running another.

• Fonts are preserved when converting Lookout 3.8 process files to
Lookout 5 using the .lks file, but font code page information is lost.
This appears to mostly affect international users whose languages use
a different code page than the US code page.

• The $Alarm object syntax in a .lks file has changed. The full URL
for a $Alarm object will be as follows:

\\machine\process\$Alarm

• Your custom built Lookout 3.8 .cbx files should run in Lookout 5
as long as they were developed using the Lookout Object Developer
Toolkit. If you have problems with a custom .cbx, contact National
Instruments technical support for help in resolving the problem.

• The Lookout HyperTrend object now accesses data through a URL
connection. The data source for that connection must be logged to the
Citadel database for the HyperTrend to display the data.

• When you convert a process with a Lookout 3.xx HyperTrend in it,
Lookout automatically creates a named expression to make the URL
connection to. Lookout automatically logs this named expression to
the Citadel database. To maintain your converted HyperTrend objects,
you must use or replace these named expressions.

• If you have Lookout 3.8 processes that use the NI DAQ or NI SCXI
objects, and you have a version 6.5.1 or earlier of NI-DAQ installed on
your computer, you must upgrade to NI-DAQ 6.5.2 or better to use
Lookout 5. You can download the current version of NI-DAQ software
from the National Instruments Web site.

If your Lookout process will be running on the same computer as
your National Instruments Data Acquisition or SCXI hardware, we
recommend that you edit your process to use the OPCClient object
to connect to NI-DAQ for performance reasons.



© National Instruments Corporation 19 Lookout 5 Release Notes

Importing Old Security Files into Lookout 5
If you are upgrading from Lookout 4.0 or Lookout 4.5, Lookout converts
your security file automatically when you open it with the National
Instruments User Account Manager. If you are upgrading from
Lookout 3.8, you can import the user account information into Lookout 5
using the User Account Manager, as follows:

1. In edit mode, select Options»User Manager from the Lookout menu.
The User Account Manager dialog box appears.

2. Select User»Import Security File. The following dialog box appears.

3. Navigate to your old Lookout 3.8 security file lookout.sec, and
select it. Lookout 3.8 kept the lookout.sec security file in the
Lookout directory.

4. Click the Open button.

5. If you have already created any user accounts in an earlier version of
Lookout that are the same as accounts you used in Lookout 3.8, you
will receive a message informing you that a user account with that
name already exists. You may replace your recently created account,
or choose not to use the old account information.

6. Exit the User Account Manager.

Note Unlike Lookout 3.8, Lookout 5 maintains the lookout.sec security file in the
Windows System directory. To implement the accounts that you have defined when you
deploy your process, you must use the same lookout.sec file for each copy of Lookout
running on your network. Copy your lookout.sec file to the Windows System directory
in every computer you intend to run Lookout on.
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