NI-SoftMotion and LabVIEW Compatibility

概要

This page shows supported versions of the NI-SoftMotion hardware driver with LabVIEW development systems. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing LabVIEW palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 5NJEFA1N: LabVIEW Version Support for the LabVIEW NI SoftMotion Module. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

Contents

NI-SoftMotion and LabVIEW Compatibility

Use this table to compare NI-SoftMotion and LabVIEW Compatibility
NI SoftMotion Version LabVIEW Version (32-bit only)
2009 2009 SP1  2010  2010 SP1  2011  2011 SP1  2012  2012 SP1  2013  2013 SP1  2014  2014 SP1  2015  2015 SP1 2016 2017 2017 SP1 2018 2018 SP1
2009                                    
2009 SP1                                    
2010                                    
2010 SP1                                    
2011                                    
2011 SP1                                    
2012                                    
2012 SP1                                    
2013                                    
2013 SP1                                    
2014                                    
2014 SP1                                    
2015                                    
2015 SP1                                    
2016                                    
2017                                  
2018                                  


Compatible


NI-SoftMotion and Microsoft Windows Compatibility

Use this table to compare NI-SoftMotion and Microsoft Windows Compatibility
Windows Operating System LabVIEW Version
2009 2009 SP1  2010  2010 SP1  2011  2011 SP1  2012  2012 SP1  2013  2013 SP1  2014  2014 SP1  2015  2015 SP1 2016 2017 2018
2000                               
XP      
Vista (32 bit)      
Vista (64 bit)      
Windows Server 2003 R2 (32 bit)          
Windows Server 2008 R2 (64 bit)    
Windows 7 (32 bit)  
Windows 7 (64 bit)  
Windows 8 (32 bit)              
Windows 8 (64 bit)              
Windows Server 2012 R2 (64 bit)                  
Windows 8.1 (32 bit)                    
Windows 8.1 (64 bit)                    
Windows 10 (32 bit)                        
Windows 10 (64 bit)                        


Compatible


Additional Resources