Version Information for Legacy Environments/Languages for .NET Hardware Drivers

Overview

This table details which versions of the NI-DAQmx, NI-VISA, and NI-488.2 drivers you need when you are using Measurement Studio support for legacy environments/languages. This table also lists the version of Measurement Studio you need for specific hardware driver versions.

Note: Measurement Studio 2009 and Measurement Studio MFC 10 are available to purchase for current Measurement Studio customers.  Refer to ni.com/mstudio/legacysupport for more information.

Contents

NI-DAQmx

Drivers are available for download on ni.com/drivers.  

Version of 
Visual Studio

Language

Most Recent NI-DAQmx Version Containing Revised  Support for This Environment/
Language*

Requires Measurement Studio?

Visual Studio 6.0 Visual C++ 6.0 NI-DAQmx 7.2 Yes, Measurement Studio 2009
Visual Basic
6.0*
NI-DAQmx 8.3 No
Visual Studio 2003 Visual C++
MFC
NI-DAQmx 9.1.7 Yes, Measurement Studio 2009
Visual C# or
Visual Basic
.NET
 NI-DAQmx 9.1.7 No
Visual Studio 2005 Visual C++
MFC
 NI-DAQmx 9.2 Yes, Measurement Studio 2009
Visual C# or
Visual Basic
.NET
NI-DAQmx 9.6.1 No
Visual Studio 2008 Visual C++
MFC
 NI-DAQmx 9.2 Yes, Measurement Studio 2009
Visual Studio 2010 Visual C++
MFC
 NI-DAQmx 9.2.3 Yes, Measurement Studio MFC 10

* Traditional NI-DAQ includes support for Visual Basic 6.0, including ActiveX controls.

Measurement Studio MFC 10 installs Visual C++ 2010 support for NI-DAQmx.  NI-DAQmx 9.2.3 installs the underlying drivers.

 

NI-VISA

Drivers are available for download on ni.com/drivers.

Version of Visual 
Studio

Language

Most Recent NI-VISA Version Containing Revised  Support for This Environment/Language

Requires Measurement Studio?

Visual Studio 6.0 Visual C++
6.0
Not supported.

Visual Basic 6.0 Not supported.

Visual Studio 2003 Visual C++
MFC
NI-VISA 5.0.2 Yes, Measurement Studio 2009
Visual C# or Visual Basic .NET NI-VISA 5.0.2 No
Visual Studio 2005 Visual C++
MFC
NI-VISA 5.0.2 Yes, Measurement Studio 2009
Visual C# or Visual Basic .NET NI-VISA 5.2 No
Visual Studio 2008 Visual C++
MFC
NI-VISA 5.0.2 Yes, Measurement Studio 2009
Visual Studio 2010 Visual C++
MFC
NI-VISA 5.0.3* Yes, Measurement Studio MFC 10

* Measurement Studio MFC 10 installs Visual C++ 2010 support for NI-VISA.  NI-VISA 5.0.3 installs the underlying drivers.

 

NI-488.2

Drivers are available for download on ni.com/drivers.

Version of Visual Studio

Language

Most Recent NI-488.2 Version Containing Revised  Support for This Environment/Language

Requires Measurement Studio?

Visual Studio 6.0 Visual C++
6.0
2.7 No
Visual Basic 6.0 2.7 Yes, Measurement Studio 2009
Visual Studio 2003 Visual C++ MFC NI-488.2 2.8 Yes, Measurement Studio 2009
Visual C# or Visual Basic .NET NI-488.2 2.8 No
Visual Studio 2005 Visual C++ MFC NI-488.2 2.8.1 Yes, Measurement Studio 2009
Visual C# or Visual Basic .NET NI-488.2 3.1 No
Visual Studio 2008 Visual C++ MFC  NI-488.2 2.8.1 Yes, Measurement Studio 2009
Visual Studio 2010 Visual C++ MFC  NI-488.2 2.8.1* Yes, Measurement Studio MFC 10

* Measurement Studio MFC 10 installs Visual C++ 2010 support for NI-488.2.  NI-488.2 2.8.1 installs the underlying drivers.