Explication du diagramme LabVIEW

Aperçu

Dans cette introduction au diagramme, nous examinons le concept de cet outil ainsi que la relation entre le diagramme et la face-avant. Nous explorons également comment ouvrir le diagramme, comment trouver des objets dans la palette Fonctions et les placer sur le diagramme, et comment utiliser les différentes icônes de la barre d’outils. De plus, nous apprenons à construire un diagramme simple pour illustrer les concepts importants de la création de code graphique dans le logiciel NI LabVIEW.

Le diagramme contient le code source graphique d’un programme LabVIEW. Le concept du diagramme consiste à séparer le code source graphique de l’interface utilisateur de manière logique et simple. Les objets de la face-avant apparaissent en tant que terminaux sur le diagramme. Les terminaux du diagramme reflètent les modifications apportées aux objets de la face-avant correspondants et vice versa.  

Fenêtre du diagramme

Lorsque vous créez ou ouvrez un nouveau VI, la face-avant s’ouvre automatiquement. Pour afficher le diagramme, sélectionnez Fenêtre»Afficher le diagramme dans la barre de menus. De plus, vous pouvez basculer entre le diagramme et la face-avant en appuyant sur <Ctrl-E>.


Objets et environnement du diagramme

Les objets du diagramme sont les terminaux, les sous-VIs, les fonctions, les constantes, les structures et les fils de liaison qui transfèrent les données aux autres objets du diagramme. Vous pouvez utiliser les outils LabVIEW pour créer, modifier et mettre au point un VI. Un outil est un mode de fonctionnement spécial du curseur de souris. Le mode de fonctionnement du curseur correspond donc à l’icône de l’outil sélectionné. LabVIEW choisit l’outil à sélectionner en fonction de l’emplacement actuel du curseur de la souris. Vous pouvez sélectionner manuellement l’outil dont vous avez besoin sur la palette Outils (dans la barre de menus, sélectionnez Affichage»Palette d’outils). Vous pouvez maintenant choisir l’outil souhaité, qui reste sélectionné jusqu’à ce que vous choisissiez un autre outil de la palette Outils.

Pour placer des objets sur le diagramme, il suffit de faire glisser et déposer dans la palette Fonctions. La palette Fonctions apparaît automatiquement lorsque vous cliquez avec le bouton droit sur l’espace de travail du diagramme. Il contient des fonctions, des constantes, des structures et quelques sous-VIs.

Observez les deux boutons en haut de la palette Fonctions.

         La punaise fixe la palette Fonctions au diagramme.

  Le bouton Rechercher ouvre une boîte de dialogue de recherche que vous pouvez utiliser pour rechercher des fonctions par nom.

Cliquez sur le bouton Rechercher pour lancer le moteur de recherche de fonctions. Le lancement prend quelques minutes.

Vous pouvez utiliser cet outil pour rechercher une fonction par nom si vous avez du mal à la trouver.

Une fois que la fonction souhaitée apparaît, double-cliquez dessus et LabVIEW passe à l’emplacement de la palette Fonctions où vous trouverez cette fonction.

Remarque : Effectuez les étapes suivantes pour changer les sous-palettes visibles sur la palette Fonctions :

1.       Utilisez la punaise pour fixer la palette Fonctions sur le diagramme.

 

2.       Observez que le bouton Affichage apparaît lorsque vous fixez la palette Fonctions au diagramme.

3.       Sélectionnez Affichage et, dans le menu local, sélectionnez Changer les catégories visibles.

4.       Dans la boîte de dialogue Changer les catégories visibles, vous pouvez sélectionner les palettes que vous utilisez le plus ou cliquer sur Tout sélectionner pour inclure toutes les palettes.

Pour modifier l’apparence du diagramme, sélectionnez Outils»Options dans la barre de menus. Dans la boîte de dialogue Options, sélectionnez la catégorie Diagramme. Ici, vous pouvez personnaliser l’apparence de votre diagramme. Pour économiser de l’espace sur le diagramme, désélectionnez Nouveaux terminaux sous forme d’icônes.


Terminaux

Les terminaux créent l’apparence du diagramme d’objets sur la face-avant. De plus, les terminaux sont les ports d’entrée et de sortie qui échangent des informations entre la face-avant et le diagramme. Tout comme les paramètres et les constantes des langages de programmation textuels, les terminaux sont de deux types : les terminaux de commande ou d’indicateur et les terminaux de nœuds. Les terminaux de commande et d’indicateur appartiennent aux commandes et indicateurs de la face-avant.

Dans l’exemple ci-dessus, les données que vous saisissez dans les commandes de la face-avant a et b intègrent le diagramme via leurs terminaux de commande respectifs a et b. Les données rentrent ensuite dans les fonctions Additionner et Soustraire. Lorsque les fonctions Additionner et Soustraire terminent leurs calculs, elles génèrent de nouvelles valeurs de données. Les valeurs de données sont transmises aux terminaux des indicateurs, où elles mettent les indicateurs de la face-avant à jour a+b et a-b.

Commandes, indicateurs et constantes

Les commandes, les indicateurs et les constantes fonctionnent comme les entrées et les sorties de l’algorithme du diagramme. Les commandes reçoivent leurs valeurs de la face-avant et transmettent des données à d’autres objets du diagramme. Les indicateurs reçoivent leurs valeurs de la logique du diagramme et transmettent les données du diagramme à la face-avant. Les constantes transmettent des données à l’objet auquel elles sont câblées. Envisagez un algorithme pour calculer l’aire d’un triangle. Vous pourriez avoir la face-avant illustrée ci-après et le diagramme correspondant.

La constante Multiplicateur triangulaire n’apparaît pas nécessairement sur la fenêtre de la face-avant, sauf éventuellement comme documentation de l’algorithme. Elle transmet simplement la valeur .5 à la fonction Multiplier. Notez que les terminaux du diagramme Base (cm) et Hauteur (cm) sont différents de ceux du terminal Aire (cm^2). Deux caractéristiques permettent de distinguer une commande d’un indicateur sur le diagramme. La première est une flèche sur le terminal qui indique la direction du flux de données. Les commandes possèdent des flèches qui montrent les données quittant le terminal, alors que les indicateurs ont une flèche qui indique les données entrant dans le terminal. La deuxième caractéristique est le cadre des terminaux. La bordure des commandes est épaisse alors que celle des indicateurs est fine.

Vous pouvez créer des commandes et des indicateurs à partir du diagramme ou de la face-avant. Ce tutoriel le montre dans une section ultérieure.

Nœuds du diagramme

Les nœuds sont des objets du diagramme qui comportent des entrées et/ou des sorties et qui réalisent des opérations pendant l’exécution du VI. Ils sont comparables aux déclarations, opérateurs, fonctions et sous-programmes des langages de programmation textuels. Les nœuds peuvent être des fonctions, des sous-VIs ou des structures. Les structures sont des éléments de contrôle du processus, tels que des structures Condition, des boucles For ou des boucles While, qui sont abordées dans un tutoriel ultérieur. L’image ci-dessous montre quelques exemples de nœuds de diagramme.

 

 

Fonctions

Les fonctions sont les éléments de fonctionnement fondamentaux de LabVIEW. Les fonctions n’ont pas de fenêtres de face-avant ou de fenêtres de diagramme. Toutefois, elles possèdent des terminaux d’entrée et de sortie pour transmettre des données de la même manière que les commandes et indicateurs. Vous pouvez déterminer si un objet du diagramme est une fonction grâce à l’arrière-plan jaune pâle de son icône. La paletteFonctions contient des fonctions organisées en groupes en fonction du type de fonction qu’elles exécutent. Recherchez dans la sous-palette Numérique les fonctions qui effectuent des opérations numériques.

 

Il existe de nombreux types de fonctions. N’oubliez pas qu’une fonction a un arrière-plan jaune pâle comme les fonctions illustrées ci-dessous.   

Sous-VIs

Les sous-VIs sont des VIs construits afin d’être utilisés dans un autre VI ou auxquels vous avez accès dans la palette Fonctions. N’importe quel VI peut être utilisé comme sous-VI. Lorsque vous double-cliquez sur un sous-VI du diagramme, sa fenêtre de face-avant apparaît et vous pouvez accéder à son diagramme. Vous trouverez ci-dessous quelques exemples de sous-VIs de la palette Fonctions.

Structures

Les structures, qui incluent des boucles For, des structures Condition et des boucles While, sont utilisées pour le contrôle de processus. Elles seront examinées dans un tutoriel ultérieur. Vous pouvez ouvrir la sous-palette Structures à partir de la palette Fonctions sous Programmation.

Vous trouverez ci-dessous quelques exemples de différentes structures et leur apparence sur le diagramme.

Créez maintenant le diagramme ci-dessous en suivant les étapes suivantes :

1.       Ouvrez un VI vide dans la barre d’outils. Sélectionnez Fichier»Nouveau VI.

2.       Placez deux fonctions de multiplication sur le diagramme en les faisant glisser sur le diagramme depuis la sous-palette Numérique sous Programmation. Répétez l’opération pour placer une deuxième fonction de multiplication sur le diagramme.

Astuce : Pour copier un objet sur le diagramme, maintenez la touche <ctr> enfoncée pendant que vous cliquez et faites glisser l’objet.

3.       Passez votre souris sur la fonction de multiplication la plus à gauche pour afficher les terminaux d’entrée et de sortie. Si vous passez votre souris sur l’un des terminaux, la bobine de fil apparaît avec le nom du terminal que vous survolez.

Pour créer une commande pour le terminal y, il suffit de passer la souris dessus et de faire un clic droit.

Faites de même pour le terminal x sur la fonction de multiplication la plus à gauche afin de disposer d’une commande pour chaque terminal d’entrée.

4.       Câblez le terminal de sortie de la fonction de multiplication de gauche à l’entrée x de la fonction de multiplication de droite en passant votre souris sur le terminal de sortie. Lorsqu’il se transforme en bobine de fil de câblage, cliquez et maintenez enfoncé le bouton pendant que vous faites glisser le fil de liaison vers l’entrée souhaitée.

5.       Pour créer la constante Multiplicateur triangulaire .5, cliquez avec le bouton droit sur le terminal d’entrée y de la fonction de multiplication la plus à droite et sélectionnez Créer»Constante. Pour modifier la valeur d’une constante, double-cliquez dessus pour mettre en évidence le texte et saisissez la nouvelle valeur. Saisissez .5 et appuyez sur <entrée>.

  

6.       Cliquez maintenant avec le bouton droit sur la sortie de la fonction de multiplication de droite et sélectionnez Créer»Indicateur pour créer un indicateur qui transmet la valeur de la logique du diagramme à la face-avant.

Astuce : Pour insérer des commentaires sur le diagramme ou la face-avant, double-cliquez sur le diagramme et saisissez votre commentaire dans le champ créé automatiquement.

Pour changer le nom des indicateurs, des commandes et des constantes, double-cliquez sur l’étiquette et saisissez le nom souhaité. Si aucune étiquette ne s’affiche, cliquez avec le bouton droit sur l’objet souhaité et sélectionnez Éléments visibles»Étiquette.

7.       Observez maintenant la face-avant générée à partir de votre travail sur le diagramme en appuyant sur <ctr-E> ou en sélectionnant Fenêtre»Afficher la face-avant. Notez que les deux commandes Base (cm) et Hauteur (cm) et l’indicateur Aire (cm^2) ont été automatiquement générés et placés sur la face-avant. Vous exécuterez ce programme après avoir pris connaissance des icônes de la barre d’outils.  

 

Barre d’outils de la fenêtre du diagramme

Lorsque vous exécutez un VI, la barre d’outils suivante apparaît sur le diagramme. Vous pouvez utiliser certains boutons de la barre d’outils du diagramme pour mettre au point le VI. Ces boutons seront abordés dans un tutoriel ultérieur.

        Cliquez sur le bouton Exécuter pour exécuter votre VI. Vous n’avez pas besoin de compiler votre code ; LabVIEW le compile automatiquement. Vous pouvez exécuter un VI si le bouton Exécuter apparaît sous la forme d’une flèche blanche pleine, représentée à gauche.

        Le bouton Exécuter apparaît brisé lorsque le VI que vous créez ou éditez contient des erreurs. Si le bouton Exécuter apparaît toujours brisé une fois que vous avez terminé le câblage du diagramme, le VI est brisé et ne peut pas s’exécuter. Cliquez sur ce bouton pour afficher la fenêtre Liste des erreurs, qui répertorie toutes les erreurs et mises en garde.  

        Cliquez sur Exécuter en continu pour exécuter le VI jusqu’à ce que vous abandonniez ou interrompiez l’exécution. Vous pouvez également cliquer une nouvelle fois sur ce bouton pour désactiver l’exécution en continu.

        Tant que le VI est en cours d’exécution, le bouton Abandonner l’exécution est affiché. Cliquez sur ce bouton pour arrêter immédiatement l’exécution du VI si vous n’avez pas d’autre choix. Si plusieurs VIs de niveau principal en cours d’exécution utilisent le VI, le bouton est grisé.

Attention : Le bouton Abandonner l’exécution arrête immédiatement le VI sans le laisser terminer l’itération en cours. L’abandon d’un VI qui fait appel à des ressources externes (à du matériel externe, par exemple) risque de laisser les ressources dans un état indéterminé si elles n’ont pas été libérées ou réinitialisées correctement. Pour éviter ce problème, utilisez un bouton Stop dans les VIs que vous créez.

        Cliquez sur Pause pour mettre l’exécution d’un VI en pause. Lorsque vous cliquez sur le bouton Pause, LabVIEW met en évidence sur le diagramme l’emplacement où vous avez suspendu l’exécution et le bouton Pause devient rouge. Cliquez une nouvelle fois sur le bouton Pause pour poursuivre l’exécution du VI.

  Sélectionnez le menu déroulant Paramètres du texte pour modifier la police de caractères des parties sélectionnées de votre VI, y compris sa taille, son style et sa couleur.

    Cliquez sur le menu déroulant Aligner les objets pour aligner les objets le long des axes et choisissez parmi les options suivantes : vertical, bord et gauche.  

    Cliquez sur le menu déroulant Répartir les objets pour redimensionner plusieurs objets de la face-avant à la même taille.

    Cliquez sur le menu déroulant Réorganiser lorsque vos objets se chevauchent et que vous souhaitez définir lequel est devant ou derrière l’autre. Sélectionnez l’un des objets à l’aide de l’outil Flèche, puis choisissez parmi les options Placer devant, Placer derrière, Placer au premier plan ou Placer en arrière-plan.  

        Cliquez sur le bouton Afficher la fenêtre d’aide contextuelle pour afficher ou non la fenêtre d’aide contextuelle.

        Valider apparaît pour vous rappeler qu’une nouvelle valeur est disponible pour remplacer l’ancienne. Le bouton Valider disparaît sur un simple clic, en appuyant sur la touche <Entrée>, ou en cliquant sur l’espace de travail de la face-avant ou du diagramme.

Exécution d’un VI à partir du diagramme

Enfin, cliquez sur le bouton Exécuter en continu sur le VI que vous venez de créer et modifiez les valeurs sur la face-avant. Observez comment la modification des valeurs de commande de a et b met à jour la valeur de l’indicateur de a*b.

 

Les valeurs placées dans les commandes de la face-avant sont transmises au diagramme et le résultat calculé par la logique du diagramme est renvoyé à l’indicateur de la face-avant.

Cliquez sur le bouton Abandonner l’exécution pour arrêter le VI. Pour enregistrer et fermer le VI, sélectionnez Fichier»Enregistrer dans la barre de menus, puis cliquez sur le bouton Fermer dans le coin supérieur droit de la fenêtre de la face-avant.

Le diagramme est l’aspect le plus fondamental de tout instrument virtuel. Il contrôle tout, du flux de données au transfert de données à l’entrée et à la sortie de la face-avant.  Une bonne compréhension du fonctionnement du diagramme est essentielle pour un programmeur LabVIEW.

 


Vidéo           L’environnement LabVIEW          Modules Home          Communauté FIRST