Compatibilité entre les versions de NI DAQmx et de Microsoft Windows

Aperçu

Cette page affiche les versions supportées du driver NI-DAQmx avec le système d'exploitation Microsoft Windows. Reportez-vous à ces informations pour vous assurer que vous installez la bonne version lors de la mise à niveau ou de la mise à jour de votre système d'exploitation, ou que vous migrer ou porter votre code vers un nouveau système. Utiliser des versions incompatibles peut entraîner des erreurs, aboutir à l'incapacité pour Windows de reconnaître ou détecter, et ensuite de trouver un driver pour votre périphérique, ou périphériques manquants dans le gestionnaire de périphérique Windows ou NI Measurement & Automation Explorer (MAX).

Veuillez remarquer que cet article remplace l'article 6HQ994XC de la Base de connaissances : Compatibilité entre les versions de DAQmx et de Windows. Certains manuels NI peuvent encore faire référence à ce document. Si vous avez été redirigé à partir de l'URL précédent de la Base de connaissances, veuillez mettre à jour vos favoris.

Contenu

Tableau de compatibilité des versions de NI-DAQmx et des systèmes d'exploitation Microsoft Windows Desktop.

Vous devez prendre en considération la compatibilité de l'application avec laquelle vous avez l'intention d'utiliser les drivers DAQmx, pas uniquement le système d'exploitation. Reportez-vous à la section Liens associés pour de plus amples informations, et au fichier readme de DAQmx pour des informations de compatibilité avec des périphériques spécifiques.

Utilisez ce tableau pour comparer les versions de NI-DAQmx avec les éditions compatibles du système d'exploitation Microsoft Windows Desktop.
NI‑DAQmx Microsoft Windows - Desktop Versions
XP1 Vista2 7 8 8.1 10
9.5.5          
9.6          
9.6.1          
9.6.2        
9.7        
9.7.5        
9.8        
9.9      
14.0      
14.1      
14.2      
14.5      
14.5.1      
15.0      
15.0.1      
15.1      
15.1.1      
15.5      
15.5.1      
16.0        
16.1        
17.0        
17.1        
17.1.1        
17.5        
17.6        
18.0        
18.1        
18.5        
18.6        
1 32 bits uniquement
2 Professionnel uniquement

Pour la configuration requise pour le Service Pack (SP), reportez-vous aux informations suivantes :

  • Windows XP : SP3 ou version ultérieure
  • Windows Vista : SP1 ou version ultérieure
  • Windows 7 : SP1 ou version ultérieure


Versions compatibles
  Service Pack requis


Pour des informations sur la compatibilité des versions plus anciennes de DAQmx ou Windows, veuillez vous référer au tableau de compatibilité DAQmx Windows joint à la section Téléchargements de ce document.


Tableau de compatibilité de NI-DAQmx et des systèmes d'exploitation Microsoft Windows Server.

Utilisez ce tableau pour comparer les versions de NI-DAQmx avec les versions compatibles de Windows Server.
NI‑DAQmx Microsoft Windows - Server Editions
2003 R21 2008 R22 2012 R22
9.5.5      
9.6      
9.6.1      
9.6.2      
9.7      
9.7.5      
9.8      
9.9      
14.0    
14.1    
14.2    
14.5    
14.5.1    
15.0    
15.0.1    
15.1    
15.1.1    
15.5    
15.5.1    
16.0    
16.1    
17.0    
17.1    
17.1.1    
17.5    
17.6    
18.0    
18.1    
18.5    
18.6    
1 32 bits uniquement
2 64 bits uniquement

Pour la configuration requise pour le Service Pack (SP), reportez-vous aux informations suivantes :

  • Windows Server 2003 R2 : SP2 ou version ultérieure
  • Windows Server 2008 R2 : SP1 ou version ultérieure


Versions compatibles
  Service Pack requis


Pour des informations sur la compatibilité des versions plus anciennes de DAQmx ou Windows, reportez-vous au tableau de compatibilité DAQmx Windows joint à la section Téléchargements de ce document.


Support pour Windows Embedded Standard (WES) 7

Certains contrôleurs compacts National Instruments sont fournis avec une version personnalisée NI de WES 7, y compris les packages nécessaires pour exécuter les logiciels et drivers NI. Cette version de WES 7 est la seule supportée par NI-DAQmx et National Instruments ne supporte pas les autres variantes de WES 7.


Téléchargements

Requirements

 

Software

Driver: NI-DAQmx 16.0