NI-FieldPoint Driver Versions Compatibility Chart

Aperçu

This page shows available versions of FieldPoint. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, or missing functions.

Note that this article replaces KnowledgeBase 3JHCMAHL: Archived: Which Versions of Software Drivers Can Be Installed With My FieldPoint CD?. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

NI-FieldPoint Compatibility Chart

Software Driver NI-FieldPoint
6.0.4 6.0.3 6.0.2 6.0.1 5.0.1 5.0 4.1 4.0.1 4.0.0
FieldPoint VI Manager 6.0.4* 6.0.3 6.0.2 6.0.1

4.1.0

4.0.0

3.1.0

3.0.0

4.0.0

3.1.0

3.0.0

3.0.0

2.0.1

1.0.28

2.0.1 2.0.1
FieldPoint Drivers 6.0.4* 6.0.3 6.0.2

6.0.0

5.1.0

5.2.0

5.1.2

5.1.0

5.0.2

5.1.2

5.1.0

5.0.2

5.0.2

4.1.7

4.1.6

4.1.7 4.1.7
LabVIEW Real-Time Support

8.6.1

8.5.1

8.x

7.1

8.x

7.x

8.x

7.x

8.2

8.0

7.1

8.0

7.1

7.1

7.0.0

6.1.3

7.0.0

6.1.1

7.0.0

6.1.1

DataSocket for LabVIEW Real-Time  

4.5.4

4.5.4

4.3

4.2

4.4

4.3

4.2

4.2    
NI-IrDA RT         1.0.2 1.0.2 1.0.1    
NI-Serial RT

3.3.3

3.3.0

3.3.2 3.3.2 3.3.0 3.1.0 2.5.6

2.5.4

2.0.2

2.5.2 2.5.2
NI-VISA

4.4

4.3

4.4 4.4 4.3 4.0.0 3.4.1 3.2 3.0.1 4.4
NI-Watchdog

3.0.0

2.1.5

3.0.0 3.0.0 2.1.5 2.1.5 2.1.4 2.1.2 2.0.0 2.0.0
Measurement and Automation Explorer 4.5.0f0 4.5 4.4 4.4 4.1.0 4.0.0 3.1.0 3.0.1 3.0.0
Network Variable Engine   1.4.1 1.4.1 1.0.0 1.2.0 1.0.0      
Variable Client Support   1.4.1 1.4.1   1.2.0 1.0.0      

 


  Compatible

Additional Resources

  • Download NI-FieldPoint Driver
  • Drivers and Updates: [c]FP-20xx Software Version 7.0 for Windows 2000/98 J/98/ME/NT/XP
  • KnowledgeBase 3N7A7A8M: Where Can I Find the Real-Time Serial Drivers For My FieldPoint Controller?