Comment convertir un VI en une version différente de LabVIEW ?

J'ai créé un VI dans une version de LabVIEW et je souhaiterais l'ouvrir dans une autre version de LabVIEW.
Parfois s'affiche l’erreur 1126 (0x466) : La version du VI est plus récente que la version actuelle de LabVIEW.
Comment puis-je convertir mon VI ?

Votre situation dépend de la version de LabVIEW que vous utilisez pour sauvegarder votre VI et de la version de LabVIEW que vous souhaitez utiliser pour ouvrir votre VI. Le tableau ci-dessous résume toutes les combinaisons possibles.

Tableau 1 : Combinaisons possibles d'ouverture et de fermeture


Kit de conversion LabVIEW Kit de conversion LabVIEW nécessaire
Version intermédiaire Version intermédiaire nécessaire pour la conversion
Kit de conversion et version intermédiaire nécessaires Kit de conversion et version intermédiaire nécessaires
VI ouvert correctement
Enregistrement en version précédente possible Enregistrement en version précédente possible
Plusieurs versions nécessaires pour la conversion Plusieurs versions nécessaires pour la conversion


Il y a six cas possibles :

Kit de conversion LabVIEW nécessaire Kit de conversion LabVIEW nécessaire

Pour charger un VI créé en LabVIEW 3.x ou version antérieure, vous devez utiliser le kit de conversion de VI LabVIEW. Ce kit peut être fourni gratuitement par National Instruments. Le numéro de référence de ce kit pour Windows et Macintosh est 776874-03.

Les VIs créés sous UNIX devront être transférés vers un Mac ou un PC pour être convertis en LabVIEW 4.0 puis transférés de nouveau vers UNIX. Le kit de conversion de VI LabVIEW n'est pas disponible sur le catalogue en ligne. Veuillez contacter directement le service commercial de National Instruments pour faire la demande de ce kit de conversion gratuit.

La conversion de VI est une procédure composée de plusieurs étapes où les VIs sont recompilés dans différentes versions de LabVIEW successivement. LabVIEW 3.1.1 et LabVIEW 4.0.1 sont disponibles sur le CD du kit de conversion de VI LabVIEW pour PC et pour Mac, et vous pouvez les exécuter directement depuis le CD.

Comme beaucoup de VIs ont changé  d’années en années, il est possible que vous ayez à remplacer manuellement certains des VIs dans le code.

Version intermédiaire nécessaire pour la conversion Version intermédiaire nécessaire pour la conversion

Pour ouvrir un VI créé avant LabVIEW 6 dans LabVIEW 8.5 ou version ultérieure, vous devez convertir le VI dans n'importe quelle version de LabVIEW comprise entre 6 et 8.2. National Instruments recommande d'utiliser la version 8.2.1 car c'est la version de LabVIEW la plus proche de la version actuelle. Contactez votre représentant local NI pour obtenir une version d'évaluation gratuite de LabVIEW 8.2.1.

Si vous avez seulement quelques VIs à mettre à jour, ouvrez-les en LabVIEW 8.2.1 et enregistrez les fichiers. Vous pouvez utiliser Fichier»Tout enregistrer pour enregistrer tous les VIs ouverts. Si vous avez un grand nombre de fichiers à mettre à jour, la fonctionnalité de recompilation dans LabVIEW peutêtre utilisée. Un fichier seul ou un répertoire entier peut être sélectionné pour la recompilation, les fichiers seront alors ouverts dans la nouvelle version, enregistrés puis fermés. Pour accéder à cette fonctionnalité, sélectionnez Outils»Avancé»Recompiler. Pour plus d'informations sur la recompilation, référez-vous à l'Aide LabVIEW.

Kit de conversion et version intermédiaire nécessaires Kit de conversion et version intermédiaire nécessaires

Le VI doit être enregistré en version 4 de LabVIEW à l'aide du kit de conversion de VI LabVIEW. Une fois le VI converti, il doit être enregistré dans une version de LabVIEW comprise entre 6 et 8.2. Pour plus d'informations sur le kit de conversion et l'enregistrement en version intermédiaire, veuillez consulter les cas mentionnés ci-dessus.

VI ouvert correctement VI ouvert correctement

La version la plus récente de LabVIEW peut ouvrir le VI. Il n'y a cependant pas de garantie que le VI fonctionnera correctement sans modification. Pour plus d'informations, vous pouvez consulter les notes de mises à jour de la version de LabVIEW avec laquelle vous essayez d'ouvrir votre VI.

Enregistrement en version précédente possible Enregistrement en version précédente possible

Le VI peut être enregistré dans une version précédente de LabVIEW. Dans LabVIEW 8 et version ultérieure, sélectionnez Fichier»Enregistrer pour une version précédente. Pour LabVIEW 7 ou version antérieure, sélectionnez Fichier»Enregistrer avec Options puis Enregistrer au format précédent.
Il existe de nombreux facteurs à considérer lorsqu'on enregistre le code LabVIEW en version précédente. Nous vous invitons à vous référer à la Base de Connaissances 203EDCXC (voir lien ci-dessous).

Plusieurs versions nécessaires pour la conversion Plusieurs versions nécessaires pour la conversion

La version souhaitée n'est pas directement disponible dans la version actuelle utilisée. Vous devez utiliser plusieurs versions de LabVIEW pour une conversion inférieure ou égale à n-2. Par exemple, pour une conversion de VI LabVIEW 8.6 en LabVIEW 7.1, vous devez d'abord le sauvegarder en LabVIEW 8.0. Voir le tableau 1 pour connaître les versions nécessaires à la conversion de vos VIs

KnowledgeBase 203EDCXC: Can I Save VIs in My Current LabVIEW Version for Use in a Previous Version?
NI LabVIEW 2010 Help: Converting VIs
NI LabVIEW 2010 Help: Mass Compile Dialog Box