Prévenir les problèmes de compatibilité logicielle pour les systèmes CompactRIO

Aperçu

Cette page répertorie les instructions et conseils pour la résolution des problèmes de compatibilité impliquant des systèmes CompactRIO.

Vous devez installer les logiciels requis avant de développer une application à l'aide d'un contrôleur CompactRIO et de modules d'E/S de la Série C. Suivez attentivement les instructions ci-dessous pour vous assurer que le système CompactRIO peut être ajouté au projet LabVIEW. Le non-respect des instructions peut entraîner des problèmes de compatibilité. Les principales causes de problèmes de compatibilité logicielles sont les suivantes :

  • Réalisation de mises à jour logicielles
  • Désinstallation de logiciels
  • Installation de versions logicielles non compatibles entre le PC de développement et le système CompactRIO
  • Installation de multiples versions de LabVIEW (par ex. : 64 bit -32 bit)
  • Installation de logiciels dans le désordre

Contenu

Ordre d'installation des logiciels et instructions

Flowchart

 

Identifier les versions logicielles minimales et maximales compatibles avec votre système CompactRIO.

Un système CompactRIO comprend un contrôleur, un châssis et plusieurs modules E/S de la Série C. La version du driver dépend de sa date de publication. Pour identifier les versions logicielles compatibles avec votre système CompactRIO, consultez le tableau joint pour connaître la version logicielle minimale et la version logicielle maximale pour votre système.

 

Installer le logiciel requis

Environnement de programmation Driver Outil de configuration
  • LabVIEW
  • LabVIEW Real-Time (RT)
  • LabVIEW FPGA1
  • NI-RIO
  • Support de module CompactRIO2
  • Drivers supplémentaires pour support de modules spécifiques3 (par ex. EtherCAT, XNET, NI-DAQmx)
  • Measurement & Automation Explorer (MAX)4

1Le module logiciel LabVIEW FPGA est facultatif,sauf si vous avez besoin de développer du code sur une cible FPGA.
2Pour en savoir plus sur le support de module NI CompactRIO, consultez le tableau ci-dessous.
3Un driver supplémentaire est requis pour ajouter un support pour certains modules spécifiques de la Série C (par ex. : NI-RIO).
4Le logiciel Measurement & Automation Explorer (MAX) s'installe avec le driver (par ex. : NI-RIO). Par conséquent, MAX ne dispose pas d'un installeur autonome.

Le support de module CompactRIO est commercialisé deux fois par an pour les nouveaux modules de la Série C. Vous pouvez installer le support de module CompactRIO en suivant l'une des méthodes suivantes :

  1. Installez le support de module CompactRIO en remplacement de l'ancienne version CompactRIO ou NI-RIO sans désinstallation. Par exemple, installez le support de module CompactRIO 14.6 à la place de NI-RIO 14.5 sans désinstaller ce dernier. Les versions majeures finissent typiquement par .0 ou .5.
  2. Installez la prochaine version supérieure de CompactRIO ou NI-RIO. Par exemple,au lieu d'installer le support de module CompactRIO 14.6, vous pouvez installer la version CompactRIO 15.0 ou une version supérieure (qui inclura le support de ces modules).

Support de module CompactRIO pour ajouter des modules spécifiques de la Série C

NI-XNET

NI-VISANI Serial Support de module NI CompactRIO NI-Industrial Communications pour EtherCAT
NI 9860 NI 9870 NI 9209 NI 9144
NI 9861 NI 9871 NI 9210 NI 9145
NI 9862   NI 9216  
NI 9866   NI 9217  
    NI 9224  
    NI 9226  
    NI 9228  
    NI 9230  
    NI 9242  
    NI 9244  
    NI 9246  
    NI 9247  
    NI 9250  
    NI 9251  
    NI 9260  
    NI 9264  
    NI 9266  
    NI 9344  
    NI 9403  
    NI 9437  
    NI 9478  
    NI 9485  
    NI 9502  
    NI 9505  
    NI-9770  
    NI 9775  

 

Activer les logiciels

Démarrez le gestionnaire de licences NI en tapant « Gestionnaire de licences » dans la barre de tâches Windows pour vérifier que le logiciel est activé. Cliquez ici pour en savoir plus sur l'activation des logiciels NI.

Le driver de périphérique NI-RIO n'a pas besoin d'être activé. Pour vérifier la version du driver de périphérique qui est activée, procédez aux actions suivantes :

  1. Ouvrez Measurement & Automation Explorer (MAX).
  2. Ouvrez le menu déroulant des logiciels situé sur la gauche et sélectionnez NI-RIO.

Cliquez ici pour télécharger NI-RIO si ce driver n'est pas dans la liste.

Remarque : installez toujours LabVIEW, LabVIEW Real-Time et le module LabVIEW FPGA avant d'installer un driver de périphérique (par ex. : NI-RIO).

Le Gestionnaire de licences NI 3.7 et les versions antérieures affichent les modules activés LabVIEW, Real-Time et FPGA. Le Gestionnaire de licences NI 4.0 affiche les modules activés LabVIEW, Real-Time et FPGA.
 

 

Ajouter votre contrôleur CompactRIO

ISi votre contrôleur CompactRIO n'est pas indiqué dans MAX, il peut s'agir d'un problème de compatibilité ou de pare-feu, ou d'un conflit d'adresse IP . Si votre contrôleur CompactRIO est doté d'une connexion USB hôte, vous pouvez le connecter directement au PC de développement pour éviter les problèmes de pare-feu et les conflits d'adresse IP. Cliquez ici pour en savoir plus.

Suivez les étapes suivantes pour exécuter Remote System Discovery Troubleshooting Wizard, l'assistant de résolution des problèmes de détection de systèmes déportés :

  1. Ouvrez MAX.
  2. Cliquez avec le bouton droit sur Système déportés et sélectionnez Troubleshoot Remote System Discovery.
  3. Sélectionnez votre contrôleur
  4. Cliquez sur Suivant.

 

Téléchargements