Software Support for CompactRIO, CompactDAQ, Single-Board RIO, R Series, and EtherCAT

Información general

This document describes the range of software versions required for the aforementioned devices and links to the most recent documentation resources available at the NI Product Documentation Center for each device.

 

Reference the information on the NI Hardware and Software Operating System Compatibility page to ensure your selected hardware, software, and driver combination is supported on your desired operating system.

 

Note: Your web browser may indicate blocked content when you view this document because it uses JavaScript to dynamically display information. This JavaScript does not contain any code that will harm your computer. Select the option in your browser to allow blocked content.

Software Downloads

Show Support Information for a Specific Device

Select your hardware from the drop-down below to view the software support.

Showing information for:

 

Note: LabVIEW support listed is referencing LabVIEW 32-bit. For LabVIEW 64-bit please confirm compatibility with the documentation. 

 

Documentation Resources

 

Most recent documentation for this device

 

 

Minimum Software Support

 

Software FPGA Interface Scan Interface NI-DAQmx EtherCAT (FPGA Interface) EtherCAT (Scan Interface)
LabVIEW          
LabVIEW FPGA Module          
LabVIEW Real-Time Module          
Device Driver Software          
Other Minimum Software          
Notes  
Software FPGA Interface Scan Interface NI-DAQmx EtherCAT (FPGA Interface) EtherCAT (Scan Interface)
Device Driver Software          
Other Minimum Software          
Notes  

 

 

NI 9151 R Series Expansion Chassis Compatibility with LabVIEW

 

Not Supported Supported Supported with Performance Limitations* Not Applicable
       
Notes *  Some devices may experience performance limitations when used with the NI 9151. 

 

Back to top

Related Links