NI Product Compatibility for Microsoft Windows 10

Overview

Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. Use the resources below to learn how Windows 10 impacts engineers and scientists and understand best practices for developing engineering and scientific applications on Windows 10.

Contents

Considerations for Using NI Software with Windows 10

Accessing NI Software in Windows 10

Windows 10 reintroduces the Start menu, which changes how you access NI products. After installing NI software using NI Package Manager, you can find your applications listed under the alphabetized 'N' section of the All Apps menu. All secondary shortcuts are under the NI section of the menu.

Windows OS 32-bit and 64-bit

Windows 10 32-bit can run on either x86 or x64 hardware. Similar to Windows XP 32-bit, Windows 10 32-bit provides access only to 32-bit addresses. As a result, even though Windows 10 32-bit will run on x64 hardware, it is limited to using 4 gigabytes of RAM. Windows 10 32-bit cannot run 64-bit versions of drivers or software designed to run natively on 64-bit operating systems.

Windows 10 64-bit can be installed only on x64 hardware. This version of the operating system allows software to use 64-bit addresses to access hardware and can therefore access much larger memory spaces.  In order to run successfully on Windows 10 64-bit, all drivers must have native 64-bit support. However, most 32-bit software applications can run within a Windows 10 64-bit emulation layer.

For more detailed information on the difference between Windows 32-bit and 64-bit, see Using NI Products on 32-bit and 64-bit Windows.

Silverlight Support 

Some NI components require Microsoft Silverlight to function properly. The default browser in Windows 10, Microsoft Edge, does not support Silverlight. Google Chrome also no longer supports Silverlight. Windows 10 includes Internet Explorer 11 for backward compatibility, which supports Silverlight. All Silverlight pages launched from MAX will use Internet Explorer, but Silverlight-based pages launched manually using a default browser that does not support Silverlight, such as Edge or Chrome, will fail to open. For more information about using Silverlight-based pages on Windows 10, refer to KnowledgeBase Remote Front Panels, NI Network Browser, and the Web Interface (WIF) Do Not Work in Google Chrome Version 42 or Higher

Fast Startup Issues

NI strongly encourages its customers to disable fast startup as this may affect NI hardware detection after upgrading to Windows 10.

Repairing NI Software After Upgrading

Performing a repair on NI software after upgrading to Windows 10 can result in a loss of access to hardware associated with repaired drivers. To restore the NI device drivers to a working state, perform a repair on the affected device drivers.

Note: This was an issue originally discovered when upgrading from Windows 8.0 to 8.1 that also applies to Windows 10 upgrades.

Using the Windows 10 Compatibility Tables

  • Note: In the tables below, the column titled 'Windows 10 64-bit (Using 32-bit Software)' indicates the first version of 32-bit software that will run within the Windows on Windows (WOW64) emulation layer.
  • In the tables below, Not supported means the end user cannot use 32-bit NI software in their 64-bit software scenarios. Not applicable means the software bitness for that version of the operating system does not exist or is not a valid configuration. For example, MAX or LabWindows™/CVI™ development environments do not have 64-bit versions of the executable, but will work on 64-bit Windows 10. A 64-bit program will not work on a 32-bit operating system.


If there is any question about the compatibility of a piece of software, please refer to the Readme.

Note: 
On May 1, 2021, NI software dropped support for Microsoft Windows 7 (32- and 64-bit), Windows 8.1 (32- and 64-bit), Windows Server 2008 R2, Windows Server 2012 R2, and all 32-bit Windows operating systems. NI hardware and software released after May 1, 2021, will not install or execute correctly on those operating systems. For product specific information, visit the Readme.

Software

The following table lists the first version of Software compatible with the listed versions of Windows 10 32-bit and Windows 10 64-bit. For more details on specific versions of software, please refer to the Readme for the version in question.

NI Software Windows 10 32-bit Windows 10 64-bit Windows 10 64-bit
(Using 32-bit Software) (Using 64-bit Software)
GPIB-Serial Converter Software 19.0 Not applicable 19.0
G Web Development Software Not applicable Not applicable 2021
LabVIEW Communications System Design Software Not applicable Not applicable 2.0
LabVIEW Communications System Design Suite Not applicable Not applicable 2.1
LabVIEW NXG Not applicable Not applicable 1.0
mmWave OTA Validation Test Software Not applicable Not applicable 1.0
NI Analog Video Generator Not supported Not supported Not supported
NI Analog Waveform Editor Not supported Not supported Not supported
NI AudioMASTER Not supported Not supported Not supported
NI Calibration Executive 3.6 - 5.0 3.6 6.0
NI DIAdem 2015 SP1 2015 SP1 2015 SP1
NI Digital Video Generator Not supported Not supported Not supported
NI Digital Waveform Editor 3.0 3.0 Not applicable
NI FlexLogger Not applicable Not applicable 2018 R2
NI Functional Safety Editor Not supported Not supported Sep-17
NI I/O Trace 15.0 15.0 15.0
NI InstrumentStudio Not applicable Not applicable 2018
LabVIEW 32-bit 2015 SP1 2015 SP1 Not applicable
LabVIEW 64-bit Not applicable Not applicable 2015 SP1
LabVIEW for LEGO® MINDSTORMS 2016 2016 Not applicable
LabWindows/CVI Run-Time Engine 2015 2015 2015
LabWindows™/CVI™ 2015 2015 Not applicable
NI Lookout (Lookout FDS) Not supported Not supported Not applicable
NI MATRIXx 7.2.8 7.2.8 7.2.8
NI Measurement & Automation Explorer (MAX) 15.0 15.0 Not applicable
NI Measurement Studio 2015 2015 2015
NI Multisim 14.0.1 14.0.1 Not supported
NI Package Builder 19.0 19.0 19.0
NI Package Manager 19.0 19.0 17.0
NI Picture Quality Analysis (PQA) Not supported Not supported Not supported
NI Real-Time Hypervisor Not supported Not supported Not supported
NI Requirements Gateway 2014 2014 Not applicable
NI SignalExpress Not applicable Not applicable Not applicable
NI Switch Executive 2017 2017 2017
NI SystemLink Client Not applicable Not applicable 17.0
NI SystemLink Server Not applicable Not applicable 17.0
NI TestStand 2014 SP1 2014 SP1 2014 SP1
NI Ultiboard 14.0.1 14.0.1 Not supported
NI Update Service 2.3 2.3 17.0
NI VeriStand 2015 - 2018 SP1 2015 - 2018 SP1 2019
NI Video Measurement Suite (VMS) Not supported Not supported Not supported
NI VirtualBench 16.0 16.0 16.0
NI Vision Builder for Automated Inspection 2015 2015 2015

 

Add-Ons and Toolkits

The following NI Add-ons and Toolkits are compatible with the listed versions Windows 10 32-bit and Windows 10 64-bit: 

NI Software Windows 10 32-bit Windows 10 64-bit Windows 10 64-bit
(Using 32-bit Software) (Using 64-bit Software)
FlexLogger Plugin Development Kit Not applicable Not applicable 1.0
NI Automotive Diagnostic Command Set 15.0 15.0 15.0
NI Bluetooth Toolkit (Run-Time, Generation, Analysis) 15.0 15.0 15.0
NI Combustion Analysis System 2015 2015 Not supported
NI ECU Measurement and Calibration Toolkit 15.0 15.0 15.0
NI FM/RDS Measurement Suite 1.0 Not Supported Not supported
NI GNSS Simulation Toolkit 3.0 Not Supported Not supported
LabVIEW Advanced Signal Processing Toolkit 15.0 3 15.0 3 2018
LabVIEW Analytics and Machine Learning Toolkit 2017 2017 2018
LabVIEW Application Builder 2015 SP1 2015 SP1 2015 SP1
LabVIEW C Generator 2015 3 2015 3 Not applicable
LabVIEW Communications MIMO Application Framework Not supported Not supported Not supported
LabVIEW Control Design and Simulation Module 2015 3 2015 3 2016
LabVIEW Database Connectivity Toolkit 2015 3 2015 3 2019
LabVIEW DataFinder Toolkit 2016 2016 Not supported
LabVIEW Datalogging and Supervisory Control Module 2015 3 2015 3 Not applicable
LabVIEW Desktop Execution Trace Toolkit 2015 3 2015 3 2016
LabVIEW Digital Filter Design Toolkit 2015 3 2015 3 2018
LabVIEW Electrical Power Toolkit 2016 2016 Not applicable
LabVIEW Embedded for ARM Module Not supported Not supported Not supported
LabVIEW FPGA Module 1 2017 2017 2018
LabVIEW FPGA Xilinx ISE 1 Not supported Not supported Not applicable
LabVIEW FPGA Xilinx Vivado 1 Not applicable 2018 2018
LabVIEW MathScript RT Module 2015 3 2015 3 2016
LabVIEW Mobile Module Not applicable Not applicable Not applicable
LabVIEW Module for LEGO MINDSTORM Not applicable Not applicable Not applicable
LabVIEW myRIO Toolkit 2015 3 2015 3 Not applicable
LabVIEW OPC UA Toolkit 2017 2017 2018
LabVIEW PDM Acquisition Toolkit Not supported 2020 Not supported
LabVIEW PID and Fuzzy Logic Toolkit 2 2015 SP1 2015 SP1 2015 SP1
LabVIEW Real-Time Module 2015 SP1 2015 SP1 20214
LabVIEW Report Generation Toolkit for Microsoft Office 2015 3 2015 3 2015 3
LabVIEW roboRIO Toolkit 2015 3 2015 3 Not applicable
LabVIEW Robotics Module 2015 3 2015 3 Not applicable
LabVIEW Softmotion Module 2015 3 2015 3 Not applicable
LabVIEW Statechart Module 2015 3 2015 3 Not applicable
LabVIEW SystemLink Toolkit 19.5 19.5 19.5
LabVIEW Touch Panel Module Not supported Not supported Not applicable
LabVIEW Unit Test Framework Toolkit 2015 3 2015 3 2016
LabVIEW VI Analyzer Toolkit 2015 3 2015 3 2016
LabVIEW Wireless Sensor Network (WSN) Module 2015 3 2015 3 Not applicable
LabWindows/CVI Execution Profiler Toolkit 1.0 1.0 1.0
LabWindows/CVI PID Control Toolkit 2.1 2.1 Not applicable
LabWindows/CVI Real-Time Module 2015 2015 Not applicable
LabWindows/CVI Signal Processing Toolkit 7.0.2 7.0.2 Not applicable
LabWindows/CVI SQL Toolkit 2.3 2.3 2.3
NI License Manager 3.7 3.7 3.7
LabVIEW Modulation Toolkit 15.0 15.0 15.0
NI Motion Assistant Not supported Not supported Not applicable
NI OPC Servers 2016 2016 Not supported
NI-RFFastACP 1.0.0 1.0.0 1.0.0
NI-RFmx 1.2 1.2 1.2
NI-RFPM Not supported 16.0.0 16.0.0
NI Software Calibration Management Toolkit for LabVIEW 2015 2015 Not supported
NI Sound and Vibration Measurement Suite 15.0 15.0 15.0 (excluding configuration of Express VIs)
NI Spectral Measurements Toolkit 15.0 15.0 15.0
NI SystemLink Server - Test Module Not applicable Not applicable 18.0
NI TDMS 15.0 15.0 15.0
NI TestStand ATML Toolkit 2013 2013 2017
NI Vision Development Module 2015 SP1 2015 SP1 2015 SP1
NI-VRTS Not applicable 1.5 1.5
NI WLAN Toolkit 15.0 15.0 15.0
RFIC Test Software Not supported 3.0 3.0
Semiconductor Device Control Add-On for InstrumentStudio Not applicable Not applicable 2019
TestStand Semiconductor Module 2016 2016 2016
VCSEL I-V Test Software Not supported Not supported 20.0


1
The LabVIEW FPGA Module is partially supported on Windows 10. However, the Xilinx tools used for your NI FPGA device might not be. For details, refer to LabVIEW FPGA Module Compatibility with Windows 10.

2 NI LabVIEW PID and Fuzzy Logic Toolkit was included with base LabVIEW beginning with LabVIEW 2014.

3 This software version only supports Windows 10 when used with LabVIEW 2015 SP1.

4 There is limited hardware supported in the LabVIEW Real-Time Module 2021 64-bit release.

Hardware Drivers

The following NI Hardware Drivers are compatible with the listed versions of Windows 10 32-bit and Windows 10 64-bit.

NI Software Windows 10 32-bit Windows 10 64-bit Windows 10 64-bit
(Using 32-bit Software) (Using 64-bit Software)
Instrument I/O Assistant 15.0 15.0 15.0
FieldPoint 15.0 15.0 Not supported
NI-488.2 15.5 15.5 15.5
NI-568x 15.0 15.0 15.0
NI-5690 15.0 15.0 15.0
NI-845x 15.0 15.0 15.0
NI-CAN 15.0 15.0 Not applicable
NI CompactRIO Device Drivers 15.5 15.5 15.5
NI-DAQmx 15.5 15.5 15.5
NI-DCPower 15.2 15.2 15.2
NI-DCPower .NET API 17.1 17.1 17.1
NI-Digital Pattern Driver 16.0 1 16.0 16.0
NI-DMM 15.2 15.2 15.2
NI-DMM .NET API 15.2 15.2 15.2
NI-ELVISmx 16.0 16.0 Not supported
NI-Embedded CAN for sbRIO Not supported Not supported Not supported
NI-FBUS 15.0 15.0 Not applicable
NI-FGEN 16.0 16.0 16.0
NI-FlexRIO 15.1 15.1 15.1
NI-High Speed Serial 15.0 15.0 15.0
NI-HSDIO 16.0 16.0 16.0
NI HWS 15.0 15.0 Not supported
NI-IMAQ 15.5 15.5 15.5
NI-IMAQ I/O 15.5 15.5 15.5
NI-IMAQdx 15.5 15.5 15.5
NI-Industrial Communications for CANopen 15.0 15.0 Not applicable
NI-Industrial Communications for DeviceNet 15.0 15.0 Not applicable
NI-Industrial Communications for DNP3 14.0 14.0 Not applicable
NI-Industrial Communications for EtherCAT (NI-ECAT) 16.0 16.0 Not supported
NI-Industrial Communications for EtherNet/IP 15.0 15.0 15.0
NI-Industrial Communications for IEC 60870-5 1.1 (with 1.1.1 patch) 1.1 (with 1.1.1 patch) Not applicable
NI-Industrial Communications for IEC 61850 15.0 15.0 Not applicable
NI IVI Compliance Package 15.0 15.0 15.0
NI-Motion 15.0 15.0 Not applicable
NI MXI-Express BIOS Compatibility Software 18.0 18.0 18.0
NI-OSI 15.0 15.0 Not applicable
NI-P2P 15.0 15.0 15.0
NI-PXImc 16.0 16.0 16.0
NI PXI Platform Services 15.1 15.1 15.1
NI PXI-5624R Digitizer Instrument Design Libraries Not supported Not supported Not supported
NI PXI-5644R/5645R/5646R Instrument Design Libraries (VST) 15.0.2 15.0.2 Not supported
NI PXI-5660 15.0 Not supported Not supported
NI-RFSA 15.0.2 15.0.2 15.0.2
NI-RFSA .NET API 16.0 16.0 16.0
NI-RFSG 15.0.2 15.0.2 15.0.2
NI-RFSG .NET API 16.0 16.0 16.0
NI-RIO 15.0 15.0 15.0
NI R Series Multifunction RIO Device Drivers 2 15.0 15.0 15.0
NI-Scope 16.0 16.0 16.0
NI-Scope .NET API 2.0 2.0 2.0
NI-Serial 17.0 17.0 17.0
NI-SLSC 1.0 1.0 1.0
NI-Switch 16.0 16.0 16.0
NI-Switch .NET API 17.0 17.0 17.0
NI-Sync 15.0.1 15.0.1 15.0.1
NI System Configuration 15.0 15.0 15.0
NI-TimeSync 15.0 15.0 Not supported
NI-USRP 14.5 14.5 14.5
NI-VISA 15.0.1 15.0.1 15.0.1
NI-VISA .NET API 15.0 15.0 15.0
NI-VNA 16.0 16.0 16.0
NI-VXI 16.0 16.0 16.0
NI-WSN 15.0 15.0 Not supported
NI-XNET 15.0 15.0 15.0
RMX-410x Power Supply Driver N/A 20.7 20.7

 

The NI-Digital Pattern Driver only supports deployment on 32-bit versions of Windows and does not support development on 32-bit Windows.

2 These modules can only be used with 64-bit software, if the bitfile used has been compiled in 32-bit software.

Was this information helpful?

Yes

No