
<!DOCTYPE HTML>
<html lang="en" data-aem-fallback-locale="en-VN">
<head>
</meta>
</meta>
<meta />
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<script>digitalData={"product":[{"productInfo":{"productID":"331428"}}],"page":{"pageInfo":{"template":"releaseNoteBug"}}};</script>
<meta name="Keywords" content="Package, Builder, 20.0, Bug, Fixes " />
<meta name="description" content="The following items are notable issues fixed between the release of NI Package Builder 19.6 and NI Package Builder 20.0, including additional patches and service packs. If you have an issue ID, you can search this list to validate that the issue has been fixed. This is not an exhaustive list of issues fixed in the current version of NI Package Builder 20.0." />
<meta name="Country" content="VN" />
<meta name="Language" scheme="rfc3066" content="en" />
<meta name="Section" content="support" />
<meta name="ContentType" content="bugs" />
<meta name="PageType" content="leaf" />
<meta name="ProductCategories" content="331428" />
<meta name="GlobalScope" content="global" />
<meta name="DocumentID" content="e39dfdc8-2027-4d4c-8de3-1967f40a83a6" />
<link rel="shortcut icon" type="image/x-icon" href="//www.ni.com/favicon.ico" />
<link rel="icon" type="image/x-icon" href="//www.ni.com/favicon.ico" />
<meta name="Robots" content="index, follow">
<meta name="DeliveredBy" content="CMS" />
<meta name="Date" scheme="iso8601" content="2020-03-31T13:14:00" /> 
<meta name="UpdateDate" scheme="iso8601" content="2020-03-31T13:14:18" /> 
<link rel="canonical" href="https://www.ni.com/en-vn/support/documentation/bugs/20/ni-package-builder-20-0-bug-fixes-.html" />
<meta name="docstatus" content="current" />
<meta name="cms_countrysite_s" content="en-vn" />
<meta name="Template_s" content="release-notes---bugs" />
<script>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</script>
</meta>
</meta>
<title>NI Package Builder 20.0 Bug Fixes - National Instruments</title>
<meta name="ShortTitle" content="NI Package Builder 20.0 Bug Fixes" />
<meta name="EnglishShortTitle" content="NI Package Builder 20.0 Bug Fixes" />

<meta http-equiv="x-dns-prefetch-control" content="on">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="dns-prefetch" href="//assets.adobedtm.com">
<link rel="dns-prefetch" href="//dpm.demdex.net">
<link rel="dns-prefetch" href="//ds.serving-sys.com">
<link rel="dns-prefetch" href="//bs.serving-sys.com">
<link rel="dns-prefetch" href="//nsmetrics.ni.com">
<link rel="dns-prefetch" href="//cdn.tt.omtrdc.net">
<link rel="dns-prefetch" href="//ni.tt.omtrdc.net">
<link rel="dns-prefetch" href="//s7d5.scene7.com">
<link rel="dns-prefetch" href="//ni.scene7.com">

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="Wrapper" content="yes" />
<meta name="viewport" content="width=device-width, initial-scale=1">

<script type="text/javascript" src="/niassets/jquery/js/jquery.min.js"></script>

<script src="/niassets/js/niua.min.js"></script>

<script src="/niassets/js/loader.min.js"></script>

<script type="text/javascript" src="/niassets/jquery/js/jquery-migrate-1.2.1.min.js"></script>

<script type="text/javascript" src="/niassets/bootstrap/js/bootstrap.min.js"></script>

<script type="text/javascript" src="/niassets/jquery/jqueryui/js/jquery-ui.min.js"></script>

<link rel="stylesheet" href="/niassets/bootstrap/css/bootstrap.min.css">
<script type="text/javascript" src="/niassets/ni.min.js"></script>

<link rel="stylesheet" type="text/css" href="/niassets/jquery/jqueryui/css/jquery-ui.min.css">

<link rel="stylesheet" type="text/css" href="/niassets/ni.min.css">


<script defer src="/niassets/flexslider/2.6/jquery.flexslider.js"></script>

<script src="/niassets/jquery/js/jquery.easing.1.3.js"></script>
<script src="/niassets/jquery/js/jquery.mousewheel.js"></script>
<link rel="stylesheet" href="/niassets/flexslider/2.6/flexslider.css" type="text/css" media="screen" />
<link rel="stylesheet" href="/etc.clientlibs/ni-commons/clientlibs/core-components.min.css" type="text/css">
<script type="text/javascript" src="/etc.clientlibs/clientlibs/granite/utils.min.js"></script>
<script type="text/javascript" src="/etc.clientlibs/ni-commons/clientlibs/core-components.min.js"></script>
</meta>
<script>
    var NI = NI || {};
    NI.utils = NI.utils || {};
    NI.utils.browserSize = function() {

        var envs = ['xs', 'sm', 'md', 'lg'];

        var $el = $('<div>');

        $el.appendTo($('body'));

        for (var i = envs.length - 1; i >= 0; i--) {
            var env = envs[i];

            $el.addClass('hidden-'+env);
            if ($el.is(':hidden')) {
                $el.remove();
                return env;
            }
        }

    }
</script>
<meta />
</head>
<body>
<div class="ni-page-wrap">
<div class="ni-wrapper-header noindex">



<nav class="navbar navbar-default">

<div class="container-fluid">
<div class="row">
<div class="container">
<div class="row">
<div class="ni_logo col-md-5 col-xs-4">
<a href="//www.ni.com/" class="navbar-brand analytics-utilitylogo-link"></a>
</div>
<div class="utility-nav col-md-7 pull-right">
<ul class="nav nav-pills pull-right">

<li class="hidden-xs myaccount-utility">
<span class="pull-left user"></span>
<span class="global-header-nav-up-wrap"></span>
</li>

<li class="cart cart-badge analytics-utilitycart-link" data-badge="0"><a href="http://sine.ni.com/apps/utf8/nios.store?action=view_cart&amp;loc=en-VN">&nbsp;</a></li>

<li class="visible-xs search search-box" role="button" data-toggle="modal" data-target="#wrapperSearchModal">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="48px" height="48px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#FFFFFF" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z" />
</g>
</g>
</svg>
</li>


<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</ul>
</div>
</div>
</div>
</div>
<div class="row">
<div class="container">
<div class="row">
<div class="ni-nav col-md-8 col-sm-9 pull-left col-xs-12">
<div id="navbar" class="navbar-collapse collapse">
<ul class="nav navbar-nav">
<li class="innovations ">
<a class="analytics-header-link" href="//www.ni.com/innovations/">INNOVATIONS</a>
</li>
<li class="products ">
<a class="analytics-header-link" href="//www.ni.com/shop/">PRODUCTS</a>
</li>
<li class="support  current">
<a class="analytics-header-link" href="//www.ni.com/en-us/support.html">SUPPORT</a>
</li>
<li class="community ">
<a class="analytics-header-link" href="//forums.ni.com">COMMUNITY</a>
</li>
<li class="nav-myaccount visible-xs">
<span class="pull-left user"></span>
<div class="mobile-nav-up-wrap">
<a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">My Account</a>
<br>
<span>
<a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">Log in</a>
</span>
</div>
</li>
</ul>
<div class="hidden-xs" id="navSlider">&nbsp;</div>
</div>

</div>
<div class="col-md-4 col-sm-3 pull-right col-xs-4 global-header-search">
<div class="hidden-xs pull-right">
<form id="autoComplete-global" name="autoComplete-global" type="GET" action="//search.ni.com/nisearch/app/main">
<div class="autoCompleteItem-global">
<div class="input-group stylish-input-group">

<input placeholder="" class="niAutocompleteInput pull-right" data-search-type="globalSearch" type="text" id="n33_autoCompleteInput" name="q" />
<input type="hidden" name="pg" id="pg" value="1" />
<input type="hidden" name="sn" id="sn" value="" />
<span class="input-group-addon">
<button type="submit">
<span class="search search-icon">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="35px" height="35px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#065FA3" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z" />
</g>
</g>
</svg>
</span>
</button>
</span>
</div>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<div class="container global-header-breadcrumb">
</div>
<div class="container-fluid ni-aem-body">
<div class="clearfix" align="center"></div>
<div><div><div class="breadcrumb row parbase">
<div class="ni-body-copy-secondary container">
<div>
<a class="left " href="/en-vn.html">Home</a>
<span class="delimiter"></span>
<a class="left " href="/en-vn/support.html">Support</a>
<span class="delimiter"></span>
<a class="left " href="https://www.ni.com/manuals/">Documentation</a>
<span class="delimiter"></span>
<span class="left breadcrumb-last">Bugs</span>
</div>
</div>
</div> </div></div>
<div class="clearfix"><div class="ni-home">
<div>
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container ni-white ">
<div>
<div class="row">
<div class="shading-container  ni-padding-top-1x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="title aem-GridColumn aem-GridColumn--default--12">
<div>
<div class="ni-notransform ni-text-align-left">
<h1 lang="en">NI Package Builder 20.0 Bug Fixes</h1>
</div>
</div></div>
</div></div>
</div>
</div>
 </div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class=" clearfix">
<div class="row  ">
<div class="container">
<div class="row">
<div class="shading-container   col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="metadata-subtitle parbase aem-GridColumn aem-GridColumn--default--12"><link rel="stylesheet" href="/niassets/font-awesome/css/font-awesome.min.css" type="text/css" />
<div class="subtitle-description lead">
<span class="lastModifiedDate">
Created Mar 31, 2020
</span>
</div>
<div class="subtitle-icons">
<ul class="list-unstyled">
<li>
<div class="icon" onclick="location.href='mailto:?subject='+document.title+'&amp;body='+window.location.href;">
<i class="fa fa-envelope"></i>
</div>
</li>
<li>
<div class="icon" onclick="window.print();">
<i class="fa fa-print"></i>
</div>
</li>
</ul>
</div>
</div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container   col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="document-archived-notification-bar notification-bar parbase aem-GridColumn aem-GridColumn--default--12">
<div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="overview aem-GridColumn aem-GridColumn--default--12">
<div class="ni-padding-bottom-1x">
<div class="ni-padding-bottom-x">
<h2>Overview</h2>
</div>
<div>
<div lang="en">
<p>The following items are notable issues fixed between the release of NI Package Builder 19.6 and NI Package Builder 20.0, including additional patches and service packs. If you have an issue ID, you can search this list to validate that the issue has been fixed. This is not an exhaustive list of issues fixed in the current version of NI Package Builder 20.0.</p>
</div>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="link parbase aem-GridColumn aem-GridColumn--default--12">
<div>
<div>
<span>
<a href="#bugsglossary">
Glossary of Terms
</a>
</span>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class=" clearfix">
<div class="row  ">
<div class="container">
<div class="row">
<div class="shading-container ni-padding-bottom-x ni-padding-top-x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="rich-text-section parbase aem-GridColumn aem-GridColumn--default--12">
<div>
<div>
<div class="rich-text-section-entry">
<div class="clearfix">
<div>
<div lang="en">
<p><span id="table" class="float-placeholder"></span> </p>
</div></div>
</div>
<div class="clearfix">
<a class="right hidden-print pointer-cursor" onclick="javascript:window.scroll(0,0);">Back to top</a>
</div>
</div>
<div class="known-issues-table parbase">
<link rel="stylesheet" href="/etc.clientlibs/ni-content/components/specialty/known-issues-table/clientlibs.min.css" type="text/css">
<script type="text/javascript" src="/etc.clientlibs/ni-content/components/specialty/known-issues-table/clientlibs.min.js"></script>
<div>
<span class="ni-aem-table table-striped-even">
<table>
<tbody>
<tr>
<th class="sortable">
<div class="flex-container">
<p>Bug Number</p>
<svg class="ni-tooltip" data-trigger="click" data-content="The ID that you can use to track this bug" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="sortable">
<div class="flex-container">
<p>Legacy ID</p>
<svg class="ni-tooltip" data-trigger="click" data-content="The issue ID from a legacy system referring to the same bug" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="minimum-width">
<div class="flex-container">
<p>Description</p>
<svg class="ni-tooltip" data-trigger="click" data-content="Information to help identify the issue and potential workarounds" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="sortable minimum-width">
<div class="flex-container">
<p>Details</p>
<svg class="ni-tooltip" data-trigger="click" data-content="Version in which the issue was discovered and resolved" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
</tr>
<tr>
<td class="align-top">897464</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Solution fails to load when input file or directory is specified using a network path</h4>
<p class="margin-above"><div><span style="display: inline;">Opening a solution errors when the solution contains an input file or directory that is specified using a network path, i.e. \\server\share.</span></div></p>
<div class="workaround-container margin-above">
 <p class="align-top"><b>Workaround:</b></p>
<p><span style="display: inline;"><div style=""><span>Create a mapped drive letter, i.e. SUBST T: \\server\share\, and configure the input item to use the mapped drive for the input file or directory, e.g. T:\directory\file.ext. Edit the solution file contents to change the network path to mapped drive path before opening the solution file.</span><br /></div><div style=""><br style="" /></div></span></p>
</div>
</td>
<td class="align-top" data-added-date="1574316000">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.0</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Nov 21, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">897669</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Solution Load Error Occurs When Package Installer Contains Packages from Unavailable Network Locations</h4>
<p class="margin-above"><div /><div><span>If a package Installer in a solution contains packages from a network location and the network location is not accessible, loading the solution fails and reports an error stating </span><span>&quot;An error occurred while loading the solution&quot;.</span><br /></div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1574316000">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.0</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Nov 21, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">943901</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Properties Pane Does Not Always Update when Selecting a File in the Dependencies View of the Input Pane</h4>
<p class="margin-above"><div>The properties pane does not update appropriately when selecting an item in the Input pane if the previous item displayed in the properties pane is a file in a package editor, a package, a package installer, or a local repository.</div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><div>Select any file in the File System View of the Input pane before selecting file in the Dependencies View of the Input Pane.</div></p>
</div>
</td>
<td class="align-top" data-added-date="1576130400">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.1</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Dec 12, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">948257</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Package Builder Crashes when Dragging a Package from an Installer to a Target Installer that Already has One Item</h4>
<p class="margin-above"><div><span>Dragging a package between package installers can cause Package Builder to crash if the target installer has </span><span>at least one item. </span></div><div><br /></div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><span style="display: inline;">Add packages to installer using &quot;Add Packages&quot; dialog.</span></p>
</div>
</td>
<td class="align-top" data-added-date="1576130400">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.6</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Dec 12, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">948258</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Drag Copy of Packages Between Installers does Nothing if One of the Packages Already Exists in the Target Installer</h4>
<p class="margin-above"><div>In 19.1, and 19.6, if you attempt to drag multiple packages from one installer to another and one of the packages is already in the target installer, nothing will be copied over. <span style="font-weight: inherit;">The same operation in 19.0.1 crashes.</span></div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><span style="display: inline;">Drag only package from the source package that are not already in target package.</span></p>
</div>
</td>
<td class="align-top" data-added-date="1576130400">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.0</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Dec 12, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">252677</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Edit Menu Commands Incorrectly Operate on the Input Pane Instead of the Active Editor Pane</h4>
<p class="margin-above"><div>Some global application commands, such as the Edit menu commands, act on selected items in the active pane. In some instances when the Editor pane is activate, the commands incorrectly operate on the selected items in the Input pane.</div><div><div><br /></div></div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1585630800">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.1</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Mar 31, 2020</p>
</td>
</tr>
<tr>
<td class="align-top">985058</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Package Builder Crashes when Discovering Dependencies for a LabVIEW NXG Project if TestStand 2019 is Installed After LabVIEW NXG</h4>
<p class="margin-above"><div>Package Builder will crash while discovering dependencies of a LabVIEW NXG project if TestStand 2019 was installed after LabVIEW NXG was installed.</div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><div>Repair the LabVIEW NXG installation.</div></p>
</div>
</td>
<td class="align-top" data-added-date="1585630800">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.6</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Mar 31, 2020</p>
</td>
</tr>
<tr>
<td class="align-top">976329</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">&#34;Build Specification Cannot be Updated&#34; Error When Building Package with Sequence File Configured to Overrides Module Settings</h4>
<p class="margin-above"><div style=""><span>Package Builder reports the error &quot;Build Specification Cannot be Updated&quot; if a LabVIEW step in a TestStand sequence is configured to override the VI call module settings using the Override Module Settings Window.</span></div><p></p></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1585630800">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builder 19.6</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Mar 31, 2020</p>
</td>
</tr>
<tr>
<td class="align-top">977012</td>
<td class="align-top"></td>
<td class="align-top">
<h4 class="summary">Error Log Entry for Exceeding the Maximum Path Length Doesn&#39;t Populate with Expected Information</h4>
<p class="margin-above"><div>When building a solution which has a file or path name that exceeds the maximum path length a build error will occur. The error log entry is not populated with the specific error information. The error log string reported is:</div><div>&quot;The product '%1%' failed to export one or more packages. A file name or path is too long. All paths for deployment output files or directories must be less than %1% characters: %2%&quot;.</div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><div>Reduce the length of the file or path name in order to remove the error. </div></p>
</div>
</td>
<td class="align-top" data-added-date="1585630800">
<p class="details-black">Reported Version:</p>
<p class="details-grey">NI Package Builderr 19.6</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">NI Package Builder 20.0</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Mar 31, 2020</p>
</td>
</tr>
</tbody>
</table>
</span>
</div></div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-1x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-1x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="link-list parbase aem-GridColumn aem-GridColumn--default--12">
<div>
<div class="row">
<div class="col-xs-12 col-sm-12">
</div>
</div>
</div></div>
<div class="richtext parbase aem-GridColumn aem-GridColumn--default--12">
</div>
</div></div>
 </div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div id="bugsglossary" class=" clearfix">
<div class="row ni-lightgrey ">
<div class="container">
<div class="row">
<div class="shading-container ni-padding-bottom-4x ni-padding-top-x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="richtext parbase aem-GridColumn aem-GridColumn--default--12">
</div>
</div></div>
</div>
</div>
</div>
</div></div>
</div></div>
</div></div>
</div>


<div id="cookieLaw" class="ni-darkgrey" style="display: none;">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-10">
<p>This site uses cookies to offer you a better browsing experience. Learn more about <a href="//www.ni.com/en-us/about-ni/legal/privacy-statement.html">our privacy statement.</a></p>
</div>
<div class="col-xs-12 col-sm-2 text-right">
<button id="btnUnderstood" class="ni-uppercase ni-btn ni-btn-tertiary" type="button">OK</button>
</div>
</div>
</div>
</div>

<footer class="footer noindex">
<div class="container-fluid">
<div class="row">
<div class="container">
<div class="row clearfix">

<div class="hidden-xs footer-nav col-xs-12 col-sm-12 col-md-9 col-lg-9">
<div class="col-xs-4 left">
<h4>PRODUCT</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/status/">Order status and history</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-us/shop/cart">Order by part number</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/myproducts/app/main.xhtml?lang=en">Activate a product</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/apps/utf8/niwq.retrieve_quote">Retrieve a quote</a>
</li>
</ul>
</div>
<div class="col-xs-4">
<h4>SUPPORT</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/srm/app/getassistance">Submit a service request</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/manuals/">Manuals</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/downloads/drivers/">Drivers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/alliance/">Alliance Partners</a>
</li>
</ul>
</div>
<div class="col-xs-4">
<h4>COMPANY</h4>
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/company/">About National Instruments</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-vn/events.html">Events</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/careers/">Careers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/contact-us/">Contact Us</a>
</li>
</ul>
</div>
</div>


<div class="visible-xs col-xs-12 panel-section">
<div class="panel-group" id="accordion">
<div class="panel inactive panel-default">
<div class="panel-heading" data-toggle="collapse" data-parent="#accordion" href="#collapse1">
<span class="glyphicon glyphicon-plus" aria-hidden="true"></span><h4 class="panel-title">PRODUCT</h4>
</div>
<div id="collapse1" class="panel-collapse collapse">
<div class="panel-body">
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/status/">Order status and history</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-us/shop/cart">Order by part number</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/myproducts/app/main.xhtml?lang=en">Activate a product</a>
</li>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/apps/utf8/niwq.retrieve_quote">Retrieve a quote</a>
</li>
</ul>
</div>
</div>
</div>
<div class="panel inactive panel-default">
<div class="panel-heading" data-toggle="collapse" data-parent="#accordion" href="#collapse2">
<span class="glyphicon glyphicon-plus" aria-hidden="true"></span><h4 class="panel-title">SUPPORT</h4>
</div>
<div id="collapse2" class="panel-collapse collapse">
<div class="panel-body">
<ul>
<li>
<a class="analytics-footer-link" href="//sine.ni.com/srm/app/getassistance">Submit a service request</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/manuals/">Manuals</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/downloads/drivers/">Drivers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/alliance/">Alliance Partners</a>
</li>
</ul>
</div>
</div>
</div>
<div class="panel inactive panel-default">
<div class="panel-heading" data-toggle="collapse" data-parent="#accordion" href="#collapse3">
<span class="glyphicon glyphicon-plus" aria-hidden="true"></span><h4 class="panel-title">COMPANY</h4>
</div>
<div id="collapse3" class="panel-collapse collapse">
<div class="panel-body">
<ul>
<li>
<a class="analytics-footer-link" href="//www.ni.com/company/">About National Instruments</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/en-vn/events.html">Events</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/careers/">Careers</a>
</li>
<li>
<a class="analytics-footer-link" href="//www.ni.com/contact-us/">Contact Us</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
<div class="motto-table col-xs-12 col-sm-12 col-md-3 col-lg-3">

<div class="motto">
<h4>MISSION</h4>
<p>NI equips engineers and scientists with systems that accelerate productivity, innovation, and discovery.</p>
</div>

<div class="visible-xs">
<div class="row">

<div class="col-md-3 col-md-offset-1 col-sm-4 col-sm-offset-1 col-xs-8">
<div class="footer-gg">
<svg class="analytics-utilitygg-link" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="24px" height="24px" viewBox="0 0 45 45" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#fff" d="M22,0C9.8,0,0,9.8,0,22s9.8,22,22,22s22-9.8,22-22S34.2,0,22,0z M36.4,35.7c-0.3,0.3-0.6,0.6-0.9,0.9l0,0   c-2.6,2.4-6,4.2-9.6,4.8c2.8-2.5,5.1-5.7,6.7-9.2c1.5,0.9,2.8,2,4.1,3.2C36.5,35.6,36.4,35.7,36.4,35.7z M7.6,8.3   C8,8,8.3,7.6,8.6,7.3l0,0c2.6-2.4,6-4.2,9.6-4.8c-2.8,2.5-5.1,5.7-6.7,9.2c-1.5-0.9-2.8-2-4.1-3.2C7.5,8.4,7.6,8.3,7.6,8.3z    M36.4,8.3l0.1,0.1c-1.3,1.3-2.6,2.4-4.1,3.2c-1.6-3.6-3.8-6.7-6.7-9.2c3.8,0.7,7.1,2.5,9.7,4.9l0,0C35.7,7.6,36,8,36.4,8.3z    M21,14.6c-2.6-0.1-5.2-0.8-7.5-1.9c1.6-3.7,4-6.9,7.2-9.5H21V14.6z M21,16.8V21h-9.4c0.1-2.2,0.4-4.3,1.2-6.3   C15.2,15.8,18,16.6,21,16.8z M21,23v4.2c-2.9,0.1-5.8,0.8-8.3,2.1c-0.6-2-1-4.1-1.2-6.3H21z M21,29.4v11.4h-0.3   c-3.2-2.6-5.8-5.9-7.2-9.5C15.7,30.2,18.3,29.5,21,29.4z M23,29.4c2.6,0.1,5.2,0.8,7.5,1.9c-1.6,3.7-4,7-7.2,9.5H23V29.4z M23,27.2   V23h9.3c-0.1,2.2-0.4,4.3-1,6.3C28.8,28.1,26,27.4,23,27.2z M23,21v-4.2c2.9-0.1,5.7-0.8,8.2-2c0.6,2,1,4.1,1.2,6.3H23V21z    M23,14.6V3.1h0.1c3.2,2.6,5.8,5.9,7.3,9.5C28.2,13.8,25.7,14.5,23,14.6z M10.8,13.7C10.1,16,9.5,18.4,9.4,21H2.1   c0.2-4.2,1.7-8.1,4.1-11.1v0.3C7.6,11.5,9.1,12.7,10.8,13.7z M9.4,23c0.1,2.5,0.5,5,1.4,7.2c-1.7,0.9-3.1,2.2-4.5,3.6v0.3   c-2.4-3-3.9-6.9-4.1-11.1H9.4z M7.6,35.7l-0.1-0.1c1.3-1.3,2.6-2.4,4.1-3.2c1.6,3.6,3.8,6.7,6.7,9.2c-3.7-0.7-6.9-2.4-9.6-4.8l0,0   C8.3,36.4,8,36,7.6,35.7z M33.2,30.3c0.7-2.3,1.3-4.7,1.4-7.2h7.3c-0.2,4.2-1.7,8.1-4.1,11.1v-0.3C36.4,32.5,34.9,31.3,33.2,30.3z    M34.6,21c-0.1-2.5-0.5-5-1.4-7.2c1.7-0.9,3.1-2.2,4.5-3.6V9.8c2.4,3.1,3.9,6.9,4.1,11.1H34.6z" />
</g>
</g>
</svg>
<a class="global-gateway analytics-utilitygg-link">
<span class="country">Choose your country</span>
</a>

<div class="gg-panel">
<div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-AU">Australia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pt-BR">Brasil</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-CA">Canada (English)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CA">Canada (Français)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-DE">Deutschland</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-ES">España</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-FR">France</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-IN">India</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="it-IT">Italia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="hu-HU">Magyarország</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-MY">Malaysia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-MX">México</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="nl-NL">Nederland</a>
</li>
</ul>
</div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-AT">Österreich</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pl-PL">Polska</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-CH">Schweiz</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-SG">Singapore</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CH">Suisse</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="sv-SE">Sverige</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-GB">United Kingdom</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-US">United States</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ru-RU">Российская Федерация</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-CN">中国 (China)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ja-JP">日本 (Japan)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ko-KR">대한민국 (Korea)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-TW">中國台灣 （Taiwan, China)</a>
</li>
</ul></div>
</div>
<div>
<div class="col-xs-12 gg-panel-bottom ">
<a href="http://www.ni.com/global-gateway/" class="analytics-utilityggallcountries-link global-gateway">See All Countries and Regions</a>
</div>
<div class="arrow"></div>
</div>
</div>
</div>
</div>

<div class="col-xs-4">
</div>
</div>
</div>

<div class="footer-social-media">
<div id="niaSvgSocial">
<a href="https://business.facebook.com/NationalInstrumentsASEAN" class="analytics-footer-link"><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33.1,0H2C0.9,0,0.1,0.9,0.1,1.9V33c0,1.1,0.9,1.9,1.9,1.9h16.8V21.3h-4.6V16h4.6v-3.9
c0-4.5,2.8-7,6.8-7c1.9,0,3.6,0.1,4.1,0.2v4.7h-2.8c-2.2,0-2.6,1-2.6,2.6v3.4h5.2l-0.7,5.3h-4.6V35H33c1.1,0,1.9-0.9,1.9-1.9V2
		C35,0.9,34.1,0,33.1,0z" /></svg></a>
<a href="//twitter.com/ni_asean" class="analytics-footer-link"><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33,0H2A2,2,0,0,0,0,2V33a2,2,0,0,0,2,2H33a2,2,0,0,0,2-2V2A2,2,0,0,0,33,0ZM26.2,13c0,.19,0,.39,0,.58A12.76,12.76,0,0,1,6.56,24.37a9.45,9.45,0,0,0,1.07.07,9,9,0,0,0,5.58-1.93A4.49,4.49,0,0,1,9,19.4a4.8,4.8,0,0,0,.85.08A4.6,4.6,0,0,0,11,19.32a4.49,4.49,0,0,1-3.6-4.4v-.06a4.41,4.41,0,0,0,2,.56,4.49,4.49,0,0,1-1.38-6,12.73,12.73,0,0,0,9.25,4.69,4.31,4.31,0,0,1-.12-1A4.49,4.49,0,0,1,25,10a8.92,8.92,0,0,0,2.85-1.09,4.43,4.43,0,0,1-2,2.48,9.29,9.29,0,0,0,2.58-.7A9.15,9.15,0,0,1,26.2,13Z" /></svg></a>
<a href="//www.youtube.com/nationalinstruments" class="analytics-footer-link"><svg class="footer-social" viewBox="5 -7 37 43"><path style="fill:#FFFFFF;" d="M43.5,5.7c0,0-0.5-3.1-1.8-4.4c-1.7-1.8-3.6-1.8-4.4-1.8C31-1,21.7-1,21.7-1l0,0
				c0,0-9.4,0-15.6,0.5C5.2-0.4,3.3-0.4,1.6,1.3C0.2,2.7-0.1,5.7-0.1,5.7S-0.6,9.4-0.6,13v3.4c0,3.6,0.5,7.2,0.5,7.2
				s0.5,3.1,1.8,4.4c1.7,1.8,4,1.8,4.9,1.9c3.6,0.4,15.2,0.5,15.2,0.5s9.4,0,15.6-0.5c0.8-0.1,2.8-0.1,4.4-1.8
				c1.4-1.4,1.8-4.4,1.8-4.4s0.5-3.6,0.5-7.2v-3.4C44,9.4,43.5,5.7,43.5,5.7z M17,20.5V8l12.1,6.3L17,20.5z" /></svg></a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row clearfix legal">
<div class="container">
<div class="row desktop">

<div class="legal-desktop hidden-xs col-md-8 col-sm-7">

<div class="left">
</div>
<div class="legal-copy">
<a class="analytics-footer-link" href="//www.ni.com/legal/">Legal</a> <span class="pipe">|</span>
<a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal/privacy-statement.html">Privacy </a>
&nbsp; &copy <span class="copyright"> </span> National Instruments. All rights reserved.
</div>
</div>
<div class="visible-xs contact-us col-xs-12">

<div class="visible-xs legal-skinny-mobile">

<p>or Call 1800 585 837</p>
<p>
<a class="analytics-footer-link" href="//www.ni.com/legal/">Legal</a> <span class="pipe">|</span>
<a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal/privacy-statement.html">Privacy </a>
&nbsp; &copy <span class="copyright"> </span> National Instruments. All rights reserved.
</p>
</div>
</div>
<div class="hidden-xs">
<div class="col-md-3 col-md-offset-1 col-sm-4 col-sm-offset-1 col-xs-8">
<div class="footer-gg">
<svg class="analytics-utilitygg-link" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="24px" height="24px" viewBox="0 0 45 45" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#fff" d="M22,0C9.8,0,0,9.8,0,22s9.8,22,22,22s22-9.8,22-22S34.2,0,22,0z M36.4,35.7c-0.3,0.3-0.6,0.6-0.9,0.9l0,0   c-2.6,2.4-6,4.2-9.6,4.8c2.8-2.5,5.1-5.7,6.7-9.2c1.5,0.9,2.8,2,4.1,3.2C36.5,35.6,36.4,35.7,36.4,35.7z M7.6,8.3   C8,8,8.3,7.6,8.6,7.3l0,0c2.6-2.4,6-4.2,9.6-4.8c-2.8,2.5-5.1,5.7-6.7,9.2c-1.5-0.9-2.8-2-4.1-3.2C7.5,8.4,7.6,8.3,7.6,8.3z    M36.4,8.3l0.1,0.1c-1.3,1.3-2.6,2.4-4.1,3.2c-1.6-3.6-3.8-6.7-6.7-9.2c3.8,0.7,7.1,2.5,9.7,4.9l0,0C35.7,7.6,36,8,36.4,8.3z    M21,14.6c-2.6-0.1-5.2-0.8-7.5-1.9c1.6-3.7,4-6.9,7.2-9.5H21V14.6z M21,16.8V21h-9.4c0.1-2.2,0.4-4.3,1.2-6.3   C15.2,15.8,18,16.6,21,16.8z M21,23v4.2c-2.9,0.1-5.8,0.8-8.3,2.1c-0.6-2-1-4.1-1.2-6.3H21z M21,29.4v11.4h-0.3   c-3.2-2.6-5.8-5.9-7.2-9.5C15.7,30.2,18.3,29.5,21,29.4z M23,29.4c2.6,0.1,5.2,0.8,7.5,1.9c-1.6,3.7-4,7-7.2,9.5H23V29.4z M23,27.2   V23h9.3c-0.1,2.2-0.4,4.3-1,6.3C28.8,28.1,26,27.4,23,27.2z M23,21v-4.2c2.9-0.1,5.7-0.8,8.2-2c0.6,2,1,4.1,1.2,6.3H23V21z    M23,14.6V3.1h0.1c3.2,2.6,5.8,5.9,7.3,9.5C28.2,13.8,25.7,14.5,23,14.6z M10.8,13.7C10.1,16,9.5,18.4,9.4,21H2.1   c0.2-4.2,1.7-8.1,4.1-11.1v0.3C7.6,11.5,9.1,12.7,10.8,13.7z M9.4,23c0.1,2.5,0.5,5,1.4,7.2c-1.7,0.9-3.1,2.2-4.5,3.6v0.3   c-2.4-3-3.9-6.9-4.1-11.1H9.4z M7.6,35.7l-0.1-0.1c1.3-1.3,2.6-2.4,4.1-3.2c1.6,3.6,3.8,6.7,6.7,9.2c-3.7-0.7-6.9-2.4-9.6-4.8l0,0   C8.3,36.4,8,36,7.6,35.7z M33.2,30.3c0.7-2.3,1.3-4.7,1.4-7.2h7.3c-0.2,4.2-1.7,8.1-4.1,11.1v-0.3C36.4,32.5,34.9,31.3,33.2,30.3z    M34.6,21c-0.1-2.5-0.5-5-1.4-7.2c1.7-0.9,3.1-2.2,4.5-3.6V9.8c2.4,3.1,3.9,6.9,4.1,11.1H34.6z" />
</g>
</g>
</svg>
<a class="global-gateway analytics-utilitygg-link">
<span class="country">Choose your country</span>
</a>

<div class="gg-panel">
<div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-AU">Australia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pt-BR">Brasil</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-CA">Canada (English)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CA">Canada (Français)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-DE">Deutschland</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-ES">España</a>
</li>
 <li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-FR">France</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-IN">India</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="it-IT">Italia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="hu-HU">Magyarország</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-MY">Malaysia</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="es-MX">México</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="nl-NL">Nederland</a>
</li>
</ul>
</div>
<div class="col-xs-6">
<ul>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-AT">Österreich</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="pl-PL">Polska</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="de-CH">Schweiz</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-SG">Singapore</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="fr-CH">Suisse</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="sv-SE">Sverige</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-GB">United Kingdom</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="en-US">United States</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ru-RU">Российская Федерация</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-CN">中国 (China)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ja-JP">日本 (Japan)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="ko-KR">대한민국 (Korea)</a>
</li>
<li class="analytics-utilityggsupportedcountry-link">
<a href="" data-locale="zh-TW">中國台灣 （Taiwan, China)</a>
</li>
</ul></div>
</div>
<div>
<div class="col-xs-12 gg-panel-bottom ">
<a href="http://www.ni.com/global-gateway/" class="analytics-utilityggallcountries-link global-gateway">See All Countries and Regions</a>
</div>
<div class="arrow"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</footer>
<div class="modal fade modalsearch" id="wrapperSearchModal" tabindex="-1" role="dialog" aria-labelledby="wrapperSearchModal">
<div class="modal-dialog" role="document">
<div class="modal-content">
<div class="modal-header">
<button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
</div>
<form id="autoComplete-global" name="autoComplete-global" class="pnx-form" type="GET" action="//search.ni.com/nisearch/app/main">
<div class="autoCompleteItem-global">
<div class="input-group stylish-input-group">
<input placeholder="" class="niAutocompleteInput" data-search-type="globalSearch" type="text" id="n33_autoCompleteInput" name="q" />
<input type="hidden" name="pg" id="pg" value="1" />
<input type="hidden" name="sn" id="sn" value="" />
<span class="input-group-addon">
<button type="submit">
<span class="search search-icon">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="48px" height="48px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
<g id="XMLID_1_">
<g>
<path fill="#FFFFFF" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z" />
</g>
</g>
</svg>
</span>
</button>
</span>
</div>
</div>
</form>
</div>
</div>
</div>

</div>
</body>
</html>