NI-Switch and LabVIEW Compatibility

Overview

This page shows supported versions of the NI-Switch hardware driver with LabVIEW development systems. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing LabVIEW palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX).

 

NI-Switch and LabVIEW Compatibility

Use this table to compare NI-Switch and LabVIEW Compatibility
NI-Switch Version LabVIEW Version
2022 Q3 2021 SP1 2021 2020 2019 2018 2017 2016 2015 2014
2022 Q4          
21.3          
20.0            
19.5            
19.1            
19.0            
18.5.1            
18.5            
18.0            
17.5            

In the Downloads section at the bottom of this page, you can download a copy of this table, which may include older software versions.

32-bit and 64 bit LabVIEW where applicable

Additional Resources

Was this information helpful?

Yes

No