NI-DAQmx Readme Updates and Corrections for Versions 14.1 and Later

Overview

This article lists the updates and corrections available for the NI-DAQmx Readme in versions 14.1 and later.

Contents

Introduction

The following list includes the known changes and updates to the NI-DAQmx Readmes since version 14.1.

NI-DAQmx 19.0, 19.1, and 19.5

The readme incorrectly indicates that cDAQ-9171, cDAQ-9174, and cDAQ-9178 are supported on Phar Lap targets. CompactDAQ chassis support on Phar Lap was discontinued entirely as of NI-DAQmx 19.0. 

NI-DAQmx 18.6

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10.

NI-DAQmx 18.5

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

In the Bug Fixes section, the link should point to http://www.ni.com/product-documentation/54628/en/.

 

NI-DAQmx 18.1

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

In the CompactDAQ Chassis section, Ethernet CompactDAQ chassis should not be listed as supporting PharLap. A column detailing LabVIEW Real-Time module support should be included as well. 

Corrected section: 

NI-DAQmx 18.0

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

 

NI-DAQmx 17.6

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

 

NI-DAQmx 17.5

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

Devices Supported in NI-DAQmx section, the table listing support for CompactDAQ Controllers has a footnote with a misleading description:

"Real-time support for this controller is only compatible with the LabVIEW Real-Time Module 2015."

This should actually read:

"Real-time support for this controller was added in the LabVIEW Real-Time Module 2015."

Corrected Section:

 

NI-DAQmx 17.1.1

The readme incorrectly states that the PCIe-6535B, PCIe-6536B, and PCIe-6537B are not supported on Windows 10. These devices are supported in Windows 10. 

Devices Supported in NI-DAQmx section, the table listing support for CompactDAQ Controllers has a footnote with a misleading description:

"Real-time support for this controller is only compatible with the LabVIEW Real-Time Module 2015."

This should actually read:

"Real-time support for this controller was added in the LabVIEW Real-Time Module 2015."

Corrected Section:

 

NI-DAQmx 17.1

  • Readme
  • Currently no known updates

 

NI-DAQmx 17.0

  • Readme
  • Currently no known updates

 

NI-DAQmx 16.1

  • Readme
  • Currently no known updates

 

NI-DAQmx 16.0.1

  • Readme
  • Currently no known updates

 

NI-DAQmx 16.0

Supported Operating Systems section should:

  • Include Windows 7 (32-bit and 64-bit)
  • Not include Windows Embedded Standard 7 (64-bit)
  • Indicate Windows Embedded is only supported on NI CompactDAQ controllers

Corrected section:

Supported Operating Systems

The following operating systems are supported in NI-DAQmx 16.0:

    • Windows 10 (32-bit and 64-bit)
    • Windows 8.1* (32-bit and 64-bit)
    • Windows 7, SP1** (32-bit and 64-bit)
    • Windows Embedded Standard 7**, SP1 (on CompactDAQ controllers)
    • Windows Server 2008 R2*, SP1 (64-bit, not supported on Server Core Role)
    • Windows Server 2012 R2* (64-bit)

*NI software installs VC2015 Runtime and .NET 4.6.1. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

**NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

To find and download an earlier version of NI-DAQmx that supports other operating systems, refer to ni.com/downloads.

 

NI-DAQmx 15.5

  • Readme
  • Devices Supported in NI-DAQmx»SC Express Accessories
  • Missing note for the NI RM-4302 and RM-4304
  • Should indicate that the RM-4302 is added as a supported accessory for the NI 4303
  • Should indicate that the RM-4304 is added as a supported accessory for the NI 4305
  • Corrected table:

  • Devices Supported in NI-DAQmx»X Series DAQ
  • Missing note for the NI 6376
  • Should indicate that support was added in the NI 6376
  • Corrected table:

 

NI-DAQmx 15.1

  • Readme
  • Windows 10 32- and 64-bit should be included under Operating System Support
  • Should include an additional important notice:

Important Notice: SCXI Systems Reclassified in Devices and Interfaces
In the configuration tree of NI MAX, your SCXI chassis will no longer appear as a child of Devices and Interfaces. Your SCXI hardware is now listed under the device you have configured as the Chassis Communicator. SCXI modules will continue to appear as children of your SCXI chassis and are now shown as parents of configured terminal blocks and accessories.

 

NI-DAQmx 15.0.1

  • Readme
  • Currently no known updates

 

NI-DAQmx 14.5.1

  • Readme
  • Currently no known updates

 

NI-DAQmx 14.5

  • Readme
  • Currently no known updates

 

NI-DAQmx 14.2 

  • Readme
  • Currently no known updates

 

NI-DAQmx 14.1

  • Readme
  • Operating System Support
  • Incorrectly lists "Windows Server 2008 R3, SP1 or greater"
  • Correct Version is "Windows Server 2008 R2, SP1 or greater"
  • Devices Supported in NI-DAQmx»Stand-Alone CompactDAQ Systems
  • Missing note for the NI cDAQ-9132/34
  • Should indicate that Support was added in the LabVIEW Real-Time Module 2014
  • Corrected table:

 

NI-DAQmx 14.0 and previous

  • This document does not cover NI-DAQmx 14.0 and previous.

 

Glossary of Terms

 

  • Bug ID - When an issue is reported to NI, you may be given this ID or find it on ni.com.  You may also find IDs posted by NI on the discussion forums or in KnowledgeBase articles.
  • Legacy ID – An older issue ID that refers to the same issue.  You may instead find this issue ID in older known issues documents.
  • Description - A few sentences which describe the problem. The brief description given does not necessarily describe the problem in full detail.
  • Workaround - Possible ways to work around the problem.
  • Reported Version - The earliest version in which the issue was reported.
  • Resolved Version - Version in which the issue was resolved or was no longer applicable. "N/A" indicates that the issue has not been resolved.
  • Date Added - The date the issue was added to the document (not the reported date).